Reference manual for using TunerStudio with your Megasquirt-2 ECU.

This version of the documentation applies to the Megasquirt-2 range of products which includes:

• MS2 using the V3.0 or V3.57 mainboards;
• MicroSquirt;
• Products derived from the MicroSquirt Module, e.g., DIYPNP and MSPNP2.
  
  AND running MS2/Extra 3.4.x firmware.

See the Setting Up manual for more detail on version numbers.

This version of the documentation **DOES NOT** apply to:

• Megasquirt-1;
• EMS Pro;
• Megasquirt-3;
• MS3-Pro or products using MS3-Pro module;
• MS3-Gold.

**OR ANY** Megasquirt-2 products running "Bowling and Grippo" firmware.

(c) 2014-8 James Murray. Additional edits by Ed Hateley.
Table of Chapters

1. Introduction....................................................................................................................................................8
2. File Menu........................................................................................................................................................23
3. Options Menu..................................................................................................................................................39
4. Data Logging Menu........................................................................................................................................43
5. Communications Menu................................................................................................................................55
6. Tools Menu...................................................................................................................................................59
7. Help Menu......................................................................................................................................................73
8. Basic / Load Settings......................................................................................................................................74
9. Fuel Settings....................................................................................................................................................94
10. Ignition Settings..........................................................................................................................................108
11. Startup / Idle................................................................................................................................................122
12. Accel Enrich................................................................................................................................................138
13. Boost / Advanced.........................................................................................................................................145
14. 3D Maps......................................................................................................................................................158
15. CAN bus / Testmodes....................................................................................................................................166
16. Upgrade.......................................................................................................................................................180
17. Dashboard Gauge Cluster.............................................................................................................................181
18. Dashboard Indicators....................................................................................................................................190
19. Diagnostics & High Speed Loggers................................................................................................................193
20. Tune Analyze Live.........................................................................................................................................198
21. Megasquirt Glossary of Terms.....................................................................................................................199
22. Firmware changes since 3.3.x.......................................................................................................................206
23. Revision history............................................................................................................................................207
Contents

1. Introduction ................................................................................................................................. 8
   1.1. Overview ................................................................................................................................. 8
   1.2. Prerequisites ............................................................................................................................ 8
   1.3. How to Use This Guide ............................................................................................................ 8
   1.4. TunerStudio MS Lite Interface ............................................................................................... 9
       1.4.1. Start Screen ....................................................................................................................... 9
       1.4.2. Main Screen ..................................................................................................................... 10
       1.4.3. Lite and Upgrade Versions of TunerStudio ................................................................... 11
   1.5. Using the Software Interface ................................................................................................ 12
       1.5.1. Data Input Screens ........................................................................................................... 12
       1.5.2. Curves ............................................................................................................................. 14
       1.5.3. 3D Tables .......................................................................................................................... 16
       1.5.4. 3D Tuning Maps ............................................................................................................... 18
   2. File Menu .................................................................................................................................. 23
       2.1. Project .................................................................................................................................. 23
           2.1.1. New Project .................................................................................................................... 23
           2.1.2. Open Project ................................................................................................................... 30
           2.1.3. Close Project .................................................................................................................... 30
           2.1.4. Export Project Archive .................................................................................................. 30
           2.1.5. Import Project Archive .................................................................................................. 30
           2.1.6. Project Properties .......................................................................................................... 31
       2.2. Tune Restore Point Dialog ................................................................................................... 35
       2.3. Open Tune ............................................................................................................................. 35
       2.4. Save Tune ............................................................................................................................... 36
       2.5. Save Tune As .......................................................................................................................... 36
       2.6. Gauge Cluster ....................................................................................................................... 36
           2.6.1. Background .................................................................................................................... 37
           2.6.2. Antialiasing Enabled ....................................................................................................... 37
           2.6.3. Designer Mode ................................................................................................................. 37
           2.6.4. Gauge Demo ................................................................................................................... 37
       2.7. Work Offline .......................................................................................................................... 37
       2.8. Exit ....................................................................................................................................... 38
   3. Options Menu ............................................................................................................................. 39
       3.1. Language ............................................................................................................................... 39
       3.2. Look and Feel ......................................................................................................................... 39
       3.3. Navigation ............................................................................................................................. 39
           3.3.1. Main Menu Style ............................................................................................................. 39
           3.3.2. Wrapping Main Menu .................................................................................................... 39
           3.3.3. Toolbar Style .................................................................................................................. 40
           3.3.4. Navigation Options ....................................................................................................... 40
       3.4. View ..................................................................................................................................... 40
           3.4.1. Show Gauges on VE Analyze .......................................................................................... 40
           3.4.2. Show Live Graphs on VE Analyze .................................................................................. 40
           3.4.3. Show Enable Condition in Menu Tooltips .................................................................... 40
       3.5. Advanced .............................................................................................................................. 40
           3.5.1. Report INI Warnings ...................................................................................................... 40
           3.5.2. Always Allow Multiple Instances .................................................................................. 40
       3.6. Preferences ........................................................................................................................... 41
           3.6.1. Set Dialog Font Size ....................................................................................................... 41
           3.6.2. Perform Difference Report on Connect ......................................................................... 41
           3.6.3. Automatically Load and Save Current Tune ................................................................. 41
       3.7. Performance .......................................................................................................................... 42
           3.7.1. Gauge Float down on start ............................................................................................ 42

(c) 2014-8 James Murray 2018-07-08 Page 3/207
3.7.2. Modal Dialogs ................................................................. 42
3.7.3. Run in Lite Mode ......................................................... 42

4. Data Logging Menu .............................................................. 43
4.1. Start Logging ................................................................... 43
4.2. Stop .................................................................................. 43
4.3. Logging Profiles ............................................................... 43
4.4. Automatic Logging........................................................... 43
4.5. Import / Conversion ......................................................... 44
4.5.1. PalmLog Import Utility ................................................. 44
4.5.2. Convert Binary Log (MS3, FRD) ................................. 44
4.6. View with MegaLogViewer .............................................. 45
4.6.1. Megasquirt-2 MegaLogViewer Datalog Fields .......... 47

5. Communications Menu ....................................................... 55
5.1. Settings ............................................................................ 55
5.2. Data Rate .......................................................................... 55
5.3. Enable GPS Support ....................................................... 56
5.4. Mini Terminal ................................................................. 56
5.5. Debug Log Comm ............................................................ 57
5.6. Megasquirt Baud Rate ...................................................... 57

6. Tools Menu .......................................................................... 59
6.1. Protocol Stats ................................................................. 59
6.2. Update / Install Firmware ............................................ 59
6.3. TunerStudio Plug-ins .................................................... 65
6.4. Calibrate TPS ................................................................. 65
6.5. Calibrate MAP / Baro .................................................... 66
6.6. Calibrate Battery Voltage ............................................. 67
6.7. Un/Lock calibrations ...................................................... 68
6.8. Calibrate Thermistor Tables ........................................ 69
6.9. Calibrate AFR Table ..................................................... 70
6.10. Calibrate MAF Table .................................................... 71

7. Help Menu .......................................................................... 73
7.1. TunerStudio Help .......................................................... 73
7.2. Check for Update .......................................................... 73
7.3. Automatic Update Check ............................................... 73
7.4. Enter Registration ......................................................... 73
7.5. About ............................................................................. 73
7.6. MS2/Extra Info ............................................................... 73

8. Basic / Load Settings .......................................................... 74
8.1. Engine and Sequential Settings ..................................... 74
8.1.1. Required Fuel Settings .............................................. 74
8.1.2. Sequential Injection Settings .................................... 75
8.2. General Settings ........................................................... 77
8.2.1. Baro Sensor Settings ............................................... 78
8.2.2. MAP Sensor Settings .............................................. 79
8.2.3. General Sensor Settings .......................................... 79
8.2.4. Secondary load Parameters .................................... 79
8.3. Rev Limiter ................................................................. 80
8.3.1. Hard Rev Limit ......................................................... 81
8.3.2. Coolant Temp Limiter ............................................. 81
8.3.3. Spark Retard ............................................................ 81
8.3.4. Spark Cut and Fuel Cut .......................................... 82
8.4. Tacho Output ............................................................... 82
8.5. Barometric Correction .................................................. 83
8.6. MAP Sample Settings .................................................. 83
8.7. ITB Load Settings .......................................................... 84
8.8. MAF Settings ............................................................... 85
8.9. MAF Flow Curve .......................................................... 86

(c) 2014-8 James Murray 2018-07-08 Page 4/207
17.1. TunerStudio gauges ................................................................. 182
17.2. AFR/EGO inputs+calcs .......................................................... 182
17.3. Calculations 1 .............................................................. 183
17.4. Calculations 2 .............................................................. 184
17.5. Outputs ........................................................................ 186
17.6. Sensor inputs 1 .............................................................. 187
17.7. Sensor inputs 2 .............................................................. 188
17.8. X-Code dev .............................................................. 189
17.9. Other Menu Items on the Gauge Pop-up Menu .................. 189
18. Dashboard Indicators ........................................................... 190
  18.1. Application Indicators .............................................. 190
  18.2. Predefined Indicators ............................................. 190
  18.3. Predefined Indicators with PORT_STATUS Deactivated (Default) .............................................. 190
    18.3.1. Predefined Indicators .................................... 190
    18.3.2. Predefined Indicators 2 .................................. 191
  18.4. Predefined Indicators with PORT_STATUS Activated .............................................. 191
    18.4.1. Predefined Indicators with PORT_STATUS Activated .............................................. 191
    18.4.2. Predefined Indicators 2 with PORT_STATUS Activated .............................................. 192
    18.4.3. Predefined Indicators 3 with PORT_STATUS Activated .............................................. 193
  18.5. Other Menu Items on the Indicator Pop-up Menu ............ 193
19. Diagnostics & High Speed Loggers ........................................ 193
  19.1. Logger Type ............................................................ 193
  19.2. Using the Loggers .................................................... 196
  19.3. Analyzing Data from the Loggers .................................. 197
20. Tune Analyze Live ............................................................... 198
21. Megasquirt Glossary of Terms ............................................... 199
22. Firmware changes since 3.3.x ................................................... 206
  22.1. Old baro .............................................................. 206
  22.2. Ignition Settings ...................................................... 206
  22.3. Programmable On/Off Outputs .................................. 206
  22.4. CAN Broadcasting .................................................. 206
  22.5. CAN Broadcast testing ............................................. 206
  22.6. CAN Realtime Data Broadcasting ................................ 206
  22.7. CAN Dash Broadcasting ........................................... 206
23. Revision history .............................................................. 207
1. Introduction

1.1. Overview

This guide aims to document the features of TunerStudio MS Lite, the tuning software that ships with the Megasquirt range of aftermarket ECUs (Electronic Control Units). This version of the documentation applies to the Megasquirt-2 range of products running the MS2/Extra firmware. The products in this range include:

- Megasquirt-2, often simply referred to as MS2;
- Microsquirt;
- Products derived from the Microsquirt Module, e.g., DIYPNP and MSPNP2.

In this guide Megasquirt will be used to refer to any of the above products unless a setting varies according to a specific Megasquirt-2 product. In this event the products will be named explicitly.

Megasquirt ECUs are designed to give enhanced flexibility in terms of engine control. They are designed for track, educational, and other off-road use. Certain jurisdictions place environmental controls over the use of aftermarket ECUs. Please check your local legislative controls before using a Megasquirt with your engine.

1.2. Prerequisites

In order to successfully use your Megasquirt with the software you will need the following:

- A Megasquirt connected to your engine using a viable sensor configuration;
- A PC running Windows or Linux, or an Apple running OS X;
- The appropriate Java Runtime Environment for your computer which can be downloaded free of charge from www.java.com;
- The latest versions of TunerStudio MS and MegaLogViewer MS which can be downloaded from http://www.tunerstudio.com/index.php/downloads;
- The latest firmware loaded onto your Megasquirt which can be downloaded from http://www.msextra.com/downloads.html;
- A good understanding of how your engine works and can be configured with your Megasquirt. If you need help community support is available at http://www.msextra.com.

1.3. How to Use This Guide

Depending on your engine, and your choice of configuration and sensors, you may not need to use all of the features included in TunerStudio, and so it is worth considering which sections are relevant to you. If you are setting up your Megasquirt for the first time you will find it helpful to use this document alongside the appropriate Hardware and Setting Up manuals for your product.
1.4. TunerStudio MS Lite Interface

1.4.1. Start Screen

When you start the software you will initially see a splash screen from the developer (EFI Analytics) whilst the software loads, followed by a start screen similar to that shown below:

Although there are a number of options available to you from this screen, creating or opening a project is usually the next step. The top menu is discussed below in more detail, but it is worth noting that the number of options within this menu is reduced at this start screen.
The File Menu (1)
The File menu can be used to open or create a new project.

The File menu of this screen contains an Open Tune (.msq) option. This is only so that a tune can be viewed for analysis and diagnostics – you cannot connect to your Megasquirt or make changes to a tune that you open from this screen, you must create or open a project to do this.

Open Last Project (2)
The Open Last Project feature is a useful way to quickly access your most recent project. For more detailed information about opening or creating a project see Section 1.1. of this guide.

1.4.2. Main Screen
Once you have opened or created a project you will see the main TunerStudio screen as shown below:

Top Menu (1)
The Top Menu is documented in Sections 2. to 7. of this guide.

This menu is largely related to the software itself, specifically dealing with areas such as:

- How to create, open and backup projects and tune files;
- How to manage the behavior and appearance of the software;
- How to capture data from your Megasquirt for analysis;
- How to manage communications between your Megasquirt and TunerStudio;
• How to calibrate some of the main sensors that you will use with your Megasquirt;
• How to access TunerStudio's internal help file and obtain information about your version of TunerStudio.

**Toolbar “Button” Menu (2)**

The Toolbar Menu is documented in Sections 8. to 16. of this guide.

This menu contains the features through which almost all of the configuration and tuning of your Megasquirt is carried out.

**Main Screen Tabs (3)**

The Main Screen Tabs are documented in Sections 17. to 20. of this guide.

This area of the screen displays two sets of visual data according to the selected tab:
• The gauge cluster and associated indicator labels;
• Diagnostics and high speed loggers.

**Status Bar (4)**

The Status Bar is not specifically documented in this guide, although it is referred to where appropriate.

The Status Bar is relatively simple and, from left to right, shows:
• The name of the current project;
• A progress bar which is used from time to time whilst the software carries out tasks;
• A link to the manufacturer's Internet Site;
• Optionally, the name of the current tune file (or CurrentTune.msq) – See Section 2.3. of this guide for more information about tune files;
• A communications indicator – the red and green boxes on the right hand side of the status bar indicate when information is being transferred between TunerStudio and your MS2.

**Title Bar**

The Title Bar shows the TunerStudio version, active Project name and Firmware version.

---

**1.4.3. Lite and Upgrade Versions of TunerStudio**

On the splash screen, the start screen, the status bar, and the last of the toolbar menu options you will see references to the Upgrade version of TunerStudio.

TunerStudio MS Lite is a fully functional tuning software product that comes free with your MS2 purchase. TunerStudio MS Lite includes all of the features required to enable and configure all of the options and settings...
within your MS2 controller. The Upgrade version also supports additional features that can be hard-wired into some MS2 controllers, and additional functionality (such as GPS and auto tune support) which are not incorporated into your Megasquirt-2 or TunerStudio MS Lite as standard.

1.5. Using the Software Interface

1.5.1. Data Input Screens

Many of the screens within the software are comprised of text boxes, drop-down boxes and buttons. The following image (taken as an example from the Cranking/Startup settings screen within the Startup/idle Toolbar Menu) demonstrates how these can be used:

![Cranking / Startup Settings](image)

**Text box (1)**

Text boxes are designed to accept numeric entries, and so will only accept numbers and decimal points. Almost all of the text boxes include up and down buttons which allow you to make incremental values although it is often much quicker to simply type your chosen value into the box. When you have selected a text box you can also increase or decrease its value with the up and down buttons on your keyboard.

**Drop-down box (2)**

Drop-down boxes allow you to select one of many options. It is worth noting that when the value of a drop-down box is changed it can radically change the other options available in the software. Enabling or disabling a feature will often not only enable or disable other text and drop-down boxes on the screen that you are using, but may also enable or disable options in other areas of the software. Wherever possible, this guide aims to outline what changes you need to make in order to enable specific options and menu items.

**Undo and Redo Buttons (3 and 4)**

This concept will be familiar for many computer users. When enabled these buttons turn blue and allow you to repeatedly reverse or re-implement recent changes.
One quirk of the software is that the “undo” button will allow you to undo changes you have made on previous screens, not just the one that you are working with. For this reason be careful how you use this feature.

Burn Button (5)

When you make changes in TunerStudio they usually need to be written (or “burned”) to the flash memory within your Megasquirt before they take effect. The only exception to this is when you make changes to Fuel Tables, Ignition Tables (and their corresponding 3D Maps) where you can “live tune”. Even in this case the changes you make need to be burned to the Megasquirt’s flash memory when you have finished live tuning before they become permanent.

Clicking “Burn” on any screen at any time will cause any changes you have made to be written to the flash memory in your Megasquirt.

You can burn changes as often as you like, although it is worth noting that the flash memory in your Megasquirt is only designed to withstand approximately 100,000 burn operations during its lifetime. Whilst you are extremely unlikely to exceed this number, it is always good practice to plan your changes carefully to enhance the life of your Megasquirt as well as to protect your engine.

The burn process takes approximately 0.02 seconds. Whilst this is taking place the main software routine within your Megasquirt-2 is temporarily interrupted. This causes a minor pause which can be enough for the engine to very briefly misfire. This effect (often referred to as “burn stumble”) is normal and should resolve itself quickly as the software routine within your Megasquirt-2 resumes its normal operations.

Close Button (6)

This button behaves like the close button in your operating system (the red cross in the above image which is taken from a Microsoft® Windows 8® screen capture). If you have not already clicked “burn” any changes that you have made will be burned automatically whenever a screen (or TunerStudio) is closed.

Tool-tips (7)

The blue question mark icons that appear throughout the toolbar menu screens provide pop-up information when clicked. Much of the content provided by these tool-tips is also included and expanded upon within this guide, although the tool-tips can be extremely helpful if you do not have this guide available. For example, clicking the blue tool-tip button for Cranking RPM will display the following:

Help (8)

On most settings screens, you will also find a Help menu, clicking on this will open up this document at the
appropriate page so you can read about all of the settings for that particular screen.
(You may need to be connected to the internet the first time you use this feature, so the PDF can be downloaded.)

1.5.2. Curves

Curves are a useful feature of TunerStudio as they allow you to make various adjustments depending on one or more states of your engine. The following image (taken as an example from the Barometric Correction screen within the Basic/Load Settings toolbar menu) demonstrates how these can be used:
X-Axis (1)
The X-Axis displays the main variable that is being used for manipulation (in this example barometric pressure) and units used (in this example kPa). It also displays a numerical range which increases from right to left (in this example 60.0 to 110.0.)

Y-Axis (2)
The Y-Axis is usually used to show percentage correction (as in this example) although it can also be used for a second variable in some curves.

Options Menu Button (3)
The small button labeled “...” on the top left of the curve allows you to customize the ranges of the X and Y Axes. Clicking this button will display a pop-up menu from which you can set minimum and maximum settings for each axis. Optionally you can also ask TunerStudio to “Auto Scale” the maximum value for each axis by enabling the appropriate option from the pop-up menu.

Variable Points (4)
Each curve has a fixed number of points (in this example there are eight) which you can use to set a correction to the curve. Clicking and dragging any of these points up or down, or left to right, sets the adjustment that you want to make.

Selected Point Information Box (5)
When any point is selected (in this example the furthest from the left) it changes color and a box of the same color appears giving its precise location relative to the axes (in this example it shows Barometer (kPa): 107.3, and Correction %: 104.4.

Data Tables (6)
Rather than clicking and dragging the points on the curve you can enter your settings into the associated data table. When you have done this the appropriate point on the curve will move. If you click and drag a point on the curve its entry in the table is highlighted in red (in this example the eighth box down is highlighted and contains the same figures shown in the Selected Point Information Box.) TunerStudio refers to these as “text based arrays.”

Often the data table for a curve is not visible by default although all curves do include a data table. The button labeled “8” (described below) can be used to display hidden data tables.

When you type an entry into a data table you will need to either use the “Enter” or “Tab” key on your keyboard to move out of that cell or click in another cell before the change will take effect. Unless you do this the point on the curve will not move and the change will not be saved or sent to your MS2 when you burn or close the screen.

Show or Hide Data Tables (7)
This button can be used to either hide or display a data table. Some curves are quite small and have their data tables hidden by default. This button is especially useful when using these smaller curves as the table often obscures the curve, and so it can be useful to toggle between the curve the table.

Gauge (8)
The appropriate gauge for the value that you are setting may appear next to some curves.
Not all curves in TunerStudio include a gauge. See Sections 2.6. and 17. for more information about gauges.

1.5.3. 3D Tables

3D Tables are used for a range of tuning roles, although Fuel VE Tables and Ignition Tables are the most commonly used. The following image (taken as an example from the Fuel VE Table 1 screen within the Fuel Settings Toolbar Menu) demonstrates how these can be used:

X-Axis and Y-Axis Bin Values (1 and 2)

These values represent the thresholds for which values can be set within the table. In this example there are 16 bin values that can be set for rpm and for fuel load (%). These thresholds can be changed by clicking any of the gray buttons on either axis. When this is done you will see a box pop-up asking you to enter a new value for that bin.
It makes sense to make sure that you are happy with the bin values for each table before you begin to set any of its values.

**Individual Cell Value (3)**

In a 16 x 16 table there are a total of 256 different values that can be set (in this example the value that is set responds to volumetric efficiency.) These numbers can be entered individually, but there are also a number of ways to simplify this process using the Hot Keys and Buttons described below.

**Hot Keys**

Clicking on a single cell (or dragging to select a range of cells) and right clicking will display a useful pop-up menu. Most of the features of this menu can also be carried out using the buttons (5) and are described later in this section. This menu also lists the keyboard Hot Keys that can be used to manipulate the values in the table.

**Current Running Point and History Trail (4)**

If you are using your Megasquirt with your engine running, this screen will display a colored point to demonstrate its current position in the table. It will also display a history trail in the form of a trace line based on recent data from the engine's sensors to illustrate the changes in table position as your engine changes (for example, when RPM increases.)

You can change the number of “reads back” that are used to build the history trail. To do this, right click on your table and click on “History Trail Length” at the bottom of the pop-up menu. This will open a pop-up text box where you can enter the number of reads you want to see displayed.

**Buttons (5)**

These buttons allow you to carry out a range of tasks to manipulate the values in the table. Most can be used either for a single cell, or for a range of cells that you can select by clicking and dragging with your mouse.

- **Opens a pop-up text box and sets the value of the selected cells to the value that you enter.**
- **Increases the values of the selected cells by one unit each time the button is clicked.**
- **Decreases the values of the selected cells by one each time the button is clicked.**
- **Opens a pop-up text box and reduces the value of the selected cells by the value that you enter.**
- **Allows you to import a table from a file.**
- **Allows you to export the table to a file.**
Opens a pop-up text box and increases the value of the selected cells by the value that you enter.

Opens a pop-up text box and increases the value of the selected cells by multiplying the original values by the value that you enter (for example, entering 1.25 will increase the values of the selected cells by 25%). This can also be used for reducing values (for example, entering 0.8 will reduce the values of the selected cells by 20%)

Adjusts all of the selected cells to values interpolated by the cells in the four corners of the selection.

The standard Microsoft® Windows® copy (Ctrl + C) and paste (Ctrl + V) features are supported and will allow a selection of values to be copied into a second table or into a spreadsheet program such as Microsoft® Excel®.

Tools (7)

This menu will display a Table Generator option on some 3D Table screens. This is an alternative method of creating values for your table which is only available in the optional Upgrade version of TunerStudio.

1.5.4. 3D Tuning Maps

3D Tuning Maps allow a flexible visual rendering of the data held in a 3D Table. Whist numbers alone can be useful, it is sometimes extremely helpful to see a visual interpretation of these numbers to get a better feel for the tune that you are putting together.

Generally, whenever a 3D Table appears in TunerStudio there is a corresponding 3D Map available. The following screen depicts the corresponding 3D Map for the Fuel VE Table 1 used in the previous example:
Whilst 3D Maps can appear quite complex at first glance they are actually relatively simple. For each of the 256 points in the 3D table, a 3D map is created using the X and Y axis, with the height at each point reflecting the numerical value (often referred to as the Z axis). This allows you to get a feel for the gradients within your tune. Like 3D tables, lower numbers are shown in blue and higher numbers are shown in red with green representing mid-range values.

One of the major advantages of a 3D map over a table is that it can be rotated to allow views from different angles to give you a clear idea of the “shape” of your tune. Each map can be manipulated either by clicking and dragging it around, or by using the Yaw and Roll sliders.

**Yaw Slider (1)**

The Yaw Slider allows you to rotate the map along the horizontal plane – allowing it to be viewed from the front, back and sides.

**Roll Slider (2)**

The Roll Slider allows you to rotate the map through the vertical plane – allowing it to be viewed from above or below.

⚠️ Using a combination of Yaw and Roll it is possible to view a map from all possible angles.

**Selected Point (3)**

All of the intersections between the lines represent a value of a cell in the corresponding 3D table. You can
select any of these points by clicking on them. When you do this the selected point in the table will be highlighted by a colored marker. You can change the value for the selected point by dragging it up or down. Rotating the map by clicking and dragging or by using the Yaw and Roll sliders will give you a good feel for how your changes fit in with the other points in the map.

Tuning is a matter of personal preference (and there are many possible approaches) but when changing any value it is generally a good idea to maintain some smoothness throughout the map. Sharp upwards or downwards points will usually result in a poor running of the engine.

Active Engine Point (4)

If your Megasquirt-2 is connected and your engine running, the active position at which the engine is operating is reflected by a second colored marker. For most (but not all) of the maps RPM is used as the X-Axis and so you will be able to see this marker moving when you open and close the throttle. Making changes to the points in a map whilst varying RPM can be a useful way to live tune.

Current and Selected Point Information Boxes (5)

When a current point is displayed you will see a text area at the top right of the map giving detailed information about what is happening at that point (in this example it shows rpm: 4501; fuelload: 99.4; %:92.)

If you are working offline or your engine is not running no Current Point will be highlighted on the map and this text area will not be displayed.

When a point on the map is selected, you will see a text area on the top left of the map giving detailed information about what would happen at that selected point (in this example it shows rpm: 801; fuelload: 35.0; Selected %: 31.) A point on the map can be selected and the text area will be displayed even without your MS2 connected.

Color Shade (6)

Clicking in the box next to Color Shade will toggle shading of the map on and off (it is “on” if there is a tick in the box). The choice of whether to use shading is a personal one, but most users find it easier to get a feel for the shape of the map with Color Shade on.

Color Theme (7)

This sets the background color for the map. Again it is a personal choice, but most users seem to prefer using a black background as it makes the shape of the shaded map appear very clearly.

Even Spacing (8)

Clicking in the box next to Even Spacing will toggle the spacing settings for the map. If Even Spacing is set as “on” the distance between lines on both axis is set to a fixed value regardless of the values associated with each axis. This makes it easier to select a point as they are never very close together.

If this option is set as “off” (no tick in the box) the spacing of the lines will reflect the values that you have set up for each axis.

Follow Mode (9)

If Follow Mode is set to off you can manually select and alter any point on the map. If it is switched on (and your Megasquirt-2 is connected and your engine running) the selected point will always reflect your engine position. For live tuning it is usually useful to have this setting set to on.

Map Gauge Cluster (10)

The Map Gauge Cluster will display an appropriate array of gauges to display your engine's behavior which may
be useful during live tuning. Right-clicking on this gauge cluster will display a pop-up menu from which you can customize the cluster. This menu is very similar to the menu for TunerStudio’s main gauge cluster which is documented in section 2.6.

Help (11)
Clicking this menu item will allow you to select the embedded “3D Table Usage” help file within TunerStudio. This provides further support for how to use these screens which can be used alongside this guide.

3D Map Hot Keys
There are a number of keyboard shortcuts that can be used to make changes to a 3D Map. These are briefly described as follows:

**Up, Down, Left and Right Arrows** – Allow you to move the selected point.

**Increase & Decrease Z values:**
- **Shift + (Up or Right) keys** – Increment selected point by 1;
- **Shift + (Down or Left) keys** – Decrement selected point by 1;
- **(> or . or q or + or =) keys** – Any of these will increment the selected point by 1;
- **(< or , or w or -) keys** – Any of these will decrement the selected point by 1;
- **CTRL + (Up or Right or > or . or q or + or =) keys** – Increment the selected point by a user defined value (the default increment is five);
- **CTRL + (Down or Left or < or , or w or -) keys** – Decrement the selected point by a user defined value (the default decrement is five).

**G** – Moves the selected point to the current active position.

**F** – Toggles Follow Mode on and off.

**M** – Increases the Yaw Angle of the table by 10 degrees.

**K** – Decreases the Yaw Angle of the table by 10 degrees.

**N** – Increases the Roll Angle of the table by 10 degrees.

**J** – Decreases the Roll Angle of the table by 10 degrees.

**Z** – Shows a top down view of table.

3D Map Menu Options
Right-clicking on the map itself will display a pop-up menu which allows you to further customize the appearance and behavior of the map. These are covered briefly below.

**Smart Select Movement** – When on (the default setting), the arrow keys will alter the selection direction so that the right key will always move to the next point on the right, left to the next point on the left, and so on relative to the position of the map as it is displayed. If this is set to off, the up and down keys will always along the Y axis, and the left and right keys will always move along the X axis regardless of the maps visual position.

**Show Active Table Values** – When on (the default setting) the values for the Z-axis (height) for both the selected and active points will be displayed on the grid.

**Show Selected X & Y Values** – This is off by default, but if set to on the selected X & Y values will be displayed along the appropriate axis.

**Increment All Active Cells** – This is off by default, but if set to on this only effects adjustments made using Follow Mode with your Megasquirt-2 connected and your engine running. In this scenario increments of Z values (height) will be applied to all table values that are currently active with a weight above the set value. This allows adjusting up to four map values (3D cells) at once if they are close enough to the active point. When set to off only the selected point will be adjusted.

**Active Weight Threshold** – This is only enabled if Increment All Active Cells is set to on. It allows for changing the weight used to determine what table values (3D cells) are adjusted. Valid values are 0% to 100% where 0% will allow up to four points to change, whilst 100% will only allow one point to move (assuming that value was matched perfectly by the engine outputs.)
**Select Active Color** – Allows you to change the color of the Active Point and Active text. By default the Active Point and text will be blue as described above.

**Select Selected Color** – Allows you to change the color of the Selected Point and Selected text. By default the Selected Point and text will be red as shown in the above example screen.

**CTRL Increment By** – As discussed in the Hot Keys section, when holding down the CTRL key whilst adjusting table values, you can increment or decrement values in steps greater than one (the default is five). This option allows you to change this multiple to a value other than five.
2. File Menu

The File Menu, the first item in the top menu, allows you to:

- Create, open and close Projects;
- Open, close and manage tune (.msq) files;
- Make changes to the gauge cluster;
- Choose whether to work online or offline;
- Exit TunerStudio.

2.1. Project

TunerStudio requires a number of key files in order to work with (and allow you to change) the raw data held in your Megasquirt. Many of these key files are held within a project directory.

Tip: TunerStudio does have the ability to open an .msq file without opening a project (allowing you to review settings from that tune). To do this, TunerStudio uses a temporary project which will not enable communications. This means that you should **always** create or open a project if you intend to connect to and configure your Megasquirt with an .msq tune file.

2.1.1. New Project

You can create a new project either from the start screen or from the main screen. The only difference is that from the start screen you need to select File > New Project, whilst from the main screen you need to select File > Project > New Project. Either will display the first “Create New Project” screen as shown below:
**Project Name**

In the Project Name box you can give the project any name using characters allowed by your operating system. Unless you change it manually, the Project Folder will also assume this name.

**Project Folder**

The “Project Directory” entry does not normally need to be changed. Depending on your operating system your project will be created in:

- Using Windows: Documents\TunerStudioProjects\ or My Documents\TunerStudioProjects\...
- Using Linux or OS X: [your directory path]/TunerStudioProjects/

**Firmware**

You need to ensure that you have the correct firmware for your Megasquirt associated with your project. Unless you want to test a development (beta) version it is recommended that you use the latest stable version of the firmware, which can be downloaded from [http://www.msextra.com/downloads.html](http://www.msextra.com/downloads.html). This manual corresponds to the stable version of the firmware shown on the front page.

To use the latest version you may need to update your Megasquirt. Information about how to do this is available in the Setting Up manual.

If you do need to update your firmware make sure that during the update you select the appropriate version according to your Megasquirt. Different versions exist for MS2 (the standard Megasquirt-2), MicroSquirt, MicroSquirt Module and MSPNP2.

The firmware version can be changed after your project has been created (see Section 2.1.6.)

Firmware selection can be accomplished in three ways. The recommended approach is to use the “Detect” process which will automatically retrieve the firmware version from your ECU. This isn't always possible for various reasons – e.g., you may be having problems with your ECU connection or be using a beta version of the firmware. In these cases you can use one of the alternative methods to selecting your firmware. The various methods can be carried out as follows:

**Detect**

To use this option you must have your Megasquirt powered up and connected to your computer. If your Megasquirt is connected to your engine it is recommended that you use Key On Engine Off (KOEO), i.e., with power to the ECU but without the engine running. You can alternately power up your Megasquirt by any other appropriate power source. Once this is done click the “Detect” button. TunerStudio will attempt to identify the firmware on your controller and select the appropriate firmware file for your Controller.

When you click the Detect button a “Detect Device” screen will appear whilst TunerStudio will attempt to find your Megasquirt and its firmware version. If successful it will list your product, firmware version and Baud rate. Check that these are correct and then click “Accept” to continue. If the “Detect Device” screen reports “No controller found” check the power and computer connections and try again. If this still does not resolve the problem move on to the “Other / Browse” method described below to set the firmware up manually.

If your ECU is identified correctly, clicking “Accept” will load the necessary configuration file to match your firmware version and you can now move on to the Project Description described later in this section.

If your ECU is identified correctly but clicking “Accept” displays a message that reports “TunerStudio does not have a configuration to support the found hardware” then it is likely either that you are running an older version of TunerStudio, or you are running a beta version of the firmware. If you are running an older version of TunerStudio you should upgrade to the latest version. If you are using a beta version of the firmware you will need to use the “Other / Browse” method described below to set up your firmware configuration manually.

**Other / Browse**
This method is recommended only if you are not able to connect to your Megasquirt, or if you are using a beta version of the firmware.

The firmware on your Megasquirt may have been provided on a disk or downloaded as a .zip file from the msextra.com Internet site. If you have downloaded your firmware and haven't done so already extract the contents of the zip file to a directory of your choice. The configuration settings for TunerStudio are the ".ini" file within the firmware folder. Note that you need to have the Windows setting "Hide known extension types" disabled to correctly see this file.

Clicking in the box next to “Other / Browse” opens a screen which lets you browse to your firmware folder. From here you should be able to select the .ini file that you want to use. It is essential that you use the .ini file that is appropriate for your Megasquirt. There are four .ini files to choose from within each version of the firmware:

- megasquirt2.ini – used for the MS2 controller.
- microsquirt.ini – used for the Microsquirt controller.
- ms2pnp.ini – used for the MS2PNP controller which is a derivative of the Microsquirt Module.
- microsquirt-module.ini – used for the generic Microsquirt Module controller (if you have purchased a proprietary Megasquirt-2 product based on the Microsquirt Module it is worth contacting the manufacturer to confirm which firmware version you should use.)

Select the file that is appropriate to your product. Now move on to the Project Description described later in this section.

Show Advanced / Offline Setup

This is the most complex and least desirable method of selecting your firmware, and should only be used as a last resort by experienced Megasquirt-2 users. To use this option you must know the firmware signature which is rarely the same as the firmware version!

Check the “Show Advanced / Offline Setup box to display the “ECU Definition” drop down box in place of the firmware label box. If you know the signature select it from this list. If you do not see the signature for your firmware (or have any doubts about which ECU definition you should use) you are strongly advised to establish a connection to your Megasquirt and use “Detect”, or to download an appropriate firmware version and use the “Other / Browse” method described above.

Project Description

This is not a required option, but it can be useful if you use a large number of projects and are creating a project for a specific purpose. Enter any information that will help you to identify the project for your own use. This entry can be changed after you have created your project.

Once these settings are complete, clicking “Next” will take you to the second “Create New Project” screen as shown below:
Verify that what they are configured to match your set up. If you are unsure the default values are likely to work well. These settings can be changed after your project has been created.

Clicking “Next” will take you to the third “Create New Project” screen as shown below:
This screen allows you to select the driver type and connection settings to connect your Megasquirt to your computer.

**Driver**

From the “Driver” drop down box, select the appropriate driver type that you use to connect to your Megasquirt. This setting is usually “RS232 (Default)”.

**Port**

From the “Port” drop down box, select the COM port that your computer is using to connect to your Megasquirt-2. This is usually COM1, but if your computer has multiple connections to other serial devices it could be COM2, COM3, etc.

You can change the COM port that you use to connect to your MS2 through Device Manager in Windows. Depending on the version of Windows that you are using, Device Manager can usually be accessed via the System settings in Control Panel. Alternately, typing “devmgmt.msc” in the Run option of the Start Menu or from a command prompt will open Device Manager in most versions of Windows.

Expanding the Ports (COM and LPT) entry in Device Manager should display a screen similar to that shown below:

![Device Manager](image)

Like almost all of the images in this manual, this image is taken from a Windows 8.1 screen capture. In other versions of Windows the screen may look slightly different.

Right clicking on the port to which your Megasquirt-2 is connected, and clicking “Properties” will display the Properties screen for that port.

Clicking on the second tab (Port Settings) should display a screen similar to that shown below:
Clicking the “Advanced” button should show a screen similar to that shown below:

![Advanced Settings for COM1](image)

Using this screen you can change the COM Port Number for the port connected to your Megasquirt. If you want to use COM1 and another device is already using COM1, you will need to change the settings for that other device before setting up the port for your Megasquirt. The Latency Timer should be set to the minimum value (1).
To avoid conflicts, make sure that there is no other device using COM1 before you select this setting!

**Baud Rate**

All Megasquirt-2 products use a baud rate of 115200. If you do not set the baud rate to 115200 you will not get a successful response when attempting to connect to your product.

Although it is extremely unlikely that you would need to do it, it is theoretically possible to set your Megasquirt to connect at a lower baud rate (see Section 5.1.) although it is not generally recommended.

**Test Port**

Once you have entered the above settings, make sure that your Megasquirt is connected to your computer and powered up and click “Test Port”. If the settings are correct you should be able to establish a connection. If not confirm that the product is powered up and connected, and recheck your settings.

It is strongly recommended that you create your project with your Megasquirt connected and powered up and using Detect and Test to be certain that your project is correctly configured. It is not, however, essential to complete this test in order to create a project. If you create a project without your Megasquirt connected you can run both Detect and Test later from the Communications Menu (see Section 5.1.)

Clicking “Next” will take you to the final “Create New Project” screen shown below:

TunerStudio MS Lite will always load the Default dashboard whenever a project is opened.

For the above reason, this screen is only really useful if you are running the Upgrade version of TunerStudio and so it is recommended that you leave the dashboard set to “Default”.

(c) 2014-8 James Murray 2018-07-08
Clicking “Finish” will complete the creation of your new project. Any current project will be closed and the new project will be opened and ready to use.

2.1.2. Open Project

You can open a project either from the start screen or from the main screen. The only difference is that from the start screen you need to select File > Open Project, whilst from the main screen you need to select File > Project > Open Project. Either will display the Open Project screen as shown below:

![Open Project Screen]

By default the “TunerStudioProjects” directory will be selected, although you can browse to another location if you have saved a project elsewhere. To open a project simply select it from the list and click “Select”. If you already have a project open and your tune is unsaved you will be prompted to save it before that project is closed. The project that you have selected will then be opened.

2.1.3. Close Project

As you might expect, clicking File > Project > Close Project will close the existing project. You will be prompted to save any changes to your tune file if any changes have been made. You will then be returned to the TunerStudio Start Screen.

2.1.4. Export Project Archive

⚠️ This is a feature of the Upgrade version of TunerStudio and is documented for reference only.

The Open Project screen lists projects rather than project files. In reality, each project is made up of a group of directories each containing a number of files required for the project.

In order to backup a project, or move it from one computer to another, the recommended method is to use the Export Project Archive feature.

From the top menu, clicking File > Project > Export Project Archive will display a dialog which will allow you to save all of the attributes and settings associated with the project into a single TunerStudio file with the .tsproj file extension. The process of restoring a project from this file is covered in the next section.

2.1.5. Import Project Archive

You can import a project either from the start screen or from the main screen. The only difference is that from
the start screen you need to select File > Import Project Archive, whilst from the main screen you need to select File > Project > Import Project Archive. Either will display the Import Project Archive screen as shown below:

Clicking on the .tsproj file that you want to restore and clicking save (to save it into a complete project folder structure) will prompt a second dialog as shown in the image below:

Be careful if you want to extract an archived project and you have another project with the same name. TunerStudio MS Lite will ask you if you want to overwrite any project with the same name, but it is good practice to make sure that any existing project with the same name is backed up.

Once you have selected the name for your project, and accepted that any other project of the same name will be overwritten, the project will be extracted. You will then be asked if you want to open the imported project.

### 2.1.6. Project Properties

As discussed in Section 2.1.1 (New Project) it is possible to change a number of the settings for each project after it has been created.

From the top menu, clicking File > Project > Project Properties will display the Project Properties screen. This has three tabs. The first tab (configuration) is shown below:
From this screen both the firmware version and the Project Description can be changed. If you were unable to use “Detect” to determine your firmware version from your Megasquirt-2 product when you created your project you can do so now if you have your product connected and any connection issues resolved.

The second tab (Settings) is shown below.
As discussed in Section 2.1.1, the contents of this tab will depend on the version of the firmware that you are using. The default settings should be expected to work with your Megasquirt, but they can be changed at any time as required.

The Third Tab (CAN Devices) is shown below:

CAN Devices are technical. You can skip the remainder of this section if you are not using an expansion board.

The CAN Devices tab has two main functions: Managing the “Project Main Controller” for the project; and managing “CAN Devices” (which are expansion boards.) The Main Controller will be (under almost all circumstances) your Megasquirt.

**Main Controller CAN ID**

Main Controller CAN ID is a setting that is almost always set to 0. This setting must match the corresponding setting within the CAN Parameters screen (see Section 15.1.)

**Do not change this setting unless specifically directed to by your vendor.**

**Serial Protocol**

The Serial Protocol setting is almost always set to “Firmware Default” and should only be changed by very experienced Megasquirt and TunerStudio users. For reference, the options for this setting are:

- **Firmware Default** – use the serial protocol that is specified in the firmware supplied ‘ini’ file.
- **Force – MS3 1.1+** - overrides the .ini (firmware) file and forces the CRC checked protocol. This protocol is used on MS2/Extra 3.3.x.
- **Force – Standard MS2 and MS3 1.0** - overrides the .ini (firmware) file and forces the older non error-
checked protocol. This protocol is used by older MS2 firmwares and some add-on devices.

**CAN Devices**

The CAN Devices section of this tab allows you to join expansion boards into your project. For example, if you have a JBperf IO-extender board connected to your Megasquirt-2, then you could use TunerStudio to collect additional sensor data from the IO-extender at the same time as collecting engine data from your Megasquirt. This is called “CAN pass-through” - TunerStudio is communicating with the expansion board with the data passing through the Megasquirt.

Note that the Megasquirt-2 will not see this remote data itself – it is simply being sent through to TunerStudio. To configure your Megasquirt to use the data from an additional board use the CAN Parameters screen (again, see Section 15.1.)

An example of a CAN Device configuration is shown below:

Many of the settings in the CAN Devices section should be provided by the vendor of your expansion board. The general settings for the options for this sections are as follows:

+ – adds an additional CAN device (expansion board) to your project.

x – removes a CAN device from your project.

**Up and Down Arrows** – will move the selected CAN Device up and down the list.

**Device Identifier (short)**

This is an abbreviated name for the selected CAN device.
Device description
This is a longer name that you choose for the selected CAN device.

Disable Runtime data
This option determines whether TunerStudio collects live runtime data (sensor data) from the CAN device. This will almost always need to be enabled. Leaving the box blank will allow you to configure the remote device through the settings menus, but will not fetch live data.

Device CAN ID
This must be set to match the CAN ID set on the CAN device. Each device on the CAN network must use a different CAN ID.

Device configuration file
Use the button containing three dots [...] to Browse for the .ini file supplied by the CAN device vendor.

Configuration settings
Any settings specific to this CAN device can be configured here as required. These work in the same way as the Project Properties -> Settings for your Megasquirt.

2.2. Tune Restore Point Dialog

This is an optional feature of the Upgrade version of TunerStudio which allows a range of restore points to be established and quickly restored. With TunerStudio MS Lite, using Save Tune As (see Section 2.5.) is the recommended method of backing up your tune files. Open Tune (see Section 2.3.) is the recommended method of restoring a tune file with this version of the software.

2.3. Open Tune

A tune file (using the file extension .msq) contains all of the settings for a specific configuration for your Megasquirt. Depending on the various performance profiles you may require at different times you can save multiple tune files for each project.

When TunerStudio connects to your Megasquirt it automatically fetches the current tuning settings and allows you to live tune online. You do not need to use Open Tune to do this.

Open Tune is used to open and view an existing saved tune. Optionally you can write this tuning data onto your Megasquirt.

Default tune files are included in the tune_files directory of the zip file for each firmware version. These can be used to start a tune offline.

TunerStudio will prompt you if you load a tune file which is incompatible with the firmware version that you are using, but in most cases you will be able to load in old settings. TunerStudio will report any problems it finds as warnings or errors. Each of these should be reviewed.

You can open a tune file by clicking File > Open Tune (msq). This will display the Open Tune screen as shown below:
Usually Tune files are saved and opened from the project directory, and so by default the directory for the current project is shown. Usually you will open Tune files from this directory to work with your current project. There are three possible exceptions to this:

- If you have downloaded and extracted a new version of the firmware you can browse to the tune_files directory within the firmware folder structure and open the default tune for your Megasquirt.
- From time to time you may have multiple projects using the same firmware and Megasquirt and it is perfectly acceptable to store and open tune files from a separate directory.
- As can be seen in Section 3.6. of this guide (Preferences) it is possible to choose from the Options Menu to automatically load and save the current tune. The advantages and disadvantages of this option are discussed in more detail in section 3.6, but if this option is selected there is usually only a need to use Open Tune in order to restore a backup of a tune file.

### 2.4. Save Tune

As discussed in the previous section, TunerStudio includes an option to automatically load and save the current tune. If you are using this option tunes will be saved automatically and you will not need to use Save Tune.

If you are not using this option, you will need to save your tune file manually. Clicking Menu > Save Tune will ensure that any changes you have made to your configuration are saved. When you close a project or exit TunerStudio you will be prompted to save any changes if you have not already done so.

### 2.5. Save Tune As

Save Tune As allows you to save your tune to an external file. This is a useful feature as means that you can backup a range of different tunes as you experiment with the configuration options.

Clicking Menu > Save Tune As will display the Save Tune As screen. From here you can choose a name and location for your tune file. For convenience it is usually recommended that you save each tune file in the directory of the project that you are using, although there is no reason that tune files cannot be stored in any folder or external disk.

It is STRONGLY recommended to use Save Tune As each time before you make configuration changes so you have a set of known working tunes. You should also use this to create a unique tune file (MSQ) before uploading to the support forum.

### 2.6. Gauge Cluster
The main gauge cluster is more fully documented in Section 17. Within the File > Gauge Cluster Menu there are four sub-Menu Options which are documented in Sections 2.6.1. to 2.6.4. below. You may notice that once you have clicked on one of the eight gauges in the gauge cluster of the main screen a number of additional items appear within the Gauge Cluster entry of the File Menu. This is largely for convenience in terms of making TunerStudio work on a wide range of operating systems. For details of these additional menu items please refer to Section 17.

2.6.1. Background
Selecting File > Menu > Gauge Cluster > Background displays four options as outlined below:

Set Background Color
This setting allows you to set the background color of the screen on which the gauges are displayed. This setting is not saved when you close your project or exit TunerStudio MS Lite.

Set Background Dither Color
This setting allows you to set the background dither color of the screen on which the gauges are displayed. This setting is not saved when you close your project or exit TunerStudio MS Lite.

Set Background Image
This setting allows you to set a background image to sit behind the gauges that are displayed. This setting is not saved when you close your project or exit TunerStudio MS Lite.

Image Position
If you have selected a background image that sits behind the gauges that are displayed, this option allows you to choose whether this image should be stretched to fill the screen, tiled to fill the screen or centered within the screen. Again, this setting is not saved when you close your project or exit TunerStudio MS Lite.

2.6.2. Antialiasing Enabled
This is an on/off option that allows you to choose whether the edges of the graphical gauges are smoothed or not. On most modern monitors and laptop screens this has a negligible effect.

2.6.3. Designer Mode
This is an Upgrade feature allowing the dash to be redesigned that is not available in TunerStudio MS Lite.

2.6.4. Gauge Demo
The gauge demo is intended to give an impression of the abilities of the gauge cluster. This option has two sub-Menu Options which start and stop the Gauge demonstration respectively.

2.7. Work Offline
This is an on/off option that allows you to make changes to your configuration without burning changes to your Megasquirt. This can be also be a useful feature if your Megasquirt experiences connection problem and goes offline, or is not available. Once you have finished working offline it is essential that you disable this option so that TunerStudio can again communicate with your Megasquirt.

When hibernating a laptop with TunerStudio still running, such as at the race track, it may be useful to select “Work Offline” before hibernating for a smoother experience after hibernation. Otherwise, some computers may not correctly find the serial device again on wake-up.
If you are working offline the dashboard will display an “Off Line” message across the screen. If you see this and your Megasquirt should be connected make sure that the Work Offline option is not enabled.

2.8. Exit

Selecting File > Exit completely closes TunerStudio. In the event that your tune requires saving you will be prompted to do so before the software exits. Closing TunerStudio using your operating system’s toolbar (e.g., the red close button on the top right of Microsoft® Windows®) will have exactly the same effect as File > Exit.

If you are updating your Megasquirt's firmware using the ms2loader_win32 application you must exit TunerStudio before you begin the firmware update. It is not possible for a Megasquirt to negotiate with the firmware updater and TunerStudio at the same time without causing errors.
3. Options Menu

The Options Menu, the second item on the top menu, allows you to:

- Customize the language used by, and the appearance of, TunerStudio;
- Customize how TunerStudio works.

3.1. Language

Clicking Options > Language gives you a list of the languages that TunerStudio supports.

⚠️ This guide, and most other Megasquirt guides, are only available in English at this time.

3.2. Look and Feel

Clicking Options > Look and Feel allows you to select from four options:

- Metal (Default)
- Nimbus
- CDE/Motif
- Windows

The choice of “Look and Feel” is entirely personal, and does not alter the layout or features of TunerStudio in any way.

⚠️ The images in this guide are all taken using the “Metal” look and feel. Although the content will not be different, the screens in the software will appear differently to the images in this guide if any of the other “Look and Feel” options are used.

3.3. Navigation

The “Navigation” options allow you to make other changes to appearance and behavior of TunerStudio.

3.3.1. Main Menu Style

Options > Navigation > Main Menu Style is a selectable option that means that both the top menu items and the toolbar button menus are combined and displayed as a single main top menu.

This has an advantage in that more of the screen is available for the visual instrumentation – i.e., the gauge cluster and diagnostics and high speed loggers (see Sections 17. to 19.) This option also makes it easier to use TunerStudio solely using a keyboard. The disadvantage is that the top menu becomes crowded using anything other than a very high resolution monitor.

3.3.2. Wrapping Main Menu

Options > Navigation > Wrapping Main Menu is a selectable option that means that both the top menu items and the toolbar button menus are combined and displayed as a single main top menu, but the contents of that menu are able to take up multiple lines.

Again this has advantages in that more of the screen is available for the visual instrumentation and TunerStudio can be easily used without a mouse. The disadvantage that the top menu becomes crowded is reduced using this option.
3.3.3. Toolbar Style
Options > Navigation > Toolbar Style is a selectable option that allows both the top menu items and the toolbar button menus are displayed separately. Whilst the room for the visual instrumentation is slightly reduced this is generally considered to be the easiest combination to use and this is the default layout.

⚠️ The images in this documentation are all taken with the Toolbar Style selected. Some of the content of the screens in the software will appear different to the images in this guide if a different layout is used.

3.3.4. Navigation Options
Options > Navigation Options > Show Disabled Menu is an on/off selection that determines if disabled menu items are displayed.

⚠️ The images in this document are taken with Show Disabled Menu switched on.

3.4. View
The “View” options allow you to show and hide some components of TunerStudio.

3.4.1. Show Gauges on VE Analyze
VE Analyze (VEAL) is an auto-tune feature of the Upgrade version of TunerStudio. Changing this option within TunerStudio MS Lite has no effect. The VEAL feature, whilst useful, is not a required feature in order to successfully configure your MS2.

3.4.2. Show Live Graphs on VE Analyze
VE Analyze (VEAL) is an auto-tune feature of the Upgrade version of TunerStudio. Changing this option within TunerStudio MS Lite has no effect.

3.4.3. Show Enable Condition in Menu Tooltips
This option enables “toolips” to be displayed when you hover the mouse over a disabled (grayed out) menu option. These tooltips can be extremely helpful as they indicate the changes you need to make in order to enable an option. This guide explains how to enable disabled options in more detail, but it is still strongly recommended that this feature is always enabled.

3.5. Advanced
The “Advanced” options provide two specific choices that you can make in terms of how you use the software.

3.5.1. Report INI Warnings
Options > Advanced > Report INI Warnings is an on/off option that determines whether the software prompts you if there are any errors within the firmware version that your project is using. This option is largely for the use of the firmware developers and therefore most users will prefer to leave it disabled.

3.5.2. Always Allow Multiple Instances
Options > Advanced > Always Allow Multiple Instances is an on/off option that determines whether you are able to easily run more than one copy (or “instances”) of the TunerStudio at the same time.

In general terms it is not a good idea to have more than one instance of the software attempting to connect to your Megasquirt at the same time, as this potentially allows conflicting information to be sent to your product.
For this reason it is **strongly recommended** that this option is always disabled.

There are times when it **may** be useful to have more than one instance of the software running at the same time – for example if you want to compare two tunes side by side whilst working offline. You are still able to do this with Always Allow Multiple Instances switched off although you will be prompted to confirm that you want to start a second instance of TunerStudio. If you choose to do this it is essential that no more than one of the instances is connected to your Megasquirt. You can use the “Work Offline” option (See Section 2.7.) to make sure that any other instances of the software are not connected to (and cannot cause conflict with) your Megasquirt.

### 3.6. Preferences

The “Preferences” options allow you to alter additional aspects of the behavior of the software.

#### 3.6.1. Set Dialog Font Size

Options > Preferences > Set Dialog Font Size allows you to choose the font size used throughout most of the software. It will alter the font size throughout TunerStudio with the exception of the top menu which has a fixed font size.

All images in this guide use the default dialog font size of 12. Screens will vary slightly with a different font size selected.

#### 3.6.2. Perform Difference Report on Connect

Perform Difference Report on Connect compares the configuration of your Megasquirt-2 with the configuration of your tune file. This can be useful if you have recently updated your firmware, or you want to restore an older tune created with an earlier version of the firmware. It is recommended that this option is enabled.

#### 3.6.3. Automatically Load and Save Current Tune

Options > Preferences > Automatically Load and Save Current Tune is an on/off option that gives you a choice of two very different ways of managing the tune file for your Megasquirt. **By default this option is enabled. when you install TunerStudio.** Feedback suggests that most users prefer to work with this option disabled, and so that is generally recommended, although if you are used to working with this option enabled there is no reason to change.

Since the use of this option is a matter of personal preference, the advantages and disadvantages of having this option enabled are briefly discussed below.

**Leaving Automatically Load and Save Current Tune Enabled (default setting)**

With this option enabled a tune file called “CurrentTune.msq” is created in the main folder for each project that you create. Any changes you make to your tune are automatically saved to this CurrentTune.msq file, which is also automatically loaded whenever you open your project. This means that your tune file is constantly available and up to date.

The downside of this option is that it is more difficult to keep track of backups, and it is more complicated to switch between tunes (as each backup needs to be loaded into CurrentTune.msq.) If you only use one tune file for each project, and you do need to regularly backup and restore, enabling this option may work well for you.

**Disabling Automatically Load and Save Current Tune**

If you disable this option you will need to open and save your tune files manually. This means that you will need to open and save tune files more often, although your latest tune will always be loaded from your Megasquirt whenever it is connected.

Whilst there is a little more opening and closing of files with this option disabled, it does give you more control in
terms of keeping track of changes, backups and the management of multiple tunes.

**Backing up Tune Files**

Regardless as to whether or not you have this option enabled, you are still **strongly recommended** to make regular backups of your tune file using the “Save Tune As” option (see Section 2.5.) It is also recommenced that you backup your tune to a flash drive, external disk or cloud storage on a regular basis.

### 3.7. Performance

The “Performance” options give you some choices in terms of how you want to use the software. These can effect the efficiency of TunerStudio and how it communicates with your Megasquirt.

#### 3.7.1. Gauge Float down on start

Options > Performance > Gauge Float down on start is a simple on/off option that determines whether the gauges in the gauge cluster are animated when the software starts. This option can be disabled without altering any other behavior of TunerStudio.

#### 3.7.2. Modal Dialogs

Options > Performance > Modal Dialogs is an on/off option that determines whether more than one of the screens displayed from the toolbar menus can be displayed at the same time. It is recommended that this option is usually enabled. Whilst this will restrict you to only being able to use one screen at a time, this is useful as it helps your Megasquirt-2 manage its memory more effectively which improves burn performance and will reduce “burn stumble”.

⚠️ There are times when it is useful to be able to view multiple screens from the toolbar menus so that you can review your tune. It is perfectly acceptable to disable Modal Dialogs and view multiple screens for review, analysis and troubleshooting. It is **strongly recommended** that you do not make changes whilst you have multiple windows open. It is **also recommended** that you close all of the open screens and re-enable Modal Dialogs before making further changes.

#### 3.7.3. Run in Lite Mode

Options > Performance > Run in Lite Mode is a feature of the Upgrade version which allows users to revert to the feature set of TunerStudio MS Lite. This option is not relevant to users of TunerStudio MS Lite and is disabled (grayed out) in this version of the software.
4. Data Logging Menu

The Data Logging Menu allows you to:

- Stop and Start logging data from your MS2;
- View your saved log files using the accompanying MegaLogViewer software.

4.1. Start Logging

Clicking Data Logging > Start will display the Start New Data Log screen as shown below:

This will prompt you to save a new TunerStudio .msl file which will contain the data that is logged from your Megasquirt. By default this file will be saved in the DataLogs directory within the current project directory, although you can choose to browse and save it elsewhere if you prefer. As soon as you click “Save” the software will start to log data from your Megasquirt into this new file.

⚠️ When data logging is running the “Data Logging” indicator label at the bottom of the gauge cluster will turn green.

4.2. Stop

Data Logging > Stop will cease data logging and the collated data file selected in the above section will be closed. Your data is now ready to be reviewed using MegaLogViewer.

⚠️ At this stage the “Data Logging” indicator label at the bottom of the gauge cluster will return to its usual color.

4.3. Logging Profiles

Data Logging > Logging Profiles is a feature of the Upgrade version of the software which allows customization of the data collected. The standard format used for data logging will be sufficient to analyze the data collected from your Megasquirt.

4.4. Automatic Logging

Data Logging > Automatic Logging is also another Upgrade feature and is not documented in this guide.
4.5. Import / Conversion

The “Import / Conversion” options allow data to be imported from two other sources:

4.5.1. PalmLog Import Utility

This option allows data collected using propriety third party hardware and applications which save to the PalmLog format to be converted into a format that can be viewed with MegaLogViewer.

Clicking Data Logging > Import / Conversion > PalmLog Import Utility will display the Target Data Log screen as shown below:

Once you have chosen the file that you want to save your data log to, the Palm Extract Utility screen will be displayed as shown below:

By following the options on this screen you will be able to produce a file that can be used viewed using MegaLogViewer.

4.5.2. Convert Binary Log (MS3, FRD)

Clicking Data Logging > Import / Conversion > Convert Binary Log (MS3, FRD) will display the Transform Raw DataLog screen as shown below:
MS3 data is not supported in this Megasquirt-2 version of TunerStudio. FRD files may possibly be accessible using proprietary 3rd party hardware and applications.

Following the options on this screen should produce a file that can be used viewed using MegaLogViewer.

### 4.6. View with MegaLogViewer

MegaLogViewer is an analysis application which accompanies TunerStudio, and for which a license is included along with your Megasquirt. **MegaLogViewer needs to be installed for this option to work.**


Complete documentation of MegaLogViewer falls outside the scope of this guide, although the key datalog fields that are relevant to your Megasquirt are documented in Section 4.6.1.

Clicking Data Logging > Import / Conversion > View with MegaLogViewer will display the Open Log File screen as shown below:
Selecting the data log file that you want to view and clicking “Open” will start MegaLogViewer with the data from your log file loaded in. A sample of the main MegaLogViewer screen is shown below:

From this screen you can review many of the sensor outputs and other readings from your Megasquirt. The “Quick View” graphs are especially useful and are easily customized using the options on the left hand side of the screen.
4.6.1. Megasquirt-2 MegaLogViewer Datalog Fields

Below are listed the main datalog fields for MegaLogViewer.

**Accel PW**
The current fuel pulsewidth adder due to acceleration enrichment.

**ADC6**
The raw ADC value from the spare analogue input 6 (JS5 / SPAREADC.)

**ADC7**
The raw ADC value from the spare analogue input 7 (JS4 / SPAREADC2.)

**AFR**
The current AFR reading from oxygen sensor 1. Useful for wideband sensors.

**AFR2**
The current AFR reading from oxygen sensor 2. Useful for wideband sensors.

**AFR load**
The “load” (e.g., MAP, TPS) used on the Y-axis of the AFR table.

**AFR target 1**
The current target value for AFR1, looked up from the AFR1 target table.

**Barometer**
The barometer reading. This will show a current value if a dedicated baro sensor is installed, the initial MAP reading, or 100kPa if barometric correction is disabled.

**Battery Voltage**
The measured battery voltage (if this is radically different from your actual battery voltage, check for wiring faults.)

**Boost Duty**
The current duty cycle output to the boost solenoid.

**Boost Target**
The target boost pressure for closed-loop mode.

**CL idle target**
The target engine speed for closed-loop idle control.

**Closed-loop idle RPM error**
The difference between actual rpm and target rpm for closed-loop idle control.

**Coolant Temp**
The measured coolant temperature (CLT).
Duty Cycle 1
The calculated injector duty cycle on channel 1 (85% is a recommended maximum, above 100% is impossible.)

Duty Cycle 2
The calculated injector duty cycle on channel 2.

Dwell
The ignition dwell (charge) time on the main spark outputs.

E85 Fuel Correction
The percentage multiplier to fueling due to the flex fuel sensor.

EAE1 %
The percentage multiplier to fueling due to Enhanced Acceleration Enrichment channel 1.

EAE2 %
The percentage multiplier to fueling due to Enhanced Acceleration Enrichment channel 2.

EAE load
The “load” (e.g., MAP, TPS) used on the Y-axis of the EAE curves.

EGO cor 1
The percentage fuel correction from AFR1 when closed-loop EGO control is used (100% means no change.)

EGO cor 2
The percentage fuel correction from AFR2 when closed-loop EGO control is used (100% means no change.)

EGT 6 temp
The ADC value converted to a temperature. This requires the custom installation of an EGT amplifier.

EGT 7 temp
The ADC value converted to a temperature. This requires the custom installation of an EGT amplifier.

Engine
This bitfield variable is a combination of binary bits about engine status. These are used to drive the engine status indicators:

<table>
<thead>
<tr>
<th>128</th>
<th>64</th>
<th>32</th>
<th>16</th>
<th>8</th>
<th>4</th>
<th>2</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>MAP decel enrichment</td>
<td>MAP accel enrichment</td>
<td>TPS decel enrichment</td>
<td>TPS accel enrichment</td>
<td>WUE active</td>
<td>ASE active</td>
<td>Cranking</td>
<td>Ready (active tach signal and pump running)</td>
</tr>
</tbody>
</table>

These values can be added together, e.g., 17 means Ready and TPS accel.
**Ethanol Percentage**
The calculated ethanol percentage in the fuel reported from the flex fuel sensor.

**Fuel: Accel enrich**
The current fuel pulsewidth percentage multiplier due to acceleration enrichment.

**Fuel: Air cor**
The percentage multiplier to fueling due to air density.

**Fuel: Baro cor**
The percentage multiplier to fueling due to barometric correction.

**Fuel: Total cor**
The total fuel percentage multiplier obtained by multiplying the other factors. If this is outside of the range 80%-120% then there is likely something wrong with your tuning settings.

**Fuel: Warmup cor**
The percentage multiplier to fueling due to Warmup and Afterstart (this should be 100% on a warmed up engine.)

**gpioadc0 – 7**
The raw ADC values captured from an optional expansion board over CAN.

**Ign Load**
The 'load' (e.g., MAP, TPS) used on the Y-axis of the ignition tables.

**InjTiming 1**
The injection timing used for all injector channels for the standard sequential/semi-sequential injection, for the semi-sequential Siamese injection mode, for sequential Siamese injection mode with a single timing value, and for sequential Siamese injection hybrid mode.

When using sequential Siamese injection mode with two timing values, this is the injection timing for cylinders 1 and 4 (outer cylinders).

**InjTiming 2**
The injection timing for cylinders 2 and 3 (inner cylinders) when using two timing values in the sequential Siamese injection mode.

**Knock In**
The signal value from an optional add-on knock sensor interface.

**Lambda**
The current lambda reading from oxygen sensor 1.

**Lambda2**
The current lambda reading from oxygen sensor 2.
Load
The primary "load" for fuel calculations (this is equal to MAP on typical speed-density installs.)

Lost Sync Counter
The count of "lost-sync" events. If the engine stalls the counter will increase by one. During startup it is acceptable to have a few lost syncs. If you see this counting up under other conditions there is a problem with your tach input.

Lost Sync Reason
A technical reason code for why the ECU lost synchronization with the tach input. Not particularly useful.

Mass Air Flow
The air-flow in g/sec calculated from the MAF sensor.

MAFload
A calculated "load" value that works similarly to MAP in a speed-density system, (makes for better use of the lookup tables.)

MAPdot
The rate of change of MAP (the increase in MAP per second.)

MAP
The measured MAP (on typical speed-density installs this should read close to 100kPa during key-on, engine-off and between 30kPa and 60kPa at idle.)

MAT
The measured intake manifold air temperature (MAT).

Nitrous Retard
The retardation to the timing due to the nitrous system.

O2
The voltage from oxygen sensor 1.

O2-2
The voltage from oxygen sensor 2.

On/Off outputs status bits
A bitfield indicating the status of the programmable on/off outputs.

PORTs AM, PORTs BDE, PORT T
Bitfields indicating the raw processor I/O – see Section .

portXX
These datalog fields record the raw status of the input/output pins on the microcontroller within the Megasquirt ECU. (Many of the inputs or outputs change too rapidly to be logged in a meaningful way.)
The layout in this manual is:
### PORTs BDE

<table>
<thead>
<tr>
<th>128</th>
<th>64</th>
<th>32</th>
<th>16</th>
<th>8</th>
<th>4</th>
<th>2</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>PTAD7</td>
<td>PTAD6</td>
<td>PORTB4</td>
<td>PE4</td>
<td>-</td>
<td>-</td>
<td>PE1</td>
<td>PE0</td>
</tr>
<tr>
<td>AD7/JS4</td>
<td>AD6/JS5</td>
<td>(IAC EN)</td>
<td>FP</td>
<td>-</td>
<td>-</td>
<td>PE1</td>
<td>PE0/JS7</td>
</tr>
<tr>
<td>SPAREADC2</td>
<td>SPAREADC</td>
<td>-</td>
<td>FP</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>FLEX</td>
</tr>
<tr>
<td>SPAREADC2</td>
<td>SPAREADC</td>
<td>(IAC EN)</td>
<td>FP</td>
<td>-</td>
<td>-</td>
<td>PE1</td>
<td>FLEX</td>
</tr>
<tr>
<td>Knock</td>
<td>Baro</td>
<td>(IAC EN)</td>
<td>FP</td>
<td>-</td>
<td>-</td>
<td>PE1</td>
<td>LAUNCH</td>
</tr>
</tbody>
</table>

### PORTs AM

<table>
<thead>
<tr>
<th>128</th>
<th>64</th>
<th>32</th>
<th>16</th>
<th>8</th>
<th>4</th>
<th>2</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>-</td>
<td>PM5</td>
<td>PM4</td>
<td>PM3</td>
<td>PM2</td>
<td>-</td>
<td>PA0</td>
</tr>
<tr>
<td>-</td>
<td>-</td>
<td>D15 / Spk C</td>
<td>D16 / Spk B</td>
<td>D14 / Spk A</td>
<td>FIDLE</td>
<td>-</td>
<td>JS11 / Spk D</td>
</tr>
<tr>
<td>-</td>
<td>-</td>
<td>WLED</td>
<td>ALED</td>
<td>TACHOUT</td>
<td>FIDLE</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>-</td>
<td>-</td>
<td>WLED</td>
<td>ALED</td>
<td>TACHOUT</td>
<td>FIDLE</td>
<td>-</td>
<td>PA0</td>
</tr>
<tr>
<td>-</td>
<td>-</td>
<td>Output 2</td>
<td>Output 1</td>
<td>TACHOUT</td>
<td>FIDLE</td>
<td>-</td>
<td>Boost</td>
</tr>
</tbody>
</table>

### PORT T

<table>
<thead>
<tr>
<th>128</th>
<th>64</th>
<th>32</th>
<th>16</th>
<th>8</th>
<th>4</th>
<th>2</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>PT7</td>
<td>PT6</td>
<td>PT5</td>
<td>PT4</td>
<td>PT3</td>
<td>PT2</td>
<td>PT1</td>
<td>PT0</td>
</tr>
<tr>
<td>IAC1</td>
<td>IAC2</td>
<td>JS10</td>
<td>Inj 2 PWM</td>
<td>Inj 2</td>
<td>Inj 1 PWM</td>
<td>Inj 1</td>
<td>Crank in</td>
</tr>
<tr>
<td>-</td>
<td>-</td>
<td>IGN</td>
<td>IGN 2</td>
<td>Inj 2</td>
<td>Cam in VR2</td>
<td>Inj 1</td>
<td>Crank in VR1 or Opto</td>
</tr>
<tr>
<td>PT7</td>
<td>PT6</td>
<td>IGN</td>
<td>IGN 2</td>
<td>Inj 2</td>
<td>Cam in VR2</td>
<td>Inj 1</td>
<td>Crank in VR1 or Opto</td>
</tr>
<tr>
<td>InjectorD</td>
<td>InjectorC</td>
<td>IGN</td>
<td>IGN 2</td>
<td>Inj 2</td>
<td>Cam in</td>
<td>Inj 1</td>
<td>Crank in</td>
</tr>
</tbody>
</table>

### PW
The fuel pulsewidth for injector channel 1 (this is the actual electrical pulsewidth including deadtime.)

### PW2
The fuel pulsewidth for injector channel 2.
PW3
The fuel pulsewidth for injector channel 3.

PW4
The fuel pulsewidth for injector channel 4.

PWM Idle Duty
The current duty cycle output to the idle valve.

RPMdot
The rate of change of RPM (the increase in RPM per second.)

RPM
The tachometer / rev counter (if this is dropping to zero or bouncing around, you probably have a problem with the tach-in signal.)

SecL
A built in clock that counts up seconds since the Megasquirt was last turned on. If this suddenly resets to zero, you probably have a power connection problem.

Secondary Ign Load
Like “Ign Load” but used for the secondary lookup table.

Secondary Load
Like “Load” but used for the secondary lookup table.

SPK: Base Spark Advance
The spark timing/advance looked up from the ignition table before other adjustments are made.

SPK: Cold advance
The advancement to the timing due to the cold advance curve.

SPK: External Advance
The external advancement to the timing, e.g., from a transmission controller.

SPK: Flex Advance
The advancement to the timing due to flex fuel.

SPK: Idle Correction Advance
The advancement to the timing due to idle correction.

SPK: Knock Retard
The retardation to the timing due to knock control.

SPK: MAT Retard
The retardation to the timing due to the MAT retard curve.
SPK: Revlim Retard
The retardation to the timing due to the rev limiter.

SPK: Spark Advance
The overall ignition advance.

SPK: Spark Table 1
The looked up spark advance from ignition table 1.

SPK: Spark Table 2
The looked up spark advance from ignition table 2.

SPK: Spark Table 3
The looked up spark advance from ignition table 3.

Status1
This bitfield variable is a combination of binary bits used to drive dash status indicators:
  1 = Need Burn – tuning data has been sent to the ECU, but not permanently saved to flash;
  2 = Lost Data – tuning changes were lost without being saved to flash;
  4 = Config Error – there is an error in your settings which needs fixing;
  8 = Not synced / Synced – whether the Megasquirt is synchronized to the crank and cam signals;
 32 = Fuel Tbl sw – fuel table switching in effect;
 64 = Spk Tbl sw – ignition table switching in effect;
128 = Half-sync / Full-sync – whether the Megasquirt is fully synchronized with cam-sync.

Status2
This bitfield variable is a combination of binary bits used to drive dash status indicators:
  1 = N2O 1 – nitrous stage 1 output;
  2 = N2O 2 – nitrous stage 2 output;
  4 = Hard limit – hard rev limiter in effect;
  8 = Launch – launch in effect;
 16 = Flat shift – flat shift in effect;
 32 = Spark cut – spark cut in effect;
 64 = Over boost – boost limiter in effect;
128 = CL idle – closed-loop idle control active.

Status3
This bitfield variable is a combination of binary bits used to drive dash status indicators:
  1 = Fuel cut – fuel cut in effect;
  2 = T-log – tooth/trigger/composite log ready (for TunerStudio internal use);
  4 = MAPsample error! – something is wrong with your MAP sample settings;
  8 = Test mode – spark / injector test mode is active;
32 = Soft limiter – soft rev limiter in effect;  
64 = Seq. Shift – sequential shift control active.

**Status 4, 5**  
Only used by developers.

**Stepper Idle position**  
The current stepper valve position (0 means fully closed.)

**Time**  
TunerStudio maintains a time since it was started and records this is the datalog. The time is shown at the bottom of the graph area. When discussing datalogs, be sure to refer to this time (e.g., look at 145s in the log where...)

**timing err%**  
A calculation of how accurately the position of the next tach tooth was predicted. Not very useful.

**TPSdot**  
The rate of change of TPS (the increase in TPS per second.)

**TPS**  
The 0-100% throttle (pedal) position (check the calibration settings if you do not get 0-100%)

**VE1**  
The looked up VE value for channel 1.

**VE2**  
The looked up VE value for channel 2.

**VE Trim 1**  
The percentage trim multiplier to fueling on injector 1.

**VE Trim 2**  
The percentage trim multiplier to fueling on injector 2.

**VE Trim 3**  
The percentage trim multiplier to fueling on injector 3.

**VE Trim 4**  
The percentage trim multiplier to fueling on injector 4.

**WallFuel1**  
The calculated fuel puddle volume on the intake port walls, channel 1.

**WallFuel2**  
The calculated fuel puddle volume on the intake port walls, channel 2.
5. Communications Menu

The Communications Menu is used to set up and test communications between your computer and your Megasquirt. It will be useful if you are having problems connecting to your Megasquirt, or if you need to used an advanced setting.

Using many of the options within the communications menu will temporarily close the connection between your computer and your Megasquirt. This is normal and necessary for these options to work effectively. TunerStudio should reconnect to your Megasquirt again automatically after the communications screen you have been using has been closed. If this doesn't happen reopen the screen and carefully check any changes that you have made.

5.1. Settings

Clicking Communications > Settings will display the Communications Settings screen as shown below:

This screen is virtually identical to the third of the Create New Project screens (See Section 2.1.1.) Please refer to that section for most of the settings options shown on this screen.

The only real addition is the “Detect” button. This will scan your computer for Megasquirt products which can be helpful if you have changed the way that you are connecting to your Megasquirt and need to update the communications settings for your project. It is also helpful if you were having problems connecting to your Megasquirt whilst creating your project.

You may see two Megasquirt devices listed with JSSC and RXTX. RXTX will use the default legacy driver and is the correct device to use at this time. RXTX is an older communications technology that will probably be phased out in the future, but remains current at the time or writing.

5.2. Data Rate

Clicking Communications > Data Rate will display the Set Data Rate screen as shown below:
As a general rule 15 Reads Per Second is the preferred setting. If you connect using a slower connection type such as bluetooth your actual data rate may be lower.

5.3. Enable GPS Support

GPS is not supported by default with Megasquirt-2, although it can be integrated using additional hardware. GPS support is only included in the Upgrade version of TunerStudio.

5.4. Mini Terminal

The Mini Terminal is a command line interface that can be used to interrogate your Megasquirt. Normally use of this terminal is restricted to diagnostics and support provided by Megasquirt technical experts.

Clicking Communications > Mini Terminal will display the Mini-Term screen as shown below:
As simple example of how Mini Terminal works is as follows: With your MS2 connected and powered up, typing “S” into the top half of the screen should display the version of your Megasquirt and the firmware that it contains as shown below:

The other commands that can be used with Mini Terminal fall outside the scope of this guide.

5.5. Debug Log Comm

Your TunerStudioProjects file will contain a file called “TunerStudioAppDebug.txt”. This is TunerStudio’s internal log file which is created when the software is first installed and is updated whenever TunerStudio is used. This file is extremely useful for technical support in the event that you should experience problems with TunerStudio.

Occasionally it is useful for those providing TunerStudio support to obtain a more detailed log file to carry out troubleshooting. The Debug Log Comm option is an on/off setting which can be enabled or disabled by clicking Communications > Debug Log Comm. When enabled, this option instructs TunerStudio to write much more detailed information to the TunerStudioAppDebug.txt file.

⚠️ Do not enable this option for any length of time or it will turn into a very large file very quickly. As a rule this option should only be enabled for a short period of time either at the request of a support technician, or for your own use if you have a good knowledge of the contents of the log file.

5.6. Megasquirt Baud Rate

Section 2.1.1. of this guide (New Project) details that for almost all Megasquirt-2 installations the baud rate should be set to 115200. The baud rate can theoretically be set to a lower level although this is generally not desirable and should only be done by advanced users under exceptional circumstances.

Clicking Communications > Megasquirt Baud Rate will display the Megasquirt baud rate screen as shown below:
Under no circumstances can a Megasquirt-2 operate at a rate above 115200, any attempt to set it to a higher value will cause the connection to your MS2 to fail. Whilst 115200 is optimal, your Megasquirt-2 can (if absolutely essential) be set to run at a baud rate of 57600, 38400, 19200 or 9600.

To set your baud rate to a lower rate than 115200 carefully follow these five steps:

- Set the reduced baud rate using the above screen and click “Close”;
- Click Communications > Settings and display the Communications Settings screen;
- Under Baud Rate select exactly the same value you entered in the Megasquirt baud rate screen;
- Click “Accept”;
- Power off and then restart your MS2. It should now connect at the reduced rate.

These steps must be carried out in the order outlined above for the change to work correctly!
6. Tools Menu

The Tools Menu contains a range of options. Of these, the options you are most likely to use are the calibration options which are an important component of your Megasquirt configuration.

Megasquirt-2 uses internal calibration tables to convert the resistance/voltage from the input sensors into a real world number. It is necessary to setup this calibration so the inputs read correctly. The built-in calibrations for coolant temperature (CLT) and air temperature (MAT) are for GM sensors, so if you have GM sensors you are safe to leave these alone. All installs should set the calibration for the AFR (air fuel ratio) table that is used for the oxygen sensor (lambda sensor) whether narrowband or wideband.

6.1. Protocol Stats

Protocol Stats are generally used by developers and for technical support. This feature lies beyond the scope of this guide.

6.2. Update / Install Firmware

This offers a 'wizard' style function to easily update or install the embedded firmware on your ECU.

This firmware loader is highly recommended instead of the previous 'DOS' style loader.

If you have an existing tune on your ECU you must be sure that you have a copy of it. It is strongly recommended that you save a copy using File > Save Tune As in TunerStudio.

Before starting, you will need some new firmware to load. This may be supplied to you by your ECU supplier or can be downloaded from www.msextra.com/downloads.

Connect your serial cables and power-on your ECU. Open TunerStudio. If you are upgrading, then open your existing vehicle project.
From the Tools menu, select Update / Install Firmware.

Pick your serial connection, then Next.

Note that TunerStudio may find a connection as both a D2XX device and an RS232 device; the D2XX connection is simply a newer driver version for USB adapters and is the preferred method if connecting over USB.
Tick the box for Other/Browse and then browse the file system on your computer to find the firmware zip file. If you just downloaded it, it will probably be in your "Downloads" folder.

Click Open, then Next on the previous screen.
On this screen it is very important to ensure you have selected the firmware variant that matches your actual ECU. TunerStudio will try to figure this out and recommend the correct one, but you MUST check it is correct!

After highlighting the correct option, click Next.
You'll then be stepped through license and readme information screens.

(c) 2014-8 James Murray 2018-07-08
After accepting the license terms and passing through the readmes, you'll reach this screen.

In this example, we are loading firmware to a fresh 'blank' processor, so be sure NOT to Preserve Sensor Calibrations as there is nothing to preserve.

When loading firmware to a 'blank' processor, the firmware loader has an additional step of loading a bootstrap loader. Follow the on-screen instructions.
After clicking Next, the firmware will start loading.

If this takes longer than a minute then you probably didn't adjust the FTDI latency setting on your USB-serial adapter.

In rare cases, the first time you install firmware it might be necessary to use the boot jumper. For MS2 or Microsquirt-module - apply the shunt to the B/LD pins on the card. For Microsquirt, connect the "BOOTLOAD" wire to ground.

When the loading process has completed, you can click Finish.
If it can, TunerStudio will try to load your tune and settings back into the ECU.

If this is a first load, you are now ready to continue by creating a project and configuring the ECU for your engine, head back over to the Setting Up Manual for more instructions.

If this was an upgrade you need to reload your tune and check through the "gotcha" items highlighted during the load process.

Always recheck your settings and verify your sensors are reading correctly after loading new firmware.

6.3. TunerStudio Plug-ins

TunerStudio Plug-ins are additional modules which are created at community level and can be used to add additional features to TunerStudio. Plug-ins are only available within the Upgrade version of TunerStudio. Any documentation for Plug-ins should be provided by their developers.

6.4. Calibrate TPS

The Calibrate TPS option allows you to calibrate your throttle position sensor. Clicking Calibrate TPS will display the Calibrate Throttle Position Sensor screen as show below:
To calibrate the throttle position sensor do the following:

- Ensure that your Megasquirt is connected and the engine is not running (i.e., KOEO).
- Ensure that the throttle is closed;
- Click the “Get Current” button to the right of “Closed throttle ADC count”;
- Fully open the throttle;
- Click the “Get Current” button to the right of “Full throttle ADC count”;
- Click Accept and your throttle sensor will be calibrated.

6.5. Calibrate MAP / Baro

The Calibrate MAP / Baro option allows you to calibrate your MAP (Manifold Absolute Pressure) and Barometric Pressure sensors.

Clicking Tools > Calibrate MAP / Baro will display the Calibrate MAP/Baro screen as shown below:

The options for these settings are described below:

**Common MAP Sensors**

This gives a list of the commonly used MAP Sensors. If you are using one of these sensors select if from the drop down list, otherwise select “Custom”.

(c) 2014-8 James Murray 2018-07-08 Page 66/207
Value at 0.0 volts (%)
If you have selected one of the Common MAP Sensors this setting will be set automatically. If you are using a custom sensor enter the appropriate value for your sensor in this text box.

Value at 5.0 volts (%)
Again, if you have selected one of the Common MAP Sensors this setting will be set automatically. If you are using a Custom sensor enter the appropriate value for your sensor in this text box.

Common Baro Sensors
This gives a list of the commonly used Baro Sensors. If you are using one of these sensors select if from the drop down list, otherwise select “Custom”.

Value at 0.0 volts (%)
If you have selected one of the Common Baro Sensors this setting will be set automatically. If you are using a custom sensor enter the appropriate value for your sensor in this text box.

Value at 5.0 volts (%)
Again, if you have selected one of the Common Baro Sensors this setting will be set automatically. If you are using a custom sensor enter the appropriate value for your sensor in this text box.

Barometric Correction At total vacuum (%)
This setting related to the barometric correction to fuel at a total vacuum.
For new installs set this value to zero and the barometric correction curve to 100% across the board.
Imported settings from older code versions use a vacuum of 147 and have the curve at zero.

Barometric Correction Rate (%)
The rate of change of correction
For new installs set this value to zero and the barometric correction curve to 100% across the board.
Imported settings from older code versions use a rate of -47 and have the curve at zero.

6.6. Calibrate Battery Voltage

⚠️ It is not usually necessary to calibrate the battery voltage. **Do not alter these values from the defaults unless you have confirmed the actual voltage reading is inaccurate.**

Clicking Tools > Calibrate Battery Voltage will display the Calibrate Battery Voltage screen as shown below:

![Calibrate Battery Voltage](image)

These settings can be used to correct battery voltage readings at (and between) zero and max.
6.7. Un/Lock calibrations

The calibration settings for Thermistor Tables, AFR Tables and MAF Tables can be locked or unlocked to prevent them from being changed accidentally.

Clicking Tools > Un/Lock calibrations will display the Un/Lock calibrations screen as shown below:

![Un/Lock calibration screen]

Selecting “Locked” or “Unlocked” will disable or enable the remaining calibration options.

⚠️ If you unlock Sensor Calibrations please ensure that they are locked again once you have made your changes.
6.8. Calibrate Thermistor Tables

Clicking Tools > Calibrate Thermistor Tables will display the Calibrate Thermistor Tables screen as shown below:

From this screen you can set the CLT (coolant temperature) calibration if needed. The options for these settings are described below:

**Sensor Table**
Select whether you are using a “Coolant Temperature Sensor” or an “Air Temperature Sensor”.

**Table Input Solution**
This value will normally be set to “3 Point Therm Generator”. It can also be set to “Custom Inc File”

⚠️ If you select “Custom Inc File” for this setting the screen will update and you will be given the option to browse for your .inc file. To use this option you need to have an .inc file containing your thermistor settings on your hard disk. If you use this option then you will not need to use the other settings described in this section.

**Common Sensor Values**
From this option you can select your sensor type. You can select from a predefined list of common sensors using the drop down list, or leave this option unselected if you are using custom settings specific to an unlisted sensor.

**Bias Resistor Value (Ohms)**
If you have selected one of the common sensors this value should be set for you. If you are using a custom sensor you may need to set this value manually. If you are using a Microsquirt these values are always set to the default of 2490 ohms. If you are using a Megasquirt-2 the values will usually also be the default of 2490 ohms unless you or your vendor have changed the resistors on the mainboard. Your vendor should inform you if these resistors have been changed prior to shipping.
If necessary, these can be checked by inspecting the mainboard. R7 is the bias resistor for the coolant temperature sensor, R4 is the bias resistor for the air temperature sensor.

**Temperature Settings (°C or °F)**

Again, if you have selected one of the common sensors these values should be set for you. If you are using a custom sensor enter the three measured temperature and resistance value pairs.

If you are setting custom values then measure these accurately rather than estimating. For greatest accuracy the bias resistor should be close to the sensor resistance at a "warm" temperature.

**Write to Controller**

Once you have completed the settings in this screen click the "Write to controller" button to burn these settings to your Megasquirt.

### 6.9. Calibrate AFR Table

Clicking Tools > Calibrate AFR Table will display the Calibrate AFR Table screen as show below:

![Calibrate AFR Table](image)

From this screen you can set the AFR (air fuel ratio) calibration if needed. The options for these settings are described below:

**EGO Sensor**

This option allows you to select an exhaust gas oxygen sensor. You can either select from the predefined list, select "Custom Linear WB" (wideband) or select "Custom Inc File".
If you select “Custom Inc File” for this setting the screen will update and you will be given the option to browse for your .inc file. To use this option you need to have an .inc file containing your EGO sensor settings on your hard disk. If you use this option then you will not need to use the other settings described in this section.

**Volts / AFR Values**

If you have selected an EGO sensor from the predefined list these values will be set for you. If you have selected “Custom Linear WB” then you will need to enter the voltage/AFR pairs from your sensor or controller manual.

**Write to Controller**

Once you have completed the settings in this screen click the “Write to controller” button to burn these settings to your Megasquirt.

### 6.10. Calibrate MAF Table

This option is only enabled if you are using the old-style calibration for MAF Settings (See section 8.8.) This is perfectly acceptable for older configurations but is not recommended for new installs.

Clicking Tools > Calibrate MAF Table will display the Calibrate MAF Table screen as show below:

From this screen you can set the MAF (mass air flow) calibration if needed. The options for these settings are described below:

**MAF Sensor**

This option allows you to select an MAF sensor. You can either select from the predefined list, leave set as “Default” or select “Custom Inc File”.
If you select “Custom Inc File” for this setting the screen will update and you will be given the option to browse for your .inc file. To use this option you need to have an .inc file containing your MAF sensor settings on your hard disk.

Write to Controller

Once you have completed the settings in this screen click the “Write to controller” button to burn these settings to your Megasquirt.
7. Help Menu

7.1. TunerStudio Help
Clicking Help > TunerStudio Help will display the TunerStudio's own help file. This may provide further information in addition to the contents of this guide.

7.2. Check for Update
Clicking Help > Check for Update will check online to see if there is a more recent version of TunerStudio available. If you have Automatic Update Check (see Section 7.3. below) enabled you should not normally need to use this option.

7.3. Automatic Update Check
Clicking Help > Automatic Update Check toggles between enabling and disabling the automatic update check that takes place every time you run TunerStudio. It is **strongly recommended** that this option is enabled as it is good practice to always use the latest stable release of TunerStudio.

7.4. Enter Registration
Clicking Help > Enter Registration will prompt you to enter a registration code if you have purchased a license for the Upgrade version of TunerStudio. You do not need to enter a registration code to use TunerStudio MS Lite.

7.5. About
Clicking Help > About will display an information screen which includes the developer's Internet site and technical support contact email address, along with the version number of TunerStudio that you are using.

7.6. MS2/Extra Info
Clicking Help > MS2/Extra Info will display an information screen which includes a link to the MSExtra Internet site.
8. Basic / Load Settings

One of the essential roles of an aftermarket ECU such as a Megasquirt-2 is to manage EFI (electronic fuel injection). Achieving the correct fuel mixture and ignition timing are vital in terms of optimizing EFI. This involves monitoring airflow into the engine and calculating optimal fuel requirement based on airflow.

There are a number of different methods to measure airflow into an engine, each based on different complex algorithms. To briefly summarize the options: Speed Density uses a MAP (manifold air pressure) sensor; Alpha-N uses a TPS (throttle position sensor); MAF (mass airflow) uses an actual airflow meter. All of these three methods have pros and cons and none is a 'magic bullet'. Some radical engines may need to use a combination of more than one sensor configurations. Most engines will achieve good results with Speed Density or MAF.

The following sections deal with how to use TunerStudio to enter the parameters that describe your engine, and to configure your choice of airflow sensors and algorithm.

8.1. Engine and Sequential Settings

Clicking Basic / Load Settings > Engine and Sequential Settings displays the following screen:

The options for these settings are described below:

8.1.1. Required Fuel Settings

The value for 'Required Fuel' (often referred to as ReqFuel) is calculated for you automatically using the your chosen algorithm. In order to do this it is essential that the settings for your engine are entered correctly. This section describes the settings that you need to complete before TunerStudio can calculate 'Required Fuel'.

Control Algorithm

The calculation method for fuel. The choices are:

- Speed Density (uses MAP sensor);
- Percent Baro (Speed-Density, but with barometric pressure difference included);
- Alpha-N (uses TPS);
- MAF (uses MAF);
- ITB (a mode specifically for Independent Throttle Bodies).

**Squirts Per Engine Cycle & Injector Staging**
Sets injector staging in non-sequential modes. For sequential set 2 Squirts/Alternating or 1 Squirt/Simultaneous.

**Engine Stroke / Rotary**
Most engines are four stroke, although some (particularly on motor-cycles) are two stroke. The other (relatively rare) option is rotary.

**No. Cylinders / Rotors**
The number of cylinders or rotors in your engine.

**Number of Injectors**
Number of primary injectors i.e. not any secondary staged injectors you may have.

**Engine Type**
Most engines are Even Fire. Typical odd-fire engines are V-twin, some V4, Vmax, some V6, V10.

**Engine Size**
Engine size or displacement in cc. Ensure that you fill this in before using the Required Fuel calculator. To convert from cu.in to cc, multiply by 16.39.

**Injector Size**
The size of each of your main/primary injectors in cc/min. Typical conversion from lbs/hr is multiply by 10.5

**Required Fuel Button**
Once you have completed all of the appropriate entries for your engine, click the 'Required Fuel' button to calculate the required fuel for your configuration. This will display a pop-up screen similar to that shown below.

The entries will have been calculated for you by complex algorithms based on the values you have already entered. Click 'Ok' to accept these settings. **It is strongly recommended that you do not modify these values manually.**

**8.1.2. Sequential Injection Settings**

⚠️ The settings for Sequential Injection are enabled or disabled automatically according to the Spark Mode
that you select in the Ignition Options / Wheel Decoder screen (see Section 10.1.)

**Sequential Injection**
There are four options that you can select from for this option:

- Untimed injection – batch fire injection non sequential;
- Sequential/Semi-sequential – injection is timed to specific crank angle, either once per rev (semi) or once per cycle (sequential);
- Semi-sequential Siamese – for siamese port engines;
- Sequential Siamese – for siamese port engines.

**Timing Trigger**
What the injection timing angle refers to. End of pulse is typically used and set so that the injection pulse is completed just before the intake valve opens.

**Fixed Timing Or Table**
Whether a single fixed injection timing value, or a mapped table of timing values, is used.

**Number Of Timing Values**
For siamese allows different timing for each 'half'.

**Fixed Injection Timing 1 (deg)**
Fixed angle for first injection.

**Fixed Injection Timing 2 (deg)**
Fixed angle for second injection.

**Fixed Injection Timing 1 When Staging On (deg)**
Allows different angles when staging.

⚠️ Staged injection must be active in order to use this setting (see Section 9.2.)

**Fixed Injection Timing 2 When Staging On (deg)**
Allows different angles when staging.

⚠️ Staged injection must be active in order to use this setting (see Section 9.2.)

**Cranking Injection Timing 1 (deg)**
Timing during cranking.

**Cranking Injection Timing 2 (deg)**
Timing during cranking.
VE Trim Tables
Allows each injection to be trimmed to allow for differing fuel requirements per cylinder.

Injector Drivers
Allows 3rd, 4th injector channels.

⚠️ Your Megasquirt-2 will require modification to enable these. Note that they **cannot** be enabled on MicroSquirt.

Single Pulse Activation RPM
Sets the RPM to switch to a single pulse per injector (Sequential Siamese Hybrid Mode.)

Hysteresis On Single Pulse Activation RPM
Deadband on that RPM (Sequential Siamese Hybrid Mode.)

Fixed Injection Timing 3 (deg)
Injector timing in single-pulse mode. (Sequential Siamese Hybrid Mode)

Fixed Injection Timing 3 When Staging On (deg)
Allows different angles when staging.

⚠️ Staged injection must be active in order to use this setting (see Section 9.2.)

8.2. General Settings
Clicking Basic/Load Settings > General Settings will display the following screen:
From this screen you can set values for many of the settings you may need for your configuration, including barometric settings, MAP sensor settings, general sensor settings and secondary load parameters.

### 8.2.1. Baro Sensor Settings

These are settings that you may use if you want altitude to be taken into account in terms of determining your engine's performance.

**Barometric Correction**

Enables or disables fuel adjustment for barometer (altitude.) The options are as follows:

- Off – ignore baro;
- Initial MAP reading – take a sample from the MAP sensor at power-on;
- Two independent sensors – use a second dedicated barometer sensor.

**Realtime Baro Port**

The connection to an external or internal barometer sensor (used if you are using two independent sensors.)

**Upper Limit (kPa)**

Maximum barometer reading that the engine will see (typically 102kPa.) Limits faulty readings.

**Lower Limit (kPa)**

Lowest possible barometer reading that the engine will see (typically 68-80kPa.) Limits faulty readings.
Default Baro (kPa)
Fixed barometer reading for when barometric correction is disabled.

Old baro calc
Enable old-style compatibility barometric calculations. Not recommended for new installs.

8.2.2. MAP Sensor Settings

MAP Sensor Input Port
The connection to the MAP sensor which should be set to “Off” for installs not using MAP.

8.2.3. General Sensor Settings

Smoothing Factors
Lag factors for a number of sensors can be smoothed with 100% representing no smoothing, and 10% representing a high degree of smoothing. This applies to:

- MAP Averaging Lag Factor;
- MAF Averaging Lag Factor;
- RPM Averaging Lag Factor;
- TPS Averaging Lag Factor;
- Lambda Averaging Lag Factor;
- CLT/MAT/Battery/Baro Averaging Lag Factor.

Dual Table Use
Allows you to choose whether to used single or dual Fuel VE and AFR Tables.

- Single Table = a single fuel algorithm (possibly using multiple blended tables.)
- Dual Table = the two injector banks have their own VE and AFR tables running independently. Inj1 is commanded from VE1 and AFR1. Inj 2 is commanded from VE2 and AFR2.

Fuel Table Size
Allows the selection of either 12 x 12 or 16 x 16 fuel tables. Before changing size, use the “Export” feature on your VE tables to save them. Change size then use the “Import” feature to bring them back.

MegaView Temp. Units
Selects the temperature units displayed on the optional MegaView.

8.2.4. Secondary load Parameters

Fuel over-run is covered in Section 9.4. of this guide

Primary Fuel Load
The calculation method for fuel. The choices are:

- Speed Density (uses MAP sensor);
- Percent Baro (Speed-Density but with barometric pressure difference included);
• Alpha-N (uses TPS);
• MAF (uses MAF);
• ITB (a mode specifically for Independent Throttle Bodies.)

Secondary Fuel Load
Enables a second modifier fuel table (VE2) – for advanced use only.

Secondary Fuel
Selects the modifier method for the secondary fuel load – for advanced use only.

Multiply MAP (Caution!)
Normal Speed-Density should enable ‘Multiply MAP’. In rare circumstances, this can be disabled. %baro works the same. With Alpha-N, enabling multiply MAP gives 'Hybrid Alpha-N', disabling multiply MAP gives 'Pure Alpha-N'. MAF never multiplies in MAP.

⚠️ This option should be used with caution – 99% of installations should use “Multiply”.

Incorporate AFRTarget
Including the AFR target in speed density mode allows the VE table to be a “real” VE table and the desired AFR to be specified in the AFR table.

With AFR not included, the AFR table is for reference only and the VE table takes full control.

⚠️ In MAF mode, this setting MUST be enabled.

⚠️ It is advised that this setting is set BEFORE you start tuning. Changing the setting will require a re-tune.

Stoichiometric AFR
The stoichiometric (chemically ideal) AFR for the fuel in use. For gasoline leave this as 14.7 and set the internal calibration on your wideband to match.

Primary Ignition Load
The load Y-axis for ignition table lookups.

Secondary Ignition Load
Enables a second modifier fuel table (Spk2) – for advanced use only.

AFR table Load
The load Y-axis for AFR table lookups.

EAE curve load
The load Y-axis for EAE curve lookups.

8.3. Rev Limiter
Clicking Basic/Load Settings > Rev Limiter will display the following screen:
From this screen you are able to control settings such as hard rev limit, coolant temperature limit, spark retard, spark cut and fuel cut.

8.3.1. Hard Rev Limit

**Hard Rev Limit (RPM)**
Specifies the rev limiter max RPM (you must also select a rev-limiter type below.)

**Soft Limit Zone / Hysteresis (RPM)**
Sets an RPM deadband, soft limiters start this many RPM below the hard limit. If fuel cut is enabled, then the RPMs must fall by this much before fuel is re-enabled. A number of hundred RPM is suggested.

8.3.2. Coolant Temp Limiter

**Rev Limiter CLT based**
Enables optional coolant based rev limiter, so that the rev limit can be lowered when the engine is cold. The curve on the right hand of the screen (or the values for Coolant Temperature and Rev Limits) can be customized either by dragging the points on the curve or entering values into the table. This sets the hard limit at your chosen temperatures.

**Rev Limit TPS Bypass (TPS %)**
Above this TPS% the coolant curve is ignored. This should be set to a high percentage, so that only in an emergency when you really need full throttle on a cold engine can you override the cold limit. Or set to over 100% so that the limit in the curve is always used whatever the throttle position.

**RPM When In TPS Bypass (RPM)**
Rev limit when the TPS bypass limit has been passed.

8.3.3. Spark Retard

**Spark Retard Mode**
There are four options for spark retardation to limit revs:
- Off – no spark retard used;
- Progressive retard – timing is progressively retarded above the set RPM;
- Fixed angle – above the set RPM the timing is immediately changed to this angle.

**Maximum Retard (deg)**
Maximum timing retard.

**Retard To (deg)**
Timing value used in fixed angle.

### 8.3.4. Spark Cut and Fuel Cut

**Enable Spark Cut Limiting**
Enables spark-cut limiting (will not work with EDIS, TFI or GMDIS.)

⚠️ If enabled this option can cause catalyst damage and is noisy in operation.

**Enable Fuel Cut Limiting**
Whether fuel-cut rev limiting is enabled.

**Progressive Fuel Cut**
Enables a progressive non-rotational fuel cut that drops cylinders as revs rise between the lower and hard fuel cut limits. Requires Sequential/Semi-Sequential.

⚠️ This option must not be used with staged or throttle-body injection.

### 8.4. Tacho Output

Clicking Basic/Load Settings > Tacho Output will display the following screen:

![Tacho Output Window](image)

The options for these settings are described below:

**Tacho Output Enabled**
Enables the tacho output.

**Output Pin**
Selects the output pin.
Speed
Can be set to one of two options:

- Normal – an output pulse is generated matching each cylinder event, i.e., 4 cylinder engines have 4 pulses per engine cycle;
- Half speed – output runs at half speed. This can enable a 4-cylinder tacho to be used on an 8-cylinder engine.

8.5. Barometric Correction
Clicking Basic/Load Settings > Barometric Correction will display the following screen:

There are two ways that barometric correction may be used:

- The current way – on the MAP/Baro page the 'At total vacuum' and 'rate' numbers must be set to zero. This curve is then normally 100% at all points and adjusted up or down to alter fueling based on the barometer reading;
- The old way – the two numbers are set to 147 and -47 and the curve is normally 0% at all points.

8.6. MAP Sample Settings
Clicking Basic/Load Settings > MAP Sample Settings will display the following screen:
The options for these settings are described below:

**MAP Sample Method**

There are two settings for this option:

- “Use event average” is useful for most engines;
- “Use timed min” is intended for 1 cylinder or V twins with highly cyclic MAP signals.

**MAP Sample Window (deg)**

How many degrees to sample over.

**MAP Sample Angle (deg)**

The starting angle (BTDC) for MAP sampling.

**No. Sample Events**

How many ignition events to sample over. Typically set to 1 for large engines, or set to 2 for 1 or 2 cylinder engines.

**Phase Detect Threshold (kPa)**

This setting is only enabled if all of the following settings are active – the last three of these settings are options within the Ignition Options / Wheel decoder screen, see section 10.1:

- You have a 1 or 2 cylinder engine;
- You are using “Toothed wheel” as spark mode;
- You have using “MAP sensor” for your Cam Input;
- You are using “Dual wheel with missing tooth” for your Trigger Wheel arrangement.

When using the MAP sensor to detect engine phase, this sets a pressure threshold that can identify the intake versus the exhaust phases. This will be highly engine dependent: 80kPa worked on a small 1 cylinder engine.

### 8.7. ITB Load Settings

The ITB Load Settings menu option is only enabled if ITB is selected as the control algorithm in Engine and Sequential Settings (see Section 8.1. of this guide.)

Clicking Basic/Load Settings > ITB Load Settings will display the following screen:
The left hand curve defines the TPS value where the MAP load reaches %Baro switchpoint. This curve will be different for each engine and should be set up using values obtained from log files from your engine. Setting this curve is an important part of ITB mode.

The right hand curve is used to allocate the bins on the VE table to either Speed-Density or Alpha-N tuning. The area of the VE table below the load value from the curve will be used for Speed-Density tuning and the area above the curve will be used for Alpha-N tuning. It is recommended that the "ITB load at TPS switchpoint" curve be set to 50% at all RPMs.

⚠️ If either of these curves are changed then the VE table will need to be re-tuned.

8.8. MAF Settings

Clicking Basic/Load Settings > MAF Settings will display the following screen:

The options for these settings are described below:

**Voltage Input Port**
Selects the hardware input pin where the MAF is connected, or set to 'Off' to disable MAF readings.

**MAT Correction Curve**
Optionally enables a trim curve based on MAT sensor input.
**Use VE1 As Trim Table**
Optionally enables VE table 1 as a trim table. Fill the table with 100% to begin with.

**MAF Sensor Range**
Sets the range to match your MAF sensor. On gasoline, 650g/s ~800hp; 1300g/s ~1600hp; 1950g/s ~2400hp and 2600g/s ~3200hp. Use the lowest range suitable for better low-end precision.

⚠️ Always set this range before loading a MAF calibration curve.

**Use Old-Style Calibration Curve (See Tools Menu)**
This option is **only** left in place to support legacy users using MAF in the 'old way' as per firmware version 1.1.x and earlier and is **not recommended for new installs**.

### 8.9. MAF Flow Curve

⚠️ The MAF Flow Curve menu option is disabled if “Voltage input port” in the previous section is set to “Off”. Selecting any other value for Voltage input port will enable this menu option.

Clicking Basic / Load Settings > MAF Flow Curve will display the following screen:

![MAF Flow Curve](image)

This curve specifies grammes/sec versus voltage. Start out with the actual flow curve for your MAF sensor and then 'tweak' to tune it to your install.

The Lite version of TunerStudio does not provide a method to load in the example flow curves provided in the tune_files directory of the firmware zip.
8.10. MAF Correction Table (Old)

The MAF Correction Table (Old) menu option is only enabled if “Use old-style calibration curve (see Tools menu)” is set as “on” using the MAF Settings dialog (see Section 8.8. MAF Options of this guide).

The MAF Correction Table (Old) is only left in place to support legacy users using MAF in the ’old way’ and is not recommended for new installs.

Clicking Basic/Load Settings > MAF Correction Table (Old) will display the following screen:

![MAF Correction Table (Old) screen]

Specifies the adjustment on top of the MAF sensor calibration you loaded through Tools-Calibrate MAF table. Start out with the correction curve at 100% (no correction) and then 'tweak' to tune it to your install.

8.11. MAF/MAT Correction Table

To enable the MAF/MAT Correction Table menu option you must:

- Set a value for “Voltage input port” in MAF Settings to a value other than off (see Section 8.8.);
- Set “MAT Correction Curve” in MAF Settings to “On” (see Section 8.8);
- Use MAF as either the Primary or Secondary Fuel Load in General Settings (see Section 8.2.4.)

Clicking Basic/Load Settings > MAF/MAT Correction table will display the following screen:
This curve allows for minor corrections to fueling based on manifold air temperature (MAT) when using MAF to control fueling. The default curve is 0% meaning no correction.

8.12. MAT Air Density Table

⚠️ To enable the MAT Air Density Table menu option you must not use MAF as either Primary or Secondary Fuel Loads (see Section 8.2.4.)

Clicking Basic/Load Settings > MAT air density table will display the following screen:
This curve is the whole air density correction exposed in full. It is based on the ‘ideal gas law’ and typically varies between 125% cold to 75% hot.

### 8.13. MAT / CLT correction

⚠️ To enable the MAT / CLT correction menu option you must not use MAF as either Primary or Secondary Fuel Loads (see Section 8.2.4.)

Clicking Basic/Load Settings > MAT / CLT correction will display the following screen:

![MAT/CLT Correction Graph](image)

The curve is the %CLT blended into the MAT reading vs. airflow.

In theory, at zero airflow the air temperature in the intake manifold will reach the manifold (coolant) temperature. At infinite airflow, the air will be unaffected by the temperature of the manifold.

The curve is setup to give the ‘best estimate’ of intake air temperature as part of the speed-density fuel calculation.

It would be expected that some CLT should be blended in at low airflows, falling away rapidly to close to zero at higher airflows.

When first enabling this curve it will be necessary to adjust the VE values at low RPMs as they will be compensating for the air density change.

Clicking Basic/Load Settings > Real Time Display will display the following screen:

This screen shows real-time information for many of the key sensors for your Megasquirt. For further detail click the “All Output Channels” tab at at the bottom left to display a full list of variables, as shown below:
8.15. Feature List Showing I/O Pins

Clicking Basic/Load Settings > Feature List Showing I/O Pins will show a screen similar to that shown in the following image:
Depending on your engine and how you have configured your Megasquirt there are many different options which could be enabled with a wide variety of settings.

This screen is for information only and settings cannot be changed using this part of the software.

This screen is useful as it shows a summary of your configuration which can be useful for analysis and troubleshooting.
8.16. Gauge and Settings Limits

Clicking Basic/Load Settings > Gauge and Settings Limits displays the following screen:

Changing these settings does not alter the behavior of your engine in any way, they ONLY change the limits which can be displayed on the screen and set the threshold limits for your tune.

This screen allows you to set the limits on the gauges within the main gauge cluster. The default settings are for cars, bike users will certainly need to change the limits available.

The options for these settings are outlined below:

**RPM – Max (rpm)**
The maximum for RPM on gauges, tables, curves and entry boxes. Adjust to suit your engine.

**RPM – Warn Level (rpm)**
The RPM 'warning' on gauges – displayed in yellow on the gauge.

**RPM – Danger Level (rpm)**
The RPM 'danger' on gauges – displayed in red on the gauge.

**Load/kPa – Max**
The maximum 'load' value, e.g., kPa on gauges, tables, curves and entry boxes.

**Air-cooled Expanded CLT Range**
Allows gauges and curves to use an expanded coolant temperature range for air-cooled engines using the CLT sensor to measure oil or head temperature.

Once these settings have been changed it is necessary to close and restart TunerStudio for the changes to be reflected in the gauge cluster.
9. Fuel Settings

Ensuring that you have the correct fuel settings is essential in terms of achieving an effective tune for your Megasquirt.

The Fuel Settings toolbar menu deals with the many options that are supported, including injection settings and timing, fuel sensor settings, automated fuel cut off, exhaust gas oxygen sensors, air fuel ratio tables, fuel volumetric efficiency tables and trim tables, and injector sequencing.

The following sections deal with these settings and options.

9.1. Injector Dead-time / PWM

Clicking Fuel Settings > Injector Dead-time / PWM displays the following screen:

![Injector Dead-time / PWM screen](image)

The options for these settings are described below:

**Injector Dead Time @ 13.2V (ms)**
Injector dead time. Typically 0.7ms for low-z (~2.5ohm) and 0.9ms for high-z (~14ohm.)

**Battery Voltage Correction (ms/V)**
Battery voltage correction factor, typically 0.2ms/V.

**PWM Current Limiting**
Enables PWM (peak and hold) current limiting for low-z injectors. (Not available on Microsquirt.)
PWM Current Limit (%)
This is the 'hold' percentage current. 30-50% is typical.

PWM Time Threshold (ms)
The full-current 'peak' time at the beginning of each pulse and is typically set to 1-1.5ms.

Injector PWM Period (us)
The period/frequency during the hold phase. Safe to leave at 66us.

Different Bank Settings
Enables different settings for a second bank of injectors. Set to "Off" unless you have installed additional injectors and are using Staged Injection.

The above settings are repeated for Bank 2 as required. **For Banks 3 and 4 it is possible to set the Injector Dead Time and Battery Voltage Correction only.**

9.2. Staged Injection
Clicking Fuel Settings > Staged Injection displays the following screen:

The options for these settings are outlined below:

**Staged Ignition First Parameter**
This setting enables staged injection and sets the primary staging parameter which is used to determine when to engage the secondary injectors.

- Off - Staging disabled.
- RPM - Stage at a specific RPM.
- MAP - Stage at a specific MAP.
- TPS - Stage at a specific throttle position.
• Duty - Stage at a specific primary injector duty cycle.
• Table - Stage based on the table included in the dialog.

Primary Injector Size (cc)
The size of each of your main/primary injectors in cc/min (typical conversion from lbs/hr is multiply by 10.5)

Secondary injector size (cc)
Size of secondary injectors in cc/min.

Staging Gradual Transition
Allows a gradual transition into staging instead of a hard switch point.

Staging Transition Events (ign events)
How many ignition events it will take to go from no staging to fully staged.

Staging Primary Reduction Delay (ign events)
Delays the reduction of the primary pulsewidth by a number of ignition events after the secondaries start coming online. (Useful if the secondaries are mounted further upstream.)

Staging Secondary Enrichment (ms)
This setting is used to inject more fuel on the secondaries than the fully staged calculation determines. This is useful when there is a small lean spot just after staged injection fully engages.

Primary Staging Thresholds (units)
Used to determine when staged injection engages when using RPM, MAP, TPS, or Duty.

Primary Staging Hysteresis (units)
Used as a deadband to determine when staged injection shuts off.

Staged Injection Second Parameter
This setting is used to add a second method for determining when to stage.

Secondary Staging Threshold (units)
Used to determine when staged injection engages when using RPM, MAP, TPS, or Duty.

Secondary Staging Hysteresis (units)
Used as a deadband to determine when staged injection shuts off.

Secondary Staging Logic
Whether both parameters or either parameter will enable staging.

Staging Table
The table-based method allows for smooth transitions in and out of staged mode.
The values in the table determine the percent staged, 0% means not staged at all, 100% means fully staged, and a percentage value between means that injection is partially staged.
Typically you would set to 0% around idle and low load regions and 100% under full load and higher RPMs.
9.3. Fuel Sensor Settings (Flex)

Clicking Fuel Settings > Fuel Sensor Settings (Flex) displays the following screen:

The options for these settings are outlined below:

**Flex Fuel Sensor**
This enables or disables the Flex Fuel system.

**Sensor Port**
Selects where the sensor is connected – either locally or via an expansion board. Expansion boards will need configuring through ‘CAN parameters’ see Section 15.1.

**Sensor Frequency**
Low – The low frequency generated by the sensor (e.g., 50Hz for the GM sensor.)
High – The high frequency generated by the sensor (e.g., 150Hz for the GM sensor.)

**Ethanol Mix**
Low – The ethanol percentage corresponding to the low frequency.
High – The ethanol percentage corresponding to the high frequency.

**Fuel Multiplier %**
(100% means no change.)
Low – The fuel multiplier. The default of 100% for 0% ethanol gives 0% additional fuel.
High – The fuel multiplier. The default of 163% for 100% ethanol gives 63% additional fuel.

**Timing Addition**
Low – The timing addition in degrees at low frequency.
High – The timing addition in degrees at high frequency. (E85 burns more slowly than pure gasoline and will require more advance.)

**Baseline Ethanol %**
Ethanol percentage in regular fuel (assumes that the main fuel and spark tables are tuned for regular fuel.)
Allows flex fuel system to be enabled without retuning base tables. Set to 0 for backwards compatibility.

**Fallback Fuel Multiplier %**
Multiplier to be used if the sensor sends an out of range frequency (faulty sensor or an error condition.)

**Fallback Timing Addition (deg)**
Timing to add under fault conditions (expected to be 0 or negative.)

### 9.4. Over-Run Fuel Cut

Clicking Fuel Settings > Over-run Fuel Cut displays the following screen:

![Over-Run Fuel Cut](image)

The options for these settings are outlined below:

**Over-Run Fuel Cut**
Over-run fuel cut is a method to totally cut off fuel during over-run situations such as coasting down a hill in gear.

⚠️ Be sure to set the parameters so that it is only triggered under true over-run conditions and not during regular driving.

**RPM Greater Than (rpm)**
Typically a number of hundred RPM above idle.

**And MAP Lower Than (kPa)**
Typically this will be below your idle kPa.

**And TPS Lower Than (%)**
This should be set close to zero such that over-run only enables when you really are off the throttle.

**And CLT Higher Than (°F/°C)**
Set this to prevent over-run operation on a cold engine.

**After delay (s)**
The delay prevents jerky on/off operation during transients.
Delay EGO After Fuel Return (s)
Over-run will give a full-lean EGO reading and so closed-loop EGO should be disabled until a sensible reading is available. Set this long enough so that the EGO sensor is returning a true reading.

Return Fuel When RPM Less Than (rpm)
Allows a deadband of RPM for smoother operation. Typically set this a few hundred RPM below your minimum RPM setting.

9.5. EGO Control
Clicking Fuel Settings > EGO Control displays the following screen:

The options for these settings are outlined below:

EGO Sensor Type
- Disabled – No EGO sensor enabled;
- Narrowband – Enable narrowband sensor(s);
- Wideband – Enable wideband sensor(s).

1st EGO Sensor Port
Selects where the sensor is connected.

2nd EGO Sensor Port
Selects where the sensor is connected.
**Use 2nd EGO Without Dual-Table**
- Off – Single EGO sensor is used for closed-loop control of all injector channels.
- On – The second EGO sensor is used for closed-loop control of PW2 and PW4. Single VE and AFR tables are used.

**Ignition Events Per Step**
The number of ignition events between each correction.

**Controller Step Size (%)**
Controls how large each correction 'step' is.

**Controller Auth +/- (%)**
The maximum amount of adjustment performed by the closed-loop algorithm.

**Active Above CLT (°F/°C)**
Only make correction above this temperature.

**Active Above RPM**
Only make correction above this RPM.

**Active Below TPS (%)**
Only make correction below this throttle position.

**Active Below MAP (kPa)**
Only make correction below this load.

**Active Above MAP (kPa)**
Only make correction above this load.

**Narrowband EGO Target (AFR)**
Stoichiometric AFR between rich and lean.

**Algorithm**
- None – no fuel changes are made in response to oxygen sensor readings.
- Simple – This method of closed-loop EGO control is well-suited to use with a narrowband O2 sensor.
- PID – This method incorporates a Proportional Integral Derivative control-loop which (when tuned properly) adjusts the amount of fuel being injected to quickly get to the target, and then maintains the target without any oscillation.

**EGO Delay After Start (s)**
Only make correction when engine has been running at least this long.

**PID Proportional Gain (%)**
Proportional term.
PID Integral (%)
Integral term.

PID Derivative (%)
Differential term.

9.6. AFR Tables (1 and 2)
The AFR Tables allow you to set values for target AFR vs RPM/load.

⚠️ When 'Incorporate AFR' is set to “off” (see Section 8.2.4.) this is a reference table only. When ‘Incorporate AFR’ is set to “on”, this table is included in the fuel calculation.

⚠️ If you intend to use these tables please ensure that you set its values before you begin tuning.

AFR Table 1
Clicking Fuel Settings > AFR Table 1 displays the following screen:

For details of how to use tables of this type see Section 1.5.3.

AFR Table 2
⚠️ The AFR Table 2 menu option is only enabled if “Dual Table Use” is set to “Dual Table” in the General Settings screen of the Basic/Load Settings toolbar menu (see Section 8.2.3.)

Clicking Fuel Settings > AFR Table 2 displays a screen which looks almost identical to that shown above and which holds separate data.

9.7. Fuel VE Tables (1 to 3)
The three Fuel VE tables allow you to set values for volumetric efficiency (VE) at a range of points depending on rpm and fuelload. Larger VE values correspond to more fuel, smaller values correspond to less fuel.
Fuel VE Table 1

Clicking Fuel Settings > Fuel VE Table 1 displays the following screen:

![Fuel VE Table 1](image)

This is the main fuel table [VE1]. Fuel VE table size can be set to either 12 x 12 or 16 x 16 – this option can be set through Basic/Load Setting > General Settings (see Section 8.2.3.)

For details of how to use tables of this type see Section 1.5.3.

Fuel VE Table 2

![Fuel VE Table 2](image)

The Fuel VE Table 2 menu option is only enabled if:

- “Dual Table Use” has been set to “Dual Tables” (see Section 8.2.3.)
- OR: A Secondary Fuel Load source has been selected (see Section 8.2.4.)

Clicking Fuel Settings > Fuel VE Table 2 displays a screen which looks almost identical to that shown above and which holds separate data.

![Secondary Fuel VE Table](image)

This secondary Fuel VE table [VE2] which can be used as a blend table with VE1.

Fuel VE Table 3

Again, The Fuel VE Table 3 menu option is only enabled if:

- “Dual Table Use” has been set to “Dual Tables” (see Section 8.2.3.)
- OR: A Secondary Fuel Load source has been selected (see Section 8.2.4.)

Clicking Fuel Settings > Fuel VE Table 3 displays a screen almost identical to that shown above and which holds separate data..
This is the alternate Fuel VE table [VE3]. It can be used as a switched table from VE1. **If this table is active any secondary fuel table (VE2) is ignored.**

**9.8. Injection Timing Tables (1 to 3)**

These tables allow you to set values for injection timing in degrees BTDC vs load/RPM. Conventional wisdom says that the injection event should finish just as the inlet valve is opening. This corresponds to around 360 BTDC as the timing is measured with respect to the spark event. Actual best timing can be determined by testing on a dyno or through road testing.

**Injection Timing Table 1**

The Injection Timing Table 1 menu option is only enabled if:

- The “Spark Mode” you have selected (see Section 10.1.) has a tach input that supports sequential ignition settings, i.e., **NOT** EDIS, EDIS Multispark, Basic trigger, Trigger return or some of the highly specific engine spark modes.
- AND “Sequential Injection” has been configured to “use Sequential / Semi-sequential” (see section 8.1.2.)
- AND “Fixed Timing Or Table” has been set to “Use table” (see section 8.1.2.)

Clicking Fuel Settings > Injection Timing Table 1 displays the following screen:

![Injection Timing Table 1](image)

This is the main Injection Timing Table.

For details of how to use tables of this type see Section 1.5.3.

**Injection Timing Table 2**

The Injection Timing Table 2 menu option is only enabled if:

- The “Spark Mode” you have selected (see Section 10.1.) has a tach input that supports sequential ignition settings, i.e., **NOT** EDIS, EDIS Multispark, Basic trigger, Trigger return or some of the highly specific engine spark modes;
- AND “Sequential Injection” has been configured to use “Sequential Siamese” (see section 8.1.2.)
- AND “Fixed Timing Or Table” has been set to “Use table” (see section 8.1.2.)
• AND “Number Of Timing Values” has been set to “Dual Values” (see section 8.1.2.)

Clicking Fuel Settings > Injection Timing Table 2 displays a screen almost identical to that shown above and which holds separate data.

This secondary Injection Timing Table is used alongside the Injection Timing Table 1 for Siamese injection when used in dual pulse mode.

Injection Timing Table 3

The Injection Timing Table 2 menu option is only enabled if:

• The “Spark Mode” you have selected (see Section 10.1.) has a tach input that supports sequential ignition settings, i.e., NOT EDIS, EDIS Multispark, Basic trigger, Trigger return or some of the highly specific engine spark modes;
• AND “Sequential Injection” has been configured to use “Sequential Siamese” (see section 8.1.2.);
• AND “Number Of Timing Values” has been set to “Dual Values” (see section 8.1.2.)

Clicking Fuel Settings > Injection Timing Table 3 displays a screen almost identical to that shown above and which holds separate data.

This third Injection Timing Table is only used for Siamese injection when used in hybrid single pulse mode.

9.9. Fuel VE Trim Tables (1 to 4)

The Fuel VE Trim Tables allow you to specify a percentage multiplier for adjustment on the basic fuel pulsewidth to allow for difference per cylinder (where 100% = no adjustment.)

Fuel VE Trim Tables apply per injector – and so Table 1 will determine the behavior of Injector 1 and Table 2 will determine the behavior of Injector 2. Tables 3 and 4 can be enabled, although these will require changes to your hardware to add additional injectors. This is possible with modifications to Megasquirt-2 but not on MicroSquirt. It can be achieved with the MicroSquirt Module through use of an add-on board.

Fuel VE Trim Table 1

The Fuel VE Trim Table 1 menu option is only enabled if:

• The “Spark Mode” you have selected (see Section 10.1.) has a tach input that supports sequential ignition settings, i.e., NOT EDIS, EDIS Multispark, Basic trigger, Trigger return or some of the highly specific engine spark modes.
• AND “Sequential Injection” has been configured to use any setting other than “Untimed injection” (see section 8.1.2.)
• AND “VE Trim Tables” has been set to “Use VE Trim Tables” (see section 8.1.2.)

Clicking Fuel Settings > Fuel VE Trim Table 1 displays the following screen:
Changes made to Fuel VE Trim Table 1 will apply to Injector 1.

For details of how to use tables of this type see Section 1.5.3.

**Fuel VE Trim Table 2**

The configuration required to enable the Fuel VE Trim Table 2 menu option is the same as that required to enable Fuel VE Trim Table 1 menu option above.

Clicking Fuel Settings > Fuel VE Trim Table 2 displays a screen almost identical to that shown above and which holds separate data.

Changes made to Fuel VE Trim Table 2 will apply to Injector 2.

**Fuel VE Trim Tables 3 and 4**

The Fuel VE Trim Table 3 and 4 menu options are only enabled if:

- The “Spark Mode” you have selected (see Section 10.1.) has a tach input that supports sequential ignition settings, i.e., **NOT** EDIS, EDIS Multispark, Basic trigger, Trigger return or some of the highly specific engine spark modes.
- AND “Sequential Injection” has been configured to use any setting other than “Untimed injection” (see section 8.1.2.)
- AND “VE Trim Tables” has been set to “Use VE Trim Tables” (see section 8.1.2.)
- AND “Injector Drivers” is set to “Additional Drivers” (see Section 8.1.2.)

You must have additionally made hardware changes to add Injectors 3 and 4 to use Fuel VE Trim Tables 3 and 4.

Clicking Fuel Settings > Fuel VE Trim Table 3 or 4 displays a screen almost identical to that shown above and which holds separate data.
Changes made to Fuel VE Trim Table 3 will apply to Injector bank 3 and changes made to Fuel VE Trim Table 4 will apply to Injector bank 4.

9.10. Sequenced Batch Fire

The Sequenced Batch Fire menu option is only enabled if “Sequential Injection” has been configured to use “Untimed injection” (see section 8.1.2.)

Clicking Fuel Settings > Sequenced Batch Fire displays the following screen:

The options for these settings are described below:

**Enable Sequenced Batch Fire**

Sequenced batch fire can be useful to give more repeatable engine operation without sequential fuel. On every startup the batch firing is aligned to the same ignition event (cylinder) when a suitable tach-in signal is available (such as a toothed wheel.) Without this feature the alignment is random.

**Injector Settings Start Trigger No.**

Specifies the ignition 'trigger'. Typically try 0 or 1.

**Injector Time Mask**

The percentage of the time between 'triggers' to fire the injectors. A rudimentary version of injector timing.

9.11. Fuel calculations Summary

Clicking Fuel Settings > Fuel Calculations Summary will display the following screen:
This screen offers a gauge cluster showing summary information of all the fuel related variables that are configured for your Megasquirt. This screen can be useful for analysis and troubleshooting.
10. Ignition Settings

There are many different ways to design an engine, and as a result there are a wide range of methods used by manufacturers to manage ignition settings.

Correctly setting up your ignition settings to ensure that your Megasquirt works well with your engine is one of the most critical areas of work when installing and configuring your Megasquirt. It is also an area where it is very easy to damage your engine if your configuration is poor, therefore take good care to plan your changes to ignition settings carefully. Seek support from the online forums at www.msextra.com if you are not certain which settings you should use.

TunerStudio MS Lite supports a wide range of ignition settings and configurations which will allow you to configure your Megasquirt to work with your engine and to achieve an effective tune.

The settings and options to do this are contained within the Ignition Settings toolbar menu. These options include the fundamental settings such as spark mode, dwell battery correction, cold advance and manifold air temperature based timing retard. They also include noise filtering, knock sensor settings as well as ignition tables and settings for rotary engines.

The following sections deal with these settings and options.

10.1. Ignition Options / Wheel Decoder

Clicking Ignition Settings > Ignition Options \ Wheel Decoder displays the following screen:

There are a significant number of different ways to configure the combined ignition options. The options for these settings are described below:
You will not need to set all of these options for your engine, disregard any options that are disabled according to your selection.

**Spark Mode (Dizzy, EDIS, Wheel)**

It is **absolutely essential** that you select the correct Spark Mode setting for your engine. If you have any doubt about which option to use please ask for help before proceeding.

Spark Mode sets the type of tach input pattern decoder to be used.

**Trigger Angle/Offset (deg)**

In 'Basic Trigger' and 'Trigger Return' this specifies the engine angle BTDC that each trigger pulse is received. (0-19 or 50-80 degrees for best results.)

In 'Toothed Wheel' this should always be set to zero – use tooth #1 angle instead.

In other modes this setting can be used to make a +/- 20 degree adjustment to the built-in reference angle.

**Angle Between Main and Return (deg)**

This is only used in CAS 4/1 mode and specifies the angular length of each tooth.

**Oddfire First Angle**

For oddfire engines this specifies the angle the engine must rotate from spark A output to spark B output.

**GM HEI/DIS Options**

With HEI7/8 this setting enables the 'bypass' output on spark B.

**Use Cam Signal If Available**

A few wheel modes have an optional cam signal. For most configurations this setting has no effect at all.

**Oddfire Phasing**

There are three settings for this option:

- Alternative – most oddfires such as Ford V4, Chevy V6, Viper V10;
- Paired – Yamaha Vmax;
- Custom – Set your own oddfire angles.

**Skip Pulses**

The number of tach input pulses at start-up that are ignored before ignition calculations and wheel decoding begins. The default value of 3 is suitable for most applications.

**Ignition Input Capture**

This must be matched to your tach input. If it is set incorrectly you can experience timing drift with rpms or mis-detection of missing teeth on a missing tooth wheel.

The tooth logger can be used to confirm polarity is correct.
Spark Output

Getting this setting right is **CRITICAL** or you will melt your ignition coils!

For Microsquirt this is typically 'Going High';
For direct coil control on Megasquirt-2 this is typically 'Going High';
For logic spark output on Megasquirt-2 this is typically 'Going Low';

Number Of Coils

Specifies the type of ignition coils in use. TFI, HEI, EDIS, GMDIS must set to 'single coil'.

Spark A Output Pin

D14 (this is the *preferred* output pin) – standard 'LED' spark output on Megasquirt-2;
JS10 – lesser used alternate spark output;
IGN1 – main logic spark output on Microsquirt;
WLED – alternate spark output capable of driving a CDI white wire input or TFI.

Cam Input (If Used)

For 1 and 2 cylinder engines this optionally enables the MAP sensor input in place of a cam sensor. Used with 'Dual wheel with missing tooth' only.

Set the MAP sensor phase threshold on the General Settings screen (see Section 8.2.)

⚠️ Do NOT select MAP sensor unless you really are using MAP-phase sensing on a one or two cylinder engine.

Flip Polarity on Hi-Res Tach / Cam

Allows the polarity to be changed on the high resolution or cam tach input signal. Most of the special decoders expect the crank and cam to have the same polarity. If that is not the case, this setting can be used to resolve it.

Trigger Wheel Arrangement

There are three settings for this option:

- Single wheel with missing tooth – typically a crank wheel such as 36-1 or 60-2;
- Dual wheel – two wheels without missing teeth e.g., Nippodenso 24/1 CAS;
- Dual wheel with missing tooth – typically a 36-1, 60-2 crank wheel and an additional cam wheel.

Trigger Wheel Teeth (teeth)

The number of effective teeth **counting the missing teeth as if they existed** – i.e., a 36-1 wheel has 35 physical teeth, but enter 36.

Missing Teeth (teeth)

The number of missing teeth. Common are 1 for 36-1, or 2 for 60-2 or 36-2. Other variations exist.

Tooth #1 Angle (deg BTDC)

Generally (with a missing tooth crank wheel) tooth #1 is the first tooth to pass the sensor after the missing tooth gap. With a non-missing tooth configuration determining tooth #1 is a little more complex and requires two
Megasquirt-2: TunerStudio MS Lite Reference Guide

sensors (on the crank and cam respectively.)
You should have determined tooth #1 and the correct angle during configuration. If you are not sure please refer to the Megasquirt-2 Setting Up and the appropriate Hardware Manual or ask on the forum at www.msextra.com.

**Wheel Speed**
Determines whether the main wheel speed used is based on the rotation at the Crank wheel or the Cam wheel.

**Second Trigger Active On**
Like ignition input capture above this specifies which voltage level is considered ‘active’.

**Level For Phase 1**
In ‘Poll level’ mode this specifies which voltage level is used for each engine phase.

**And Every Rotation Of.**
Sets how often are the second trigger (e.g., cam) input pulses received.

**Fixed Advance**
There are two options for this setting:
- Fixed Advance – locks timing to the value set below. This is used for confirming timing with a strobe timing light during setup;
- Use table – normal operation where the spark advance table is used.

**Use Prediction**
There are two options for this setting:
- 1st Deriv. Prediction – engine acceleration / deceleration is allowed for in timing calculation (normal setting);
- No Prediction – no allowance.

**Timing For Fixed Advanced (degrees)**
The timing to lock to in 'Fixed' mode.

**Cranking Dwell (ms)**
Specifies the base coil dwell time during cranking before battery correction is applied.

**Cranking Advance (degrees)**
Specifies the ignition advance to be used while cranking. Typically 5-10 deg BTDC.

**Toyota Multiplex**
Enables specific multiplexed outputs for use with the Toyota ignition module such as used on the 7MGTE.

**Dwell Type**
There are four options for this setting:
- Standard Dwell – this is the setting to use for most installs;
- Fixed Duty – locks the spark output to a constant duty cycle instead of controlling dwell. e.g., Ford's 'Push Start' TFI modules, Bosch 'smart' ignition modules, or MSD and other CD boxes;
• Time After Spark – only intended for Saab Tri-Ionic DI cassettes;
• Charge at trigger – rarely used. Could be used with MSD type CDI boxes when running Basic Trigger only.

**Nominal Dwell (ms)**
The base dwell time before battery voltage correction. Typical values are 3-4 ms.

**Spark Duration (ms)**
The time required for the spark to complete, typically in the order of 1 ms.

**Dwell Time (ms)**
The backwards dwell time for Time-After-Spark

**Dwell Duty (%)**
For fixed duty, this specifies the percentage duty cycle of the output signal.

**Spark Hardware Latency**

⚠️ Should only be used if you notice spark retard with increasing rpms.

If you notice a slight retarding of ignition timing with rpm while strobing with fixed timing, you can enter a small number in here to remedy it.

**Middle LED indicator**

⚠️ Only applies to Megasquirt-2.

For Trigger Return mode only, the middle LED on the case can be used to echo the input signal from the distributor to help in setting up the base timing.

**Kick-start crank delay**
Primarily for kick-start engines, this enables a delayed spark during cranking. The dwell and spark are both scheduled at the trigger-return point for less chance of kick-back.

⚠️ Can only be used with:
- 'Trigger-Return' or
- 'Basic Trigger' when the Trigger Angle < 20

**Delay (ms)**
How long after the trigger-return to wait before starting the coil dwell in kick-start mode.

**Custom oddfire angles in sequence from #1**

• 1\textsuperscript{st} – Number of crank degrees engine rotates from spark A to spark B;
• 2\textsuperscript{nd} – Number of crank degrees engine rotates from spark B to next cylinder;
• 3\textsuperscript{rd} – Number of crank degrees engine rotates from spark C to next cylinder;
• 4\textsuperscript{th} – Number of crank degrees engine rotates from spark D to next cylinder.
10.2. Trigger Wizard

The Trigger Wizard menu option is not enabled if “Fuel Only” or “Toothed Wheel” have been selected as the “Spark Mode” (see Section 10.1.)

Clicking Ignition Settings > Trigger Wizard displays the following screen:

In 'Basic Trigger' and 'Trigger Return' this specifies the engine angle BTDC that each trigger pulse is received.

- In 'Toothed Wheel' this should always be set to zero – use tooth#1 angle instead.
- In other modes this setting can make a +/- 20 degree adjustment to the inbuilt reference angle.

10.3. Dwell Battery Correction

The Dwell Battery Correction menu option is not enabled if “Fuel Only” has been selected as the spark mode (see Section 10.1.)

Clicking Ignition Settings > Dwell Battery Correction displays the following screen:
This curve specifies the percentage adjustment to the nominal dwell based on battery voltage.

Inductive coils require greater dwell (charge time) at lower voltages.

10.4. Cold Advance

The Cold Advance menu option is not enabled if “Fuel Only” has been selected as the “Spark Mode” (see Section 10.1.)

Clicking Ignition Settings > Cold Advance displays the following screen:

This curve optionally allows ignition timing to be advanced during warmup. Conversely, some engines may prefer retard during warmup (to pre-heat the catalytic convertor).

10.5. MAT-Based Timing Retard

The MAT-Based Timing Retard menu option is not enabled if “Fuel Only” has been selected as the spark mode (see Section 10.1.)

Clicking Ignition Settings > MAT-Based Timing Retard displays the following screen:
This curve allows ignition timing to be retarded based on intake temperature. This is primarily for forced induction installs where there is charge heating.

10.6. Noise Filtering

⚠️ There is one Noise Filtering screen for all ignition modes. Older firmwares had a different screen for EDIS.

Clicking Ignition Settings > Noise Filtering displays the following screen:

The options for these settings are described below:

10.6.1. Primary Tach (crank)

Noise Filter Enabled
Use the noise filter curve on the right hand side of the screen to tune.

Enables noise filtering. Uses the curve to set the filter period. The filter measures the width of the tach-in pulse in order to reject short noise spikes and allow through valid wider tach-in pulses. Typically set to 1000us or more at low revs and 100us or more at high revs. Basic distributor setups can use far larger numbers.

**Tach Period Rejection**
Enables ignoring of bogus tach pulses, although they **will** still be recorded in the composite logger.

**TachInterrupt Masking**
The tach input is disabled for a short period of time after a valid tach pulse to mask out any bogus tach pulses.

**Time (ms)**

*This value must be set to less than the shortest ever valid time on your install.*

The absolute time after a valid tach pulse when new pulses are ignored. The time value that you should use here depends greatly on the type of tach input you are using, e.g., a 60-2 wheel spinning at 10000rpm has a real tach pulse every 0.1ms. A distributor pickup on a 4-cylinder engine at 600rpm has a real tach pulse every 50ms.

**Percentage (%)**
This works as a percentage of the last valid tooth time. 30-50% are typical values.

**10.6.2. Secondary Tach (cam)**

**Noise Filter Enabled**
Enables a simple noise filter on the cam tach input.

**Noise Filter Time Period (μs)**
Equivalent to the time on the curve used for the crank input.

**Tach Period Rejection**
Enables ignoring of bogus tach pulses, although they will still be recorded in the composite logger.

**Tach Interrupt Masking**
The tach input is disabled for a short period of time after a valid tach pulse to mask out any bogus tach pulses.

**Time (ms)**

*This value must be set to less than the shortest ever valid time on your install.*

The absolute time after a valid tach pulse when new pulses are ignored. The time value here depends greatly on the type of tach input in use.

e.g., a 60-2 wheel spinning at 10000rpm has a real tach pulse every 0.1ms. A distributor pickup on a 4-cylinder engine at 600rpm has a real tach pulse every 50ms.
### 10.7. Knock Sensor Settings

Clicking Ignition Settings > Knock Sensor Settings displays the following screen:

![Knock Sensor Settings Screen](image)

The options for these settings are described below:

#### Knock Control

There are three options for this setting:

- **Disabled**: do not use knock feedback for ignition advance control;
- **Safe Mode**: use knock retard, but keep the advance below that which caused knock. This backs the advance one small step back and leaves it at that until TPS or MAP changes or knock comes back. This 'safe mode' scheme is recommended for a DIY set-up.
- **Aggressive Mode**: use knock retard, but keep advance at threshold of knock occurring. That is, the program advances (up to the timing table value) if it doesn't see knock, and retards if does see knock. The difference from safe mode is that the timing can be advanced all the way to the table value after knock, not just up to one step below knock. This may result in the knock returning, in which case the timing is retarded again, then advanced slowly, and so on.

#### Input Type

There are two options for this setting:

- **On/Off**: basic on/off 'knock' or 'no-knock' external input.
- **Analogue**: external analogue input proportional to knock signal level.

⚠️ If set to Analogue the knock input threshold can be set using the table on the right hand side of the screen. This sets an allowable knock level before retard is triggered. **The numbers here are highly engine dependent.**

#### Knock Input Pin

Selects where the sensor/module is connected. Local connections are advised for faster response.
Expansion boards for on/off inputs will need configuring through 'CAN parameters' (see Section 15.1.)
Analogue inputs from expansion board are not supported.

Knock Indicated By:
The logic input level, i.e., when set to 'low' then a zero volt signal means there is knock. This matches the GM module.

Pull Up / Down On Input
Determines whether or not an internal pull-resistor should be applied.

Knock Count (knocks)
Number of knock events detected before control is started.

Knock Ignored Above MAP (kPa)
Disable knock retard above this MAP.

RPM Window Low (rpm)
Knock control is implemented above this RPM.

RPM Window High (rpm)
Knock control is implemented below this RPM.

Maximum Retard (deg)
Maximum total retard when knock occurs.

Retard Check Time (seconds)
The time between knock retard corrections.

Retard Step Size (deg)
How much to retard by on each correction step when knock is first detected. Make it large to quickly retard the timing and stop knock.

Advance Check Time (s)
The time between knock advance corrections (i.e., timing return to normal)

Advance Step Size (deg)
How much to retard by on each correction step if knock restarts after it had stopped.

Recovery Advance (deg)
If ignition table timing changes by this much then return to normal timing as the engine is clearly operating in different area.
10.8. Ignition Tables (1 to 3)

All of the Ignition Tables menu options will be disabled if “Spark Mode” is set to “Fuel Only” (see Section 10.1.)

To enable the Ignition Table 2 menu option configure a “Secondary Ignition Mode” in Basic/Load Settings > General Settings (see Section 8.2.4.)

To enable the Ignition Table 3 menu option enable “Spark Table Switching“ in Boost/Advanced > Table Switching control (see Section 13.5.)

Clicking Ignition Settings > Ignition Table 1, 2 or 3 will display a variation of the following screen:

Ignition Table 1
The main ignition table [Spark1]. Numbers are actual timing BTDC.

Ignition Table 2
The secondary ignition table [Spark2], can be used as a blend table with Spark1.

By default Ignition Table 2 will be filled with zero values and will require configuration.

Ignition Table 3
The alternate ignition table [Spark3]. Can be used as a switched table from Spark1. When Spark3 is active any secondary ignition table (Spark2) is ignored.
If you intend to use any of these three Ignition Tables please ensure that you set them before you begin tuning.

10.9. Rotary Settings

To enable the Rotary Settings menu option you need to set Engine Stroke/Rotary to “Rotary” in the Engine and Sequential Settings screen (see Section 8.1.)

Clicking Ignition Settings > Rotary Settings displays the following screen:

The options for these settings are described below:

**Output Mode**

There are two settings for this option:

- FC mode = combined trailing coil for two trailing plugs;
- FD mode = individual coils for each trailing plug.

**Allow Negative Split?**

Split usually fires trailing coils after leading coils. If “negative split” is allowed, the split may be negative, causing the trailing coils to fire before the leading coils.

**Trailing Dwell Time (ms)**

Dwell time applied to trailing coil(s).

10.10. Rotary Split Table

To enable the Rotary Split Table menu option you need to set Engine Stroke/Rotary to “Rotary” in the Engine and Sequential Settings screen (see section 8.1.)

Clicking Ignition Settings > Rotary Split Table displays the following screen:
This table specifies the split (delay) in degrees between leading and trailing coils.

### 10.11. Spark Calculations Summary

Clicking Ignition Settings > Spark Calculations Summary displays the following screen:

This screen is for information purposes only and displays the spark advance at any given stage when the engine is running. This screen can be useful for analysis and troubleshooting.
11. Startup / Idle

Correctly selecting the fuel settings required when the engine is started, during the afterstart phase, and at idle is essential. These settings are all accessible from the Startup / Idle toolbar menu.

The following sections explain how to set up the basic cranking and startup options, configure priming and cranking pulses, and afterstart percentage and taper as well as warmup enrichment.

It also covers both closed-loop and open-loop idle control, managing changes when air conditioning is used and idle advance settings (whether based on load, RPMs or adaptive advance).

11.1. Cranking / Startup settings

Clicking Startup / Idle > Cranking / Startup settings displays the following screen:

![Cranking / Startup Settings](image)

The options for these settings are described below:

**Cranking RPM**
Set this a few hundred RPM above your typical fast cranking speed.

**Flood Clear TPS (%)**
Above this throttle position no fuel will be injected during cranking to help clear a flood situation. It will also disable priming.

**Cranking Fuel Pulse Rate**
Engines with many cylinders such as V12s may find that the injecting fuel on every tach event gives difficult hot starting due to small pulsewidths.
This option allows the fuel to be injected on alternate events (with twice the pulsewidth.)

**Priming Pulse Delay(s)**
Delays the priming pulses to allow a lazy fuel pump to build pressure.

**Ignore MAT Correction During ASE**
Can be used to help with perceived heat-soak issues.
11.2. Priming Pulse

Clicking Startup/idle > Priming Pulse will display the following screen:

![Priming Pulse Screen]

The priming pulse is used to wet the intake manifold walls and provide some initial starting fuel. Setting the curve to all zeros will also disable fuel pump priming.

11.3. Cranking Pulse %

Clicking Startup / Idle > Cranking Pulse % will display the following screen:

![Cranking Pulse % Screen]

This percentage table controls the fuel injected when the engine is cranking. Most engines need 200-400% when cold and near 100% when hot.
This is a percentage of ReqFuel, so if you swap injectors this curve can be left alone.

11.4. AfterStart Enrichment (ASE)

Clicking Startup / Idle > AfterStart Enrichment (ASE) displays the following screen:

Immediately after the engine has started it is normal to need additional fuel. This curve specifies how much fuel is added as a percentage – usually (5 to 50%)

Note that ASE is a percent adder, i.e. 5% means 5% additional fuel.

A value of 100% would mean doubling the fuel which is probably wrong.
11.5. AfterStart Enrichment (ASE) Taper

Clicking Startup > idle > Afterstart Enrichment (ASE) Taper displays the following screen:

![AfterStart Enrichment (ASE) Taper](image)

Specifies how long (in engine cycles) to apply afterstart enrichment.

11.6. Warmup Enrichment (WUE)

Clicking Startup / Idle > Warmup Enrichment (WUE) displays the following screen:

![Warmup Enrichment (WUE) - Percent Multiplier](image)

Specifies the percentage multiplier for fuel during warmup. At cold temperatures 200-300% may be required.

⚠️ At fully warm (the final row in the table or point on the curve) 100% must be specified.

The only except to this is engines running LPG may use values less than 100%
11.7. Idle Control

Clicking Startup / Idle > Idle Control displays the following screen:

The options for these settings are described below, and in Sections 11.7.1. and 11.7.2.

Idle Valve Type

Selects the method of idle control. There are four possible options for this setting:

- None – no idle control valve;
- On/Off valve – basic open or closed valve (rare);
- PWM valve (2,3 wire) – common from Ford or Bosch;
- Stepper valve (4,6 wire) – common with GM and Subaru.

Algorithm

This option only applies if “PMW valve” or “Stepper valve” are selected as the “Idle Valve Type”.

There are two possible options for this setting:

- “Open-Loop” controls the valve purely based on temperature;
- “Closed-Loop” adjusts the valve position to achieve a target RPM.

Fast Idle Temperature (°F/°C)

This option (also referred to as FIDLE Temperature) only applies if “On / Off valve” is selected as the “Idle Valve Type”.

Opens the idle valve below this temperature for fast-idle.
Hysteresis (°F/°C)

This option only applies if “On / Off valve” is selected as the “Idle Valve Type”.

Sets a deadband of coolant temperature so the valve doesn’t jitter on and off if the coolant is right on the limit.

11.7.1. Stepper idle

This section only applies if “Stepper valve” is selected as the “Idle Valve Type”.

Time Step Size (ms)

Time between each stepper motor step. Increase this if the motor appears to behave intermittently.

Initial Time Step Size (ms)

The length of the first motor step. Typically set a little longer to improve reliability.

Minimum # Steps To Move (steps)

Minimum number of steps to move in one go.

Increase from the default of 1 if the valve moves unreliably.

Homing Steps

On startup the stepper motor will move this many steps to ensure it has reached the home position. Set the value to a number larger than the number of steps required for full travel. (This was formerly called “Start Value”)

Homing Direction

Whether to home the valve to the fully closed or fully open position.

Wide Open Steps

Number of steps from closed to fully open. Homing steps must be set to a larger number.

Crank-To-Run Taper Time (s)

After the engine starts, the idle valve moves from the 'cranking position' to the 'run' position. This setting controls how long that transition takes.

Hysteresis (°F/°C)

Amount the coolant temperature must vary before the idle position is changed.

Connection

Selects between normal stepper motor output connections or optional connections for the MicroSquirt add-on box. (In this case the three options listed are the connections for IACEN, IAC1, IAC2.)

Power Between Steps

Stepper motor current control when not stepping. There are three possible options:

- Moving only – turns off power between steps, motor stays cooler but may be unreliable;
- Hold current – a holding current is applied between steps;
Always on – full current is always applied. Reliable, but can cause excess heat in motor.

11.7.2. PWM idle

This section only applies if “PWM Valve” is selected as the “Idle Valve Type”.

Crank-To-Run Taper Time (s)
After the engine starts, the idle valve moves from the 'cranking position' to the 'run' position. This setting controls how long that transition takes.

Valve Mode
Virtually all valves work with “Normal –0%” = “Off” corresponding to valve closed, although rarely this setting is inverted.

Run Valve Before Start
Determines whether the idle valve runs during Key-On-Engine-Off (KOEO). This can potentially help starting by giving additional air during the first few engine rotations.

PWM Idle Port
Output for PWM idle valve. Use FIDLE as default unless it is being used elsewhere in your configuration.

Valve Frequency
Frequency to operate at. This varies with valve type. Ford/Bosch valves typically operate 50-100Hz. Miata valves are closer to 300Hz.

Be aware that above 78Hz the output becomes less precise.

11.8. Idle Cranking Duty / Steps

The Idle Cranking Duty / Steps menu option is only enabled if “Idle Valve Type” has been set to “PWM valve” or “Stepper valve” - see Section 11.7.

Clicking Startup / Idle > Idle Cranking Duty / Steps displays the following screen:
This curve sets the idle valve position during cranking. This should be set high enough so that the engine can start without touching the throttle when cold, but not so high that the engine revs up too far immediately after starting.

11.9. Idle Warmup Duty / Steps

⚠️ The Idle Warmup Duty / Steps menu option is only enabled if “Algorithm” has been set to “Open-loop (warmup)” - see Section 11.7.

Clicking Startup / Idle > Idle Warmup Duty / Steps displays the following screen:

This curve specifies the PWM Idle Duty vs. coolant temperature to be used during warmup. Large duties are more open. Typically zero is fully closed. (Some 2 wire Bosch valves have a closed position of about 35%)

The curve will start high at cold temperatures and descend towards zero at high temperatures.
11.10. Closed-Loop Idle settings

⚠️ The Closed-Loop Idle settings option is only enabled if “Algorithm” has been set to “Closed-loop” - see Section 11.7.

Clicking Startup / Idle > Closed-Loop Idle Settings displays the following screen:

The options for these settings are described in Sections 11.10.1 to 11.10.4 below:

11.10.1. Closed-Loop Idle Settings

Idle Valve Closed Duty (%)
The duty below which changes in duty no longer have an effect on RPM.

Idle Valve Open Duty (%)
The duty above which changes in duty no longer have an effect on RPM.

Dashpot Adder (%)
The amount to increase the idle valve duty / steps by when throttle is lifted. This should be set to a value that results in RPM being slightly above the target RPM.

Dashpot Decay Factor
This setting determines how quickly the duty added by the dashpot adder decays to 0. The faster RPM falls, the longer the dashpot stays in effect.

Use Last Value Or Table
This setting controls whether the initial duty value used upon entering closed loop idle is taken from the last time in closed loop or taken from the initial value table.
Use CLT Or MAT In Table Lookup
This setting is used to set whether the initial values table y-axis lookup is done using CLT or MAT.

Close Delay – 0 Means Do Not Close (s)
This setting controls the amount of time between pressing the throttle and closing the valve while driving. A value of 0 disables this setting.

⚠️ The timer does not start until actual RPM is **200 RPM above** the target.

Leave Valve Closed Above: (rpm)
The RPM above which the idle valve will remain closed when shifting gears.

For This Number Of Seconds: (sec)
The longest amount of time that a shift takes. After this timer expires, the valve will follow normal dashpot behavior.

11.10.2. Closed-Loop Idle PID Gains

Tuning Mode
If set to “Basic” then Proportional Gain, Integral Gain and Derivative Gain are not used to calculate overall Gain. If set to “Advanced” these three settings can be defined.

Closed Loop Gain
Use this slider based setting to tune how aggressively the idle speed controller tries to reach the target RPM. Adjust the slider up until the idle speed starts oscillating, then back down until it stops. Wait 5-10 seconds between each adjustment to give your Megasquirt a chance to settle.

Proportional Gain (%)
Proportional gain for closed-loop idle PID loop. Reacts immediately to change in RPM.

Integral Gain (%)
Integral gain for closed-loop idle PID loop. Reacts to sustained difference between target RPM and actual RPM.

Derivative Gain (%)
Derivative gain for closed-loop idle PID loop. Reacts to rate of change of RPM.

11.10.3. Closed-Loop Idle PID Delays and Behavior

PID Delay (s)
Controls how long all conditions for entering closed-loop idle must be met for before entering closed-loop control.

Crank To Run Taper (s)
After the engine starts, the idle valve moves from the 'cranking position' to the 'run' position. This setting controls how long that transition takes.
PID Ramp To Target Time (s)
How long after entering closed loop idle it will take for actual RPM to match target RPM.

PID Control Intervals (ms)
Controls how often the closed loop idle algorithm runs.

PID Disable RPMdot
Use so that engaging clutch without throttle does not leave PID running. Avoids situations where PID stays running while not actually idling causing stalls once PID is entered again.

11.10.4. Closed Loop Idle PID activation Settings

Idle Activation TPS Threshold (%)
The TPS value below which the other factors for entering closed-loop idle are considered.

RPMdot Threshold (rpm/sec)
The value RPMdot must be below before closed-loop idle can be activated.

Max Decel Load (%)  
The value load must be above before closed-loop idle can be activated.

PID Lockout On Switch Active
Enables the use of a clutch or neutral switch to help determine when closed-loop idle should be active.

PID RPM Window Size (1 = off)
An RPM smoothing feature.

11.11. Closed-Loop Idle Target RPM Curve

The Closed-Loop Idle Target RPM Curve menu option is only enabled if:

- “Algorithm” has been set to “Closed-loop” (see Section 11.7.)
- OR “Idle Advance On” is set to “Adaptive” (see Section 11.15.)

Clicking Startup / Idle > Closed-Loop Idle Target RPM Curve displays the following screen:
This curve displays the closed loop idle RPM target depending on coolant temperature. It is normal to set a high idle on a cold engine, tapering down as the engine warms up.

11.12. Closed-Loop Idle Initial Values

The Closed-Loop Idle Initial Values menu option is only enabled if:

- “Algorithm” has been set to “Closed-loop” - see Section 11.7;
- AND “Use Last Value Or Table” is set to “Use initial value table” - see Section 11.10.1.

Clicking Startup / Idle > Closed-Loop Idle Initial Values displays the following screen:

The best-guess idle valve position for RPM/load. This allows you to 'kick-start' the closed-loop idle by setting the valve to the most likely position.

11.13. PWM Idle Voltage Compensation

The PWM Idle Voltage Compensation menu option is only enabled if “Idle Valve Type” has been set to “PWM valve” (see Section 11.7.)

Clicking Startup / Idle > PWM Idle Voltage Compensation displays the following screen:
Some 2 wire PWM idle valves will operate differently depending on the system voltage. This allows a compensation to be applied to allow for that difference.

Typically at lower voltages the valve will need slightly more duty (positive number) and at higher voltages it will need less duty (negative number.)

11.14. Air Conditioning Idle-up

Clicking Startup / Idle > Air Conditioning Idle-up displays the following screen:

The options for these settings are described below:

A/C Idle-up
Enables feature.

Idle-up Output
Output to engage compressor.

Idle-up Input
Switch input.

Idle-up Input Polarity
Sets the active state of the input.
Normally, the idle-up switch input is a ground-switch and the 'Low' settings should be used. In certain installations with appropriate wiring, an active 'High' input can be required.

**Idle-up Delay (ms)**
Delay after switch is pressed before engaging compressor.

**Idle-up Min RPM (rpm)**
Lowest RPM that AC compressor can be turned on.

**Compressor Delay Since Last On (s)**
Sets a delay to prevent rapid cycling on/off.

**Idle-up Duty Adder (%)**
Only enabled if “Idle Valve Type” has been set to “PWM valve” (see Section 11.7.)

Additional PWM idle duty cycle to add when A/C is active.

**Idle-up Steps Adder (steps)**
Only enabled if “Idle Valve Type” has been set to “Stepper valve” (see Section 11.7.)

Additional idle steps to add when A/C is active.

**Idle up Target RPM Adder (rpm)**
Bump up RPM by this much when A/C is active.

### 11.15. Idle Advance Settings

Clicking Startup / Idle > Idle Advance Settings displays the following screen:

![Idle Advance Settings](image)

The options for these settings are described below:

**Idle Advance On**
Enables / disables Idle-advance feature. There are four options for this setting:

- Off – Disables Idle advance;
• Load – Timing varies based on engine load only;
• RPMs – Timing varies based on engine RPM only;
• Adaptive – Timing changes are used to assist closed-loop idle.

Apply As:
• Set Value – timing is set to the value from the curve
• Adder – value from curve adds to existing timing.

Condition Is:
Use the conditions below or link to closed-loop idle.

Conditions
• TPS is Below: (%) – Only activate below this TPS;
• And RPM is Below: (rpm) – Only activate below this RPM;
• And load is Above: (%) – Only activate above this load (helps code ignore over-run situations);
• And CLT is Above: (°F/°C) – Only activate above this coolant temperature (typically idle-advance does not work too well during warmup);
• And After Delay: (sec) – After the conditions are met, wait this long before enabling idle-advance. This helps reduce false activations.

11.16. Idle Load Advance Timing

The Idle Load Advance Timing menu option is only enabled if “Idle Advance On” has been set to “Load” (see Section 11.15.)

Clicking Startup / Idle > Idle Load Advance Timing displays the following screen:

Sets the timing vs. engine load when Idle-Advance is active. Typically the curve will ramp from low advance at low load to more advance at higher loads to stabilize idle.

11.17. Idle RPMs Advance Timing

The Idle RPMs Advance Timing menu option is only enabled if “Idle Advance On” on has been set to “RPMs” (see Section 11.15.)
Clicking Startup / Idle > Idle RPMs Advance Timing displays the following screen:

Sets the timing vs engine RPM when Idle Advance is active. Typically the curve will ramp from higher advance at lower RPMs to less advance at higher RPMs to stabilise idle.

### 11.18. Idle Adaptive Advance Timing

⚠️ The Idle Adaptive Advance Timing menu option is only enabled if “Idle Advance On” has been set to “Adaptive” (see Section 11.15.)

Clicking Startup / Idle > Idle Adaptive Advance Timing displays the following screen:

Sets the timing vs engine load when Idle Advance is active. Typically the curve will ramp from higher advance at negative RPM deltas (below target) to lower advance at positive RPM deltas (above target) to help stabilise idle.
12. Accel Enrich

The settings on the accel enrich menu are intended to improve engine performance during transients such as opening the throttle. There are a number of different methods available from simple to more scientific. At the most basic level, when you snap open the throttle, you will need a burst of additional fuel. Formerly this was provided by the acceleration pumper on a carburettor.

12.1. Accel Enrich Settings

Clicking Accel Enrich > Accel Enrich Settings displays the following screen:

![Accel Enrich Settings]

The options for these settings are described below:

**Wall-Wetting AE (EAE)**

Enables a well-wetting transient system.

**TPSdot Uses %WOT**

Enables a curve to model effective 100% TPS for a given RPM. This allows smaller throttle movements to be more responsive at lower RPMs and ignores changes in throttle above ‘wide-open’.

12.2. Time-Based Accel Enrichment

Clicking Accel Enrich > Time-Based Accel Enrichment displays the following screen:
The options for these settings are described below:

**Map Based AE Curve**

⚠️ The Map Based AE Curve is only enabled if the “Accel Enrichment MAPdot<->TPSdot Blend (%)” slider is set to a value less than 100% - see the third entry in this section.

This curve specifies a fuel pulsewidth percent adder based on rate of change of MAP (MAPdot).

This is part of the basic time based accel enrichment scheme. Larger changes in MAP require more fuel to be added. The number is a percentage of ReqFuel.

**TPS Based AE Curve**

This curve specifies a fuel pulsewidth percent adder based on rate of change of TPS (TPSdot).

This is part of the basic time based accel enrichment scheme. Larger changes in TPS require more fuel to be added. The number is a percentage of ReqFuel.

**Accel Enrichment MAPdot<->TPSdot (%)**

This slider set a weight (0-100) to be given to TPSdot over MAPdot for accel enrichment.

**Realtime graphing**

The graphing in the middle of the screen gives a real-time live indication of the acceleration parameters.

**Accel MAPdot Threshold (kPa/s)**

Triggers enrichment above this MAPdot value.
**End Pulsewidth (ms)**
After main enrichment event, taper down to this amount of enrichment.

“0” is suggested for this setting.

**Accel Time (s)**
Length of main enrichment pulse.

**Accel Taper Time (s)**
Length of ‘taper’ time after main enrichment pulse

“0” is suggested for this setting.

**Accel TPSdot threshold (%/s)**
Trigger enrichment above this TPSdot value.

**Decel Fuel Amount**
Deceleration fuel cut amount in percent. 100% is no cut, 0% is complete cut of fuel.

100% is suggested for this setting.

**Cold Accel Adder (ms)**
At full cold (-40 °C/°F), add this amount to the enrichment.

**Cold Accel Multiplier (%)**
At full cold (-40 °C/°F), multiply the enrichment by this percentage.

**Full Accel Below: (rpm)**
Below this RPM full enrichment is enabled.

**Zero Accel Above: (rpm)**
Above this RPM, there is no enrichment. In between, the enrichment is on a sliding scale.

### 12.3. TPS WOT curve

The TPS WOT menu option is only enabled if the “TPSdot uses %WOT” setting is set to “On” see Section 12.1.

Clicking Accel Enrich > TPS WOT curve displays the following screen:
This curve sets the TPS% that is considered wide-open-throttle based on RPM. i.e., at low RPMs, partial throttle will flow the same air as full throttle. At maximum RPMs full throttle is required for full air flow.

When the throttle is at, or beyond, the new ‘full throttle’ it is considered to be 100% throttle. This has the effect of making TPS based accel enrichment more sensitive at lower throttle opening at lower RPMs and also prevents TPS accel enrichment if the throttle is already ‘fully open.’

12.4. EAE Adhere-to-walls Coefficient

⚠️ The EAE Adhere-to-walls Coefficient menu option is only enabled if the “Wall-Wetting AE (EAE)” setting is **NOT** set to “Off” see Section 12.1.

Clicking Accel Enrich > EAE Adhere-to-walls Coefficient displays the following screen:

This curve determines how much fuel is being added to the port walls per injection event. It is a percentage (Y-axis) of each injection event based on load (X-axis).
12.5. EAE Sucked-from-walls Coefficient

⚠️ The EAE Adhere-to-walls Coefficient menu option is only enabled if the “Wall-Wetting AE (EAE)” setting is **NOT** set to “Off” see Section 12.1.

Clicking Accel Enrich > EAE Sucked-from-walls Coefficient displays the following screen:

![EAE Sucked-from-walls Coefficient](image)

This curve determines how much fuel is being sucked from the walls on each intake (valve open) event. It is a percentage (Y-axis) of the total amount of fuel that has adhered to the walls based on load (X-axis), so therefore the percentages are much smaller (about 10x smaller) than the Adhere-to-walls coefficients.

12.6. EAE Adhere-to-walls RPM Correction

⚠️ The EAE Adhere-to-walls RPM Correction menu option is only enabled if the “Wall-Wetting AE (EAE)” setting is **NOT** set to “Off” see Section 12.1.

Clicking Accel Enrich > EAE Adhere-to-walls RPM Correction displays the following screen:

![EAE Adhere-to-walls RPM Correction](image)

This curve modifies the EAE Adhere-to-walls curve. It allows the amount of correction specified by the EAE Adhere-to-walls curve to be increased or decreased based on RPM.
12.7. EAE Sucked-from-walls RPM Correction

The EAE Sucked-from-walls RPM Correction menu option is only enabled if the “Wall-Wetting AE (EAE)” setting is **NOT** set to “Off” see Section 12.1.

Clicking Accel Enrich > EAE Sucked-from-walls RPM Correction displays the following screen:

![EAE Sucked-from-walls RPM Correction](image)

This curve modifies the EAE Sucked-from-walls curve. It allows the amount of correction specified by the EAE Sucked-from-walls curve to be increased or decreased based on RPM.

12.8. EAE Adhere-to-walls CLT Correction

The EAE Adhere-to-walls CLT Correction menu option is only enabled if the “Wall-Wetting AE (EAE)” setting is **NOT** set to “Off” see Section 12.1.

Clicking Accel Enrich > EAE Adhere-to-walls CLT Correction displays the following screen:

![EAE Adhere-to-walls CLT Correction](image)

This curve modifies the EAE Adhere-to-walls curve. It allows the amount of correction specified by the EAE Adhere-to-walls curve to be increased or decreased based on coolant temperature.
12.9. EAE Sucked-from-walls CLT Correction

The EAE Sucked-from-walls CLT Correction menu option is only enabled if the “Wall-Wetting AE (EAE)” setting is **NOT** set to “Off” see Section 12.1.

Clicking Accel Enrich > EAE Sucked-from-walls CLT Correction displays the following screen:

This curve modifies the EAE Sucked-from-walls curve. It allows the amount of correction specified by the EAE Sucked-from-walls curve to be increased or decreased based on coolant temperature.

12.10. EAE Lag Compensation

The EAE Lag Compensation menu option is only enabled if the “Wall-Wetting AE (EAE)” is set to “On with lag compensation” see Section 12.1.

Clicking Accel Enrich > EAE Lag Compensation settings displays the following screen:

The options for these settings are described below:

**Source**
The trigger for lag compensation: Can be either MAPdot or TPSdot.

**Threshold (unit/sec)**
The threshold at which lag compensation is triggered.

**Max RPM (rpm)**
The maximum RPM at which lag compensation can be triggered.
13. Boost / Advanced

This chapter focuses on how to configure additional performance for your engine through the Boost / Advanced toolbar menu. Boost control is relevant if you have a turbocharger.

This chapter also describes how to enable fuel and spark switching. Finally it covers configuration of launch control, nitrous injection, and sequential / bike shift spark cut.

13.1. Boost Control Settings

Clicking Boost / Advanced > Boost Control Settings displays the following screen:

![Boost Control Settings](image)

The options for these settings are described below and in Sections 13.1.1 and 13.1.2.

**Boost Control Enabled**

Controls whether boost control is enabled.

**Boost Control Use Initial Value Table**

⚠️ This setting will only be enabled if “Closed-loop” is selected below.

For use with closed-loop boost control. Controls whether the initial values table is used to set the initial duty before closed-loop is engaged.

**Solenoid Frequency**

Sets the output frequency to the solenoid.

**Control Interval (ms)**

Controls how often the boost control algorithm runs.
**Boost Control Location**
Enables a solenoid connected to an expansion board.

**Boost Control Pin**
Output pins available when using the slow frequency range.

**Boost Control Remote Port**
Selects where the solenoid is connected.

**Output Polarity**
Set this so that higher duty yields higher boost.

**Closed Duty (%)**
(Closed loop) The duty below which changes in duty no longer cause changes in boost pressure.

**Open Duty (%)**
(Closed loop) The duty above which changes in duty no longer cause changes in boost pressure.

**Algorithm**
Controls whether open loop or closed loop control algorithm is used.

⚠️ The following six settings will only be enabled if “Algorithm” is set to “Closed-loop”.

**Boost Control Lower Limit Delta (kPa)**
Boost pressure must be within this many kPa of the target boost before closed-loop control will activate. Outside of this range the valve is held wide open (keeping the wastegate shut) for fastest spooling.

**Closed-loop Boost Tuning Mode**
Can be set to:
- Basic – uses fixed PID parameters ($P = 100, I = 100, D = 100$);
- Advanced – uses adjustable PID parameters for greater control (as described below).

**Closed-loop Sensitivity**
Use this slider based setting to tune how aggressively the boost controller tries to reach the target boost. Adjust the slider up until the boost oscillates around the target, then back down until it stops.

**Proportional Gain (%)**
Proportional gain for closed-loop control. Proportional control causes immediate changes to output duty with changes in boost error.

**Integral Gain (%)**
Integral gain for closed-loop control. Integral control causes changes in duty with boost error over time. The longer boost is off target, the stronger the reaction due to the integral term.

**Differential Gain (%)**
Derivative gain for closed-loop control. Derivative control causes larger reactions in boost duty with faster rate of
change of boost error. The faster error changes, the more duty will change to counteract.

### 13.1.1. Overboost Protection Settings

**Overboost Protection**
Selection can be fuel-cut, spark-cut, or both. “Fuel” cut only cuts fuel. “Spark” cut only cuts spark. “Both” cuts both fuel and spark.

**Maximum Boost (kPa)**
Maximum desired boost before overboost protection cuts fuel / spark.

**Hysteresis (kPa)**
With overboost protection enabled, this determines how far pressure must drop before spark / fuel are re-enabled after boost has reached the maximum.

**Boost Tolerance**
Trips the overboost protection if boost is a certain pressure above boost target. Allows overboost to track the boost target table.

**Tolerance (kPa)**
How far MAP can exceed the boost target before overboost cuts in.

### 13.1.2. Flex/Boost

**Use Flex On Y-Axis Of Target Table**
Uses Flex% (rate of change in Flex) as the Y-axis on the boost target table instead of TPS. This allows you to vary boost by E85 percentage.

**Above TPS (%)**
Minimum TPS to enable boost control. Zero boost will be targeted below this TPS%.

### 13.2. Boost Control Duty Table

⚠️ The Boost Control Duty Table menu option is only enabled if:
- “Boost Control Enabled” is set to “On”
- AND Algorithm is set to “Open-loop” (see section 13.1. for these settings.)

Clicking Boost / Advanced > Boost Control Duty Table will display the following screen:
For Open-loop boost, this table sets the output duty cycle vs. TPS/RPM.

### 13.3. Boost Control Target Table

The Boost Control Target Table menu option is only enabled if:

- “Enable Boost Control” is set to “On”
- AND “Algorithm” is set to “Closed-loop” (see section 13.1. for these settings.)

Clicking Boost / Advanced > Boost Control Target Table will display the following screen:

For Closed-loop boost, this table sets the target boost vs. TPS/RPM

### 13.4. Boost Control Initial Duty Table

The Boost Control Initial Duty Table menu option is only enabled if:

- “Enable Boost Control” is set to “On”
- AND “Boost Control Use Initial Value Table” is set to “On”
- AND “Algorithm” is set to “Closed-loop” (see section 13.1. for these settings.)

Clicking Boost / Advanced > Boost Control Initial Duty Table displays the following screen:
The best-estimate boost valve duty for target load vs. RPM. This allows you to 'kick-start' the closed-loop boost by setting the valve to this position before engaging closed-loop PID control.

The table is determined by reviewing datalogs or taking a known open-loop table.

13.5. Table Switching Control

Clicking Boost / Advanced > Table Switching Control displays the following screen:

The options for these settings are described below:

**Fuel Table Switching**

Enables Fuel Table switching. Switches from using Fuel VE Table 1 with Fuel VE Table 2 to using Fuel VE Table 3 alone.

**Switch Source**

Hardware refers to a physical switch. The other options are: rpm, kPa and TPS. Depending on the selection you make here, one of the following four options will be enabled.

**Switch Location**

Enabled when “Switch Source” is set to “Hardware”. Selects where the switch is connected.
Expansion boards will need configuring through ‘CAN parameters’ (see Section 15.1.)

**RPM Greater Than (rpm)**
Enabled when “Switch Source” is set to “rpm”. Represents the rpm threshold for fuel switching.

**MAP Greater Than (kPa)**
Enabled when “Switch Source” is set to “kPa”. Represents the kPa threshold for fuel switching.

**TPS Greater Than (%)**
Enabled when “Switch Source” is set to “TPS”. Represents the TPS threshold for fuel switching.

**Spark Table Switching**
Enables Ignition Table switching. Switches from using Ignition Table 1 with Ignition Table 2 to using Ignition Table 3 alone.

**Switch Source**
Again, hardware refers to a physical switch and the other options are rpm, kPa and TPS. Depending on the selection you make in this options one of the following four options will be enabled.

**Switch Location**
Enabled when “Switch Source” is set to “Hardware”. Selects where the switch is connected.

Expansion boards will need configuring through ‘CAN parameters’ (see Section 15.1.)

**RPM Greater Than (rpm)**
Enabled when “Switch Source” is set to “rpm”. Represents the rpm threshold for spark switching.

**MAP Greater Than (kPa)**
Enabled when “Switch Source” is set to “kPa”. Represents the kPa threshold for spark switching.

**TPS Greater Than (%)**
Enabled when “Switch Source” is set to “TPS”. Represents the TPS threshold for spark switching.

### 13.6. Launch Control
Clicking Boost / Advanced > Launch Control displays the following screen:
The options for these settings are described below:

**Launch Control Option**
This option can be set to one of three options:

- **Off** – all of launch is turned off;
- **Launch** – launch only, no flat shift;
- **Launch/flatshift** – launch and flat shift.

Flat shift is used on manual gearboxes for full throttle shifts with a clutch switch to engage the limiter.

**Input Pin**
Input for launch switch.

**Launch Hard Limit (rpm)**
Above this rpm the hard limiter methods are used when the launch conditions are met.

**Soft Limit Zone (rpm)**
The soft limit is this many rpm below the hard limit (this is sometimes called the control range.)
200 rpm is typical.

**Soft Limit Retard To (deg)**
The absolute timing to retard to, i.e., 5 gives 5 BTDC timing.

**Enable Launch When TPS Above (%)**
Launch is only active when the throttle is open a certain percentage. Most users can safely set this to a very low percentage.

**Limiter Method**
This option can be set to one of four settings:
None – do not use;
• Spark cut – drop sparks, this is the most common limiter used but **will not** work with EDIS ignition;
• Fuel cut – cuts fuel;
• Spark and fuel – cuts both.

**Flat Shifting Arming RPM (RPM)**
This rpm set point is used to differentiate between a flat shift and launch condition, typically set to a few hundred RPM above idle.

**Flat Shift Hard To Rev Limit (RPM)**
Above this rpm the hard limiter methods are used when the flat-shift conditions are met.

**Soft Limit Retard To (deg)**
The absolute timing to retard to, i.e., 5 gives 5 BTDC timing.

### 13.7. Nitrous System
Clicking Boost / Advanced > Nitrous System displays the following screen:

The options for these settings are described below:

**Nitrous Control**
Enables the feature.

**Turn N₂0 On When Above (RPM)**
The minimum RPM to enable nitrous.

**And Coolant Temp Above (°F/°C)**
The minimum coolant temperature to enable nitrous.
Megasquirt-2: TunerStudio MS Lite Reference Guide

And TPS > (%)
The minimum throttle position to enable nitrous.

Enable Input
Input to use to enable the nitrous system (expects a ground signal at the CPU.)

⚠️ Expansion boards will need configuring through 'CAN parameters' (see Section 15.1.)

Output Pins For Stage 1+2
Selects where the outputs are connected.

⚠️ Expansion boards will need configuring through 'CAN parameters' (see Section 15.1.)

Additional Fuel PW @ N₂0 Min RPM (ms)
Fuel pulsewidth to add at the min RPM (tapers down between min and max.)

Max RPM
The maximum RPM to enable nitrous.

Additional Fuel PW @ N₂0 MAX RPM (ms)
Fuel pulsewidth to add at the max RPM (tapers down between min and max.)

Enrich Which Bank In Dual Table
Set to “Both” for most installs. If “dual table” or “Staging” are in use it selects which injector bank receives any addition fuel pulsewidth.

If ST2 Off Retard Ignition By (deg)
Sets a fixed ignition retard when nitrous is active.

Nitrous Delay After Launch (s)
Sets a minimum time after launch control is released before nitrous can activate.

Nitrous Delay After Flat Shift (s)
Sets a minimum time after flat-shift is released before nitrous can activate.

Nitrous Stage 2
Enables the second stage.

13.8. Nitrous Stage 2

⚠️ The Nitrous Stage 2 option is only enabled if “Nitrous Stage 2” is enabled (see Section 13.7.)

Clicking Boost / Advanced > Nitrous Stage 2 displays the following screen:
The options for these settings are described below:

**Enable Stage 2 Above (RPM)**
The activation RPM for stage 2.

**Max RPM**
The maximum RPM for stage 2.

**Delay After Stage 1 (s)**
Sets a minimum time delay after stage 1 activates before stage 2 can activate.

**Retard Ignition By (deg)**
Sets an additional ignition retard when stage 2 is active.

**Additional Fuel PW @ N20 Min RPM (ms)**
Fuel pulsewidth to add at the min RPM (tapers down between min and max.)

**Additional Fuel PW @ N20 Max RPM (ms)**
Fuel pulsewidth to add at the max RPM (tapers down between min and max.)

**13.9. Sequential Shift Cut**
Clicking Boost / Advanced > Sequential Shift Cut will display the following screen:

The options for these settings are described below:
Shifter Spark Cut System
Enables the sequential / bike shift cut system.

Button Input
Input used for the button.

Solenoid Output
Output to the shift solenoid.

RPM > (RPM)
Minimum RPM to allow shifting.

And TPS > (%)
Minimum throttle to allow shifting.

Delay Before Spark Cut (s)
The solenoid is activated immediately, then wait this long before cutting spark.

Spark Cut Times (s)
How long to cut spark for.

Solenoid Delay (s)
How long to keep the solenoid powered after the spark is returned.

Re-shift Hold-off Time (s)
Ignore button for this long after shifting – to prevent a false shift.

13.10. Programmable On/Off Outputs
Clicking Boost / Advanced > Programmable On/Off Outputs displays the following screen:

This screen allows you to customize the use of the programmable outputs for your Megasquirt. The options for these settings are outlined in Sections 13.10.1. to 13.10.3. below:
13.10.1. Output Port

On the left hand side of this screen is a list of ports that you can program to carry out different tasks.

This gives a list of the ports that can be programmed. The above image is a sample list of ports shown when connected to a Megasquirt-2. Your lists of ports may differ depending on your product, although they can be used in the same way.

When you click on any of the ports listed, the settings in the “Port Settings” and the “Active Conditions” sections on the right hand of the screen (documented in Sections 13.10.2. and 13.10.3. respectively) will apply to the port you have selected.

Be careful that you don’t attempt to program a port that is already in use! The most obvious example is FIDLE, which can optionally be set as the PWM Idle port in the “Idle Control” screen (see Section 11.7.) If you are using FIDLE for this purpose you will encounter errors if you attempt to program it for a second role. Whilst this is the most obvious potential conflict, it is worth making sure that any port that you program is not being used for any other role.

13.10.2. Port Settings

These settings allow you to select whether a port is used and when it is used.

Enabled

Clicking the check box (so that it contains a tick) means that you are going to use the selected port. The gray icon next to the port you are using in the Output Port list will change to green when this setting is checked.

Power On Value

This is a setting that determines if the output will be on or off when your MS2 powers up. Please take the active conditions (see Section 13.10.3.) into account when deciding whether to set this to on or off.

Typically this value is set to “Off”.

Active Value

This is an on/off setting that determines if the output is triggered when the conditions for it to become active are met.

Typically this value is set to “On”.

13.10.3. Active Conditions

These settings allow you to determine the conditions under which the output becomes active.

Output channel

This is a list of Megasquirt variables - much the same as the various gauges you can select in dashboard.

Operator

This ‘logical operator’ forms part of the equation. There are four options for this setting:

- > (is greater than);
- = (is equal to – this options is rarely useful);
- < (is less than);
• And (performs a bitwise AND operation – useful for setting outputs based on status bits.)

Threshold
The value at which the output channel is compared using the operator to establish whether the condition is considered to be “Active”.

Hysteresis
It is very common for a value to hover around the threshold which would cause the output to turn on and off rapidly. This setting helps to prevent that by creating a deadband below the threshold which prevents the output from being repeatedly activated during borderline conditions.

Threshold and Hysteresis in bitwise AND mode
Bitwise AND changes the meaning of the threshold and hysteresis field such that, in programming terms:
result = ((value & THRESHOLD) == HYST)

Additional condition
There are three options for this drop down box:
• No additional condition – only a single condition is used
• Or – output triggers if either condition 1 OR condition 2 is met
• And – output triggers only when condition 1 AND condition 2 are both met

⚠️ If “Or” or “And” are selected then complete the second Output Channel, Operator, Threshold and Hysteresis using the procedures described above.
14. 3D Maps

As described in Section 1.5.4, there are 3D Maps for many of the 3D Tables that are used throughout TunerStudio. That section outlines the purpose of these maps and how they can be used.

All of the maps are accessible from the 3D Maps toolbar menu. Sections 14.1. to 14.8. below outlines the type of maps available and refers back to the relevant sections that include the 3D Tables to which they correspond. You can make changes to either the 3D Table or the 3D Map at any time, although it is strongly recommended that you do not change both simultaneously if you have modal dialogs disabled.

14.1. Fuel VE Tables [1 to 3]

The three Fuel VE 3D Maps directly correspond to the three Fuel VE Tables which are documented in Section 9.7. That section of this guide outlines the options that are required to enable each of those tables. Those same options will enable the equivalent menu options in the 3D Maps toolbar menu.

Clicking 3D Maps > Fuel VE Table [1, 2 or 3] will displays variant of the following screen:

![Fuel VE Table 1](image)

The screen will be a direct transformation of the numerical values in the matching Fuel VE Table. The X & Y axes represent rpm & fuelload respectively, and the height at each point reflects the percentage for the same point in the table.

You can use the methods described in Section 1.5.4. to view and make changes to these values.
14.2. Fuel VE Trim Tables [1 to 4]

The four Fuel VE Trim 3D Maps directly correspond to the four Fuel VE Trim Tables which are documented in Section 9.9. That section of this guide outlines the options that are required to enable each of those tables. Those same options will enable the equivalent menu options in the 3D Maps toolbar menu.

Clicking 3D Maps > Fuel VE Trim Table [1, 2, 3 or 4] will display a variant of the following screen:

The screen will be a direct transformation of the numerical values in the matching Fuel VE Trim Table. The X & Y axes represent rpm & fuelload respectively, and the height at each point reflects the percentage for the same point in the table.

You can use the methods described in Section 1.5.4. to view and make changes to these values.
14.3. AFR Tables [1 and 2]

The two AFR Maps directly correspond to the two AFR Tables which are documented in Section 9.6. That section of this guide outlines the options that are required to enable both of those tables. Those same options will enable the equivalent menu options in the 3D Maps toolbar menu.

Clicking 3D Maps > AFR Table [1 or 2] displays a variant of the following screen:

The screen will be a direct transformation of the numerical values in the matching AFR Table. The X & Y axes represent rpm & afr load respectively, and the height at each point reflects the AFR for the same point in the table.

You can use the methods described in Section 1.5.4. to view and make changes to these values.
14.4. Ignition Tables [1 to 3]

The three Ignition Maps directly correspond to the three Ignition Tables which are documented in Section 10.8. That section of this guide outlines the options that are required to enable each of those tables. Those same options will enable the equivalent menu options in the 3D Maps toolbar menu.

Clicking 3D Maps > Ignition Table [1, 2 or 3] displays a variant of the following screen:

The screen will be a direct transformation of the numerical values in the matching Ignition Table. The X & Y axes represent rpm & ignition load respectively, and the height at each point reflects the degrees for the same point in the table.

You can use the methods described in Section 1.5.4. to view and make changes to these values.
14.5. Rotary Split Table

The Rotary Split Map directly corresponds to the Rotary Split Table which is documented in Section 10.10. That section of this guide outlines the options that are required to enable that tables. The same options will enable the Rotary Split Table menu option in the 3D Maps toolbar menu.

Clicking 3D Maps > Rotary Split Table displays the following screen:

![Image of Rotary Split Table]

The screen will be a direct transformation of the numerical values in the Rotary Split Table. The X & Y axes represent rpm & ignition load respectively, and the height at each point reflects the degrees for the same point in the table.

You can use the methods described in Section 1.5.4. to view and make changes to these values.
14.6. Boost Control Duty Table

The Boost Control Duty Table Map directly corresponds to the Boost Control Duty Table which is documented in Section 13.2. That section of this guide outlines the options that are required to enable that table. The same options will enable the Boost Control Duty Table menu option in the 3D Maps toolbar menu.

Clicking 3D Maps > Boost Control Duty Table displays the following screen:

![Boost Control Duty Map](image)

The screen will be a direct transformation of the numerical values in the Boost Control Duty Table. The X & Y axes represent rpm & throttle respectively, and the height at each point reflects the percentage for the same point in the table.

You can use the methods described in Section 1.5.4. to view and make changes to these values.
14.7. Boost Control Target Table

The Boost Control Target Table Map directly corresponds to the Boost Control Target Table which is documented in Section 13.3. That section of this guide outlines the options that are required to enable that table. The same options will enable the Boost Control Target Table menu option in the 3D Maps toolbar menu.

Clicking 3D Maps > Boost Control Target Table displays the following screen:

The screen will be a direct transformation of the numerical values in the Boost Control Target Table. The X & Y axes represent rpm & throttle respectively, and the height at each point reflects the percentage for the same point in the table.

You can use the methods described in Section 1.5.4. to view and make changes to these values.
14.8. Injection Timing Tables [1 to 3]

The three Injection Timing 3D Maps directly correspond to the three Injection Timing Tables which are documented in Section 9.8. That section of this guide outlines the options that are required to enable each of those tables. Those same options will enable the equivalent menu options in the 3D Maps toolbar menu.

Clicking 3D Maps > Injection Timing Table [1, 2 or 3] displays a variant of the following screen:

![Injection Timing Table 1](image)

The screen will be a direct transformation of the numerical values in the matching Injection Timing Table. The X & Y axes represent rpm & fuelload respectively, and the height at each point reflects the degrees for the same point in the table.

You can use the methods described in Section 1.5.4. to view and make changes to these values.
15. CAN bus / Testmodes

The feature set of the Megasquirt can be extended using external expansion boards which connect to the mainboard over a two wire "CAN" connection. The CAN connection is documented in the Hardware manual for your Megasquirt. CAN (Controller Area Network) bus settings configure the communication with the expansion board. Sections 15.1. to 15.7. below outline how this can be done.

The majority of the CAN settings relate to the proprietary Megasquirt 29bit CAN header protocol. Standard 11bit broadcasting is covered in section 15.2. (For reference, greater support of standard 11bit CAN is available in firmware 3.4.x)

Megasquirt also includes a number of “test modes” to allow you to check your hardware. These allow you to confirm operation of some system components independent of the normal ECU operation. This is highly recommended before first starting the engine. These are outlined in sections 15.8. to 15.10. below.

15.1. CAN Parameters

Clicking CAN bus / Testmodes  > CAN Parameters displays the following screen:

The options for these settings are described below:

**My CAN ID**
Set to 0 unless you specifically want to configure this as a secondary data capture ECU.

**Master Enable**
Enables fetching data from expansion board via CAN.

**Enable PWM Polling**
Enables capturing PWM (pulse/frequency) from expansion board.

If this setting is **not enabled** the next five settings will remain disabled.

**Remote CAN ID**
CAN ID of the expansion board used for PWM polling.
Remote Table Number For PWM Data
The table number on the expansion board for PWM data.

Remote Table Offset For PWM Data (bytes)
Data offset on the expansion board used for PWM data.

Remote PWM Clock Frequency (MHz)
Clock frequency on expansion board (see the documentation that came with the expansion board.)

Remote PWM Clock Prescale
Prescaler on expansion board (see the documentation that came with the expansion board.)

Enable Ports Polling
Enables ports polling from expansion board.

⚠️ If this setting **is not enabled** the next seven settings will remain disabled.

Remote CAN ID
The CAN ID of expansion board used for ports polling.

Remote Table Number For Ports Data
The table number on the expansion board used for ports data.

Remote Table Offset For Ports Data (bytes)
Data offset on the expansion board used for ports data.

Remote Ports Direction
Selects combination of inputs or outputs. There are three options that you can select here to give yourself a choice of input / output ranges:

- 3 Inputs – port 1, port 2 & port 3 used for input;
- 2 Inputs, 1 Output – port 1 used for output; port 2 and port 3 used for input;
- 1 Input, 2 Outputs – port 1 & port 2 used for output; port 3 used for input.

Remote Port 1 Type
There are two options for this setting:

- Digital – converts into 8 on/off inputs/outputs;
- Single value – one input or output.

Remote Port 2 Type
The same options that apply to Port 1 also apply to Port 2.

Remote Port 3 Type
The same options that apply to Port 1 also apply to Port 3.
Use For Remote On/Off Outputs
Enables the use of programmable on/off outputs on expansion board (select the remote port that you want to use for programmable on/off outputs.)

⚠️ Requires that at least one port be defined as an output, i.e., this option will not be enabled if “3 Inputs” is selected under “Remote Ports Direction” (see above.)

15.1.1. CAN ADC Selection

⚠️ These options are only enabled if “Master Enable” is set to “Enabled” (see above.)

CAN ADC 0-3
Enables capturing analogue inputs from expansion board and stores them in ADC 0-3.

⚠️ The following three options are only enabled if this setting is enabled.

CAN Id
The CAN Id of the expansion board enabling capture on CAN ADC 0-3.

Table
The table number on the expansion board responsible for capture on CAN ADC 0-3.

Offset
Data offset on the expansion board responsible for capture on CAN ADC 0-3.

CAN ADC 4-7
Enables capturing analogue inputs from expansion board (4-7).

⚠️ The settings for ADC 4-7 work in exactly the same way as those for ADC 0-3.

15.2. CAN Broadcasting

⚠️ The CAN bus / Testmodes > CAN Broadcasting menu option is only enabled if “Master Enable” is set to “Enable” in the CAN Parameters screen (see Section 15.1.)

Clicking CAN bus / Testmodes > CAN Broadcasting displays the following screen:
The options for these settings are described below:

**Enable Broadcasting**

Enables broadcasting of parameters over CAN.

⚠️ Unless this setting is **enabled**, all other settings on the screen will be disabled.

**Broadcast Interval (ms)**

How frequently to broadcast.

**Broadcast Messages**

Specific messages can be enabled for broadcasting. Any appropriate selection can be set to “On”. These messages are listed as follows:

- 0x280 – rpm * 4;
- 0x280 – rpm * 1;
- 0x289 0 – coolant;
- 0x316 – rpm;
- 0x329 – coolant;
- 0x561 – Alfa / Fiat / Lancia Dash;
- 0x361 – Alfa / Fiat / Lancia;
- 0x041 – Alfa / Fiat / Lancia.
- Holset HE351VE VGT turbo - this broadcasts 'boost duty' with a 29bit CAN identifier specific to the turbo to control the variable vanes.
- User defined testing - enables user defined messages to be broadcast, see next section.

**15.3. CAN Broadcast testing**

A custom identifier (decimal) and payload can be broadcast. (Always 8 bytes.)

Clicking CAN bus / Testmodes > CAN Broadcast Testing displays the following screen:
Megasquirt-2: TunerStudio MS Lite Reference Guide

**Identifier**

The message ID in decimal

**Data 0-7**

The 8 data bytes in decimal.

### 15.4. CAN Realtime Data Broadcasting

This allows all of the engine parameters to be broadcast to the CAN using standard 11bit identifiers which can then be received and displayed by suitable 3rd party dashes or dash loggers. (This is a major enhancement in 3.4.x firmware.)

Clicking CAN bus / Testmodes > CAN Realtime Data Broadcasting displays the following screen:

Once enabled, the user can select which data packets to broadcast and at what frequency. Be aware that the maximum capacity of CAN is around 4000 packets per second i.e. 40 channels at 100Hz. For reliable operation of other devices on the network it is suggested that a lower limit of 1-2000 be applied.
More technical details of this feature are available in a specific PDF available from http://www.msextra.com/doc/pdf/

15.5. CAN Realtime Data Broadcasting 2
More data channels in the real-time broadcasting system.

15.6. Dash Broadcasting
Dash broadcasting allows a simplified pre-defined set of data channels to be broadcast over CAN. These can then be received by compatible third-party dashes or dataloggers.

The aim is to allow simple data sharing without the user having to get involved in the technical details of CAN. "Just turn it on and go!"

Technical details of the channels broadcast are available in a PDF at: http://www.msextra.com/doc/pdf/

Clicking CAN Bus / Testmodes > Dash Broadcasting displays the following screen:

Enable
Enables or disables the broadcasting.

Configuration
• Automatic - CAN id = 1512, rate = 20Hz
• Advanced - allows CANid and transmit rate to be set.

Generally it is advised to leave it set to Automatic. The following settings are only available in Advanced mode.

Base CAN identifier
The decimal identifier used for the first packet in the dataset broadcast.

Outputs transmit rate
The transmission interval (data rate.)

15.7. Remote On / Off Outputs

⚠️ The CAN bus / Testmodes > Remote On/Off Outputs menu option will only be enabled if “Use for remote on/off outputs is enabled and a remote port is selected (see Section 15.1.)

Clicking CAN bus / Testmodes > Remote On / Off Outputs displays the following screen:
This screen will be familiar from Section 13.10 which covers the built-in programmable On/Off Outputs. The main difference is that an expansion card will give additional remote On/Off outputs in addition to those which are built into your Megasquirt. The documentation that shipped with your expansion card will be necessary to configure these outputs accurately, although the basic concepts are the same and are described below.

15.7.1. Output Port

The output port supports up to eight Channels (which are derived from the 8 bits contained within a single byte of data).

When you click on any of the ports listed, the settings in the “Port Settings” and the “Active Conditions” sections on the right hand of the screen (documented in Sections 15.7.2. and 15.7.3. respectively) will apply to the port you have selected.

Be careful that you don't duplicate between built-in and remote outputs. It is worth referring back to your settings in Boost / Advanced > Programmable On / Off outputs whilst you plan how to use your remote outputs.

15.7.2. Port Settings

These settings allow you to select whether a port is used and when it is used.

Enabled

Clicking the check box (so that it contains a tick) means that you are going to use the selected port. The gray icon next to the port you are using in the Output Port list will change to green when this setting is checked.

Power On Value

This is a setting that determines if the output will be on or off when your Megasquirt powers up. Please take the active conditions (see Section 15.7.3.) into account when deciding how to set this.

Typically this value is set to “Off”.

Active Value

This is an on/off setting that determines whether or not the output is triggered when the conditions for it to become active are met.
Typically this value is set to “On”.

15.7.3. Active Conditions

These settings allow you to determine the conditions under which the output becomes active.

Output channel

This is a list of Megasquirt variables - much the same as the various gauges you can select in dashboard.

Operator

This ‘logical operator’ forms part of the equation. There are four options for this setting:

- > (is greater than);
- = (is equal to – this options is rarely useful);
- < (is less than);
- And (performs a bitwise AND operation – useful for setting outputs based on status bits.)

Threshold

The value at which the output channel is compared using the operator to establish whether the condition is “Active”.

Hysteresis

It is very common for a value to hover around the threshold which would cause the output to turn on and off rapidly. This setting helps to prevent that by creating a deadband below the threshold which prevents the output from being repeatedly activated during borderline conditions.

Additional condition

There are three options for this drop down box:

- No additional condition – only a single condition is used;
- Or – output triggers if either condition 1 OR condition 2 is met;
- And – output triggers only when condition 1 AND condition 2 are both met.

If “Or” or “And” are selected then complete the second Output Channel, Operator, Threshold and Hysteresis in the same way as described above.
15.8. Output Test Mode – Inj/Spk

Clicking CAN Bus / Testmodes > Output Test Mode – Inj/Spk displays the following screen:

![Output Test Mode - Inj/Spk](image)

This test mode allows direct control and testing of the coils and injectors.

⚠️ Used by accident this could cause flooding of the engine and potential damage, therefore a special initialisation method is required to enable it. Do not attempt to test injectors or coils on a running engine. Before testing injectors on an engine be sure to depressurise the fuel rail - this can be achieved by unplugging the fuel pump while the engine is idling. Unless you are flow testing injectors on a flow-bench, you are strongly advised to remove the fuel pump fuse during all of this testing.

⚠️ Before using the test mode ensure that you have already configured the correct number of cylinders and type of injector and spark output etc, i.e., if you want to test 8 cylinder COP mode, you need to have correctly configured those settings beforehand.

First ensure that you are key-on, engine-off (or that RPM is set to zero on the stim if you are carrying out bench testing.) In this condition the ‘Enable Test Mode’ button will be available. Click the button to enable the test mode.
**Fuel Pump**

- Clicking “Fuel Pump On” will enable the fuel pump output and light the ‘Ready’ indicator on TunerStudio.
- Clicking “Fuel Pump Off” will disable the fuel pump output and turn off the ‘Ready’ indicator.

### 15.8.1. Coil Testing

The coil test mode is useful to confirm you have the coils wired correctly and to check dwell settings.

**Exercise extreme caution** during this test as ignition coils put out a potentially lethal voltage – typically 30,000V or more!

There are five settings to consider when carrying out coil testing:

**Output Interval (ms)**

How often to pulse the coil.

**RPM (Coil On Plug) (RPM)**

Approximate equivalent RPM (this cannot be set directly, but is a function of Output Interval.)

**Coil Testing Mode**

Needs to be set to “One” in order to carry out coil testing.

**Coil Output to test**

Gives a list of available coils than can be tested.

**Dwell (ms)**

Dwell used during testing – no voltage correction is applied.

**Follow the following steps to carry out coil testing:**

- Choose the desired Output Interval;
- Set Coil Testing Mode to “One”;
- Choose which coil to test (e.g. CoilA);
- Choose your Dwell time in milliseconds (start low, e.g., 2.5ms);
- If your coils are powered via the fuel pump relay (recommended) set the fuel pump to “On”;
- Check the above settings, then click the “Start” button;
- When finished, click “Stop”.

If the coils get hot or your coil fuses pop, then you almost certainly have a basic settings mistake with output polarity. Turn off power **immediately** and review those settings.

### 15.8.2. Injector Testing

The coil test mode is useful to confirm you have the injectors wired correctly and to experiment with opening times, PWM settings or to measure flow rate if you have an injector test bench setup.
Using flammable liquids while testing is hazardous and can lead to serious fires. Non-flammable injector test liquid is available and you are strongly recommended to use it.

If your injectors are fitted to the engine you must not run the test mode with fuel pressure or you will fill your engine with fuel! Remove the fuse from your fuel pump and depressurise the line first.

There are six settings to consider when carrying out injection testing:

**Output Interval (ms)**
How often to pulse the injector.

**RPM (Full Sequential) RPM**
Approximate equivalent RPM (again, this cannot be set directly, but is a function of Output Interval.)

**Injector Testing Mode**
Needs to be set to “One” or “All” in order to carry out injector testing.

**Injector Channel To Test**
Gives a list of available injectors than can be tested (only applies if “One” has been selected in Injector Testing Mode.

**Pulsewidth (ms)**
Pulsewidth used during testing – no dead-time is added and no voltage correction is applied.

**Total Number Of Injections**
Number of injection pulses in each test.

**Follow the following steps to carry out injection testing:**

- Choose the desired Output Interval (the estimated RPM equivalent will be displayed.);
- Set Injector Testing Mode to “One” or “All” (depending whether you want to test one injector alone or all injectors together;
- If you have selected “One” in step 2, choose which injector to test, e.g., “InjA”;
- Choose your Pulsewidth time in milliseconds;
- If your injectors are powered via the fuel pump relay (as is recommended) set the fuel pump to On;
- For functional testing, set the total number of injections to 65535 (the maximum) or for flow testing use your chosen number;
- With valid settings entered the “Start” button should be active, if so click it.
- The number of injections gauge will count down and stop at zero.
- To stop testing sooner, click “Stop” at any time during the test.

**15.8.3. PWM Settings**
The PWM settings section allows you to test different PWM settings for the two injector bank outputs while in
test mode. There are four settings that can be configured for this.

**Injector PWM Parameters**

Allows testing of different PWM current limiting parameters (the following three settings will only be enabled if this setting is set to “As below.”)

**PWM Current Limit (%)**
The PWM duty cycle.

**PWM Time Threshold (ms)**
The full-current time at the beginning of each pulse.

**Injector PWM Period (μs)**
The PWM period (or frequency.)

⚠️ When you have finished using the test mode, close the test mode window and power off your Megasquirt. If you disconnected your fuel pump you can reconnect it now.

### 15.9. Output Test Mode – I/O

Clicking CAN Bus / Testmodes > Output Test Mode – I/O displays the following screen:

![Output Test Mode - I/O](image)

This allows you to test some of the on/off and pulsed outputs in a controlled manner.

⚠️ As with the other tests, be cautious – this mode allows you complete control over the outputs and it is important to take care not to cause any accidental damage.

First ensure that you are key-on, engine-off (or that RPM is set to zero on the stim if bench testing.) In this condition the ‘Enable Test Mode’ button will be available. Click the button to enable the test mode.

For each of the outputs you can select

- Off – turns the selected output off;
• On – turns the selected output on;
• Pulsed – pulses the output at the selected frequency and duty.

Remember that all of the power outputs from the Megasquirt are ground switching, so typically you will not be able to measure any voltage at the output with a meter. Use a small test lamp or test LED connected between 12V and the output.

When you have finished using the test mode, close the test mode window and power off your Megasquirt.

15.10. Output Test Mode – Idle Valve

This Output Test Mode – Idle Value menu option will only be enabled if you have an appropriate setting selected for “Idle Valve Type” (see Section 11.7.)

Clicking CAN bus > Testmodes > Output Test Mode – Idle Valve displays the following screen:

The idle valve test mode can be used with the engine running or stationary. Note that with a PWM idle valve you may need to run a temporary fused 12V supply to the valve if you normally take power from the fuel pump relay and are testing with the engine off. You need to have enabled idle control before this is available.

There are three main settings for this screen:

**Idle Valve Homing Steps**

*This only applies to stepper idle valves.* This setting determines how many steps the motor should move during homing to ensure it has reached the home position. The number needs to be large enough to close the valve from any unknown starting position (this is because there is no position feedback – in non-automotive control applications there is often a feedback encoder.)

**Idle Valve Step**

The desired valve position, larger numbers should give a more open valve and higher rpm (for stepper motors.)
**PWM idle duty%**

The desired valve position, larger numbers should give a more open valve and higher rpm. (For PWM valves)

⚠️ Some Bosch rotary PWM valves feature a failsafe mode so that zero flow is at, for example, 20% duty. Above that the valve operates as expected where more duty gives more airflow. Below this specific point is a failsafe mode that allows airflow even if there is no control signal. This is readily observed during test mode.

There are also three control buttons:

**Enable Test – Home Position**

For stepper idle valves this moves the valve through the number of homing steps back to the home position. (If it doesn't get all the way back to the stop, increase the number of homing steps.) The valve will move to the run position shortly afterwards.

**Enable Test – Run Position**

Enable test mode where the steps or duty setting controls the valve position

**Stop Testing**

Disable test mode and allow normal idle control to operate.
16. Upgrade

The Upgrade toolbar does not display a drop down menu, but will instead display a page of information screen about the Upgrade version of TunerStudio similar to that shown below:

![Upgrade Page](image)

This screen includes information from the developer's Internet Site and is subject to change. It provides detailed information about the additional features included within the Upgrade version, and includes a link to purchase an upgrade license should you so wish.
17. Dashboard Gauge Cluster

In the main screen, there are three tabs “Gauge Cluster”, “Diagnostics & High Speed Loggers”, and “Tune Analyze Live – Tune For You”, labeled as (1) in the following image:

“Gauge Cluster” is the default tab which is displayed when you open TunerStudio. Using the default dash this gives you access to eight customizable gauges and a set of indicators. The gauges are labeled as (1) in the following image and are documented in this section. The dash indicators are documented in Section 18.
Right-clicking on any gauge in this gauge cluster will bring up a pop-up menu allowing you to swap the gauge for one of the alternatives as described in Sections 17.1. to 17.8. below:

17.1. TunerStudio gauges
These gauges are technical statistics for TunerStudio itself and will be rarely used.

Interrogation Progress
For developer use only.

Records Logged
The total number of datalog records recorded.

Runtime Data Rate
Shows how fast TunerStudio is communicating with the Megasquirt in frames per second.
(The data rate can be adjusted on the Communications menu.)

17.2. AFR/EGO inputs+calcs

AFR1 target
The current target value for AFR1, looked up from the AFR1 target table.

AFR2 target
The current target value for AFR2, looked up from the AFR2 target table.

Air: Fuel Ratio1
The current AFR reading from oxygen sensor 1. Useful for wideband sensors.

Air: Fuel Ratio2
The current AFR reading from oxygen sensor 2 (if used.)

EGO Correction 1
The percentage fuel correction from AFR1 when closed-loop EGO control is used (100% means no change.)

EGO Correction 2
The percentage fuel correction from AFR2 when closed-loop EGO control is used (100% means no change.)

EGO Correction
The average of EGO corrections 1 and 2. Only useful if both channels are being used.

Exhaust Gas Oxygen 1
The current voltage reading from oxygen sensor 1. Useful for narrowband sensors.

Exhaust Gas Oxygen 2
The current voltage reading from oxygen sensor 2 (if used.)
Exhaust Gas Oxygen
This gauge will display voltage or lambda or AFR for the first oxygen sensor.

Lambda 1
The current lambda reading from oxygen sensor 1.

Lambda 2
The current lambda reading from oxygen sensor 2 (if used.)

Stoich
The value of the stoichiometric setting (typically 14.7 AFR for gasoline.)

17.3. Calculations 1
Unless otherwise noted, all multiplier values use 100% to mean no change.

Accel Enrich PW
The current fuel pulsewidth adder due to acceleration enrichment.

Accel Enrich%
The current fuel pulsewidth percentage multiplier due to acceleration enrichment.

Advance Bucket
This gauge is for historical purposes only.

Air Density Correction
The percentage multiplier to fueling due to air density.

Barometric Correction
The percentage multiplier to fueling due to barometric correction.

Clock
A built in clock that counts the seconds since the Megasquirt was last turned on. If this suddenly resets to zero, you probably have a power connection problem.

DeadTime 1
The current injector deadtime value (allowing for battery voltage correction.)

E85 Fuel Correction
The percentage multiplier to fueling due to the flex fuel sensor.

EAE Fuel Correction 1
The percentage multiplier to fueling due to Enhanced Acceleration Enrichment channel 1.

EAE Fuel Correction 2
The percentage multiplier to fueling due to Enhanced Acceleration Enrichment channel 2.
Fuel on the walls 1
The calculated fuel puddle volume on the intake port walls, channel 1.

Fuel on the walls 2
The calculated fuel puddle volume on the intake port walls, channel 2.

Nitrous Added Fuel
The fuel pulsewidth adder from the nitrous system.

Req Fuel (calc)
The current effective 'ReqFuel' value.

Total cor
The total fuel percentage multiplier obtained by multiplying the other factors. If this is outside of the range 80%-120% then there is probably something wrong with your tuning settings.

VE Trim 1
The percentage trim multiplier to fueling on injector 1.

VE Trim 2
The percentage trim multiplier to fueling on injector 2.

VE Trim 3
The percentage trim multiplier to fueling on injector 3.

VE Trim 4
The percentage trim multiplier to fueling on injector 4.

Warmup Enrichment
The percentage multiplier to fueling due to Warmup and Afterstart (this should be 100% on a warmed up engine.)

17.4. Calculations 2

Base Spark Advance
The spark timing/advance looked up from the advance table before other adjustments are made.

Boost Target
The target boost pressure for closed-loop mode.

CL idle target
The target engine speed for closed-loop idle control.

Cold advance
The advancement to the timing due to cold advance curve.
External Advance
The external advancement to the timing, e.g., from a transmission controller.

Flex Advance
The advancement to the timing due to flex fuel.

Idle Correction Advance
The advancement to the timing due to idle correction.

Knock Retard
The retardation to the timing due to knock control.

Lost Sync Counter
The count of “lost-sync” events. If the engine stalls the counter will increase by one. During startup it is acceptable to have a few lost syncs. If you see this counting up under other conditions, there is a problem with your tach input.

Lost Sync Reason
A technical reason code for why the ECU lost synchronization with the tach input. Not particularly useful.

MAPdot
The rate of change of MAP (the increase in MAP per second.)

MAT Retard
The retardation to the timing due to the MAT retard curve.

Nitrous Retard
The retardation to the timing due to the nitrous system.

RPMdot
The rate of change of RPM (the increase in RPM per second.)

Revlim Retard
The retardation to the timing due to the rev limiter.

Spark Table 1
The looked up spark advance from ignition table 1.

Spark Table 2
The looked up spark advance from ignition table 2.

Spark Table 3
The looked up spark advance from ignition table 3.

TPSdot
The rate of change of TPS (the increase in TPS per second.)
Timing pred err
A calculation of how accurately the position of the next tach tooth was predicted (not often used).

User defined
Does nothing as standard. Can be used by user customized firmware.

VE Current 1
The looked up VE value for channel 1.

VE Value
This gauge is for historical purposes only.

VE Current 2
The looked up VE value for channel 2.

17.5. Outputs

Boost Duty
The current duty cycle output to the boost solenoid.

Duty Cycle 1
The calculated injector duty cycle on channel 1 (85% is a recommended maximum, above 100% is impossible.)

Duty Cycle 2
The calculated injector duty cycle on channel 2.

Dwell (Trailing)
The ignition dwell (charge) time on the rotary trailing outputs.

Dwell
The ignition dwell (charge) time on the main spark outputs.

Idle PWM%
The current duty cycle output to the idle valve.

Idle Stepper position
The current stepper valve position (0 means fully closed.)

Ignition Advance
The overall ignition advance.

Injection Timing 1
The injection timing used for all injector channels for the standard sequential/semi-sequential injection, for the semi-sequential Siamese injection mode, for sequential Siamese injection mode with a single timing value, and for sequential Siamese injection hybrid mode. When using sequential Siamese injection mode with two timing values, this is the injection timing for cylinders 1 and 4 (outer cylinders).
Injection Timing 2
The injection timing for cylinders 2 and 3 (inner cylinders) when using two timing values in the sequential Siamese injection mode.

pulsewidth 1
The fuel pulsewidth for injector channel 1 (this is the actual electrical pulsewidth including deadtime.)

cpulsewidth 2
The fuel pulsewidth for injector channel 2.

cpulsewidth 3
The fuel pulsewidth for injector channel 3.

cpulsewidth 4
The fuel pulsewidth for injector channel 4.

17.6. Sensor inputs 1

AFR load
The 'load' (e.g. MAP, TPS) used on the Y-axis of the AFR table.

Barometer
The barometer reading. This will show: a current value if a dedicated baro sensor is installed; the initial MAP reading; or 100kPa if barometric correction is disabled.

Battery Voltage
The measured battery voltage (if this is radically different from your actual battery voltage, check for wiring faults.)

Boost – boostbarGauge
The relative boost pressure in bar.

Boost – boostpsigGauge
The relative boost pressure in psig.

Coolant Temp
The measured coolant temperature (CLT.)

EAE load
The 'load' (e.g. MAP, TPS) used on the Y-axis of the EAE curves.

Engine MAP
The measured MAP (on typical speed-density installs this should read near 100kPa during key-on, engine-off and 30-60kPa at idle.)

Engine Speed
The tachometer / rev counter (if this is dropping to zero or bouncing around, you probably have a problem with
the tach-in signal.)

**Est. Intake Air Temp**
A calculated estimate to the intake air temperature using a blend of measured air and coolant temperatures. See the MAT/CLT blending setting.

**Fuel Load**
The primary 'load' for fuel calculations (this is equal to MAP on typical speed-density installs.)

**Ign Load**
The 'load' (e.g. MAP, TPS) used on the Y axis of the ignition tables.

**MAF Volts**
The voltage from the MAF sensor.

**MAFLoad**
A calculated 'load' value that works similarly to MAP in a speed-density system (make for better use of the lookup tables.)

**Manifold Air Temp**
The measured intake manifold air temperature (MAT.)

**Mass Air Flow**
The airflow in g/sec calculated from the MAF sensor.

**Secondary Fuel Load**
Like 'Fuel Load' but used for the secondary lookup table.

**Secondary Ign Load**
Like 'Ign Load' but used for the secondary lookup table.

**Throttle Position**
The 0-100% throttle (pedal) position (check the calibration settings if you do not get 0-100%).

**Vac/Boost**
Shows the MAP sensor in vacuum / boost imperial units.

### 17.7. Sensor inputs 2

**ADC 6**
The raw ADC value from the spare analogue input 6 (JS5 / SPAREADC.)

**ADC 7**
The raw ADC value from the spare analogue input 7 (JS4 / SPAREADC2.)

**EGT – egtGauge6**
The ADC value converted to a temperature. This requires the custom installation of an EGT amplifier.
EGT – egtGauge7
The ADC value converted to a temperature. This requires the custom installation of an EGT amplifier.

Ethanol Percentage
The calculated ethanol percentage in the fuel reported from the flex fuel sensor.

GPIO ADC [0 – 7]
The raw ADC values captured from an optional expansion board over CAN.

Knock Input
The signal value from an optional add-on knock sensor interface.

17.8. X-Code dev
These gauges are typically only of use by developers.

-- 0 deadGauge
A gauge that does nothing.

Injection Count
Used by injector test mode to show the number of remaining test squirts.

Mainloop time
How long each pass through the ‘mainloop’ of code is taking in microseconds.

Status [1 – 3]
These are bitfield values that are used to drive the indicators. See section 4.6.1 for their definitions.

Status [4 – 5]
Only used by developers.

17.9. Other Menu Items on the Gauge Pop-up Menu
The “Background”, “Antialiasing Enabled”, “Designer Mode” and “Gauge Demo” menu options are replicated from the File > Gauge Cluster sub menu, which is documented in Section 2.6.
18. Dashboard Indicators

The Dashboard Indicators are located at the bottom of the default dash below the gauges and are labeled as (1) in the following image. The indicators are generally customizable and are used to indicate on/off events.

Right-clicking on any of these indicators will bring up a pop-up menu allowing you to swap the indicator for one of the alternatives as described in Sections 18.1 to 18.4 below:

18.1. Application Indicators

- Datalogging – highlighted if data logging is active
- Protocol Error – highlighted if there is a serial communication problem

18.2. Predefined Indicators

The list of alternative indicators will vary depending on whether you have activated “PORT_STATUS” in your Project Properties. Activating PORT_STATUS will add access to additional indicators and also changes the way the menus are laid out.

18.3. Predefined Indicators with PORT_STATUS Deactivated (Default)

Sections 18.3.1. and 18.3.2. list the options that will be offered to you if you right click on any of the indicators if PORT_STATUS for your project has been left deactivated.

18.3.1. Predefined Indicators

- **AC** – determines whether air conditioning is active.
- **ASE / ASE OFF** – determines whether running in After Start Enrichment mode.
- **CL idle** – closed-loop idle control active.
Config Error – if there is an error in your settings, in this case fix the settings.
Cranking / Not Cranking – currently cranking.
Flat shift – flat shift in effect.
Fuel Tbl sw – fuel table switching in effect.

Full RPM-sync / Half RPM-sync – whether the Megasquirt is fully synchronized to crank and cam signals enough to run coil-on-plug or sequential (this might show a cam fault.)
Hard limit – hard rev limiter in effect.
Knock – knock signal detected.
Launch – launch in effect.
Lost Data – if something went wrong and data was not saved.
MAP Accel Enrich – currently in an accel enrichment event due to MAP.
MAP Decel – currently in an decel enleanment event due to MAP.
MAPsample error! – something is wrong with your MAP sample settings.
N2O 1 – nitrous stage 1 output.
N2O 2 – nitrous stage 2 output.
Need Burn – if unsaved data is waiting to be burned to flash memory.
Over boost – boost limiter in effect.
Ready / Not Ready – shows when there is an active tach signal and pump is running.
Seq. shift / No Seq. Shift – sequential shift control active.
Soft limiter / No soft limit – soft rev limiter in effect.
Spark cut – spark cut in effect.

18.3.2. Predefined Indicators 2
Spk Tbl sw – spark (ignition) table switching in effect.

RPM-Synced / Not RPM-synced – whether the Megasquirt is synchronized to the crank and cam signals
T-log – tooth/trigger/composite log ready (TunerStudio internal use.)
TPS Accel Enrich – currently in an accel enrichment event due to TPS.
TPS Decel – currently in an decel enleanment event due to TPS.
Test mode – spark / injector test mode is active.
WUE OFF / WUE – in WarmUp Enrichment mode.

18.4. Predefined Indicators with PORT_STATUS Activated

Sections 18.4.1. to 18.4.3. list the options that will be offered to you if you right click on any of the indicators if PORT_STATUS for your project has been activated.

18.4.1. Predefined Indicators with PORT_STATUS Activated
AC – determines whether air conditioning is active.
ASE / ASE OFF – determines whether running in After Start Enrichment mode.
**CL idle** – closed-loop idle control active.

**Config Error** – if there is an error in your settings, in this case fix the settings.

**Cranking / Not Cranking** – currently cranking.

**Flat shift** – flat shift in effect.

**Fuel Tbl sw** – fuel table switching in effect.

**Fuel Cut** – fuel cut in effect.

**Full RPM-sync / Half RPM-sync** – whether the Megasquirt is fully synchronized to crank and cam signals enough to run coil-on-plug or sequential (this might show a cam fault.)

**Hard limit** – hard rev limiter in effect.

**Knock** – knock signal detected.

**Launch** – launch in effect.

**Lost Data** – if something went wrong and data was not saved.

**MAP Accel Enrich** – currently in an accel enrichment event due to MAP.

**MAP Decel** – currently in a decel enleanment event due to MAP.

**MAP sample error!** – something is wrong with your MAP sample settings.

**N2O 1** – nitrous stage 1 output.

**N2O 2** – nitrous stage 2 output.

**Need Burn** – if unsaved data is waiting to be burned to flash memory.

**Over boost** – boost limiter in effect.

See also section 4.6.1 for more information on the portXX fields.

**PORTA0** – JS11, PA0

**PORTAD6** – ADC6 digital value

**PORTAD7** – ADC7 digital value

**PORTB4** – IAC enable

**18.4.2. Predefined Indicators 2 with PORT_STATUS Activated**

**PORTE0** – PE0/JS7, FLEX, LAUNCH

**PORTE1** – PE1 (table switch input)

**PORTE4** – fuel pump

**PORTB4** – IAC enable

**PORTM2** – FIDLE

**PORTM3** – INJ LED

**PORTM4** – ACC LED

**PORTM5** – WU LED

**PORTT0** – main tach input

**PORTT1** – INJ1

**PORTT2** – PWM1 (or cam in)

**PORTT3** – NJ2
PORTT4 – PWM2
PORTT5 – JS10 / cam in, IGN1
PORTT6 – IAC 1
PORTT7 – IAC 2

Ready / Not Ready – shows when there is an active tach signal and pump is running.
Seq. shift / No Seq. Shift – sequential shift control active.
Soft limiter / No soft limit – soft rev limiter in effect.
Spark cut – spark cut in effect.
Spk Tbl sw – spark (ignition) table switching in effect.
RPM-Synced / Not RPM-synced – whether the Megasquirt is synchronized to the crank and cam signals
T-log – tooth/trigger/composite log ready (TunerStudio internal use.)
TPS Accel Enrich – currently in an accel enrichment event due to TPS.
TPS Decel – currently in a decel enleanment event due to TPS.
Test mode – spark / injector test mode is active.

18.4.3. Predefined Indicators 3 with PORT_STATUS Activated
WUE OFF / WUE – in WarmUp Enrichment mode.

18.5. Other Menu Items on the Indicator Pop-up Menu
The “Background”, “Antialiasing Enabled”, “Designer Mode” and “Gauge Demo” menu options are replicated from the File > Gauge Cluster sub menu, which is documented in Section 2.6.

19. Diagnostics & High Speed Loggers
The diagnostics tab allows access to the high-speed ignition loggers built into the Megasquirt firmware. These should be used during initial installation to confirm that tach signals are present and clean. They can also be used later as fault finding tools. Selecting the Diagnostics & High Speed Loggers tab from the main screen will display a screen similar to that shown below:

19.1. Logger Type
This selects which of the Megasquirt firmware supplied loggers to use. The tooth logger and composite logger are generally the most useful. Although your firmware may give you additional options, the four standard loggers are briefly described below.

For all of the loggers, you are seeing a decoded version of the input signal. The processor inside the Megasquirt only sees a 0-5V signal, the raw analogue signal is pre-processed by the tach-in circuits.
Composite Logger

This logger records both crank and cam signals in a format similar to an oscilloscope. The exact display will depend on a number of factors:

- ignition mode
- whether the cam signal is used
- noise filtering

Most ignition modes only listen for a single "edge" of the input signal and the composite logger will reflect that with a series of vertical lines for each input pulse. The cam signal will only display if the input is in use and enabled and there is a cam signal coming in.

Enabling the "noise filter" makes the ECU listen to both edges of the input signal and the display will look different for the same actual signal.

During initial setup or for test purposes the ignition mode "Log crank & cam" can be selected to put the Megasquirt into a diagnostics mode that will record the full digital signal on both crank and cam inputs. (The engine will not run in this mode.)
Sync Error Logger
This logger records a composite log up until a sync-loss occurs. The data shown is the crank and cam pattern that led up to the faulty signal causing sync-loss.

Tooth Logger
The tooth logger records just the crank pattern. It is useful for validating crank sensor polarity on missing-tooth wheels. (Correct polarity will show as a single long tooth, incorrect polarity will show as two fairly long teeth.)
The trigger logger records the internally decoded tach signal with one pulse per cylinder. This is not particularly useful for tracking down tach input problems. It will show up any uneven running of the engine.

19.2. Using the Loggers

Using the loggers is relatively straightforward. The options are described below:
Start
Starts capture of data from the Megasquirt.

Stop
Stops capture of data from the Megasquirt.

Clear
Clears the screen of any captured data.

Fetch interval
How often to collect data from the Megasquirt. This only applies to the Tooth and Trigger loggers.

During cranking when the engine is turning slowly, set the time to longer (e.g. 4000ms means 4 seconds) to enable a useful amount of data to be captured. You will need to wait at least this long before any data is displayed, so be patient.

Capture to Logfile
Enables the log to be recorded to a file on disk. The file can then be shared for support purposes.

Typical use of the logger:
Generally the following steps will enable you to capture data for analysis using one of the loggers.

• Turn on Megasquirt.
• Pick the Logger type
• Tick ‘Capture to Logfile’
• Choose a filename or just press Enter.
• Click Start
• Crank the engine
• Wait for data to show
• Click Stop
• Untick “Capture to Logfile”.

19.3. Analyzing Data from the Loggers
When the logger is running the data that is being collected will be displayed in the list on the left side of the screen. This screen can be re-sized using the left and right arrows on the top right of this list.

The log traces (the visual representation of the output) is displayed in the chart area on the right hand side of the screen.

Depending on your engine and your Megasquirt configuration the loggers can provide a wide range of outputs.
20. Tune Analyze Live

Tune Analyze Live is a feature of the Upgrade version of TunerStudio. Documentation of this feature lies outside the scope of this document. Clicking this option will display an upgrade screen as shown below from which it is possible to purchase a license to the upgrade version should you so wish.
21. Megasquirt Glossary of Terms

**ADC** – stands for “analog-to-digital converter”. In this case, it is part of the conversion circuitry in the CPU that translates the varying voltage signal to a digital value that the CPU can understand and operate on. All of the sensors (TPS, MAP, CLT, MAT) send their signal to a particular ADC pin on the processor. The ADC result is used by the processor as a ‘count’. MS-I has an eight bit ADC, so the counts can be from 0 to 255. MS2 and MS3 have a more precise 10-bit ADC, so the count can be from 0-1023. Both of these are mapped over a 0-5 Volt range (so the voltage into the ADC = ADC count * 5.0/1023 for MS2, for example); however, higher external voltage may be brought down to a 0-5 volt range with a voltage divider or boosted with an amplifier (such as for EGTs).

**AE** – Acceleration Enrichment, the enriched mixture provided when the throttle position sensor signal (TPSdot) or map sensor signal (MAPdot) changes at various rates.

**AFM** – Air Flow meter. Often a vane or flapper type device used to measure air-flow into an engine.

**AFR** – Air Fuel Ratio, the mass ratio of air to fuel in the combustion chamber. See lambda, NB- and WB-EGO sensors, below.

**Alpha-N** – Fuelling algorithm that uses throttle position as the primary load. Should not be used on turbocharged engines.

**ASE** – After Start Enrichment, the enriched mixture provided for a number of engine cycles when MegaSquirt detects that the engine has transitioned from cranking to running.

**AMC** – Automatic Mixture Control, a control system available in MS2/BG code to automatically tune fuel within the ECU using feedback from the oxygen sensor without use of a laptop. Should be used with great caution as a defective O2 sensor could cause a good VE table to be wiped out.

**ATDC** – After Top Dead Center, the crankshaft position with respect to the piston being at the top of its travel, meaning it has passed it's highest position and is descending.

**Baro** – Barometer - the ambient air pressure. At sea level this is around 100kPa. At high elevations it may be 80kPa. The fuelling needs to take account of this.

**%baro** – a fuelling algorithm where engine load = MAP/Baro and the speed-density system is used. This alters what values are looked up in the fuel VE table.

**Barometric correction** – a calculation that alters fuelling based on the ambient air pressure. Important at varying elevations. Of little importance in low-lying countries.

**BIP373** – a robust ignition driver transistor from Bosch. Features over-current and over-temperature protection. Used in all good Megasquirt kits. Beware of lesser alternatives.

**BTDC** – Before Top Dead Center, the crankshaft position with respect to the piston being at the top of its travel, meaning it has NOT passed it's highest position and is rising. Most normal spark event occur BTDC.

**CAN** – (Controller Area Network) - a dedicated automotive networking system to allow different automotive processors to communicate and share inputs and calculated results. Used as a convenient way to extend the inputs and outputs of the Megasquirt ECU. (Not available on Megasquirt-1)

**Carbon Monoxide (CO)** – Poisonous gas produced during combustion process. In an automotive context, generally refers to regulated carbon monoxide (CO) tail pipe emissions.

**CAS** – Crank Angle Sensor. Often used to refer to combined crank and cam position sensors mounted where historically a distributor would have been.

**Catalytic converter** – a chemical device in the vehicle’s exhaust system that can reduce the amount of regulated emissions emitted by converting Nox to N2 + O2, CO to CO2 and HC to CO2 + H2O. Catalytic means the converter active substrate facilitates the reactions, but is not consumed (and thus has a long life with no replenishment requirements).

**CID** – Cubic Inch Displacement. The imperial measure of the swept volume of the pistons. 61.02 cubic inches = 1 litre.

(c) 2014-8 James Murray

2018-07-08

Page 199/207
Closed loop – refers to those times when an EFI computer is using feedback from a sensor to alter outputs

Closed loop boost – Megasquirt uses a PID to keep boost in line with a boost target table

Closed loop EGO – Megasquirt controls the EGO to the target table by varying the injected fuel amounts.

Closed loop idle – Megasquirt controls the idle rpm by opening or closing the idle valve as required.

CHT – Cylinder Head Temperature, used instead of coolant temperature (CLT) on air-cooled engines.

CKP – Crankshaft position sensor

CLT – Coolant Temperature sensor (aka. CTS). Usually the CLT sensor is an NTC (Negative Temperature Coefficient) thermistor, or a resistor whose resistance varies with temperature (NTC means the resistance goes down as the temperature goes up).

CMP – Camshaft position sensor

CNP – Coil Near Plug – See Coil on Plug

Coil On Plug – One ignition coil is installed per spark plug. Either directly on top of the plug e.g., a ‘pencil’ coil. Or in close proximity with a short plug-lead (actually coil near plug.) This setup can give maximum spark energy and can be the neatest install with least lost spark energy.

COP – Coil on Plug – See Coil on Plug

CPS – Possibly ambiguous Crankshaft or camshaft position sensor

CPU – Central Processing Unit, aka. “processor” or “microprocessor” the computational engine that performs the calculations to operate the injection and ignition functions in MegaSquirt®. It has a number of support circuits, like the power circuit, the clock circuit, the serial and CAN communications circuits, and various input and output conditioning circuits.

CTS – Coolant Temperature Sensor (aka. CLT). Usually the CTS is an NTC (Negative Temperature Coefficient) thermistor, or a resistor whose resistance varies with temperature (NTC means the resistance goes down as the temperature goes up).

Diode – A two lead electrical device that allows current to flow in only one direction (see also Zener diodes).

DIY – Do-It-Yourself.

DMM – (digital multi meter) electronic current/resistance/potential measuring tool. (Required tool for any Megasquirt install.) May also be referred to as DVM (digital volt meter.)

Dual table – A firmware feature allowing different injector outputs to have independent fuel tables. Can be used as an awkward method to achieve per-bank trim. More commonly used (with external relays) to map for regular fuel and LPG.

Duty Cycle – (DC)– A number indicating the amount of time that some signal is at full power. In the context of MegaSquirt EFI Controller, duty cycle is used to describe the amount of time that the injectors are on, and to describe the “hold” part of the peak and hold injector drivers (see Low Impedance Injectors, below).

ECU – (Electronic Control Unit) is the general term for a fuel injection controller, of which MegaSquirt is an example.

EDIS – Electronic Distributorless Ignition System is Ford’s wasted-spark computer-controlled ignition module, which has a simple two wire hookup to MegaSquirt for full mapped ignition control.

EGO Sensor – Exhaust Gas Oxygen sensor, used to describe the sensor in the exhaust that measures the lean/rich state of the intake mixture. Used to control the fuel via a feedback algorithm called “closed loop”.

EGR – Exhaust Gas Recirculation. Used by OEMs for emissions purposes. Not supported by Megasquirt.

EGT – (Exhaust Gas Temperature) is the temperature of the exhaust gases, typically measured with a K-type thermocouple. Megasquirt does not have on-board hardware for a direct connection. An add-on board is required.

FET – (field effect transistor) - In MegaSquirt EFI Controller, the transistors used to control the activation of the
injectors.

**Fidle** – Fast Idle. A device used to control idle speed with additional air supplied by a vacuum solenoid. More commonly a fully variable PWM idle valve is used instead. This term is most frequently applied to a connection from the Megasquirt ECU that can be used to drive an on/off valve or a PWM valve.

**Gamma** – Used to indicate the change in a fuel amount from the calculated amount.

**GammaE** – A collection of all enrichments and minor corrections to fuel (see speed density.) Now renamed as 'totalcor'.

**Gear tooth sensor** – an “active”, tooth presence sensor. It is based on the Hall effect. The Hall effect sensor consists of semiconductor material which will conduct current when the material is subject to a magnetic field. These types of sensors include a magnet within the sensor and will detect a steel tooth in close proximity. No external magnets are required. Very simple to use.

**Gego** – Gego is short for 'Gamma – Exhaust Gas Oxygen'. It is the change applied to the fuelling equation based on the EGO O2 sensor feedback. This feedback can (and is) done in a number of different ways, depending on the type of sensor, etc. The important thing is that this is a result of an external measurement, not a pure calculation, so it appears a bit mysteriously in the equation. Now renamed as ‘egocor’.

**Hall sensor** – an “active”, magnetic field presence sensor. It is based on the Hall effect. The Hall effect is the change of resistance in a semiconductor in a magnetic field. The Hall effect sensor consists of semiconductor material which will conduct current when the material is subject to a magnetic field. These types of sensors require a “flying magnet”, wheel. Instead of teeth on the wheel, as in a variable reluctor sensor, you must have small magnet and a shutter wheel.

**Hydrocarbon (HC):** in an automotive context, generally refers to regulated unburned hydrocarbon tail pipe emissions.

**HEI** – the distributor based electronically controlled ignition system from General Motors. There are a number of variants, identified by the module they use:

- **4-Pin module**: non-computer controlled electronic ignition,
- **7-Pin module**: computer controlled electronic ignition used in 'large cap' distributors,
- **8-Pin module**: computer controlled electronic ignition used in 'small cap' distributors.

**High Impedance Injectors** – (a.k.a. hi-Z or high ohm) Fuel injectors designed to work with a simple switch in a 12 volt circuit, no special signal conditioning is required to drive them. The resistance of a high impedance injector is about 10-15 ohms.

**Hz** – (Hertz) the measurement of the frequency of a cyclical event, it represent the number of times per second the cycle is completed.

**IAC** – Idle Air Controller, though this term is sometimes used more generally, it usually refers to GM's 4 wire stepper motor controller for additional idle air (and hence engine speed) during warm-up and for idle regulation.

**IAT sensor** – Intake Air Temperature sensor, same as MAT, see below.

**IGBT** – Insulated Gate Bipolar Transistor a particular kind of transistor especially suitable for driving ignition coils. e.g., VB921, BIP373

**Incorporate AFR** – An MS2 and MS3 feature where the AFR target table is included in the fuelling equation. The Fuel VE table then becomes far closer to a true VE table. Enrichment or enleanment from stoichiometric comes from the AFR table. Ideally this setting should be turned on before any tuning and the AFR table set to your target AFRs. Then the VE table is tuned to achieve that AFR. Turning the setting on/off will require a complete re-tune.

**Interpolate** – The dictionary meaning is to insert an intermediate value into a series by estimating or calculating it from surrounding known values. On all tables and curves, when you are between points, the Megasquirt interpolates the intermediate values. Some older other brands were unable to do this and required monstrously large tables to overcome this limitation.

**kPa (kiloPascals)** – the measurement of air pressure used in MegaSquirt® computations. It ranges from 0
(vacuum) to 101.3 kPa (standard atmospheric pressure at sea level) to 250 kPa (21psi of boost) or higher.

**Lambda** – an alternative term to AFR where 1.0 is stoichiometric. Lambda numbering is fuel independent. 1.0 is always stoich.

**Low Impedance Injectors** – (a.k.a low-Z, low ohm) Fuel injectors that are designed to run at a much lower current than would be supplied by a direct 12 volt connection. They require a special signal that is initially at full current (4-6 amps, a.k.a. “peak current”) for about 1.0-1.5 ms, but then drops down to about 1 amp (“hold current”) for the rest of the opening pulse. The resistance of a low-impedance injector is typically 1-3 ohms. These may need a “peak and hold” board or a resistor pack.

**LSU-4** – Bosch wide-band oxygen sensor.

**MAF sensor** – Mass Air Flow sensor. A sensor used to measure the mass of air flow through the intake tract (which must be sealed at the senor and downstream).

**MAP sensor** – Manifold Absolute Pressure sensor. Measure of the absolute pressure in the intake manifold (related to the engine vacuum), to determine the load on the engine and the consequent fueling requirements. The standard MAP sensor in MegaSquirt® is the MPX4250 (2.50 BAR, or 15 psi (vacuum) + 21 psig (boost)). A basis of the “speed density” fuelling algorithm.

**MAPdot** – rate of change of MAP value. (dMAP/dt) Used mainly to trigger Accel enrichment.

**MAT Sensor** – Manifold Air Temperature sensor, the same as IAT. The MAT circuit is identical to the CLT circuit, see CLT, above.

**.MSL** – file extension used by the MegaSquirt for storing datalogs (.XLS might also be used for datalogs with older versions of tuning software).

**MPX4250AP** – the standard internal MAP sensor used in MegaSquirt.

**MS** – MegaSquirt, used in this document to refer to the MegaSquirt® fuel injection controller or its embedded software. e.g., MS1 = MegaSquirt-1, MS2 = MegaSquirt-2, MS3 = MegaSquirt-3

**MS1/Extra** – The most commonly used firmware on the MegaSquirt-1 chip. Gives fuel and spark control. Used to be called MegaSquirt’n'spark-extra or MSnS-extra. The original basic MS1 code was fuel only.

**MS2/Extra** – Firmware for the MS2 chip and Microsquirt with multiple spark outputs, many wheel decoders, closed loop idle, boost, nitrous, table switching and more

**MS2/BG** – More basic firmware for the MS2 chip and Microsquirt from Bowling and Grippo.

**.MSQ** – file extension used for saving MegaSquirt fuel injection controller user settings (aka. "parameters") on a tuning computer. Since approximately 2005, these have been readable XML format, so you can open these in Notepad or similar text editors. This format allows some exchange of tune data between different code versions.

**NB-EGO Sensor** – Narrow Band EGO sensor, gives a switch at the stoichiometric ratio (the chemically correct mixture of air and fuel), but unreliable for AFR other than stoichiometric.

**Ohm's Law** – A fundamental law of electricity, that states that the current flow (I) is equal to the voltage (V) divided by the resistance (R), or:

\[ I = \frac{V}{R} \]

**Oxides of Nitrogen (NOx)** – in an automotive context, generally refers to regulated 'mono-nitrogen oxides' (NO and NO2) tail pipe emissions.

**OEM** – (original equipment manufacturer) - refers to parts produced for initial assembly of a new vehicle. (As opposed to after market parts.)

**Open Loop** – refers to those times when MegaSquirt works entirely from its calculations with no feedback from a sensor (compare Closed Loop.)

**Open Loop Boost** – there is no feedback from the map sensor – boost duty is controlled by the duty table only.

**Open Loop EGO** – there is no feedback from the oxygen sensor – fuelling is from the VE table only.

**Open Loop Idle** – there is no feedback loop with rpm – idle valve position is set only from the table.
PCB – (printed circuit board) – the fiberglass board that has the MegaSquirt component layout and circuits imprinted on it.

PID – (Proportional, Integral, Derivative) - a method of closed-loop feedback control

Pull-up Circuit – A very simple circuit consisting of a voltage supply and a current limiting resistor designed to prevent a signal from floating, it forces the signal to either be high (equal to the pull up voltage) or low (grounded).

P&H Injectors – Peak and hold injectors; see Low Impedance injectors.

PIP – Profile Ignition Pick-up is the term used for the signal sent from Ford's Electronic Distributorless Ignition System (EDIS) to the electronic control unit. The EDIS module decodes the 36-1 wheel and sends 2, 3 or 4 PIP pulses per engine revolution depending on EDIS4,6,8. The PIP signal into the ECU is a square wave switched at 12 volts. It provides information about both the engine speed and position.

PW – (Pulse Width) is the amount of time a signal is applied during each period. For example, is the amount of time (in milliseconds) an injector is pulled low (grounded) to inject fuel.

Pulse Width Modulation (PWM) – A signal with a fixed pulse width (frequency), which is turned on for part of the pulse. The percent of time that the signal is on is called its duty cycle. PWM is used to limit current to low impedance fuel injectors, as well as for solenoids such as idle valves, boost solenoids and VVT

Realtime baro – a dedicated second pressure sensor is used to monitor ambient pressure. Required if your vehicle will go on journeys at varying elevations.

Required Fuel – (Req_Fuel) The injector pulse width, in milliseconds, required to supply the fuel for a single injection event at stoichiometric combustion, 100% volumetric efficiency and standard temperature.

RPM – Revs Per Minute. The term used to describe engine speed.

SAW – Spark Advance Word is the 'returning' signal to a Ford EDIS ignition unit from the ECU that sets the amount of ignition advance requested. It is in the form of a 5 volt square wave.

Semi-sequential – Fuelling system where injection events are timed to each cylinder (like spark is) but occur twice per cycle. Offers some of the benefits of full sequential without needing a cam wheel input.

(Fully) Sequential – Fuelling system where injection events are timed to each cylinder (like spark is) and occur once per cycle. Do not confuse with direct injection. Sequential uses normal injectors of a normal size, but their timing can give slight power and/or economy increases

Stim (MegaStimulator) – the original stimulator is a small board which plugs into the connector of the MegaSquirt® controller. It simulates all the sensor the inputs the MegaSquirt® controller would normally see (but the rpm signal is only suitable for use with distributor or EDIS configurations) and provides power to the MegaSquirt® controller. The Stimulator also allows you to monitor the MegaSquirt® controller's injection pulses [actual], fuel pump relay operation, and fast idle solenoid output with four LEDs. The JimStim is an enhanced version that simulates many wheel patterns and has more LEDs for multiple spark outputs.

Speed Density – Fuel control algorithm that calculates fuelling based primarily on pressure, air temperature and volumetric efficiency.

PW = dead time + (ReqFuel * MAP * VE(rpm,map) * GammaE)
All the corrections are included within GammaE.

Stoichiometric – the chemically ideal air:fuel mixture. Expressed as 1.0 Lambda for all fuels or 14.7 for petroleum/gasoline.

SPOUT – Spark Out is the spark advance signal sent from MS-II™ to the Ford TFI module to set the timing advance.

Table blending – A firmware feature that allows the user to combine two tables, usually using different algorithms. e.g., one table could be a regular speed-density table and the other alpha-n. This could be useful on an individual throttle body install or as a way of extending the table size.

Table switching – A firmware feature that allows the user to swap to a different fuel, spark, etc table. Can be used in conjunction with dual fuels or nitrous or as a way of extending the table size.
TBI – Throttle Body Injection is a form of injection is which the fuel is injected above the throttle(s). It was typically used on older engines since it can be a simpler system, but is also found on some very high output racing engines because the vaporization time is longer than with port injection.

TPI – Tuned Port Injection is General Motors bank-fire port fuel injection system. It was widely used on 305 and 350 cid V8 in the mid to late 1980's.

TPS – Throttle Position Sensor, a voltage divider that gives information to a MegaSquirt® controller about throttle opening, from which it computes rate of throttle opening for acceleration enrichment.

TPSdot – rate of change of TPS value. (dTPS/dt) Used mainly to trigger Accel enrichment.

Transistor – A solid-state (no moving parts) electronic device that uses a small voltage (on the base pin) to control a larger current (across the emitter and collector pins). There are two basic types of transistors, PNP and NPN. A PNP transistor allows current to flow if there is no signal on the base, and restricts the current as the base current increases. An NPN transistor allows current to flow in proportion to the signal on the base, and restricts the current as the base current decreases.

TS (TunerStudio MS) – The standard software for tuning MegaSquirt EFI controllers. (The previous, now obsolete, software was called Megatune.)

Volatile Organic Compounds (VOC) – in an automotive context, generally refers to organic components or precursors to smog formation. Organic compounds are all chemical compounds containing carbon-hydrogen (C-H) bonds of covalent character. The U.S. Environmental Protection Agency defines a VOC as any organic compound that participates in a photoreaction. An example of a VOC is PAN (peroxyacetyl nitrate), CH3COOONO2.

Voltage divider – A simple circuit that uses two resistors in series to reduce the output voltage Vo proportionally to the input voltage Vi. Two resistors, R1 and R2, are arranged in series, with one end connected to the external signal, and the other to ground. The signal is taken from between the two resistors. From Ohm's Law we can calculate that the total current will be I = Vi/(R1+R2). The same current flows in each resistor because they are in series. The voltage drop across each resistor is: V1 = I*R1 and V2 = I*R2 = Vo. V2 is output voltage Vo, which we can write as:

\[ Vo = \frac{Vi}{R2/(R1+R2)} \]

V2.2 – The first mainstream circuit board used within Megasquirt. While still available for sale, it is largely obsolete.

V3.0 – The current circuit board used within Megasquirt (accurate Nov 2010). This superceded the V2.2 adding better support for low-z injectors and a circuit for VR conditioning.

V3.57 – A surface mount circuit board, largely the same as the V3.0 board.

VB921 – a particular IGBT designed for use with automotive ignition coils. Now superceded by BIP373.

VE – Volumetric Efficiency. The actual amount of air being pumped by the engine as compared to its theoretical maximum. A 2000 cc engine will theoretically move 2000 cc of air in one cycle at 100% efficiency. If the engine is actually running at 75% VE, then it will move 1500 cc of air on each cycle.

Vref – a 5 Volt supply used to power the TPS (and sometimes other external components needing a 5 Volt supply, like ignition modules or pull-ups).

VR sensor - Variable reluctor sensor – is an induction type sensor, it is "passive", i.e., it does not require a power source, and has a small magnet built in. Needs to use a conditioning circuit – as provided on the V3.0 and V3.57 mainboard. Cannot be used directly on the V2.2 mainboard.

Wasted-COP – a method where individual coils are fitted per spark plug, but the coils are fired in a 'wasted' manner twice per cycle. This is used during startup in some wheel modes and could also be used temporarily by a user before full coil-on-plug is installed.

Wasted Spark – A method of firing spark plugs in which one 'double-ended' coil simultaneously fires two coils on different cylinders. One of the cylinders is the intended 'target', and is near TDC on its compression stroke, the other cylinder is offset by 360° in the firing order (of the 720° 4-stroke cycle), so it is near TDC on its exhaust stroke. The second spark is said to be 'wasted' because it does not ignite a mixture. On the other hand, the hot
ionized exhaust gases require little energy to create a spark, so nearly all the energy goes to the 'target' cylinder. An example of a wasted spark system is Ford's EDIS. The advantage is that while a missing tooth crank wheel is required, no cam sync signal (and the corresponding wheel and sensor) are needed.

**WB-EGO Sensor** – Wide Band EGO sensor, can be used to derive real AFR data with mixtures from 10:1 to 20:1, i.e., anything you are likely to be interested in. Allows for lean or rich tuning.

**WOT** – Wide open throttle.

**WUE** – Warm Up Enrichment, the enriched mixture applied when the coolant temperature is low.

**Zener diode** – A diode that allows current to flow in one direction, unless the reverse voltage is higher than its rated avalanche voltage, in which case it will flow in the reverse direction. Often used to limit excessive voltage to certain circuits by shunting it either to ground or the power supply.
22. Firmware changes since 3.3.x
This section gives a brief overview of firmware features that have changed between 3.3.x and 3.4.x firmware releases.

22.1. Old baro
The "old" baro calculation included 1/baro in the fuel calculation, this is disabled by default now.

22.2. Ignition Settings
The "Flip polarity on hi-res tach / cam" settings can now be used to invert the cam polarity if needed for modes where this was not previously possible.
Kick-start mode is a new feature.

22.3. Programmable On/Off Outputs
The meaning of threshold and hysteresis are changed when using a bitwise AND operation.

22.4. CAN Broadcasting
Two new options
Holset HE351VE VGT turbo - this broadcasts ‘boost duty’ with a 29bit CAN identifier specific to the turbo.
User defined testing - allows custom CAN packets to be broadcast

22.5. CAN Broadcast testing
A custom identifier (decimal) and payload can be broadcast.

22.6. CAN Realtime Data Broadcasting
This is a major enhancement allowing all of the engine parameters to be broadcast to the CAN using standard 11bit identifiers which can then be received and displayed by suitable 3rd party dashes or dash loggers.

22.7. CAN Dash Broadcasting
Allows a fixed set of data to be broadcast for use by dashes.
## 23. Revision history

<table>
<thead>
<tr>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2014-09-07</td>
<td>Revision history started. Minor edits.</td>
</tr>
<tr>
<td>2014-12-23</td>
<td>Idle advance text.</td>
</tr>
<tr>
<td>2015-01-31</td>
<td>Glossary from MS3.</td>
</tr>
<tr>
<td>2015-04-08</td>
<td>Clarify CLT rev limiter</td>
</tr>
<tr>
<td>2015-07-10</td>
<td>Update with new or changed 3.4 features and settings.</td>
</tr>
<tr>
<td>2016-01-19</td>
<td>Incorp AFR note for MAF.</td>
</tr>
<tr>
<td>2016-01-22</td>
<td>Add trigger angle note for basic trigger.</td>
</tr>
<tr>
<td>2018-07-06</td>
<td>Add Firmware loader instructions.</td>
</tr>
<tr>
<td>2018-07-08</td>
<td>Add port bitmap meanings to datalog fields section.</td>
</tr>
</tbody>
</table>