UI glitch after loading second ignition log

Questions specific to Megalogviewer

Moderator: LT401Vette

UI glitch after loading second ignition log

Postby jsiedlicki » Thu Nov 30, 2017 10:18 am

I noticed that after I load a second ignition file from TS (*.csv) the "Loading Ignition Log" dialog fails to disapear after the file is loaded. It is greyed out and will not let you close it. You can move it around the screen but not close it. It only happens on the second file loaded, and every one their after, but not the first.

Screenshot3.png
Screenshot3.png (18.2 KiB) Viewed 85 times


Screenshot2.png
Screenshot2.png (94.48 KiB) Viewed 85 times
MS3-Pro (6 cyclinder Subaru EZ36R)
MS2-extra (8 cyclinder Ford 347 stroker)
jsiedlicki
Helpful MS/Extra'er
 
Posts: 139
Joined: Sun Jun 23, 2013 3:52 pm

Re: UI glitch after loading second ignition log

Postby LT401Vette » Fri Dec 01, 2017 1:34 pm

I have tried reproducing this on Windows, OS X and Linux. No luck..
Anything else about what you have here would be good.
How big a log?
Can you post / send the log it is happening with?
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10409
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: UI glitch after loading second ignition log

Postby jsiedlicki » Fri Dec 01, 2017 2:16 pm

Here are two short tooth logs that cause the problem on my system. It happens on both my desktop and laptop. Both are Linux Mint.

If you would like I can post a short screen capture video showing the problem happening?
Attachments
tooth-raising-edge-2017-11-29_10.22.09.csv
(9.93 KiB) Downloaded 3 times
tooth-failing-edge-2017-11-29_10.20.45.csv
(9.63 KiB) Downloaded 3 times
MS3-Pro (6 cyclinder Subaru EZ36R)
MS2-extra (8 cyclinder Ford 347 stroker)
jsiedlicki
Helpful MS/Extra'er
 
Posts: 139
Joined: Sun Jun 23, 2013 3:52 pm

Re: UI glitch after loading second ignition log

Postby LT401Vette » Fri Dec 01, 2017 9:11 pm

Short logs are interesting, I was using longer logs as the dialog doesn't normally pop up on short ones.
Are you opening from the main menu or the ignition logger button?
Either should work, I'm still trying to reproduce though.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10409
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: UI glitch after loading second ignition log

Postby jsiedlicki » Fri Dec 01, 2017 9:34 pm

Here is a link to a short screen grab video showing the glitch. Some times it takes more than two times opening a file to get it to happen.

In the video I am using the mouse for all selections though the pointer does not appear in the video.

https://youtu.be/q8y028FrEl0
MS3-Pro (6 cyclinder Subaru EZ36R)
MS2-extra (8 cyclinder Ford 347 stroker)
jsiedlicki
Helpful MS/Extra'er
 
Posts: 139
Joined: Sun Jun 23, 2013 3:52 pm

Re: UI glitch after loading second ignition log

Postby LT401Vette » Mon Dec 04, 2017 7:16 am

Ahh.. It looks like you were opening an empty file in the video. That may be the key.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10409
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: UI glitch after loading second ignition log

Postby jsiedlicki » Mon Dec 04, 2017 7:51 am

The file is not empty, the data does not start until the second page of the tooth log.

It seems like since the log is so small, maybe the code is close the dialog before the windowing system has had a chance to initialize and display the dialog, just a guess :D
MS3-Pro (6 cyclinder Subaru EZ36R)
MS2-extra (8 cyclinder Ford 347 stroker)
jsiedlicki
Helpful MS/Extra'er
 
Posts: 139
Joined: Sun Jun 23, 2013 3:52 pm


Return to Megalogviewer

Who is online

Users browsing this forum: No registered users and 3 guests