Idle closep loop 6 wire problem

All questions about MS2/Microsquirt/Microsquirt module. See also MS2/Extra manuals

Moderators: jsmcortina, muythaibxr

Idle closep loop 6 wire problem

Postby japotec » Thu Jul 20, 2017 6:58 am

Hello friends.

I need help to solve a problem in a ms2, I have a 6 wire iac mitsubishi from one moment to another started with variations when the engine is reaching its hot spot, the start step is 90 and idle step 33 approximate to 800rpm, But from one moment to another the step is going to max step 90 down to 400rpm if it is configured open loop (warmup) works without problems.

Best regards
japotec
MS/Extra Newbie
 
Posts: 4
Joined: Sun May 13, 2012 11:07 am

Re: Idle closep loop 6 wire problem

Postby rickb794 » Fri Jul 21, 2017 8:45 am

No MSQ
No MSL
No picture of the valve.
With only "6 wire" and "Mitsubishi" as clues not much can be determined.
I do note that if it works in warmup, would seem to point to closed loop configuration as the problem.

I also note that your symptoms seem to parallel a problem I am working on.
http://www.msextra.com/forums/viewtopic.php?f=101&t=66723
This is my brain on MegaSquirt!
Use only these manuals http://www.msextra.com/manuals/
Avoid the common pitfalls, Read this before start http://www.msextra.com/forums/viewtopic.php?f=101&t=65757
rickb794
Super MS/Extra'er
 
Posts: 2892
Joined: Sun Dec 21, 2008 10:28 am
Location: Portland OR

Re: Idle closep loop 6 wire problem

Postby japotec » Fri Jul 21, 2017 10:46 am

Thanks for the help rick

No MSQ
R: I send it during the day

I do note that if it works in warmup, would seem to point to closed loop configuration as the problem.
R:I tried different configurations, the valve worked well for a long time and from one moment to another began with the problem.

Thanks.
Iac.jpg
Iac.jpg (24.79 KiB) Viewed 236 times

MS.jpg
MS.jpg (371.25 KiB) Viewed 236 times

ms2.jpg
ms2.jpg (379.99 KiB) Viewed 236 times
japotec
MS/Extra Newbie
 
Posts: 4
Joined: Sun May 13, 2012 11:07 am

Re: Idle closep loop 6 wire problem

Postby japotec » Sat Jul 22, 2017 3:31 pm

Datalog attachment

2016-06-07_17.36.35.rar
(262.36 KiB) Downloaded 12 times


When I turn on the lights and the general heating the problem faster.
japotec
MS/Extra Newbie
 
Posts: 4
Joined: Sun May 13, 2012 11:07 am

Re: Idle closep loop 6 wire problem

Postby jamies » Sat Jul 22, 2017 10:14 pm

its probably not too different to a toyota ICS,Try chahnging min steps to move from 1 to 3 and see if it behaves a bit better
jamies
Experienced MS/Extra'er
 
Posts: 342
Joined: Tue Apr 07, 2009 12:22 am

Re: Idle closep loop 6 wire problem

Postby japotec » Sun Jul 30, 2017 6:40 pm

Hi friends.

I tell you to check all the wiring and modify some operating points, but the problem is still the problem.
japotec
MS/Extra Newbie
 
Posts: 4
Joined: Sun May 13, 2012 11:07 am


Return to MS2/Extra, MS2, Microsquirt and Microsquirt module support

Who is online

Users browsing this forum: No registered users and 3 guests