3400 7x problem

All questions about MS2/Microsquirt/Microsquirt module. See also MS2/Extra manuals

Moderators: jsmcortina, muythaibxr

3400 7x problem

Postby Chevyalltheway95 » Mon Jan 01, 2018 2:09 pm

I recently got my 3400 swap running using the factory dis ignition. Due to the inability to control timing below 10* or cut spark I have attempted to swap to the 7x signal directly to fire ls2 truck coils and I believe all my wiring to be correct but I'm unable to get it to start. I know I have fuel and spark but it seems like improper timing. It will crank and crank and all that happens is a sputter and every once in awhile I get a loud backfire out the exhaust. I have tried changing offset but no change. Thanks in advance
Chevyalltheway95
MS/Extra Newbie
 
Posts: 10
Joined: Sun Dec 17, 2017 8:13 pm

Re: 3400 7x problem

Postby rickb794 » Mon Jan 01, 2018 5:21 pm

Check timing with a light while cranking
This is my brain on MegaSquirt!
Use only these manuals http://www.msextra.com/manuals/
Avoid the common pitfalls, Read this before start http://www.msextra.com/forums/viewtopic.php?f=101&t=65757
rickb794
Super MS/Extra'er
 
Posts: 2893
Joined: Sun Dec 21, 2008 10:28 am
Location: Portland OR

Re: 3400 7x problem

Postby Six_Shooter » Mon Jan 01, 2018 9:49 pm

How did you have the original DIS wired?

I've used that exact DIS system several times, including with MS and have no issues with it.

Follow the HEI system wiring, but in the offset set to 60* and for dwell set to fixed duty at 50%.
Tha Toy: 1973 Datsun 240Z Turbocharged, and loads of fun, now MS'd
Tha Otha Toy: 1923 T-bucket Hot Rod, Yes, it's MS'd
Tha Daily: 2000 GMC Yukon, not so fun
Tha Long Term Project: 1985 GMC S-10 Jimmy, hasn't been fun for a while
Six_Shooter
Master MS/Extra'er
 
Posts: 416
Joined: Mon Oct 17, 2011 7:28 pm
Location: South Western Ontario

Re: 3400 7x problem

Postby Chevyalltheway95 » Thu Jan 04, 2018 9:45 pm

The original dis was wired as per the manual for the v3.57 d14 for est and d16 controlled bypass relay, those were the settings I used the only problem I had was an inability to use spark cut. I have no way currently to check timing while cranking as I am by myself but all it will do is backfire out the exhaust almost like a distributor that is 180 out. I have tried rising edge capture and falling and have tried adjusting vr conditioner pots but no luck so far.
Chevyalltheway95
MS/Extra Newbie
 
Posts: 10
Joined: Sun Dec 17, 2017 8:13 pm

Re: 3400 7x problem

Postby rickb794 » Fri Jan 05, 2018 7:11 am

Use a mechanics remote starter switch.
This is my brain on MegaSquirt!
Use only these manuals http://www.msextra.com/manuals/
Avoid the common pitfalls, Read this before start http://www.msextra.com/forums/viewtopic.php?f=101&t=65757
rickb794
Super MS/Extra'er
 
Posts: 2893
Joined: Sun Dec 21, 2008 10:28 am
Location: Portland OR

Re: 3400 7x problem

Postby Chevyalltheway95 » Fri Jan 05, 2018 5:57 pm

I will see about rigging something up if the timing is off what could be possible causes or solutions to that the 7x setting only allows for 20* of offset
Chevyalltheway95
MS/Extra Newbie
 
Posts: 10
Joined: Sun Dec 17, 2017 8:13 pm

Re: 3400 7x problem

Postby Chevyalltheway95 » Fri Jan 05, 2018 11:59 pm

Crank sensor keeps losing sync while cranking and I've tried everything I can think of to remedy it so I'm just putting the dis back on until I can get a 36-1 wheel and hall effect sensor. The ls coils would be nice but until I can come up with something more reliable I'd rather have the truck running. Thanks for your input but can anyone confirm or deny the ability of the dis system to spark cut?
Chevyalltheway95
MS/Extra Newbie
 
Posts: 10
Joined: Sun Dec 17, 2017 8:13 pm

Re: 3400 7x problem

Postby Six_Shooter » Sat Jan 06, 2018 2:47 pm

I'm pretty sure I'm using spark cut with my car. I know I hit the limiter almost every time I have the car out, it revs to 6800 RPM way quicker than I would have expected. lol

To get into some of the theory of it, as long as the bypass line is pulled to 5V, the ICM will be looking for coil triggering signals on the white (EST) wire, which contains timing and dwell information. If this signal drops out completely, as it would when a spark limiter would do, then spark can't happen.

If you want to test it, set a low rev limiter, such as about 2000 RPM via spark and test once you get the DIS system back in. It's really a great system, just too many people think it's a lot like the Ford EDIS system that has more limitations.
Tha Toy: 1973 Datsun 240Z Turbocharged, and loads of fun, now MS'd
Tha Otha Toy: 1923 T-bucket Hot Rod, Yes, it's MS'd
Tha Daily: 2000 GMC Yukon, not so fun
Tha Long Term Project: 1985 GMC S-10 Jimmy, hasn't been fun for a while
Six_Shooter
Master MS/Extra'er
 
Posts: 416
Joined: Mon Oct 17, 2011 7:28 pm
Location: South Western Ontario

Re: 3400 7x problem

Postby Chevyalltheway95 » Sat Jan 06, 2018 3:32 pm

I got the dis rewired back in and I don't know exactly what I did but the spark cut works now lol. Loud as hell at 3500 rpm. Thank you all for your input I reckon I'll stick with the dis as spark cut was all I was going for so no need for ls coils now.
Chevyalltheway95
MS/Extra Newbie
 
Posts: 10
Joined: Sun Dec 17, 2017 8:13 pm

Re: 3400 7x problem

Postby Six_Shooter » Sat Jan 06, 2018 4:36 pm

Spark cut wouldn't work if the ECU was not controlling timing, so now that it is controlling timing, spark cut will work.
Tha Toy: 1973 Datsun 240Z Turbocharged, and loads of fun, now MS'd
Tha Otha Toy: 1923 T-bucket Hot Rod, Yes, it's MS'd
Tha Daily: 2000 GMC Yukon, not so fun
Tha Long Term Project: 1985 GMC S-10 Jimmy, hasn't been fun for a while
Six_Shooter
Master MS/Extra'er
 
Posts: 416
Joined: Mon Oct 17, 2011 7:28 pm
Location: South Western Ontario

Re: 3400 7x problem

Postby Chevyalltheway95 » Sat Jan 06, 2018 7:56 pm

Ok I have one last little hiccup. I was playing with my launch control and it was cutting spark then all of a sudden it began revving again. All of my connections are solidly soldered together so I don't think it's that. I shut the truck of and restarted it then attempted it again and it worked again as it's suppose to. One headache to another
Chevyalltheway95
MS/Extra Newbie
 
Posts: 10
Joined: Sun Dec 17, 2017 8:13 pm

Re: 3400 7x problem

Postby Six_Shooter » Sat Jan 06, 2018 10:10 pm

I read a few people that have had similar issues with launch control, on different ignition setups. So I'd start by looking at that specifically.
Tha Toy: 1973 Datsun 240Z Turbocharged, and loads of fun, now MS'd
Tha Otha Toy: 1923 T-bucket Hot Rod, Yes, it's MS'd
Tha Daily: 2000 GMC Yukon, not so fun
Tha Long Term Project: 1985 GMC S-10 Jimmy, hasn't been fun for a while
Six_Shooter
Master MS/Extra'er
 
Posts: 416
Joined: Mon Oct 17, 2011 7:28 pm
Location: South Western Ontario


Return to MS2/Extra, MS2, Microsquirt and Microsquirt module support

Who is online

Users browsing this forum: No registered users and 3 guests

cron