MegaTunix on OS-X (revised)

Questions specific to Megatunix - alternate tuning software that runs on unix and windows.
Note that Megatunix is obsolete.

Moderator: djandruczyk

Did this work for you?

Yes
4
67%
No
1
17%
It had a problem somewhere, I posted a question in this thread.
1
17%
 
Total votes : 6

Re: MegaTunix on OS-X (revised)

Postby viking_oz » Sun Dec 28, 2014 7:45 pm

Hi Dave,

That's fantastic news! I'll go and have a poke at it right now.

Many thanks again for all your hard work.


UPDATE: Still no joy. I even wiped out my entire MegaTunix source directory and refreshed it from Git. Which makes me think - am I using the right git store?

I used the command described in one of the forum posts here - git clone git://github.com/djandruczyk/MegaTunix.git


UPDATE 2: Got it. I found a git repository here: https://git.libreems.org/libreems-suite/megatunix.git. Hitting it with a "git clone" and then doing the autogen / configure / make routine gave me a compiled copy of MT at long last.
viking_oz
Helpful MS/Extra'er
 
Posts: 35
Joined: Tue May 04, 2004 6:54 pm
Location: Melbourne, Australia

Re: MegaTunix on OS-X (revised)

Postby eazy-v » Fri Jul 17, 2015 10:24 pm

viking_oz wrote:Hi Dave,

That's fantastic news! I'll go and have a poke at it right now.

Many thanks again for all your hard work.


UPDATE: Still no joy. I even wiped out my entire MegaTunix source directory and refreshed it from Git. Which makes me think - am I using the right git store?

I used the command described in one of the forum posts here - git clone git://github.com/djandruczyk/MegaTunix.git


UPDATE 2: Got it. I found a git repository here: https://git.libreems.org/libreems-suite/megatunix.git. Hitting it with a "git clone" and then doing the autogen / configure / make routine gave me a compiled copy of MT at long last.


Which version of MegaTunix are you using and what OS and processor?
eazy-v
MS/Extra Newbie
 
Posts: 7
Joined: Thu Jul 16, 2015 9:19 pm

Re: MegaTunix on OS-X (revised)

Postby djandruczyk » Sat Jul 18, 2015 5:20 am

eazy-v wrote:
viking_oz wrote:Hi Dave,

That's fantastic news! I'll go and have a poke at it right now.

Many thanks again for all your hard work.


UPDATE: Still no joy. I even wiped out my entire MegaTunix source directory and refreshed it from Git. Which makes me think - am I using the right git store?

I used the command described in one of the forum posts here - git clone git://github.com/djandruczyk/MegaTunix.git


UPDATE 2: Got it. I found a git repository here: https://git.libreems.org/libreems-suite/megatunix.git. Hitting it with a "git clone" and then doing the autogen / configure / make routine gave me a compiled copy of MT at long last.


Which version of MegaTunix are you using and what OS and processor?


Megatunix's repo has moved yet again (several months ago). Apologies for the confusion and bad links.
The current repo is https://gitlab.com/libreems-suite/megatunix.git
David J. Andruczyk
MegaTunix author. The only non-java cross platform tuning software for MS-I/II hardware.
Where to get and how to install:
http://msextra.com/viewtopic.php?t=23080
http://sourceforge.net/projects/megatunix
User avatar
djandruczyk
MS/Extra Guru
 
Posts: 1210
Joined: Fri May 07, 2004 6:55 pm
Location: Rochester, NY, U.S.A.

Re: MegaTunix on OS-X (revised)

Postby viking_oz » Sat Jul 18, 2015 7:18 am

eazy-v wrote:Which version of MegaTunix are you using and what OS and processor?


I've compiled MegaTunix 0.9.24-Snapshot-1376-g734de2b (according to the top of it's window). OS wise, I'm using OS X 10.10.3, Intel_64, Xcode 6.2 with the command-line tools installed (and heaps of stuff via MacPorts).

My Megasquirt is a v1.0 hardware with whatever firmware was most current in 2006.

The motorcycle I installed the MS into hasn't run since 2008 or so and is slowly rusting away. :-(
viking_oz
Helpful MS/Extra'er
 
Posts: 35
Joined: Tue May 04, 2004 6:54 pm
Location: Melbourne, Australia

Re: MegaTunix on OS-X (revised)

Postby eazy-v » Sun Jul 19, 2015 2:29 am

djandruczyk wrote:
eazy-v wrote:
viking_oz wrote:Hi Dave,

That's fantastic news! I'll go and have a poke at it right now.

Many thanks again for all your hard work.


UPDATE: Still no joy. I even wiped out my entire MegaTunix source directory and refreshed it from Git. Which makes me think - am I using the right git store?

I used the command described in one of the forum posts here - git clone git://github.com/djandruczyk/MegaTunix.git


UPDATE 2: Got it. I found a git repository here: https://git.libreems.org/libreems-suite/megatunix.git. Hitting it with a "git clone" and then doing the autogen / configure / make routine gave me a compiled copy of MT at long last.


Which version of MegaTunix are you using and what OS and processor?


Megatunix's repo has moved yet again (several months ago). Apologies for the confusion and bad links.
The current repo is https://gitlab.com/libreems-suite/megatunix.git


Do you know if this version of MegaTunix would work on a PPC iBook running OS 10.5.8?
eazy-v
MS/Extra Newbie
 
Posts: 7
Joined: Thu Jul 16, 2015 9:19 pm

Re: MegaTunix on OS-X (revised)

Postby viking_oz » Sun Jul 19, 2015 3:36 am

eazy-v wrote:Do you know if this version of MegaTunix would work on a PPC iBook running OS 10.5.8?

I can't see why not. I built very early versions of MegaTunix (0.4.something) on a PPC Powerbook running OS X 10.3 or 10.4.

You may need to custom compile all the GTK / Gnome libraries from source before you can build MegaTunix. The MacPorts / Fink package should be able to do all that for you.
viking_oz
Helpful MS/Extra'er
 
Posts: 35
Joined: Tue May 04, 2004 6:54 pm
Location: Melbourne, Australia

Re: MegaTunix on OS-X (revised)

Postby eazy-v » Sun Jul 19, 2015 11:59 am

Steps done:
1. completely remove MacPorts and re-install most recent PKG 2.3.3 = OK
2. run sudo port -v install git gtk2 gtkglext libglade2 = OK
3. git://github.com/djandruczyk/MegaTunix.git = OK

4. ./autogen.sh –enable-debug = gtkgl-2.0 not found
- I changed line to gtkglext-1.0 in configure.ac then re-tried = OK

5. make = this where is does not finish and I get various errors about gtkglarea
- first I got error that gtkgkarea.h not found
- I installed via sudo port -v install gtglexarea then re-tried = goes further must still gets gtkglarea errors:
Code: Select all
In file included from 3d_vetable.c:78:
/opt/local/include/gtkgl/gtkglarea.h:53: error: syntax error before ‘gtk_gl_area_get_type’
/opt/local/include/gtkgl/gtkglarea.h:53: warning: type defaults to ‘int’ in declaration of ‘gtk_gl_area_get_type’
/opt/local/include/gtkgl/gtkglarea.h:53: warning: data definition has no type or storage class
3d_vetable.c: In function ‘ve3d_configure_event’:
3d_vetable.c:919: warning: implicit declaration of function ‘GTK_CHECK_CAST’
3d_vetable.c:919: error: syntax error before ‘GtkGLArea’
3d_vetable.c:924: error: syntax error before ‘GtkGLArea’
3d_vetable.c: In function ‘ve3d_expose_event’:
3d_vetable.c:963: error: syntax error before ‘GtkGLArea’
3d_vetable.c:1001: error: syntax error before ‘GtkGLArea’
3d_vetable.c: In function ‘ve3d_realize’:
3d_vetable.c:1104: error: syntax error before ‘GtkGLArea’
3d_vetable.c:1104: error: syntax error before ‘)’ token
3d_vetable.c: At top level:
3d_vetable.c:1121: error: syntax error before ‘return’
3d_vetable.c: In function ‘gl_create_font’:
3d_vetable.c:3447: warning: ‘pango_ft2_get_context’ is deprecated (declared at /opt/local/include/pango-1.0/pango/pangoft2.h:112)
make[3]: *** [3d_vetable.o] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2


Since I am using GIT, this is for MegaTunix 0.9.24, any suggestions?

NOTE: I tried using older versions of MegaTunix and get various errors and Segment fault when trying to run megatunix
eazy-v
MS/Extra Newbie
 
Posts: 7
Joined: Thu Jul 16, 2015 9:19 pm

Re: MegaTunix on OS-X (revised)

Postby viking_oz » Sun Jul 19, 2015 5:12 pm



You need to use the GIT repository that Dave mentions about 4 posts back.



eavy-v wrote:4. ./autogen.sh –enable-debug = gtkgl-2.0 not found

Did you install the gtkglarea2 package?

My installed packages include the following. I don't know if they are all relevant - I have a lot of stuff installed by MacPorts for various other things.

gtk2
gdk-pixbuf2
gtkglarea2
gtkglext
libglade2
viking_oz
Helpful MS/Extra'er
 
Posts: 35
Joined: Tue May 04, 2004 6:54 pm
Location: Melbourne, Australia

Re: MegaTunix on OS-X (revised)

Postby djandruczyk » Sun Jul 19, 2015 6:36 pm

have you tried "sudo port install gtkglext" ?

I don't have my mac nearby to remember what I used the last time I did a clean install..
David J. Andruczyk
MegaTunix author. The only non-java cross platform tuning software for MS-I/II hardware.
Where to get and how to install:
http://msextra.com/viewtopic.php?t=23080
http://sourceforge.net/projects/megatunix
User avatar
djandruczyk
MS/Extra Guru
 
Posts: 1210
Joined: Fri May 07, 2004 6:55 pm
Location: Rochester, NY, U.S.A.

Re: MegaTunix on OS-X (revised)

Postby eazy-v » Mon Jul 20, 2015 7:43 pm

Ok, so I got a bit further after installing gtkglarea2 (I previously installed gtkglarea), so here is the current error:

Code: Select all
(megatunix:72093): GLib-GObject-WARNING ***: gvalue.c:181: cannot initialize GValue with type 'gchararray', the value has already been initialized as '(null)'
Segmentation fault


Any idea was this is?
eazy-v
MS/Extra Newbie
 
Posts: 7
Joined: Thu Jul 16, 2015 9:19 pm

Re: MegaTunix on OS-X (revised)

Postby viking_oz » Mon Jul 20, 2015 7:48 pm

Have you changed the GIT repository?

I had all manner of GL issues with the old GIT source tree. Once I started using the right source code, it built without any problems at all.
viking_oz
Helpful MS/Extra'er
 
Posts: 35
Joined: Tue May 04, 2004 6:54 pm
Location: Melbourne, Australia

Re: MegaTunix on OS-X (revised)

Postby eazy-v » Mon Jul 20, 2015 7:53 pm

viking_oz wrote:Have you changed the GIT repository?

I had all manner of GL issues with the old GIT source tree. Once I started using the right source code, it built without any problems at all.


I installed using: git clone https://gitlab.com/libreems-suite/megatunix.git and got no errors until actually trying to run megatunix in Terminal and also X11

Any ideas?
eazy-v
MS/Extra Newbie
 
Posts: 7
Joined: Thu Jul 16, 2015 9:19 pm

Re: MegaTunix on OS-X (revised)

Postby viking_oz » Mon Jul 20, 2015 7:58 pm

Hmmm. Not too many idea as to where you can go from here.

I guess the first question is which version of gtk have you installed? Dave said something about gtk3 not working properly.

Other than that, I'm afraid I haven't a clue.
viking_oz
Helpful MS/Extra'er
 
Posts: 35
Joined: Tue May 04, 2004 6:54 pm
Location: Melbourne, Australia

Re: MegaTunix on OS-X (revised)

Postby eazy-v » Tue Jul 21, 2015 5:04 pm

I wonder if it is related to the gcc compiler, do you know off hand how to force glib2 to compile on apple-gcc42?
eazy-v
MS/Extra Newbie
 
Posts: 7
Joined: Thu Jul 16, 2015 9:19 pm

Previous

Return to Megatunix (obsolete)

Who is online

Users browsing this forum: No registered users and 2 guests