Trouble loading correct ini file

For discussion of Phil Tobin's Tuner Studio software (Only about the tuning software itself, not about how to tune or firmware features)

Moderator: LT401Vette

Trouble loading correct ini file

Postby STSMX5 » Sat Jul 15, 2017 7:19 am

I have a specific ini file that is required for my unusual MS1 build. It is unusual because it uses an afm instead of a map sensor so the ini file includes support to read the AFM as the map. So I followed the setup instructions to load from that ini file and at first it worked. The map gauge read as the AFM. For about 15 seconds. Then it stopped and I cannot get it to work again. I have tried changing the properties of the project, I redownloaded the ini file and started a new project and nothing. It keeps reading from the default ini. Any help would be appreciated because I cannot tune until tunerstudio recognises my AFM signal.
Last edited by STSMX5 on Sat Jul 15, 2017 2:03 pm, edited 1 time in total.
STSMX5
MS/Extra Newbie
 
Posts: 7
Joined: Sat Jul 15, 2017 7:14 am

Re: Trouble loading correct ini file

Postby LT401Vette » Sat Jul 15, 2017 1:49 pm

What firmware is this based on?

TS will always read the ini file found at:
[YourProjectFolder]/projectCfg/mainController.ini
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10454
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Trouble loading correct ini file

Postby STSMX5 » Sat Jul 15, 2017 2:06 pm

Sorry, there was a typo that I fixed now. It's an ms1extra, Hr_10g5.
For some reason it appears to be changing the file in that folder to the default, even if I insert the correct file there.
STSMX5
MS/Extra Newbie
 
Posts: 7
Joined: Sat Jul 15, 2017 7:14 am

Re: Trouble loading correct ini file

Postby STSMX5 » Sat Jul 15, 2017 3:55 pm

Also, if I manually insert the freshly downloaded ini into the folder [YourProjectFolder]/projectCfg/mainController.ini then it says that there is an error opening the project. Any advice would be greatly appreciated!
STSMX5
MS/Extra Newbie
 
Posts: 7
Joined: Sat Jul 15, 2017 7:14 am

Re: Trouble loading correct ini file

Postby LT401Vette » Sun Jul 16, 2017 9:18 am

It is probably best if you upload / send a project back so I can see how you have it set up.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10454
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Trouble loading correct ini file

Postby STSMX5 » Sun Jul 16, 2017 9:50 am

Okay I'll see if I can figure out how to do that tonight. I appreciate it.
STSMX5
MS/Extra Newbie
 
Posts: 7
Joined: Sat Jul 15, 2017 7:14 am

Re: Trouble loading correct ini file

Postby STSMX5 » Sun Jul 16, 2017 11:37 am

this is the ini file I am trying to implement. I'm still trying to figure out how to upload a project file.
Attachments
mainController (2).ini
ini file
(181.8 KiB) Downloaded 10 times
STSMX5
MS/Extra Newbie
 
Posts: 7
Joined: Sat Jul 15, 2017 7:14 am

Re: Trouble loading correct ini file

Postby STSMX5 » Sun Jul 16, 2017 11:49 am

Well now I'm unable to upload any files. I am 'all eat up' with computer problems at the moment it seems.
Anyway, that ini was written by the guy that built my MS1 and many others of the same layout. It's a completely plug and play (to meet racing class rules) unit for an early Miata. I know the file can work because it worked for me for a moment before something went wrong and now it just won't. I'm sure there is an easy solution but I am out of ideas. I'll keep trying to upload a project file. I know I can't upload the whole project folder, so what would the project file be named? Is it the project.properties file?
STSMX5
MS/Extra Newbie
 
Posts: 7
Joined: Sat Jul 15, 2017 7:14 am

Re: Trouble loading correct ini file

Postby STSMX5 » Mon Jul 17, 2017 5:07 pm

I figured out the problem. Well I mostly did anyway. Thanks for the responses.
STSMX5
MS/Extra Newbie
 
Posts: 7
Joined: Sat Jul 15, 2017 7:14 am

Re: Trouble loading correct ini file

Postby LT401Vette » Tue Jul 18, 2017 6:10 am

And what was it?
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10454
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC


Return to Tuner Studio

Who is online

Users browsing this forum: No registered users and 2 guests