Can't open project after update

For discussion of Phil Tobin's Tuner Studio software (Only about the tuning software itself, not about how to tune or firmware features)

Moderator: LT401Vette

Can't open project after update

Postby E4ODnut » Wed Sep 13, 2017 8:21 am

I have 3 old projects using modified MSnS Extra code. I haven't needed to even look at them until recently but when I try I get this error message.
"No O2 configuration selected: You'll need to fix the settings.ini.\n\nMegatune terminating"
I went to my old laptop using TunerStudio MS V 0.999.7 and they open up just fine on that machine. Is there something in the update that could have corrupted a file?
Robert
'95 Ford E150, 300 cid six. MS1. Custom MSnS-Extra
'92 Winnebago Elante, Ford 460 cid V8. MS1. Custom MSnS-Extra
'93 Bayliner 3288, twin Ford 351 cid Windsors. Converted to tuned port EFI. MS1. Custom MSnS-Extra
'95 Dodge 2500 4x4 488 cid V10. MS3, work in progress
E4ODnut
Experienced MS/Extra'er
 
Posts: 356
Joined: Sun May 02, 2004 9:13 pm
Location: Gibsons, BC, Canada

Re: Can't open project after update

Postby LT401Vette » Wed Sep 13, 2017 9:02 am

0.999.7 is rather old... about 8 years. But, TS projects should be backward compatible all the way back.

That message implies there is no O2 sensor selected.

If you can zip and post your project, I can tell more.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10389
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Can't open project after update

Postby E4ODnut » Wed Sep 13, 2017 10:00 am

Hi Phil,
Thanks for the quick response. I have to go away for a couple of weeks, but as soon as I get back I'll zip and post for you.
Robert
'95 Ford E150, 300 cid six. MS1. Custom MSnS-Extra
'92 Winnebago Elante, Ford 460 cid V8. MS1. Custom MSnS-Extra
'93 Bayliner 3288, twin Ford 351 cid Windsors. Converted to tuned port EFI. MS1. Custom MSnS-Extra
'95 Dodge 2500 4x4 488 cid V10. MS3, work in progress
E4ODnut
Experienced MS/Extra'er
 
Posts: 356
Joined: Sun May 02, 2004 9:13 pm
Location: Gibsons, BC, Canada

Re: Can't open project after update

Postby E4ODnut » Thu Nov 02, 2017 4:56 pm

Hi again Phil,
Sorry this has taken so long, but life got in the way of my hobby so I couldn't justify any time on it until now.

I did discover something though. Because I have modified the code and the mainController.ini file a lot I found that the .ini file that I use appears with the .bak extension and nothing I can do will allow TS to use it. It looks like my custom file has been substituted with the original file. Fortunately I have an old laptop that I use for tuning . It has no connection to the internet so it still uses the old version of TS and the files are still good and I can open them. What information would you like me to send you?
Robert
'95 Ford E150, 300 cid six. MS1. Custom MSnS-Extra
'92 Winnebago Elante, Ford 460 cid V8. MS1. Custom MSnS-Extra
'93 Bayliner 3288, twin Ford 351 cid Windsors. Converted to tuned port EFI. MS1. Custom MSnS-Extra
'95 Dodge 2500 4x4 488 cid V10. MS3, work in progress
E4ODnut
Experienced MS/Extra'er
 
Posts: 356
Joined: Sun May 02, 2004 9:13 pm
Location: Gibsons, BC, Canada

Re: Can't open project after update

Postby LT401Vette » Thu Nov 02, 2017 8:50 pm

Your modified ini perhaps.

I have a feeling, if you are using an MS1, the trouble may be the error may be related to these line:

#error "No O2 sensor configuration selected; Youll need to fix the settings.ini.\n\nMegaTune terminating."
#exit ; Terminate MT

Some older versions of TS may not have completely failed here as expected.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10389
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Can't open project after update

Postby E4ODnut » Fri Nov 03, 2017 7:46 am

Is there a fix for it, or failing that, Can I download the older version into my current laptop so I can open the project there?
Robert
'95 Ford E150, 300 cid six. MS1. Custom MSnS-Extra
'92 Winnebago Elante, Ford 460 cid V8. MS1. Custom MSnS-Extra
'93 Bayliner 3288, twin Ford 351 cid Windsors. Converted to tuned port EFI. MS1. Custom MSnS-Extra
'95 Dodge 2500 4x4 488 cid V10. MS3, work in progress
E4ODnut
Experienced MS/Extra'er
 
Posts: 356
Joined: Sun May 02, 2004 9:13 pm
Location: Gibsons, BC, Canada

Re: Can't open project after update

Postby LT401Vette » Fri Nov 03, 2017 2:59 pm

Comment out those lines in the ini with a ; in front and it should work..
However, those lines are there because there are things undefined if the O2 sensor is not set.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10389
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Can't open project after update

Postby E4ODnut » Sat Nov 04, 2017 8:43 am

I can't seem to find the settings.ini file. Where should it be?
Robert
'95 Ford E150, 300 cid six. MS1. Custom MSnS-Extra
'92 Winnebago Elante, Ford 460 cid V8. MS1. Custom MSnS-Extra
'93 Bayliner 3288, twin Ford 351 cid Windsors. Converted to tuned port EFI. MS1. Custom MSnS-Extra
'95 Dodge 2500 4x4 488 cid V10. MS3, work in progress
E4ODnut
Experienced MS/Extra'er
 
Posts: 356
Joined: Sun May 02, 2004 9:13 pm
Location: Gibsons, BC, Canada

Re: Can't open project after update

Postby LT401Vette » Mon Nov 06, 2017 6:52 am

There is no settings.ini
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10389
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Can't open project after update

Postby E4ODnut » Mon Nov 06, 2017 8:52 am

I suppose that is why I can't find it.

Is the .ini file you are referring to "mainController.ini" in the "projectCfg" folder? If so, which lines to you want me to comment out? But I think there is another problem.

My version of the mainController.ini, which has been working just fine for years with my modified code has no reference to the O2 sensor configuration. This file now appears in the "projectCfg" folder as "mainController.ini.bak and is completely different than the "mainController.ini file in that folder.
Robert
'95 Ford E150, 300 cid six. MS1. Custom MSnS-Extra
'92 Winnebago Elante, Ford 460 cid V8. MS1. Custom MSnS-Extra
'93 Bayliner 3288, twin Ford 351 cid Windsors. Converted to tuned port EFI. MS1. Custom MSnS-Extra
'95 Dodge 2500 4x4 488 cid V10. MS3, work in progress
E4ODnut
Experienced MS/Extra'er
 
Posts: 356
Joined: Sun May 02, 2004 9:13 pm
Location: Gibsons, BC, Canada

Re: Can't open project after update

Postby LT401Vette » Mon Nov 06, 2017 11:02 am

E4ODnut wrote:Is the .ini file you are referring to "mainController.ini" in the "projectCfg" folder? If so, which lines to you want me to comment out?


Yes, that would be the one..


My version of the mainController.ini, which has been working just fine for years with my modified code has no reference to the O2 sensor configuration. This file now appears in the "projectCfg" folder as "mainController.ini.bak and is completely different than the "mainController.ini file in that folder.


That sounds like it may be your trouble..
TS doesn't make a .ini.bak file. So it sounds like your ini was renamed to a .bak file and a different .ini was put in there??

Have you tried replacing the mainController.ini file with the .bak file?

Most of this you would do in the Project properties dialog. It is risky playing with all the files directly, that is why the UI is there.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10389
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Can't open project after update

Postby E4ODnut » Mon Nov 06, 2017 5:42 pm

I did try replacing the .ini with the .ini.bak before, with no success, but I tried it again just now.

This is very interesting! I created a temp folder within the config folder and moved the .ini file into it for safe keeping. Then I renamed the mainController.ini.bak file, which is my custom file, to just plain mainController.ini. Then I opened TS, and I got the same message. When I opened the config file again the mainController.ini.bak was there again, which is my customized file. mainController.ini was also there. A comment on it states "last edited for version 029Y2 and MT2.25 (release). This looks to me like it should be the original mainController.ini for the MSnSExtra firmware.

I don't know what is happening here,but does this give you any clues?
Robert
'95 Ford E150, 300 cid six. MS1. Custom MSnS-Extra
'92 Winnebago Elante, Ford 460 cid V8. MS1. Custom MSnS-Extra
'93 Bayliner 3288, twin Ford 351 cid Windsors. Converted to tuned port EFI. MS1. Custom MSnS-Extra
'95 Dodge 2500 4x4 488 cid V10. MS3, work in progress
E4ODnut
Experienced MS/Extra'er
 
Posts: 356
Joined: Sun May 02, 2004 9:13 pm
Location: Gibsons, BC, Canada

Re: Can't open project after update

Postby LT401Vette » Tue Nov 07, 2017 8:24 am

LT401Vette wrote:If you can zip and post your project, I can tell more.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10389
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Can't open project after update

Postby E4ODnut » Tue Nov 07, 2017 8:50 am

I have 3 different projects that I cannot open. They are similar but have differences. They are all based on MSnSExtra. I am trying to open them with TS 3.0.28 I'm attaching a projectCfg zip file for the project called "Hocus Pocus"
Attachments
projectCfg.zip
(224.26 KiB) Downloaded 6 times
Robert
'95 Ford E150, 300 cid six. MS1. Custom MSnS-Extra
'92 Winnebago Elante, Ford 460 cid V8. MS1. Custom MSnS-Extra
'93 Bayliner 3288, twin Ford 351 cid Windsors. Converted to tuned port EFI. MS1. Custom MSnS-Extra
'95 Dodge 2500 4x4 488 cid V10. MS3, work in progress
E4ODnut
Experienced MS/Extra'er
 
Posts: 356
Joined: Sun May 02, 2004 9:13 pm
Location: Gibsons, BC, Canada

Re: Can't open project after update

Postby LT401Vette » Thu Nov 09, 2017 2:42 pm

I see your trouble now...
TS has an updated and modified ini file for 29y3 bundled with it.
It will update your ini file with it's own if the iniVersion is lower than it's own.
Your edited file has no iniVersion, so it is taken as old.

This is what you need in your ini file:
Code: Select all
[TunerStudio]
   iniVersion = 3.0


That will prevent TS from over writing yours.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10389
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Can't open project after update

Postby E4ODnut » Fri Nov 10, 2017 9:38 pm

Very good! That allowed me to open the projects. I still get a bunch of errors and warnings, but at least I can open them to see if I can fix those problems.

Thanks for your help
Robert
'95 Ford E150, 300 cid six. MS1. Custom MSnS-Extra
'92 Winnebago Elante, Ford 460 cid V8. MS1. Custom MSnS-Extra
'93 Bayliner 3288, twin Ford 351 cid Windsors. Converted to tuned port EFI. MS1. Custom MSnS-Extra
'95 Dodge 2500 4x4 488 cid V10. MS3, work in progress
E4ODnut
Experienced MS/Extra'er
 
Posts: 356
Joined: Sun May 02, 2004 9:13 pm
Location: Gibsons, BC, Canada


Return to Tuner Studio

Who is online

Users browsing this forum: Bing [Bot] and 1 guest