A bug... I think?

For discussion of Phil Tobin's Tuner Studio software (Only about the tuning software itself, not about how to tune or firmware features)

Moderator: LT401Vette

A bug... I think?

Postby elaw » Tue Dec 26, 2017 5:18 pm

While trying to adjust ASE on my car I just experienced something that I thought was a tuning limit, but it appears to me to be a bug in TS?

Here's how I can reproduce it on my machine:
* First make sure in the ASE (not ASE taper, just ASE) dialog, that the option to "Auto scale Y axis maximum" is off.
* Open the attached .msq - at least for me I get the same result if I open a predefined or temporary project.
* Open the dialog to edit ASE. It should come up looking like this:
Capture.PNG
Capture.PNG (51.36 KiB) Viewed 144 times

* In the graph window, click to edit the leftmost visible point (the blue dot just below the 100% Y-axis line).
* Use the up or down arrow to change the value. The graph should rescale so it looks like this:
Capture2.PNG
Capture2.PNG (52.2 KiB) Viewed 144 times

* In the graph window, click the leftmost blue dot to edit it.
* Try to increase the value. When I do that, it won't allow me to increase the value above 140.

I thought this was because the ASE values were somehow limited to 140. But when I go into the table and manually edit the numbers (or use Q/W to increase/decrease), I can go all the way up to 400!

If I turn on the "Auto scale Y axis maximum" option, the behavior is somewhat different. As I try to increase the value, up to a point the Y axis will rescale and allow me to continue increasing the value... up to a point. Eventually it will rescale with the Y max somewhere in the low 300s and won't allow me (by using up/down in the graph) to increase the value further.

Oh and this is TS version 3.0.50.23 running on Windows 10 x64. The problem doesn't seem dependent on firmware version... I tried a bunch of (MS3) .msq files I had going back years and the problem occurs with all of them.
Attachments
2017-12-17_07.40.25.msq
(287.4 KiB) Downloaded 3 times
Eric Law
1990 Audi 80 quattro with AAN turbo engine: happily running on MS3+MS3X
2012 Audi A4 quattro, desperately in need of tweaking

Be alert! America needs more lerts.
User avatar
elaw
Super MS/Extra'er
 
Posts: 2877
Joined: Fri Oct 16, 2009 6:20 am
Location: Wilmington, MA

Re: A bug... I think?

Postby LT401Vette » Sun Dec 31, 2017 2:45 pm

In the ini the max Y for that view is set to 100, that is what TS uses by default. But if the underlying constant has a higher max, it will rescale when needed to allow it.

Note the line:
yAxis = 0, 100, 6
The 100 is the max.

Code: Select all
       curve = asePct, "Afterstart Enrichment (ASE) Percentage"
         topicHelp = "file://$getProjectsDirPath()/docs/Megasquirt3_TunerStudio_MS_Lite_Reference-1.4.pdf#asep"
          columnLabel = "Coolant", "Afterstart"
          xAxis       = -40, {clthighlim}, 9
          yAxis       =   0, 100, 6
          xBins       = temp_table_p5, coolant, readonly
          yBins       = asePctTable
          gauge       = cltGauge

Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10409
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC


Return to Tuner Studio

Who is online

Users browsing this forum: No registered users and 1 guest