Error warning message

For discussion of Phil Tobin's Tuner Studio software (Only about the tuning software itself, not about how to tune or firmware features)

Moderator: LT401Vette

Error warning message

Postby Philip Lochner » Wed Feb 07, 2018 7:29 am

I get the warning message on project load despite Options / Advanced / Report INI warnings being switched off.

W10
TS: 3.0.28
FW : MSX 3.2.4
Kind regards
Philip
'74 Jensen Interceptor 440ci (EFI'ed with MS2 and wasted spark + GM 4L60e GPIO controlled - both on Extra FW)
Philip Lochner
Super MS/Extra'er
 
Posts: 1003
Joined: Thu Feb 16, 2006 6:18 am
Location: Centurion, South Africa

Re: Error warning message

Postby LT401Vette » Wed Feb 07, 2018 10:05 am

What is the message? W10?
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10454
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Error warning message

Postby Philip Lochner » Thu Feb 08, 2018 9:07 am

W10 = Windows 10 (Sorry!)

Error message attached.
TS error message.png
TS error message.png (15.06 KiB) Viewed 88 times
Kind regards
Philip
'74 Jensen Interceptor 440ci (EFI'ed with MS2 and wasted spark + GM 4L60e GPIO controlled - both on Extra FW)
Philip Lochner
Super MS/Extra'er
 
Posts: 1003
Joined: Thu Feb 16, 2006 6:18 am
Location: Centurion, South Africa

Re: Error warning message

Postby LT401Vette » Thu Feb 08, 2018 1:54 pm

It won't prompt you on warnings unless it is turned on under the Advanced menu.
However, TS will always prompt you with Errors. In that screenshot there are 52 errors.

What are the errors?
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10454
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Error warning message

Postby Philip Lochner » Fri Feb 09, 2018 3:25 am

custom.ini file attached. I can't figure out what the problem is.

52 Errors:
Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:751]: entry = time, "Time", float, "%.3f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:752]: entry = seconds, "SecL", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:753]: entry = rpm, "RPM", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:754]: entry = map, "MAP", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:756]: entry = throttle, "TP", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:757]: entry = batteryVoltage, "vBatt", float, "%.2f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:759]: entry = afr1, "Actual AFR", float, "%.2f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:760]: entry = afrtgt1, "AFRtrgt1", float, "%.2f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:761]: entry = afrerr1, "AFR Error", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:763]: entry = mat, "IAT", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:764]: entry = coolant, "CLT", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:765]: entry = engine, "Engine", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:768]: entry = airCorrection, "Gair", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:769]: entry = warmupEnrich, "Gwarm", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:770]: entry = baroCorrection, "Gbaro", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:771]: entry = gammaEnrich, "Gammae", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:772]: entry = accDecEnrich, "AccelEnrich", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:774]: entry = veCurr1, "Gve", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:775]: entry = pulseWidth1, "PW", float, "%.3f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:776]: entry = dutyCycle1, "DutyCycle1", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:778]: entry = advance, "SparkAdv", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:779]: entry = coldAdvDeg, "ColdAdv", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:780]: entry = tpsDOT, "tpsDOT", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:781]: entry = mapDOT, "mapDOT", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:782]: entry = iacstep, "IAC", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:784]: entry = deltaT, "deltaT", float, "%.0f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:751]: entry = time, "Time", float, "%.3f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:752]: entry = seconds, "SecL", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:753]: entry = rpm, "RPM", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:754]: entry = map, "MAP", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:756]: entry = throttle, "TP", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:757]: entry = batteryVoltage, "vBatt", float, "%.2f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:759]: entry = afr1, "Actual AFR", float, "%.2f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:760]: entry = afrtgt1, "AFRtrgt1", float, "%.2f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:761]: entry = afrerr1, "AFR Error", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:763]: entry = mat, "IAT", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:764]: entry = coolant, "CLT", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:765]: entry = engine, "Engine", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:768]: entry = airCorrection, "Gair", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:769]: entry = warmupEnrich, "Gwarm", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:770]: entry = baroCorrection, "Gbaro", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:771]: entry = gammaEnrich, "Gammae", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:772]: entry = accDecEnrich, "AccelEnrich", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:774]: entry = veCurr1, "Gve", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:775]: entry = pulseWidth1, "PW", float, "%.3f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:776]: entry = dutyCycle1, "DutyCycle1", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:778]: entry = advance, "SparkAdv", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:779]: entry = coldAdvDeg, "ColdAdv", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:780]: entry = tpsDOT, "tpsDOT", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:781]: entry = mapDOT, "mapDOT", float, "%.1f"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:782]: entry = iacstep, "IAC", int, "%d"

Error: Malformed [OutputChannel] entry, Problem at:
[custom.ini]:[Line:784]: entry = deltaT, "deltaT", float, "%.0f"
Attachments
custom.ini
(30.85 KiB) Downloaded 2 times
Kind regards
Philip
'74 Jensen Interceptor 440ci (EFI'ed with MS2 and wasted spark + GM 4L60e GPIO controlled - both on Extra FW)
Philip Lochner
Super MS/Extra'er
 
Posts: 1003
Joined: Thu Feb 16, 2006 6:18 am
Location: Centurion, South Africa

Re: Error warning message

Postby Philip Lochner » Fri Feb 09, 2018 4:56 am

I deleted all the datalog stuff and now my errors are gone. Am I right that the datalogging parameters in mainController.ini will still apply?
Kind regards
Philip
'74 Jensen Interceptor 440ci (EFI'ed with MS2 and wasted spark + GM 4L60e GPIO controlled - both on Extra FW)
Philip Lochner
Super MS/Extra'er
 
Posts: 1003
Joined: Thu Feb 16, 2006 6:18 am
Location: Centurion, South Africa

Re: Error warning message

Postby LT401Vette » Fri Feb 09, 2018 9:21 am

It looks like your DataLog entries are in your OutpuChannels section.
did the [Datalog] section header get deleted?
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 10454
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Error warning message

Postby Philip Lochner » Fri Feb 09, 2018 5:59 pm

LT401Vette wrote:It looks like your DataLog entries are in your OutpuChannels section.
did the [Datalog] section header get deleted?


Yes, I deleted that as well.
Kind regards
Philip
'74 Jensen Interceptor 440ci (EFI'ed with MS2 and wasted spark + GM 4L60e GPIO controlled - both on Extra FW)
Philip Lochner
Super MS/Extra'er
 
Posts: 1003
Joined: Thu Feb 16, 2006 6:18 am
Location: Centurion, South Africa


Return to Tuner Studio

Who is online

Users browsing this forum: No registered users and 3 guests