S54 dual VANOS VVT

Testing and development of Megasquirt 3

Moderators: jsmcortina, muythaibxr

Re: S54 dual VANOS VVT

Postby AbatelliCristian » Thu Jan 22, 2015 6:32 am

Abatelli did you have all VR sensors? Or Crank VR with hall sensors on the cams?


Bmw S54 have hall sensor in the cranck and hall sensor for cam... in my application I have used VR sensor in the cranck for convenience.
AbatelliCristian
Master MS/Extra'er
 
Posts: 787
Joined: Sun Oct 10, 2010 6:33 am

Re: S54 dual VANOS VVT

Postby ragepower » Thu Feb 12, 2015 5:32 pm

Yesterday I notice my cpu was damage and I sent it to repair. Before that I tried the vvt test mode.

The cam was fully retarded and I started to increase the duty cycle. When I something above 50% like 60%, the cam goes to fully advance. When I came back to a value like 30 % nothing happen. In this case, the must go to fully retard,right?
ragepower
Experienced MS/Extra'er
 
Posts: 278
Joined: Fri Dec 17, 2010 9:13 am
Location: Leiria - Portugal

Re: S54 dual VANOS VVT

Postby AbatelliCristian » Fri Feb 13, 2015 12:42 am

yes, is correct
AbatelliCristian
Master MS/Extra'er
 
Posts: 787
Joined: Sun Oct 10, 2010 6:33 am

Re: S54 dual VANOS VVT

Postby Mario » Thu Feb 19, 2015 1:36 pm

Can someone have a look here for me regarding the "cam fault" I can't shake when VVT is enabled.

viewtopic.php?f=125&t=57579
1967 Beetle My test mule
The Dub Shop
Facebook
Megasquirt for life!
Mario
Master MS/Extra'er
 
Posts: 409
Joined: Sun Jan 30, 2005 11:13 pm
Location: Monroe, Wa.

Re: S54 dual VANOS VVT

Postby Mario » Sun Mar 01, 2015 4:23 pm

We where able to get on a Dyno Friday. We achieved 290rwhp & 242lb/ft but ran out of time on this trip to really optimize the package. We are happy with the big end and will address the lower portion at another time. Thank for the help everyone.

2015-02-27 22.44.16.jpg
1967 Beetle My test mule
The Dub Shop
Facebook
Megasquirt for life!
Mario
Master MS/Extra'er
 
Posts: 409
Joined: Sun Jan 30, 2005 11:13 pm
Location: Monroe, Wa.

Re: S54 dual VANOS VVT

Postby Peter Florance » Mon Mar 02, 2015 4:26 am

ragepower wrote:Hi james, my engine, s62b50, uses the same vanos system but for v8, so it is needed the double of the outputs.

This week I hope to get start the engine with MS, only need to solve some problems and to do the cam protection circuits.

About the high-side driver for vanos solenoids and vanos oil pressure accumulator solenoid (100hz), the TIP125 is enough? Can I use the vtec control circuit from diyautotune website ( http://www.diyautotune.com/diypnp/images/vtec_alt_lg.gif )?

EDIT: Is possible to double the outputs to control this vanos?

BTW, every time I see this drawing, I want to point out that emitter and collector are reversed.

The pin numbers are correct, but there's no way that part would work with emitter as output.
Peter Florance
PF Tuning
81 BMW Euro 528i ESP Car
60-2 Wheel LS2 Coils, Low Z Inj
Co-Driver 1999 BMW E46 DSP car.
User avatar
Peter Florance
Super MS/Extra'er
 
Posts: 3619
Joined: Fri Apr 02, 2004 8:40 pm
Location: Virginia Beach, VA

Re: S54 dual VANOS VVT

Postby ragepower » Mon Mar 02, 2015 6:34 am

Peter Florance wrote:
ragepower wrote:Hi james, my engine, s62b50, uses the same vanos system but for v8, so it is needed the double of the outputs.

This week I hope to get start the engine with MS, only need to solve some problems and to do the cam protection circuits.

About the high-side driver for vanos solenoids and vanos oil pressure accumulator solenoid (100hz), the TIP125 is enough? Can I use the vtec control circuit from diyautotune website ( http://www.diyautotune.com/diypnp/images/vtec_alt_lg.gif )?

EDIT: Is possible to double the outputs to control this vanos?

BTW, every time I see this drawing, I want to point out that emitter and collector are reversed.

The pin numbers are correct, but there's no way that part would work with emitter as output.


It works since the the transistor is an pnp, it isn't an npn like usual.

BTW : it is working. On vvt test mode, it is all good. Next I will try to use some angle to see how it react. Is usual cam angle to have some fluctuation? Like 0.3 degree?[url][/url]

Edit :http://www.msextra.com/forums/viewtopic.php?f=131&t=56041&start=120
Where you have a log. I have a problem. I have a sync lost reason 2.
ragepower
Experienced MS/Extra'er
 
Posts: 278
Joined: Fri Dec 17, 2010 9:13 am
Location: Leiria - Portugal

Re: S54 dual VANOS VVT

Postby Peter Florance » Mon Mar 02, 2015 7:09 am

Hmm.. I've never seen a PNP transistor source current from the emitter.
Peter Florance
PF Tuning
81 BMW Euro 528i ESP Car
60-2 Wheel LS2 Coils, Low Z Inj
Co-Driver 1999 BMW E46 DSP car.
User avatar
Peter Florance
Super MS/Extra'er
 
Posts: 3619
Joined: Fri Apr 02, 2004 8:40 pm
Location: Virginia Beach, VA

Re: S54 dual VANOS VVT

Postby ragepower » Mon Mar 02, 2015 11:10 am

Não
Peter Florance wrote:Hmm.. I've never seen a PNP transistor source current from the emitter.


It was another transistor controlling the tip125.
ragepower
Experienced MS/Extra'er
 
Posts: 278
Joined: Fri Dec 17, 2010 9:13 am
Location: Leiria - Portugal

Re: S54 dual VANOS VVT

Postby Peter Florance » Mon Mar 02, 2015 11:29 am

ragepower wrote:Não
Peter Florance wrote:Hmm.. I've never seen a PNP transistor source current from the emitter.


It was another transistor controlling the tip125.

I think it should be drawn like this
vtec.gif
Peter Florance
PF Tuning
81 BMW Euro 528i ESP Car
60-2 Wheel LS2 Coils, Low Z Inj
Co-Driver 1999 BMW E46 DSP car.
User avatar
Peter Florance
Super MS/Extra'er
 
Posts: 3619
Joined: Fri Apr 02, 2004 8:40 pm
Location: Virginia Beach, VA

Re: S54 dual VANOS VVT

Postby ragepower » Mon Mar 02, 2015 1:54 pm

Ok, I now understand what you are saying. I was on the phone and the image was very small and didn't notice the difference.

Yes I think you are right. I must agree with what you was saying.
ragepower
Experienced MS/Extra'er
 
Posts: 278
Joined: Fri Dec 17, 2010 9:13 am
Location: Leiria - Portugal

Re: S54 dual VANOS VVT

Postby Peter Florance » Mon Mar 02, 2015 5:39 pm

ragepower wrote:Ok, I now understand what you are saying. I was on the phone and the image was very small and didn't notice the difference.

Yes I think you are right. I must agree with what you was saying.

Thanks, I'm just worried someone will try to use it and it won't work.
Peter Florance
PF Tuning
81 BMW Euro 528i ESP Car
60-2 Wheel LS2 Coils, Low Z Inj
Co-Driver 1999 BMW E46 DSP car.
User avatar
Peter Florance
Super MS/Extra'er
 
Posts: 3619
Joined: Fri Apr 02, 2004 8:40 pm
Location: Virginia Beach, VA

Re: S54 dual VANOS VVT

Postby eeklaca » Mon May 15, 2017 11:36 pm

I'm Laszlo from Hungary. I play an S50B32 engine with MS3, dual vanos 4 solenoids. Can anybody share me the base vvt settings for the actual code level (1.5)? My problem is: one of the solenoid from one pair (intake or exhaust) is always give a pwm signal, and is very hot. If I read correctly, if the cam is the right position, all the 2 solenoids are off, no pwm signal. I use VN920-E high side driver (http://www.farnell.com/datasheets/17613 ... 1471331580), 4 pcs. In test mode working good.

Laszlo_s50b32.msq
S50B32 tune file
(274.28 KiB) Downloaded 12 times
eeklaca
MS/Extra Newbie
 
Posts: 10
Joined: Fri Mar 27, 2015 2:26 pm

Re: S54 dual VANOS VVT

Postby Peter Florance » Tue May 16, 2017 4:15 am

I have settings from older firmware that I can post. I used TIP125 so the polarity may not be the same

Sent from my XT1080 using Tapatalk
Peter Florance
PF Tuning
81 BMW Euro 528i ESP Car
60-2 Wheel LS2 Coils, Low Z Inj
Co-Driver 1999 BMW E46 DSP car.
User avatar
Peter Florance
Super MS/Extra'er
 
Posts: 3619
Joined: Fri Apr 02, 2004 8:40 pm
Location: Virginia Beach, VA

Re: S54 dual VANOS VVT

Postby eeklaca » Tue May 16, 2017 1:28 pm

Today I played some hours, but the result is not to good.

I searching info about the cam tooth, and I found this:

Exhaust 6+1

Intake 6

If I use intake for cam 1, cam settings: poll level, low, tooth 1, I can read a stable vvt 1 angle, but the cam fault is red. If I use exhaust for cam 1, cam settings: poll level, low, tooth 13, I can't read a stable vvt1 angle, but the cam fault not red.

I think the cam decoder BMW S54 setting is not good for the 6+1 tooth exhaust cam. Is it right?

sorry for my poor english
eeklaca
MS/Extra Newbie
 
Posts: 10
Joined: Fri Mar 27, 2015 2:26 pm

Re: S54 dual VANOS VVT

Postby eeklaca » Tue May 16, 2017 1:35 pm

Peter Florance wrote:I have settings from older firmware that I can post. I used TIP125 so the polarity may not be the same

Sent from my XT1080 using Tapatalk


please send me your settings, I was sent you my mail address in pm.

Thank You
eeklaca
MS/Extra Newbie
 
Posts: 10
Joined: Fri Mar 27, 2015 2:26 pm

Re: S54 dual VANOS VVT

Postby Peter Florance » Tue May 16, 2017 2:01 pm

eeklaca wrote:
Peter Florance wrote:I have settings from older firmware that I can post. I used TIP125 so the polarity may not be the same

Sent from my XT1080 using Tapatalk


please send me your settings, I was sent you my mail address in pm.

Thank You

Sorry, it has been a very busy day.
Here is a screenshot of the settings.
https://www.dropbox.com/s/apgksw1t0hvv5 ... 9.png?dl=0
Peter Florance
PF Tuning
81 BMW Euro 528i ESP Car
60-2 Wheel LS2 Coils, Low Z Inj
Co-Driver 1999 BMW E46 DSP car.
User avatar
Peter Florance
Super MS/Extra'er
 
Posts: 3619
Joined: Fri Apr 02, 2004 8:40 pm
Location: Virginia Beach, VA

Re: S54 dual VANOS VVT

Postby eeklaca » Tue May 16, 2017 2:13 pm

Peter Florance wrote:
eeklaca wrote:
Peter Florance wrote:I have settings from older firmware that I can post. I used TIP125 so the polarity may not be the same

Sent from my XT1080 using Tapatalk


please send me your settings, I was sent you my mail address in pm.

Thank You

Sorry, it has been a very busy day.
Here is a screenshot of the settings.
https://www.dropbox.com/s/apgksw1t0hvv5 ... 9.png?dl=0


Thank you!

I think your engine is an S54, exhaust cam teeth number is 8. In my S50b32 engine the exhaust cam is a 6+1 teeth, and I think this is the problem.
eeklaca
MS/Extra Newbie
 
Posts: 10
Joined: Fri Mar 27, 2015 2:26 pm

Re: S54 dual VANOS VVT

Postby Peter Florance » Tue May 16, 2017 7:38 pm

eeklaca wrote:
Peter Florance wrote:
eeklaca wrote:[quote="Peter Florance"]I have settings from older firmware that I can post. I used TIP125 so the polarity may not be the same

Sent from my XT1080 using Tapatalk


please send me your settings, I was sent you my mail address in pm.

Thank You

Sorry, it has been a very busy day.
Here is a screenshot of the settings.
https://www.dropbox.com/s/apgksw1t0hvv5 ... 9.png?dl=0


Thank you!

I think your engine is an S54, exhaust cam teeth number is 8. In my S50b32 engine the exhaust cam is a 6+1 teeth, and I think this is the problem.[/quote]
Certainly.
So this is M52 TU?

Sent from my XT1080 using Tapatalk
Peter Florance
PF Tuning
81 BMW Euro 528i ESP Car
60-2 Wheel LS2 Coils, Low Z Inj
Co-Driver 1999 BMW E46 DSP car.
User avatar
Peter Florance
Super MS/Extra'er
 
Posts: 3619
Joined: Fri Apr 02, 2004 8:40 pm
Location: Virginia Beach, VA

Re: S54 dual VANOS VVT

Postby eeklaca » Tue May 16, 2017 11:22 pm

My engine (S50b32) is the E36 M3 engine (96-99) eu version, 3.2 litre. I think the M52TU is the US version.

https://en.m.wikipedia.org/wiki/BMW_M50

Tapatalkkal küldve az én EVOLVEO_StrongPhone_Q8_LTE eszközömről
eeklaca
MS/Extra Newbie
 
Posts: 10
Joined: Fri Mar 27, 2015 2:26 pm

PreviousNext

Return to MS3 Development

Who is online

Users browsing this forum: No registered users and 1 guest