MAF lookup bug ?

Testing and development of Megasquirt 3

Moderators: jsmcortina, muythaibxr

MAF lookup bug ?

Postby W126 » Sun Nov 12, 2017 1:22 am

Hi,

the MAF lookup (mapping MAF voltage to MAF) seems buggy to me.
I have sorted a log file by MAF voltage and got different MAF values for identical voltages.
Then I made a Tuner Studio custom channel "MafCurve" which does a MAF lookup in the
MAF Flow Curve and compared that to the MAF values.
MafCurve = { tableLookup(array.mafflow, array.mafv, maf_volts) }, "g/s";
The max error in this log is 24% !.

error.jpg
error.jpg (45.29 KiB) Viewed 137 times


FW 1.5.1

I had to cut the log.
Attachments
2017-11-11_20.49.39.cut.msl.zip
(686.17 KiB) Downloaded 13 times
W126
Helpful MS/Extra'er
 
Posts: 109
Joined: Sun Aug 24, 2014 10:32 am

Re: MAF lookup bug ?

Postby jsmcortina » Sun Nov 12, 2017 5:34 pm

Please attach your MSQ.
There could be a number of factors here, ones that spring to mind:
- the datalog points are not synchronised with the actual calculation.
- the curve is linearly interpolated which might not be exactly the same as your comparison curve.

I did a scatter plot in MegaLogViewer of MAF vs. MAFvolts and it give a "fat" line, showing a bit of a spread.

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 33911
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: MAF lookup bug ?

Postby W126 » Mon Nov 13, 2017 9:45 pm

Hi James,

thank you for your reply.
Attached you'll find my tune.

Jan
Attachments
MyTune.msq
(286.33 KiB) Downloaded 3 times
W126
Helpful MS/Extra'er
 
Posts: 109
Joined: Sun Aug 24, 2014 10:32 am

Re: MAF lookup bug ?

Postby jsmcortina » Tue Nov 14, 2017 5:39 am

I looked at your log again and your tune. Nothing is jumping out as incorrect. You have a 50% lag enabled on MAF. So the value will rarely match the instantaneous table lookup due to the smoothing. This will be especially visible during transients.

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 33911
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: MAF lookup bug ?

Postby W126 » Tue Nov 14, 2017 6:25 am

Hi James,

thank you for your analysis.
The 50% lag is the default.
Which lag factor do you recommend for MAF ?

Jan
W126
Helpful MS/Extra'er
 
Posts: 109
Joined: Sun Aug 24, 2014 10:32 am


Return to MS3 Development

Who is online

Users browsing this forum: No registered users and 2 guests