BMW m60 ms3x help - no start

General support questions and announcements for MS3. See also MS3 manuals.

Moderators: jsmcortina, muythaibxr

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Fri Apr 28, 2017 4:08 pm

Ok, i'll probably just adjust, crank, adjust crank etc.

Wideband is fixed. As soon as it started reading something half decent, i let auto tune smooth out the fuel table and it immediately was running better. Once i get this cam thing figured out i'll start posting my timing table for you to help me with :D :D :D
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Mon May 01, 2017 7:09 am

So as it turns out, the m60 uses a 2 wide/2 narrow wheel. Switched to poll level on tooth 10 and got full rpm sync. Took it out for it's first drive yesterday, putted around my neighborhood then ventured to the gas station. Continuing to let the live analysis tweak the fuel table, and once that's in better shape i may start fiddling with the timing, but all is well for now.
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Sun Sep 10, 2017 8:44 am

6 month bump: I eventually got the car running pretty well. Had some issues with full sequential, I think i had some noise in the signal wire, so reverted to semi-seq and called it a day. Car was running great for a few weeks. Then after I put 60lb injectors in it blew up. Prettty sure I had an injector stick open, but after inspection of my fuel table, the scaling was way off especially in the decel area. I think it was just dumping way too much fuel and backfired then went up in flames. Long story short, I got another 540 and swapped all the turbo stuff over. But now I can't get it started on the same tune that was running the car previously. I did have to redo the adatper harness because the old one got a little crispy. It cranks, will sometimes let out a little 'thump thump', all the voltages look normal, can't figure it out. Any advice on where to start? what to double check?
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby grom_e30 » Sun Sep 10, 2017 8:52 am

is it syncing up ok?
1990 bmw 320i daily driver with m20b25 ms3 sequential fuel, 380cc injectors, d585 coil near plug, home made cam sync, launch control, fan control, vss, homebrew egt logging what's next????
grom_e30
Super MS/Extra'er
 
Posts: 4004
Joined: Thu Mar 08, 2012 12:44 pm
Location: UK

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Sun Sep 10, 2017 8:56 am

Yup. I get the full RPM sync light when cranking. Ah...moment of clarity, it's syncing in full sequential mode, which for whatever reason it had trouble running on previously. For some reason the fuel map needed to be scaled waayyyy back because it was running extra rich. like single digit AFRs. I should put it in semi-seq and see if that helps, because i smell a lot of fuel after cranking it
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Sat Sep 23, 2017 12:18 pm

Finally got it running! Turns out the main relay wasn't being triggered by the megasquirt, so i had to bridge it. Fired right up after that. But now I have a lot of noise in the TPS signal. The gauge in tunerstudio bounces all over the place, like 20% jump from 0. The grey reference line fluctuates from 4.96 to 4.97 volts, and the signal line is between 4.94 and 4.95 with the throttle closed. Something seems amiss here. I'm going to try adding a ground right off of the sensor to see if that helps, but has anybody dealt with similar issues?
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Thu Oct 05, 2017 7:10 am

Turns out it was a grounding issue. Car is running well now. A bit rich, in the lower RPMs, but it seem pretty happy for the most parts
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Tue Oct 24, 2017 11:30 am

Late October update: My innovate LC2 decided it was done with me, so now I'm using an AEM x series and I must say, loveit. better than the innovate. Faster response, 4 digits over 3, easy install, integrated controller. A+ product. Anyway, been having a little tourble with getting it to idle well, but its getting closer. Hopefully today I can drive around and let the VE live clean up the fuel table, maybe do a couple 3rd gear pulls to look at the logs with and just generally get it all tidied up. Next steps will be building in some safeguards (AFR cut, overboost protection, etc.) then start upping the boost. Only on wastegate pressure still and that only spikes to like 4psi
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby cj.surr » Mon Oct 30, 2017 6:40 am

What exactly happened when the engine "died"? Seems kind of strange that anything could kill an engine during decel.
cj.surr
Helpful MS/Extra'er
 
Posts: 39
Joined: Fri Jul 29, 2016 4:28 am

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Mon Oct 30, 2017 6:49 am

cj.surr wrote:What exactly happened when the engine "died"? Seems kind of strange that anything could kill an engine during decel.


I'm not 100% certain, and of course I wasn't datalogging at the time so I'll never really know, but my best guess is some combination of an injector sticking open, fuel rain lift, and a crap timing table. It would backfire like crazy on the 24lb injectors, so triple the fuel flow and now all of a sudden there's a nice atomized cloud of vapor in the intake manifold just waiting to be ignited. I lifted in 3rd gear, it popped and burbled a few times then *bang*...smoke and flames followed suit.
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Tue Oct 31, 2017 9:50 am

grom_e30 wrote:It has to be wired per the firing order so a=1 b= next to fire and so on


I'm working on finally setting up my M62b44 with MS3+MS3X, and this statement above has me a bit perplexed. I have already established my firing order in Tuner Studio, so I was planning to wire a=1, b=2, and so on... Is that wrong, or is it only wrong if you leave firing order setup as 1,2,3,4,5,6,7,8?
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Tue Oct 31, 2017 11:02 am

Tjabo wrote:I'm working on finally setting up my M62b44 with MS3+MS3X, and this statement above has me a bit perplexed. I have already established my firing order in Tuner Studio, so I was planning to wire a=1, b=2, and so on... Is that wrong, or is it only wrong if you leave firing order set up as 1,2,3,4,5,6,7,8?


Took me a minute to understand this as well, so I'll try to explain as simply as possible haha... You are correct in already Establishing the firing order in tunerstudio, so leave that as is. The wiring is the tricky(ish) bit and it sounds like you were going to do what I did at first which is Channel A = Cylinder 1, Channel B = Cyl 2, etc. This is wrong. Channel A goes to the first cylinder to fire, B goes to the second cylinder to fire, etc. m6x firing order is 1-5-4-8-6-3-7-2, so you should wire it as A=1, B=5, C= 4, etc. Make sense?

Feel free to give my wring diagram a peek, it's for the m60b40, whcih uses the motcronic 3.3, so the pin numbers will be different, but should at least help out with orders, sensors, etc.

https://docs.google.com/spreadsheets/d/ ... =drive_web
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Tue Oct 31, 2017 1:26 pm

Thank you!!

I totally understand what you are saying, and I NEVER would have thought to do it that way. :D

Since I like all of my MegaSquirt Extra/MS3 stuff to make perfect sense, I scoured through the manuals until I found the documentation of this matter in 5.3 of the hardware manual 1.4. Of course then I wanted to check on fuel injector sequencing too, even though it's not nearly so important. In 4.10.2.6 of the hardware manual 1.4, it says the same thing about the fuel injectors. This all leaves me wondering why Tuner Studio needs to know the firing order the way it does. There is clearly a piece of the puzzle that I'm not seeing!

[EDIT] I found the piece of the puzzle I was missing. In the handy dandy note bubble in the firing order section of Engine and Sequential Settings, it clearly says: "Firing order is used for trim and per-cylinder corrections so the adjustment is applied to the correct cylinder number. Injectors and coils must still be wired in firing order sequence. i.e. InjA=cyl1, InjB=next cylinder to fire" James and the gang have done a bang up job of having everything extremely well documented, there is just a ton of information to sort through.

By the way, I see that you are not only running an M60, but also with a turbo! Have you done a "Success" thread on it in here by chance? I'd really like to see what you have going on with that. Or maybe on bimmerforums?
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Tue Oct 31, 2017 1:52 pm

Any time my man! Also, TS needs firing order if you're running sequential ignition (which i am).

No big success or build thread. I've posted about it in a few places on BFc and Facebook groups. This is probably the most robust thread I have haha. I have a ton of video footage i've compiled and started a youtube channel too, but its in the early stages still. Car runs great though, fun to drive, super fast haha.

Edit-waiit I recognize you're pic from bfc. I have the e34 haha.
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Tue Oct 31, 2017 1:54 pm

What's your YT channel?

Ah, ok!! Wait, is this the E34 that had the fire and is getting transplanted to a new chassis? I get confused, haha... :? :lol:
Last edited by Tjabo on Tue Oct 31, 2017 1:55 pm, edited 1 time in total.
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Tue Oct 31, 2017 1:55 pm

Tjabo wrote:What's your YT channel?

Ah, ok!!


You mean the name or a description? because so far its s***. haha
https://www.youtube.com/watch?v=frHZEXNMgfw
plenty more to come. Lots of pics on instagram though. @abeebe_718 or @maintenancemafia
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Wed Nov 01, 2017 7:58 am

Tjabo wrote:Ah, ok!! Wait, is this the E34 that had the fire and is getting transplanted to a new chassis? I get confused, haha... :? :lol:


Haha yes. It was originally in my oxford msport (RIP), now in an Orient blue car which is actually in better shape, lower miles. As much as the ordeal sucked, it kinda worked out. Now I'm just trying to make some real power. Except the stupid oil drain keeps coming off the oil pan. I had it welded on the upper section of the pan originally. Since the car was lifted and had access to a TIG at the time at my buddy's shop, I just dropped the lower pan and welded it from the inside, since you have to either drop the sub frame or pull the engine to get the upper section off. I don't have a TIG at my house, so I just drilled a hole in the same spot and epoxied a drain tube (read: JB weld) on, but it's knock off epoxy (again read: JB Weld), so once it get's up to temp it fails. Twice now. Soo need to either get some braising rods and solder it on, or get some better high temp epoxy (a third time read: JB Weld) or get like a plumbing fitting with sandwich nuts/o rings to replace my current setup.
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Wed Nov 01, 2017 8:04 am

I hear you, I spent all of my free time on two or three (probably three) days just getting my drain worked out. I wouldn't necessarily suggest for anyone to do what I did, but it seems to be working well, and I only had to drop the lower pan, so that was good. Oh, no welding on that piece of the project either!
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Wed Nov 01, 2017 8:14 am

Tjabo wrote:I hear you, I spent all of my free time on two or three (probably three) days just getting my drain worked out. I wouldn't necessarily suggest for anyone to do what I did, but it seems to be working well, and I only had to drop the lower pan, so that was good. Oh, no welding on that piece of the project either!


Ok i'm intrigued...what'd you do? haha
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Wed Nov 01, 2017 8:26 am

It's kind of hard to explain, but the last part of the drain is a large 90* pipe fitting elbow that drops the oil into the horizontal top surface of the front of the upper pan... I found a couple of pictures I took that sort of show it. I can email them to you if you like.

I'll follow your lead and give Google drive a try. Here are two pics. The brass piece on top of the grungy front of the upper oil pan is my 90* elbow into the top of the pan. There is an AN -10 to 1/2"(?)NPT adapter bringing the oil in from the opposite side you are looking at in the pics:

https://drive.google.com/open?id=0B3J7c ... lZFd2RhQVU

https://drive.google.com/open?id=0B3J7c ... lRlT21uV3M
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

PreviousNext

Return to MS3 General Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 6 guests