BMW m60 ms3x help - no start

General support questions and announcements for MS3. See also MS3 manuals.

Moderators: jsmcortina, muythaibxr

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Wed Nov 01, 2017 10:39 am

Tjabo wrote:It's kind of hard to explain, but the last part of the drain is a large 90* pipe fitting elbow that drops the oil into the horizontal top surface of the front of the upper pan... I found a couple of pictures I took that sort of show it. I can email them to you if you like.

I'll follow your lead and give Google drive a try. Here are two pics. The brass piece on top of the grungy front of the upper oil pan is my 90* elbow into the top of the pan. There is an AN -10 to 1/2"(?)NPT adapter bringing the oil in from the opposite side you are looking at in the pics:

https://drive.google.com/open?id=0B3J7c ... lZFd2RhQVU

https://drive.google.com/open?id=0B3J7c ... lRlT21uV3M


Makes sense. How'd you secure the 90* in the pan? is it threaded?
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Wed Nov 01, 2017 10:45 am

Yep, NPT pipe thread tapped into the pan ceiling.
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Wed Nov 01, 2017 10:48 am

Brilliant. I may actually steal that idea if i can't get my current setup to work. Any leaks? Did you tap the pan first or just run the fitting in?
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Wed Nov 01, 2017 10:56 am

I did tap it. It was a bit of a pain to get the tap to run in perpendicular to the surface of the pan as is necessary. IIRC, I drilled and tapped from the bottom with the lower pan removed. I think...

Basically no part of putting a turbo on an E39 540 hasn't been a big pain. :lol:
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Thu Nov 02, 2017 6:46 am

Tjabo wrote:Basically no part of putting a turbo on an E39 540 hasn't been a big pain. :lol:


It hasn't exactly been a walk in the park with the e34 either. But probably significantly easier just based on space in the engine bay. Glad to see other people taking the plunge and actually doing a challenging build too though. So tired of turbo e36 m3s. OOOoooh wow you and 7 thousand other people...
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Thu Nov 02, 2017 7:08 am

Funny you should mention that! :lol:

I started really trying to build this 540 project in the winter toward the end of 2015 I guess... I have fabricated most of everything for it except I used the factory exhaust manifolds on the driver side (left side for our right-side-drive friends), and made good progress through the winter and spring. But then in April 2016 I bought a piece of junk E36 -- automatic trans because it was the cheapest thing I could get -- to start fooling around with drifting. I spent about 4 months getting that thing driftable, so I didn't work on the 540 much. Then late in the summer of 2016 I got back to working on the 540 again.

In February of 2017 I decided to turbo the E36, and have it done before the first drift event at the end of April. I really didn't even start on the build until mid-March, other than the tuning, and I finished it in time. The actual build and sorting process took me about 6 weeks of my free time, versus the year worth of free time or whatever I have into the 540. Just a ridiculous, night and day difference in difficulty between the two.

Granted, I did spend a bit of extra time on the E36 learning to use RomRaider to tune it, and tuning it on E85 with Siemens Deka 80# injectors. But there again, I have spent MONTHS messing with the DME tune for the 540 with WinOLS. It's just absurd when you have experience with MegaSquirt and TunerStudio.

So last night I got the 540 running with MS3X running the Siemens Deka 80s with E85 I have in it also. It reminded me just how beautiful and luxurious TunerStudio is to use compared to the other tuning options I've been dealing with. It sort of makes me regret the time I've spent messing with the other stuff, but it's all good learning experience I guess.. Sorry for the book of largely irrelevant blather. :oops:
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Thu Nov 02, 2017 7:22 am

Haha i forgot you had that e36 too. I was originally looking for one to turbo when i bought my first 540, so i don't have much room to talk.

But ya the amount if trial and error to get the 540 all sorted out is significantly more than nearly anything else i've tried. I thought about going down the emulator road originally and doing like Ostrich or something, but obviously went the MS route. Even though it's my first foray into a standalone or actual tuning, it's been pretty smooth all things considered (minus the fire lol).

Awesome man! glad you got it running. I had SD 60# in the car that blew up, still don't know if they're usable, guessing not. Have some 42# Bosch green giants for the new car. I think e85 is in my future as well, but probably a couple months out still. What fuel pump are you using?
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Thu Nov 02, 2017 7:27 am

I have a Walbro 450 in the 540, currently with all stock fuel system other than the Siemens Deka 80s. Did I say I love them? Lol
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Thu Nov 02, 2017 7:31 am

Nice, that's a lot of pump. haha. was planning on just a 255, but might go with the AEM 340 ethanol pump instead.
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Thu Nov 02, 2017 7:53 am

Nothing wrong with a lot of pump, they are cheap and good. But as I always say, you need to do what feels right to you! After all, we do things like this for our enjoyment. :D
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Sun Nov 26, 2017 10:42 am

Thanksgiving update:

Finally got the 42# injectors installed yesterday and ordered an Aeromotive 340 e85 pump on black friday sale. Car is running a bit rich with the bigger injectors. I updated the required fuel settings but it's still rich. around .5 - 1 point richer than the target AFR table t idle. Guessing this is either a pulsewidth or injector timing issue, but i'm not too worried about it. Inj timing is 360* across the board.

The one thing thats giving me pause is when i rev it up a few times and then chop the throttle shut, it has a tendency to "pop" at the end of it decelling. Ex, give it some revs up to about 3500 or so, then as its falling down right around 1000rpms it does a bang. Normally I'd think "oh neat, fireballs", buuuut that's what was (partially) the death of the first engine so I'm extra weary of any extracurricular noises. Also having some troubles with open loop idle control. Attached is the current msq. Can post a datalog this afternoon to replicate the popping for anyone that may have some insight there.
Attachments
turbo m60.msq
(266.04 KiB) Downloaded 6 times
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Sun Nov 26, 2017 10:45 am

Without looking at your .MSQ, did you make an appropriate change to your dead time for your new injectors.
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Sun Nov 26, 2017 10:48 am

Tjabo wrote:Without looking at your .MSQ, did you make an appropriate change to your dead time for your new injectors.


I did not change it. Currently set to .9ms. Google has revealed to me the .763 may be a more appropriate number
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Sun Nov 26, 2017 10:55 am

My guess is that it won't make a big difference between those values, but it might be noticeable at idle.
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Sun Nov 26, 2017 11:15 am

Tjabo wrote:My guess is that it won't make a big difference between those values, but it might be noticeable at idle.


I'll give it a whirl and report back. Still need to take it for a drive too. Should be able to make some real boost now :D
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Sun Nov 26, 2017 2:00 pm

How much boost are you running so far? I've used up to 19.4psi from the billet wheel 78/75 turbo so far. It's starting to feel pretty fun! :twisted:
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Sun Nov 26, 2017 2:21 pm

Tjabo wrote:How much boost are you running so far? I've used up to 19.4psi from the billet wheel 78/75 turbo so far. It's starting to feel pretty fun! :twisted:


Gawd dang! That’s gotta be fast. Most I’ve ever seen is 4psi. Haha. And even that is fun


Sent from my iPhone using Tapatalk
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby Tjabo » Sun Nov 26, 2017 5:08 pm

It's pretty fast. I'm almost out of the capacity of my clutch though, so I'm not quite getting all of the torque translated into acceleration.. It's going to be expensive to get enough clutch to hold this sucker.
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 795
Joined: Sat Nov 05, 2005 7:36 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Sun Nov 26, 2017 5:14 pm

Tjabo wrote:It's pretty fast. I'm almost out of the capacity of my clutch though, so I'm not quite getting all of the torque translated into acceleration.. It's going to be expensive to get enough clutch to hold this sucker.


What clutch are you using? I'm using an e39 m5 clutch. I've read it's supposedly good for 500 ft lbs.
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

Re: BMW m60 ms3x help - no start

Postby abeebe718 » Sun Nov 26, 2017 5:23 pm

Ok, so day 2 with the new injectors and it's significantly better. Idle isn't quite fixed, but it's definitely solvable with WUE and IACV settings. Fuel table is taking shape now thanks to the VEAL. I'm still puzzled by the fact that it's almost always rich. Like, at times 2 full points. normally between .5 and 1 though. I've attached the current tune and a few datalogs. Haven't really leaned into it yet. Also it's still backfiring a decent amount on decel...how do I tune that out? Probably doesnt help I'm only running a downpipe and no exhaust
Attachments
turbo m60.msq
(265.99 KiB) Downloaded 3 times
2017-11-26_16.05.03.msl
(217.45 KiB) Downloaded 2 times
2017-11-26_16.01.49.msl
(164.86 KiB) Downloaded 4 times
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 49
Joined: Wed Feb 15, 2017 8:03 pm

PreviousNext

Return to MS3 General Support

Who is online

Users browsing this forum: Bing [Bot] and 4 guests