MS3 Pro ultimate - M62

General support questions and announcements for MS3. See also MS3 manuals.

Moderators: jsmcortina, muythaibxr

MS3 Pro ultimate - M62

Postby nicodenhertog » Wed Nov 01, 2017 5:34 pm

Hello to everyone

This is my first ECU project,

Engine:
BMW M62TUB35 (3.5L V8)
VVT on intake

ECU:
MS3 Pro ultimate
2x Quadspark

Status at this moment

Wiring harnas connected to:
-Quadspark
-COP (OEM)
-Injectors (OEM)
-MAT (OEM)
-TPS
-Fuel pump + relais
-12+ connected (with big a switch) directly to the accu

Things what's working
-Injectors
-TPS
-Fuel pump
-MAT

Settings Tunerstudio:
-Falling edge
-Going high
-wasted spark

Where I need help:

I got nothing out of the spark (in test mode)
They are 3 wire
In my daily car i got the same engine so i checked all the wires
Pin 1 Signal
Pin 4a Ground
Pin 15 12+

If i measure on my daily (all OEM) i got between 1 & 15 12volts
With engine OFF and RUNNING

I hope someone can help me with something

Nico Den Hertog
nicodenhertog
MS/Extra Newbie
 
Posts: 9
Joined: Wed Nov 01, 2017 4:54 pm
Location: the Netherlands

Re: MS3 Pro ultimate - M62

Postby nicodenhertog » Tue Nov 07, 2017 6:26 am

Yesterday i buy some brand new VW COP's

test them olso in spark test mode, but agian nothing (test them directly on MS without quadspark)

see in attachments
-.MSQ -- file how i test the BMW COP's(3 Wire) and the VW COP's (4 wire)
-Wiring power & output's -- this is all what i wired right now
-Wiring input's -- this is all what is wired right now (before the CKP was olso wired but at this moment disconnected)

Nico den Hertog
Attachments
2017-11-07_14.07.30.msq
(285.59 KiB) Downloaded 13 times
Wiring power output.pdf
(105.95 KiB) Downloaded 12 times
Wiring inputs.pdf
(92.82 KiB) Downloaded 10 times
nicodenhertog
MS/Extra Newbie
 
Posts: 9
Joined: Wed Nov 01, 2017 4:54 pm
Location: the Netherlands

Re: MS3 Pro ultimate - M62

Postby Tjabo » Thu Nov 09, 2017 5:12 pm

I have an M62b44 (non-VANOS) running on full sequential from MS3+MS3X for the past several days now, and with a tune that is getting quite acceptable. I'm not sure about the differences between some of the sensors and trigger wheels on our engines, but if your engine has the crank position sensor on the flywheel, it is probably the same Tooth #1 angle as mine. I've found that to be 66 degrees.

Also, since you're set to full sequential, I think you need a second trigger input from the cam. I am not familiar with the MS3 Pro inputs and outputs, but I am guessing that the cam input and the spark output shouldn't both be JS10?

For my engine, second trigger is "poll level", and Level for phase 1 is "High." Since I'm using MS3X, my spark hardware is "MS3X Spark," and my cam input is "MS3X Cam In."

I don't know if any of this can help you, but I don't think there are too many of us M62 guys around, so it can be nice to have a bit of assistance from time to time! :)
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 797
Joined: Sat Nov 05, 2005 7:36 pm

Re: MS3 Pro ultimate - M62

Postby nicodenhertog » Fri Nov 10, 2017 1:19 am

Thanks for your reply!

my CKP sensor and CMP sensor is working very good

my engine is with VANOS so the first tooth angle will be higher

i got the same settings for my CAM input (that feels good :D )
there are many differences in pin numbers of the MS3X and MS3 Pro

but my big problem is, the coils are not woring... :oops:

what type of COP's do you use?
and how are those wired?

IMG_20171025_222405.jpg
2 weeks ago (It's a mess now)
IMG_20171025_222405.jpg (665.02 KiB) Viewed 307 times
Attachments
log crank and cam.png
log crank and cam.png (125.95 KiB) Viewed 307 times
nicodenhertog
MS/Extra Newbie
 
Posts: 9
Joined: Wed Nov 01, 2017 4:54 pm
Location: the Netherlands

Re: MS3 Pro ultimate - M62

Postby jsmcortina » Fri Nov 10, 2017 6:21 am

There's a simple test you can try.
First off - unplug all of the coils.

Connect a volt meter between ground and spk A trigger signal.

Now, in the "Output test mode -I/O 2" you can directly turn spk A on and off. Check that you see 0V or 5V on your meter.

Repeat for other outputs.

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 34054
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: MS3 Pro ultimate - M62

Postby Tjabo » Fri Nov 10, 2017 7:13 am

nicodenhertog wrote:my engine is with VANOS so the first tooth angle will be higher


Are you sure about that from checking with a timing light? I'm not disagreeing with you, but I do find it unexpected that they changed the trigger wheel on the flywheel when going from the non-vanos to vanos.. If so, I wonder why it was necessary..

nicodenhertog wrote:what type of COP's do you use?
and how are those wired?


I am currently using the factory COPs that are the same between the M62b44 and M52b28 engines that I have. I created an "Octoshock" (as named by my daughter) with 8 BIP373s in it, so it is wired the same as the Quadsparks are on the coil side. On the MS3 side I am running the BIP373s from the MS3X logic level spark outputs, with the normal 330 Ohm resistor in line.

Image

Image


By the way, your engine install is SOOOO CLEAN AND TIDY!! Makes me think I need to completely rewire the top of my engine that is still messy with factory wiring boxes and whatnot..
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 797
Joined: Sat Nov 05, 2005 7:36 pm

Re: MS3 Pro ultimate - M62

Postby nicodenhertog » Fri Nov 10, 2017 7:19 am

Tjabo wrote:
nicodenhertog wrote:my engine is with VANOS so the first tooth angle will be higher


Are you sure about that from checking with a timing light? I'm not disagreeing with you, but I do find it unexpected that they changed the trigger wheel on the flywheel when going from the non-vanos to vanos.. If so, I wonder why it was necessary..


Sure i will check it first , but i read something about the diffeneces

jsmcortina wrote:There's a simple test you can try.
First off - unplug all of the coils.

Connect a volt meter between ground and spk A trigger signal.

Now, in the "Output test mode -I/O 2" you can directly turn spk A on and off. Check that you see 0V or 5V on your meter.

Repeat for other outputs.

James


I did the test before and it was 5v

The same test with the quadspark gives 12V but its a very weak signal if i connect a 1.2W light on it the volts will go down to 1.88v

Thanks

Nico
nicodenhertog
MS/Extra Newbie
 
Posts: 9
Joined: Wed Nov 01, 2017 4:54 pm
Location: the Netherlands

Re: MS3 Pro ultimate - M62

Postby jsmcortina » Fri Nov 10, 2017 9:22 am

The Quadspark is a ground-switch - it doesn't put out any voltage. Seeing about 1V at the output when it is connected to a bulb is probably ok (I've not measured that.)

Did you test bulb light up brightly?

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 34054
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: MS3 Pro ultimate - M62

Postby nicodenhertog » Fri Nov 10, 2017 9:36 am

jsmcortina wrote:The Quadspark is a ground-switch - it doesn't put out any voltage. Seeing about 1V at the output when it is connected to a bulb is probably ok (I've not measured that.)

Did you test bulb light up brightly?

James


Yes, i did the test with the light, there was a very small light but it was not a bright light!

when i measure that 12V on the output of the Quadspark it was between Quadspark output and 12V+
and with the light connected the voltage between quadspark output and 12V+ is 1.88 V

With how many watt lights do other people test?

Thanks

Nico
nicodenhertog
MS/Extra Newbie
 
Posts: 9
Joined: Wed Nov 01, 2017 4:54 pm
Location: the Netherlands

Re: MS3 Pro ultimate - M62

Postby abeebe718 » Mon Nov 13, 2017 8:04 am

I have an m60b40 on MS3X, so slightly different but settings should be nearly the same. Also using quadspark with OEM coils. Couple things, why wasted spark instead of sequential? Also I *think* it should be rising edge, not falling. Not in front my tuning computer so I can't be 100% sure, but i'm nearly positive. What are your trigger wheel settings?
turbo e34 540
ms3x full sequential m60b40
abeebe718
Helpful MS/Extra'er
 
Posts: 52
Joined: Wed Feb 15, 2017 8:03 pm

Re: MS3 Pro ultimate - M62

Postby Tjabo » Mon Nov 13, 2017 8:32 am

My M62b44 is running perfectly now, full-sequential, with fuel, spark, and idle controlled by MS3+MS3X. I am on rising edge as you say abeebe718.
--'97 BMW 540i/6spd -- Single Front/Top Mount Turbo -- MS3+MS3X V3.0 Full Sequential
User avatar
Tjabo
Master MS/Extra'er
 
Posts: 797
Joined: Sat Nov 05, 2005 7:36 pm

Re: MS3 Pro ultimate - M62

Postby nicodenhertog » Mon Nov 13, 2017 10:20 am

abeebe718 wrote:I have an m60b40 on MS3X, so slightly different but settings should be nearly the same. Also using quadspark with OEM coils. Couple things, why wasted spark instead of sequential? Also I *think* it should be rising edge, not falling. Not in front my tuning computer so I can't be 100% sure, but i'm nearly positive. What are your trigger wheel settings?


Thanks

last week i stared with the trigger wheel settings but there isn't het problem i think, there is no spark in testing mode (the wasted spark was only to test something)
but you are right the trigger wheel settings has to be rising edge only then i got a good log
nicodenhertog
MS/Extra Newbie
 
Posts: 9
Joined: Wed Nov 01, 2017 4:54 pm
Location: the Netherlands

Re: MS3 Pro ultimate - M62

Postby jsmcortina » Mon Nov 13, 2017 10:58 am

You need to get the coils firing in test mode before doing anything else.

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 34054
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: MS3 Pro ultimate - M62

Postby nicodenhertog » Wed Nov 15, 2017 1:11 pm

Today i did an other test

The engine in the car is the same as in my project car

E38 coil test.jpg
E38 coil test.jpg (545.56 KiB) Viewed 210 times


Power and ground from the car to the MS3 Pro wiring
Power and ground from the MS3 Pro to the coils
Coil trigger from the car to the COP's

And i got a spark

so the Power and ground is good from the MS3 Pro wiring

But in testmode still no spark

if someone has tips on how to measure the triggering of the car

Nico
nicodenhertog
MS/Extra Newbie
 
Posts: 9
Joined: Wed Nov 01, 2017 4:54 pm
Location: the Netherlands

Re: MS3 Pro ultimate - M62

Postby jsmcortina » Wed Nov 15, 2017 1:47 pm

I'm not sure what to suggest, try contacting your supplier?

If you are really stuck, you could send me the ECU to confirm it is working ok.

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 34054
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: MS3 Pro ultimate - M62

Postby nicodenhertog » Wed Nov 15, 2017 2:17 pm

jsmcortina wrote:I'm not sure what to suggest, try contacting your supplier?

If you are really stuck, you could send me the ECU to confirm it is working ok.

James


This is my first project, so i try to find out what i'm doing wrong or maybe if its broken or not

It will be great if we can test the MS3 Pro box
nicodenhertog
MS/Extra Newbie
 
Posts: 9
Joined: Wed Nov 01, 2017 4:54 pm
Location: the Netherlands


Return to MS3 General Support

Who is online

Users browsing this forum: No registered users and 4 guests