Problem - MS3 Engine Run-On with Key Off

General support questions and announcements for MS3. See also MS3 manuals.

Moderators: jsmcortina, muythaibxr

Problem - MS3 Engine Run-On with Key Off

Postby goodysgotacuda » Mon Nov 06, 2017 5:23 am

Help! Engine will not turn off with key, sometimes. MS3 Gold Box

I have have had an engine run-on issue that has come and gone on my car. It went away completely for about 2 months and just recently showed back up. About 50% of the time the engine shuts off with the key, the other 50% the engine will continue to run. Sometimes I can turn the key on/off several times and it will die, sometimes that doesn't work. It's very inconsistent.

When the engine runs-on my ECU is seeing 8.0v, somewhere I am getting a backfed source of power that is knocked down from the battery. I verified that by powering the voltage regulator with the engine running on and the 8.0v went up to 9.5v.

What I know:
*When the engine is running on*
- 8.0v to the ECU and control side of fuel pump and inj/coil relays
-Engine will run "forever" in this state, the 8.0v is knocked down from the battery. Somewhere.
- I can pull the main relay, car still runs, see note in attachment.
- Sometimes I can toggle the ign switch on/off and it will die.
- I have completely disconnected the ignition switch, it has nothing to do with the issue, from what i can tell
- It typically happens after the engine has been idling for 1+min
- If i pull the 20a inj/coil fuse the engine will die [obviously], but the 8.0v *goes away* and the ECU will go offline
-If I pull the fuel pump relay, the engine runs itself out of fuel [on 8.0v]
- I can rev the engine and it will die
- I can open the alt charging circuit to the battery, it has no effect. I have not removed alt field wires, the field is divorced from the rest of the car with the key off. [no charge light]


I wired up the car completely from scratch and I like to think that I am pretty savvy at wiring. This one has got me baffled!!!! For now I have worked around it with a tableswitch with RPM and battery voltage <9.0v. But I hate having to do that.


Screen Shot 2017-11-05 at 4.33.16 PM.png
Screen Shot 2017-11-05 at 4.33.16 PM.png (106.77 KiB) Viewed 153 times
1972 Plymouth 'Cuda - 5.7L Hemi w/T56 Magnum

MS3 Gold Box

I'm new to Megasquirt!
goodysgotacuda
Helpful MS/Extra'er
 
Posts: 106
Joined: Sun Oct 05, 2014 5:07 pm

Re: Problem - MS3 Engine Run-On with Key Off

Postby Marek » Mon Nov 06, 2017 6:11 am

If you make the main relay supply the power for the rest of the car, e.g. for the injectors and for the fuel pump, rather than just for relay coils, then no ignition switch will mean no 12v to the injectors or fuel pump.

The alternative approach is to put diodes across relay coils, so they cannot be backfed.

kind regards
Marek
Marek
Experienced MS/Extra'er
 
Posts: 371
Joined: Sun May 10, 2009 1:20 am
Location: Guildford UK

Re: Problem - MS3 Engine Run-On with Key Off

Postby jsmcortina » Mon Nov 06, 2017 6:24 am

Do you have any other relays or solenoids connected to the ECU ? Where do they get their 12V from?

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 33991
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: Problem - MS3 Engine Run-On with Key Off

Postby jamies » Mon Nov 06, 2017 9:05 am

have you got any fans operating that run off the ignition switch?
jamies
Experienced MS/Extra'er
 
Posts: 342
Joined: Tue Apr 07, 2009 12:22 am

Re: Problem - MS3 Engine Run-On with Key Off

Postby okubricko » Tue Jan 02, 2018 1:22 pm

Hey, I don't know if this will help you, but I had the same issue with my MS3X installation. The only way to get the engine to stop was to disconnect the main relay. I found out that the alternator can feed power back to the Megasquirt's main relay and keep it energized. I needed to add a diode from the alternator to the warning light in my dash. I have a '73 Volkswagen which has stupid simple wiring, but this can be commonplace with many aftermarket engine management systems and vehicles. See the attached for more information. I used the 1N4001 as indicated and it immediately solved the issue. Hope this helps.

Engine Run On Diode.jpg
Engine Run On Diode.jpg (142.28 KiB) Viewed 53 times


Ignition Run On.pdf
(223.35 KiB) Downloaded 2 times
okubricko
Helpful MS/Extra'er
 
Posts: 50
Joined: Thu Nov 17, 2016 12:09 pm

Re: Problem - MS3 Engine Run-On with Key Off

Postby Drunken.Swagger » Thu Jan 11, 2018 8:07 pm

Your problem lies in the secondary relays getting their +12v for the coils off of the same wire that supplies +12V to the MegaSquirt. The MegaManual specifies a dedicated relay for the MS switched power input which prevents if from back-feeding power.
2011 Kia Soul
G4GC + 5 Spd
MS3x in progress
Drunken.Swagger
MS/Extra Newbie
 
Posts: 1
Joined: Thu Jan 11, 2018 7:56 pm


Return to MS3 General Support

Who is online

Users browsing this forum: No registered users and 1 guest