Ms2 assembled but not doing anything?

Ask questions about DIY board assembly issues, fault finding and testing. (Covers all Megasquirt versions and board.)

Moderators: jsmcortina, muythaibxr

Ms2 assembled but not doing anything?

Postby humdinger » Fri Dec 01, 2017 10:37 pm

Board has been assembled for a couple of months but i finally just got around to running wires and installing it in my car. Tried to upload firmware but that was a no go due to error messages. Since this is my first big soldering job and first board i've ever assembled i started researching and found a thread that gave me a few places to check voltage so i did (readouts below). I took my time and really tried to be careful but i did have one part q20 that i had installed backwards and had trouble getting it back out so i'm hoping it didnt damage anything. The readouts are just the megasquirt hooked up to the harness in the car and ignition on... nothing else.

Battery Voltage 12.1v
S12 12.1v
Q9 12.1v
Q12 12.1v
Left leg D3 12.1v
Left leg D9 11.3v
Left leg U5 11.3v

5 volt readouts
S5 .1v
+5 protos .1v .1v
Right leg D9 5.1v
Left leg D19 .1v
Right leg U5 5.1v

Thanks for any and all help!
humdinger
MS/Extra Newbie
 
Posts: 1
Joined: Fri Dec 01, 2017 10:23 pm

Re: Ms2 assembled but not doing anything?

Postby billr » Tue Dec 05, 2017 12:31 pm

Remove the MS from the car, remove the MS2 daughterboard, connect only 12V and ground, and do the voltage checks at the mainboard 40-pin socket per the build manual.
billr
Super MS/Extra'er
 
Posts: 5016
Joined: Sun May 15, 2011 11:41 am
Location: Walnut Creek, Calif. USA

Re: Ms2 assembled but not doing anything?

Postby 142 guy » Tue Dec 05, 2017 7:41 pm

As billr recommends, go to the Megamanual - Megasquirt / Boards / V3.00 / Build Guide. The build guide provides instruction on how to test the operation of the board at various stages of construction. Ultimately you may need a jimStim to test the board; but, that won't be of any use until you get the firmware loaded successfully.

Did you follow the procedure for downloading firmware as set out in the build guide? If the communication link is not working that will prevent you from downloading the firmware. The build guide includes a test for confirming that the communication link is working.
142 guy
Helpful MS/Extra'er
 
Posts: 43
Joined: Thu Oct 22, 2015 9:05 am

Re: Ms2 assembled but not doing anything?

Postby billr » Tue Dec 05, 2017 8:08 pm

No, not the Megamanual! It is obsolete and has not been kept current or corrected. Use the manuals linked-to at the top of every page here.
billr
Super MS/Extra'er
 
Posts: 5016
Joined: Sun May 15, 2011 11:41 am
Location: Walnut Creek, Calif. USA


Return to Board assembly and testing

Who is online

Users browsing this forum: No registered users and 3 guests