AODE/4R70W Analog Issues (requires code correction)

'Microsquirt' Transmission Control development and support.

Moderators: jsmcortina, muythaibxr

Re: AODE/4R70W Analog Issues (requires code correction)

Postby ashford » Wed Sep 27, 2017 12:30 pm

i think that he is complaining that the toggle switch settings are greyed out. james, if you have questions on ford trans i can probably answer them.
a few things i can point out
1. 4r70w can swap out mlps sensors( gear position switches) between analog and digital since they are external.
2 most ford rwd 4 speed trans have a 1-2-od-n-r-p shift pattern with an od cancel button ie 4r70, aode, 4r75, e4od and older 4r100.
3 to the best of my knowledg all digital mlps have the same logic. just that the few that have 4 selectable forward gears have an extra data point.
4. beta 2 is needed for digital mlps on 4r70 earlier versions have wrong input pattern
5. the last design of 4r75w has a turbine sensor, i have it hooked up on mine
ashford
Super MS/Extra'er
 
Posts: 1349
Joined: Sun Apr 27, 2008 4:29 pm

Re: AODE/4R70W Analog Issues (requires code correction)

Postby wes kiser » Mon Oct 30, 2017 8:43 am

It has been nearly two years since I have used it, but 4r70w worked fine with me. I believe I was the person that let James know the button is OD cancel, not OD enable. Button worked for us.

We were also Digital TRS, although I think in both variants an OD cancel button was expected.
86 Rx-7, swapped to 2.3 ford turbo (BW EFR 6758), ms3/ms3x sequential fuel /waste spark, ls2 coils
88 Tbird 2.3t, Microsquirt Module (PIMP), TFI ignition
wes kiser
Super MS/Extra'er
 
Posts: 1323
Joined: Tue Jan 03, 2006 2:49 pm
Location: Charlotte, NC

Re: AODE/4R70W Analog Issues (requires code correction)

Postby 64bit » Wed Nov 15, 2017 6:19 am

I've been away for a little while, but I managed to get some time in with the 1.0.2beta2 firmware. It seems as though my wild VSS reading issues have gone away. OD control is now available, I just haven't wired it yet. Lockup seems to be working now that I added a 10ohm resistor to the circuit.
I just found the 1.0.2beta3 and I'll be giving it a run here this week.

James, did you add a filtering to the VSS circuit readout? Is there a way to make it openly adjustable like the filtering in my MS3?
64bit
MS/Extra Newbie
 
Posts: 22
Joined: Fri Jul 21, 2017 5:18 am

Re: AODE/4R70W Analog Issues (requires code correction)

Postby Kaw-a-holic » Sat Dec 30, 2017 8:08 pm

Is there an update on this post? I really don't want want to purchase a Micro for my E4OD without knowing it is going to work correctly.
Kaw-a-holic
MS/Extra Newbie
 
Posts: 1
Joined: Thu May 18, 2017 12:26 pm

Re: AODE/4R70W Analog Issues (requires code correction)

Postby 64bit » Mon Jan 01, 2018 5:16 pm

Kaw-a-holic wrote:Is there an update on this post? I really don't want want to purchase a Micro for my E4OD without knowing it is going to work correctly.
This post had nothing to do with the E4OD. My issue was specifically with the 4R70W code in firmware 1.0.1

I have since updated, but ive been too busy, and it's been to cold for me to do additional wiring and testing in my car.

Sent from my SAMSUNG-SM-G930A using Tapatalk
64bit
MS/Extra Newbie
 
Posts: 22
Joined: Fri Jul 21, 2017 5:18 am

Previous

Return to Transmission Control

Who is online

Users browsing this forum: No registered users and 1 guest