Fuel Pump Wont Stop!

All Megasquirt 1 support questions. See also the Documentation

Moderators: jsmcortina, muythaibxr

Re: Fuel Pump Wont Stop!

Postby Matt Cramer » Thu Nov 16, 2017 8:20 am

Something is causing the processor to command the fuel pump to switch on while on the car but not on the Stim. The most likely cause is something that the MS1 interprets as an RPM signal.
Matt Cramer
Super MS/Extra'er
 
Posts: 13646
Joined: Thu Apr 16, 2009 8:08 pm

Re: Fuel Pump Wont Stop!

Postby DaveEFI » Thu Nov 16, 2017 9:27 am

Do you get anything odd on the Tuner Studio dash between the MS1 and the MS2 when the pump is running with the engine stopped?
Rover SD1 3.5 EFI
MS2 V3
EDIS
Tech Edge O2
London UK.
DaveEFI
Super MS/Extra'er
 
Posts: 2751
Joined: Sun Apr 15, 2012 12:55 am

Re: Fuel Pump Wont Stop!

Postby Corysvdub » Thu Nov 16, 2017 9:53 pm

DaveEFI wrote:Do you get anything odd on the Tuner Studio dash between the MS1 and the MS2 when the pump is running with the engine stopped?


The only thing weird I saw was one bar stating the engine Knocked and the pulse width gauge would go from zero to about three point something milliseconds every few seconds.
MS1 V. 3.0 Not assigned to a motor
MS2 V. 3.57 Subaru Powered Squareback
MS2 V. 3.57 Startup Stand W/ 1800cc Turbo VW
Corysvdub
MS/Extra Newbie
 
Posts: 25
Joined: Mon Oct 30, 2017 9:51 pm

Re: Fuel Pump Wont Stop!

Postby Corysvdub » Thu Nov 16, 2017 9:57 pm

The tachometer was at a steady zero by the way so it isn't seeing rpm to have the pump come on.
MS1 V. 3.0 Not assigned to a motor
MS2 V. 3.57 Subaru Powered Squareback
MS2 V. 3.57 Startup Stand W/ 1800cc Turbo VW
Corysvdub
MS/Extra Newbie
 
Posts: 25
Joined: Mon Oct 30, 2017 9:51 pm

Re: Fuel Pump Wont Stop!

Postby Corysvdub » Thu Nov 16, 2017 10:03 pm

I did try something though, I unplugged the power wire for the coil pack and EDIS.... Then the pump functioned as it should by priming and then shut off. So is there a difference in the pin out from a MS1 to a MS2 I'm not catching? Weird, it works fine with the MS2 but not the MS1...
MS1 V. 3.0 Not assigned to a motor
MS2 V. 3.57 Subaru Powered Squareback
MS2 V. 3.57 Startup Stand W/ 1800cc Turbo VW
Corysvdub
MS/Extra Newbie
 
Posts: 25
Joined: Mon Oct 30, 2017 9:51 pm

Re: Fuel Pump Wont Stop!

Postby DaveEFI » Fri Nov 17, 2017 4:04 am

Corysvdub wrote:I did try something though, I unplugged the power wire for the coil pack and EDIS.... Then the pump functioned as it should by priming and then shut off. So is there a difference in the pin out from a MS1 to a MS2 I'm not catching? Weird, it works fine with the MS2 but not the MS1...


Looking at your sig, your MS2 have V3.57 PCBs. These use a different design of pump relay driver to the V3 PCB. Not sure if this has any bearing, though.
Rover SD1 3.5 EFI
MS2 V3
EDIS
Tech Edge O2
London UK.
DaveEFI
Super MS/Extra'er
 
Posts: 2751
Joined: Sun Apr 15, 2012 12:55 am

Re: Fuel Pump Wont Stop!

Postby Matt Cramer » Fri Nov 17, 2017 6:32 am

Corysvdub wrote:I did try something though, I unplugged the power wire for the coil pack and EDIS.... Then the pump functioned as it should by priming and then shut off. So is there a difference in the pin out from a MS1 to a MS2 I'm not catching? Weird, it works fine with the MS2 but not the MS1...


What happens if you put the MS2 processor on the MS1 board?

How exactly is the MS1 board set up for tach input?

It looks like there's just enough noise pulses getting through to make the fuel pump turn on.
Matt Cramer
Super MS/Extra'er
 
Posts: 13646
Joined: Thu Apr 16, 2009 8:08 pm

Re: Fuel Pump Wont Stop!

Postby Corysvdub » Sat Nov 18, 2017 9:22 am

I have it set up per the manual with the relay board
You do not have the required permissions to view the files attached to this post.
MS1 V. 3.0 Not assigned to a motor
MS2 V. 3.57 Subaru Powered Squareback
MS2 V. 3.57 Startup Stand W/ 1800cc Turbo VW
Corysvdub
MS/Extra Newbie
 
Posts: 25
Joined: Mon Oct 30, 2017 9:51 pm

Re: Fuel Pump Wont Stop!

Postby DaveEFI » Sun Nov 19, 2017 2:13 am

Those are the instructions for using EDIS with B&G code. Extra code modifies the opto input in a different way.
Rover SD1 3.5 EFI
MS2 V3
EDIS
Tech Edge O2
London UK.
DaveEFI
Super MS/Extra'er
 
Posts: 2751
Joined: Sun Apr 15, 2012 12:55 am

Re: Fuel Pump Wont Stop!

Postby Corysvdub » Mon Nov 20, 2017 11:08 pm

DaveEFI wrote:Those are the instructions for using EDIS with B&G code. Extra code modifies the opto input in a different way.


Okay so where would I be looking to find this info?
MS1 V. 3.0 Not assigned to a motor
MS2 V. 3.57 Subaru Powered Squareback
MS2 V. 3.57 Startup Stand W/ 1800cc Turbo VW
Corysvdub
MS/Extra Newbie
 
Posts: 25
Joined: Mon Oct 30, 2017 9:51 pm

Re: Fuel Pump Wont Stop!

Postby Corysvdub » Mon Nov 20, 2017 11:50 pm

Is this it?
You do not have the required permissions to view the files attached to this post.
MS1 V. 3.0 Not assigned to a motor
MS2 V. 3.57 Subaru Powered Squareback
MS2 V. 3.57 Startup Stand W/ 1800cc Turbo VW
Corysvdub
MS/Extra Newbie
 
Posts: 25
Joined: Mon Oct 30, 2017 9:51 pm

Re: Fuel Pump Wont Stop!

Postby Corysvdub » Sun Nov 26, 2017 5:24 pm

Yes? No?... Nobody?... Thanks
MS1 V. 3.0 Not assigned to a motor
MS2 V. 3.57 Subaru Powered Squareback
MS2 V. 3.57 Startup Stand W/ 1800cc Turbo VW
Corysvdub
MS/Extra Newbie
 
Posts: 25
Joined: Mon Oct 30, 2017 9:51 pm

Re: Fuel Pump Wont Stop!

Postby DaveEFI » Mon Nov 27, 2017 2:28 am

Yes - those are the mods for using the opto input with EDIS and a V3 board and Extra Code.
Rover SD1 3.5 EFI
MS2 V3
EDIS
Tech Edge O2
London UK.
DaveEFI
Super MS/Extra'er
 
Posts: 2751
Joined: Sun Apr 15, 2012 12:55 am

Previous

Return to MS1/Extra support

Who is online

Users browsing this forum: No registered users and 2 guests