TinyIOx Scanner and MicroSquirt cant "see" it

A forum for discussing the MegaSquirt related (but non-B&G) board development, assembly, installation, and testing.

Moderators: jsmcortina, muythaibxr

TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Wed Mar 08, 2017 11:19 am

I have powered the TinyIOx from the MicroSquirts 5v Sensor lead, which measures 4.94v at the pins on the TinyIOX

I have soldered in CAN High to CAN High and CAN low to CAN low.

I have not added anything else to the board yet. Only power and CAN.

Without the TinyIOx attached to the MicroSquirt, the CAN leads measure about 114 kOhm, on both the TinyIOX and the MicroSquirt.

I have configured Tuner Studio to add the TinyIOx to the project with tinyIOx020_default.msq and the .s19 file in the same directory. The tuning options are successfully added to Tuner Studio.

The problems I'm having are; the TinyIOx does not show up in the port scanner and when I start Tuner Studio, I get a message that essentially says "tuner studio cant find the TinyIOx press okay to disable it's functions so other controllers can connect. changes to the TinyIOx setting will not be saved"

I'm sure I'm just missing a simple configuration step. A little assistance please.
You do not have the required permissions to view the files attached to this post.
SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby racingmini_mtl » Wed Mar 08, 2017 12:49 pm

Are you running the port scanner without TunerStudio running (or at least no project open)? If so, you should see the TinyIOx regardless of your project settings. If you're not seeing it that means there is a hardware problem related to the CAN bus connection or the TinyIOx itself.

You mention the resistance on the CAN leads. Is it the resistance between CANH and CANL? Is it 114k or 114? This should be around 120 Ohms not 120k. And did you measure it with the TinyIOx connected? In that case, the resistance should be around 60 Ohms.

Also, you mention that you have 5V at the TinyIOx but are you sure you have the polarity correct? And where did you connect the ground on the TIOx?

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 8013
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Wed Mar 08, 2017 1:22 pm

racingmini_mtl wrote:Are you running the port scanner without TunerStudio running (or at least no project open)? If so, you should see the TinyIOx regardless of your project settings. If you're not seeing it that means there is a hardware problem related to the CAN bus connection or the TinyIOx itself.

You mention the resistance on the CAN leads. Is it the resistance between CANH and CANL? Is it 114k or 114? This should be around 120 Ohms not 120k. And did you measure it with the TinyIOx connected? In that case, the resistance should be around 60 Ohms.

Also, you mention that you have 5V at the TinyIOx but are you sure you have the polarity correct? And where did you connect the ground on the TIOx?

Jean

If I run the scanner with TunerStudio open it doesn't show anything. Run the scanner after closing TunerStudio it shows the MicroSquirt as CAN 0

You're right. 114 Ohms, not kOhm. Yes between the high and low to the MicroSquirt and also to the TinyIOx. I did not check it with the TinyIOx connected to the MicroSquirt.

I'm 99% sure the 5v polarity is correct. I double checked it right before I measured the voltage. I'll triple check it though. The TinyIOx is grounded to the sensor ground and all the sensors are working properly in this configuration.
SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby racingmini_mtl » Wed Mar 08, 2017 1:42 pm

Please post a screen capture of the port scanner window.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 8013
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby racingmini_mtl » Wed Mar 08, 2017 1:47 pm

I've taken a quick look at your msq. For now, disable all the CAN polling until you can get a response from the port scanner. Also, you have CAN broadcasting set to 'On' which you do not want to be on. Moreover, you don't even have selected anything to be broadcast so that might create issues.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 8013
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Wed Mar 08, 2017 2:04 pm

racingmini_mtl wrote:I've taken a quick look at your msq. For now, disable all the CAN polling until you can get a response from the port scanner. Also, you have CAN broadcasting set to 'On' which you do not want to be on. Moreover, you don't even have selected anything to be broadcast so that might create issues.

Jean

After the setup procedure and it not working, I started flipping options in hopes of identifying a setting that may have been causing the connection issue. That, and a bit of off line tinkering and fiddling with settings has made quite a mess of everything. I figured once I got it to connect up, I'd just reset everything and start from scratch. However, it didn't connect up before fiddling and changing settings either. I'll turn the polling and broadcasting back off.

I'll post up the scanner screenshot this evening.

Thank you Jean

-Seth-
SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby racingmini_mtl » Wed Mar 08, 2017 2:16 pm

Once you have the Microsquirt back to the default configuration, another thing you can try with the TIOx is the bootloader mode. You would need to short the 2 pads with the power off and then power up the unit with the short still in place (use a short piece of metal wire (wire clip, for example) between the 2 pads). This puts the TIOx in bootloader mode which would be visible on the port scanner even if for some reason the TIOx code got corrupted.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 8013
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Wed Mar 08, 2017 4:39 pm

Screen Shot of Port Scanner
You do not have the required permissions to view the files attached to this post.
SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby racingmini_mtl » Wed Mar 08, 2017 5:35 pm

That seems to confirm what I was saying earlier. Was that with the Microsquirt back to the default settings, i.e., no CAN polling or broadcasting? If so, you need to try with the bootloader mode as I mentioned in my last post.

Another thing to try would be to try connecting the TIOx serial port directly to the PC but that would require some sort of an adapter. But that could confirm if the TIOx is responding at all and would not involve the CAN bus or the Microsquirt. Let me know if you want to try this and I'll elaborate on what's needed.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 8013
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Wed Mar 08, 2017 5:39 pm

Alright, I tripple checked the 5v polarity. The ground is nearest the proto area and positive inboard of that. Just like this picture shows.

Image

I checked the across the high and low with the TinyIOx hooked up and it measures 59.9 Ohms

I checked that there wasn't any solder in contact between the CAN leads and the little 8 legged component right next to them. All clear.

I put everything in Tuner Studio back to their stock settings, and double checked that polling and broadcasting were off. They were. Updated MSQ attached.

With everything off, I shorted the bootloader pins, then powered up.

No change. the Port Scanner still isn't picking it up and Tuner Studio is still giving me the same message about not being able to find the tinyIOx
You do not have the required permissions to view the files attached to this post.
SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Wed Mar 08, 2017 5:46 pm

racingmini_mtl wrote:That seems to confirm what I was saying earlier. Was that with the Microsquirt back to the default settings, i.e., no CAN polling or broadcasting? If so, you need to try with the bootloader mode as I mentioned in my last post.

Another thing to try would be to try connecting the TIOx serial port directly to the PC but that would require some sort of an adapter. But that could confirm if the TIOx is responding at all and would not involve the CAN bus or the Microsquirt. Let me know if you want to try this and I'll elaborate on what's needed.

Jean

I think the Innovate serial connecter that the TinyIOx is designed to be used with is the same cable and connector that's used with MicroSquirt.

I plugged just plugged it in to the TinyIOx and powered it up. Port Scanner is saying (COM7 is the USB serial adapter)
You do not have the required permissions to view the files attached to this post.
SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby racingmini_mtl » Wed Mar 08, 2017 6:00 pm

From all that, you should be seeing the TIOx on the port scanner. So there's either a problem with the TIOx or the CAN chip on the Microsquirt.

As I said, you could try to use the serial port on the TIOx. What you would need for that is to make an adapter using a 2.5mm stereo plug and a female DB9 connector. You need to connect the tip on the 2.5mm plug to pin 2 on the DB9, the ring on the 2.5mm plug to pin 3 on the DB9 and the sleeve on the 2.5mm plug to pin 5 on the DB9. You then connect this to you PC using an RS232 port/cable or a USB-serial adapter.

Note that this adapter is not the same as the one used for the Microsquirt since the RX and TX connections are swapped. A null modem adapter could be used to make this work but I'm not sure that this is something that is still used or available (I'm ancient so that is something I have used in the past but I have not seen one in years).

Jean

p.s. I was writing this as you posted.
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 8013
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Wed Mar 08, 2017 6:10 pm

SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby racingmini_mtl » Wed Mar 08, 2017 6:19 pm

Yes. You would put that between the Microsquirt DB9-2.5mm adapter and the USB-serial adapter. That swaps pins 2 and 3 and connects pin 5 straight through (it does more on the other pins but that's not important here).

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 8013
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Wed Mar 08, 2017 6:22 pm

lt will be here Friday. I'll let you know what happens.
SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Thu Mar 09, 2017 11:49 am

One thing I forgot to mention. I thought it was a little odd that voltage measured at Vref on the TinyIOx was in the low 3's. 3.13 or something like that, when it was measuring 4.9 at the 5v+.

Does that seem off? Does it indicate anything I should check on the board?
SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby racingmini_mtl » Thu Mar 09, 2017 12:50 pm

Yes, that's a problem. By default, Vref is directly connected to the 5V supply.

Just besides the 'C4' label near one corner of the CPU, you will see a solder jumper pad (two squarish solder pads very close to one another). That is what connects Vref to 5V. With power off, check that you have continuity between the 2 sides (0 Ohm). And with power on, check the voltage on both sides (with respect to ground).

If you don't have continuity or have a different voltage, you should put a solder jumper on this. This is simply adding a blob of solder to connect both sides. The board has a trace connecting the 2 sides but it is possible that either there was a defect when the board was made or that something scratched the trace.

One more thing you should check is if the CPU chip heats up. If you can feel any warmth from it, that is suspect.

If you find any issue with this solder jumper (no continuity or different voltage), it would be interesting to take a close up picture of it and post it here. I might be able to see of there is indeed something that looks suspect.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 8013
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Thu Mar 09, 2017 1:25 pm

Here's a pic I took the day I received it, before adding the power and CAN leads.
You do not have the required permissions to view the files attached to this post.
SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby racingmini_mtl » Thu Mar 09, 2017 3:59 pm

I can't see anything from this picture. The picture below shows you the traces for Vref. You should be able to see them with the board in hand and see if anything looks suspicious. Again, you would need to measure the voltage on the solder jumper pads (upper right in the picture). The left pad should be the same as the 5V supply, the right one should be the same as the Vref pad and both should be the same.

Jean
You do not have the required permissions to view the files attached to this post.
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 8013
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: TinyIOx Scanner and MicroSquirt cant "see" it

Postby SethU » Sat Mar 11, 2017 3:04 pm

Between the left and right jumper pads measures 0.1 Ohm. Measuring from the 5v terminal to either of those pads I get 67 kOhms. Same measurement between 5v and Vref too. Thinking there might be something wonky with the 5v solder joint I de-soldered it. No change, 67 kOhms from the 5v terminal to any of the points.
SethU
Helpful MS/Extra'er
 
Posts: 84
Joined: Tue Mar 29, 2016 6:57 pm

Next

Return to Expansion boards

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests