CAN-EGT EGO Not Working In TS

A forum for discussing the MegaSquirt related (but non-B&G) board development, assembly, installation, and testing.

Moderators: jsmcortina, muythaibxr

CAN-EGT EGO Not Working In TS

Postby CMac89 » Tue Apr 25, 2017 9:29 am

I've been having an issue where I am able to get EGTs to read, but I cannot get my two CAN EGO outputs to work. You can see the msq file for how I have the settings. I have tried to connect directly to the module by creating a project for it but i get a timeout message that I attached. I also attached the msq I used for the direct connection to the module.

I have tried to connect the OUT of the LC2 and my MTX-L to the serial port of the module, but cannot get either to display. Anyone have an idea of what I could have wrong? I have verified that the analog outputs are reading in TS.
You do not have the required permissions to view the files attached to this post.
MS3Pro
1994 Thunderbird SC Fully Sequential SVO V6
Versafueler Peak and Hold Injector Driver
IGN-1A Coils
DIY Cherry Crank Sensor with Ford half-moon hall effect cam sensor
DIY 36-1 toothed crank wheel
1500hp goal!
CMac89
Helpful MS/Extra'er
 
Posts: 116
Joined: Tue Jun 12, 2012 8:47 pm

Re: CAN-EGT EGO Not Working In TS

Postby racingmini_mtl » Tue Apr 25, 2017 9:40 am

Exactly how did you connect the LC2 and MTX-L to the CAN-EGT? And how did you try to communicate with the CAN-EGT: through the CAN bus using the MS3 and CAN passthrough or through the USB port on the CAN-EGT? Also, why does the error message say CAN USB?

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 8012
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: CAN-EGT EGO Not Working In TS

Postby CMac89 » Tue Apr 25, 2017 10:45 am

racingmini_mtl wrote:Exactly how did you connect the LC2 and MTX-L to the CAN-EGT? And how did you try to communicate with the CAN-EGT: through the CAN bus using the MS3 and CAN passthrough or through the USB port on the CAN-EGT? Also, why does the error message say CAN USB?

Jean


I'm trying to daisy chain them, but for sake of testing I undid the daisy chain and plugged the 4-pin to serial innovate cable into the OUT of the MTX-L then plugged the serial barrel connector into the CAN EGT box. I tried to connect via CAN bus and by the USB port on the CAN EGT on separate occassions. The 'CAN USB' came from a project I set up strictly for testing the EGT module whenever I directly connected through USB, thus receiving the screen shot I posted.

Over CAN bus, I am getting the EGT signals but no O2. So far I haven't successfully gotten anything to readout by directly connecting. I think I'm doing something wrongly.
MS3Pro
1994 Thunderbird SC Fully Sequential SVO V6
Versafueler Peak and Hold Injector Driver
IGN-1A Coils
DIY Cherry Crank Sensor with Ford half-moon hall effect cam sensor
DIY 36-1 toothed crank wheel
1500hp goal!
CMac89
Helpful MS/Extra'er
 
Posts: 116
Joined: Tue Jun 12, 2012 8:47 pm

Re: CAN-EGT EGO Not Working In TS

Postby CMac89 » Wed Apr 26, 2017 5:45 am

Any ideas? :)
MS3Pro
1994 Thunderbird SC Fully Sequential SVO V6
Versafueler Peak and Hold Injector Driver
IGN-1A Coils
DIY Cherry Crank Sensor with Ford half-moon hall effect cam sensor
DIY 36-1 toothed crank wheel
1500hp goal!
CMac89
Helpful MS/Extra'er
 
Posts: 116
Joined: Tue Jun 12, 2012 8:47 pm

Re: CAN-EGT EGO Not Working In TS

Postby CMac89 » Fri Apr 28, 2017 8:52 am

TTT???
MS3Pro
1994 Thunderbird SC Fully Sequential SVO V6
Versafueler Peak and Hold Injector Driver
IGN-1A Coils
DIY Cherry Crank Sensor with Ford half-moon hall effect cam sensor
DIY 36-1 toothed crank wheel
1500hp goal!
CMac89
Helpful MS/Extra'er
 
Posts: 116
Joined: Tue Jun 12, 2012 8:47 pm

Re: CAN-EGT EGO Not Working In TS

Postby CMac89 » Fri Apr 28, 2017 10:51 pm

I was able to get it working tonight after reflashing the firmware and loading the config file. Seems when I created a project for the CAN EGT via USB, I set up a CAN device for it, but that was unnecessary. After I got it to read through USB, I then went back to my main controller project to get it to work through CAN BUS and got it to work after realizing that I was getting a weird offset because my AFR gauges are gas stoich and I had TS stoich at 9.8, so there was a 5 point offset.

So, whenever I started the motor up to finally do some tuning, all of a sudden I got an Active Filter in autotune of "calibrating O2" and now the CANEGT device can't be recognized. I tried to hook it up to USB and i'm getting a message in the footer of TS saying invalid data received.

I also tried to reload firmware and it isn't giving me the option to. The command prompt just flashes whenever I click the batch file.

Is there a common failure mode and resolution to sudden drops of detection of the CAN EGT module?

Any help would be appreciated as i'm running out of ideas and can't seem to get help.
You do not have the required permissions to view the files attached to this post.
MS3Pro
1994 Thunderbird SC Fully Sequential SVO V6
Versafueler Peak and Hold Injector Driver
IGN-1A Coils
DIY Cherry Crank Sensor with Ford half-moon hall effect cam sensor
DIY 36-1 toothed crank wheel
1500hp goal!
CMac89
Helpful MS/Extra'er
 
Posts: 116
Joined: Tue Jun 12, 2012 8:47 pm

Re: CAN-EGT EGO Not Working In TS

Postby jsmcortina » Sat Apr 29, 2017 4:13 am

It is probably best to contact your supplier directly for support. Your configuration may well be too specific for many readers here to be able to help.

I'm not quite sure I understand what you are saying. But I do know that with MS3 there is no need or desire to add the CAN EGT as a "CAN device" in your project, don't do it. Instead configure the MS3 to collect the EGT and O2 data from the CANEGT with the relevant settings. The CANEGT manual shows the EGT part for sure.

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 33984
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: CAN-EGT EGO Not Working In TS

Postby CMac89 » Sat Apr 29, 2017 9:44 pm

I'll have a follow back up with DIY again. I removed adding a CAN device in the project as you mentioned and seems to not really have made much difference so that's good. Really the only issue I have is that I'm not able to get the CAN EGO to read. Seems the EGT box will only communicate over USB very inconsistently. I got it to attempt to connect today, once, and the few other times I tried, it was unresponsive, but I'll have to talk to them about that.

If the EGT box doesn't a device to be added in the project, then do you know how I would go about changing and applying the CAN EGT's tune file? Also, where would I be able to get the EGT box's s tune file signature and configuration signature to match?
MS3Pro
1994 Thunderbird SC Fully Sequential SVO V6
Versafueler Peak and Hold Injector Driver
IGN-1A Coils
DIY Cherry Crank Sensor with Ford half-moon hall effect cam sensor
DIY 36-1 toothed crank wheel
1500hp goal!
CMac89
Helpful MS/Extra'er
 
Posts: 116
Joined: Tue Jun 12, 2012 8:47 pm

Re: CAN-EGT EGO Not Working In TS

Postby dll67 » Sat May 13, 2017 11:07 pm

Post an update to your situation so others having the same problem can benefit.
MS3X & IOx on 540 ci BBC w/325cc intake runners, 2100CFM TB, 72LB Inj, d585 coils, 60-2 wheel w/cam sensor Muncie 4 speed with 10 tooth VSS, Tilton 7.25" 2 disk cerametalic clutch on Tilton 8.5LB flywheel, Frd 9" detroit locker and disk brakes all around in a 67 RS camaro
dll67
Experienced MS/Extra'er
 
Posts: 155
Joined: Fri Aug 23, 2013 11:37 pm

Re: CAN-EGT EGO Not Working In TS

Postby jsmcortina » Sun May 14, 2017 3:58 am

CMac89 wrote:If the EGT box doesn't a device to be added in the project, then do you know how I would go about changing and applying the CAN EGT's tune file? Also, where would I be able to get the EGT box's s tune file signature and configuration signature to match?

You wouldn't. That's the whole point. You don't need any of those to get the CAN-EGT to work with MS3.

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 33984
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: CAN-EGT EGO Not Working In TS

Postby MS2tester » Sun Jul 02, 2017 11:38 am

you can fix a lot with port port scanner
if you still have problems and code loading does not work
you can hard reset the CAN EGT by having 2 pins (where it says BOOT ) on the board connected while turning on the power
http://forum.jbperf.com/viewtopic.php?f=2&t=1282
http://forum.jbperf.com/viewtopic.php?f=9&t=1550
MS2tester
Master MS/Extra'er
 
Posts: 438
Joined: Sat Apr 11, 2009 12:54 pm
Location: Aalsmeer the netherlands


Return to Expansion boards

Who is online

Users browsing this forum: No registered users and 2 guests