V3 inj1 vs. inj2 different

This is a forum for discussing the development and testing of alpha MS2/Extra code. Documentation
(Runs on MS2 and Microsquirt)

Moderators: jsmcortina, muythaibxr

V3 inj1 vs. inj2 different

Postby franksidebike » Mon May 15, 2017 10:16 am

Hallo
In MS2/Extra pre-3.4.3 beta 3 released is the same Bug as V3 inj1 vs. inj2 different (was MS3 pre-1.5.1 beta 2)
My Settings a Sequential
Picture from same Setting
graph gleich.png
graph gleich.png (15.47 KiB) Viewed 333 times

Picture from Different Setting
graph.png
graph.png (15.34 KiB) Viewed 333 times

AFR swings!
Frank
franksidebike
Experienced MS/Extra'er
 
Posts: 221
Joined: Fri Apr 08, 2005 2:08 pm
Location: Wathlingen, Germany

Re: V3 inj1 vs. inj2 different

Postby jsmcortina » Mon May 15, 2017 1:24 pm

It cannot be the same bug because it isn't the same code. The MS2 vs. MS3 injection code is often very different.

:msq:
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 33672
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: V3 inj1 vs. inj2 different

Postby ChristianK » Tue May 16, 2017 3:08 am

But there is a bug. I've testet this with fullseq and with semiseq at two ports. All the same. Without changing the different deadtime, there are always differences at the squirttime. :?
Golf MK1 Cabrio 1.85L 8v X-Flow ITB MS2
ChristianK
MS/Extra Newbie
 
Posts: 23
Joined: Sun Aug 24, 2014 4:40 pm

Re: V3 inj1 vs. inj2 different

Postby jsmcortina » Tue May 16, 2017 5:36 am

Not seeing MSQ/MSL.

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 33672
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: V3 inj1 vs. inj2 different

Postby ChristianK » Wed May 17, 2017 6:31 am

James, it's the same thing, like Frank's post.

The PW curves in the log are a bit different. Like my msq, it was 1.25ms for Channel 1 and the basic 1.0ms for the channel 2.

So at the log ch 1 has everey time nearly 0.25ms more opening time. Only nearly, cause there are also different voltage corrections.

If you didn't have any ms2 in one our cars, you could test it at the stim.

Wrote the same daedtime and voltcor, the problem went awey...
Golf MK1 Cabrio 1.85L 8v X-Flow ITB MS2
ChristianK
MS/Extra Newbie
 
Posts: 23
Joined: Sun Aug 24, 2014 4:40 pm

Re: V3 inj1 vs. inj2 different

Postby jsmcortina » Tue Jun 06, 2017 3:34 am

Still waiting for tune and log.

James
I can supply, repair or upgrade Megasquirts in UK. http://www.jamesmurrayengineering.co.uk

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 33672
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: V3 inj1 vs. inj2 different

Postby mike2coupe » Wed Jun 28, 2017 4:33 pm

Look at the actual values in your pictures... they are the same.

the lines look different only because your peak ms was higher for one probably only during Acceleration enrichment, that causes the scales to be different and not overlay each other perfectly.

I had the same look to a log once and then noticed it was the same values.
mike2coupe
MS/Extra Newbie
 
Posts: 19
Joined: Wed Dec 26, 2007 1:59 pm


Return to MS2/Extra Development

Who is online

Users browsing this forum: No registered users and 1 guest