36-4 questions (was Getting a new trigger wheel added)

This is a forum for discussing the development and testing of alpha MS2/Extra code. Documentation
(Runs on MS2 and Microsquirt)

Moderators: jsmcortina, muythaibxr

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Sun May 16, 2010 4:38 pm

down the bottom it says.....

Sequential COP)
max size = 4cy using MS2-Extra
MS2-Extra ONLY

also please note indent on the right side of large tooth, this lines up to other mark at tdc
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Sun May 16, 2010 4:59 pm

Dual_Wheel_MS2.jpg
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Mon May 24, 2010 8:20 pm

195 deg appears to be the magic number
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby pit_celica » Mon May 24, 2010 8:36 pm

Did you verify that you are in sync with a timing light (MS timing vs timing light at idle)?

Anyway, great work! You will be the first to have megasquirted a 4th gen 3SGTE using stock COP and all stock ignition related items. I will be the second one :twisted: (If I can have my daughterboard fixed or if the MS3 can be available soon)

Would you mind posting your MSQ file? How are you controlling the OEM IAC valve?

Let me know!

Sam
pit_celica
Master MS/Extra'er
 
Posts: 631
Joined: Tue Jul 18, 2006 3:12 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Mon May 24, 2010 10:36 pm

it is dying over 3000 rpm, and running very rich
how do you put a timing light on a cop?
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby 90turbovan » Mon May 24, 2010 10:56 pm

Those docs are wrong, doesn't look like James has changed them yet. Tooth #1 angle is the crank angle BTDC compression (in the 720 degree cycle) of the crank tooth after the cam signal is seen. Numbers over ~300 degrees don't seem to work properly for me, I'm running a distributor so it doesn't matter. Your spark outputs may need re-arranging if you can't get the proper number.

viewtopic.php?f=101&t=31756&p=212230#p212230

This caused me much confusion in the beginning.

James/Ken correct me if I'm wrong, but that's how I've been setting up the dual trigger.

I pulled apart my timing light (inductive Craftsman one) and just connected the one side of the pickup coil to the logic side of the ignition driver. One of the pins of the pickup coil was connected internally to ground, the other to the strobe firing circuitry. Works well, not sure how it'll go with different lights/non-inductive ones.
90turbovan
MS/Extra Newbie
 
Posts: 24
Joined: Sun Aug 10, 2008 9:05 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Tue May 25, 2010 12:50 am

sam its not a pure gen 4 3sgte so you may be the first....lol
its a gen 2 block with gen 2 turbo ct26...gen 3 stainless steel headers and downpipe with everything else gen 4....with aftermarket water to air intercooler plus other electronic gadgets
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby pit_celica » Tue May 25, 2010 4:59 am

Batgirl,

To put a timing light on a COP system, you will need a 3SGTE spark plug wire.

-Remove cyl#1 COP
-Install the spark plug wire over the cyl#1 spark plug like you should if you were using a distributor
-Connect the distributor end of the spark plug wire to the end of the COP
-Tape them togheter
-Install the timing light on the spark plug wire and verify timing.

Do you have any mod list of your engine? I would like to see some pics. Any links? Great build BTW!

Sam
pit_celica
Master MS/Extra'er
 
Posts: 631
Joined: Tue Jul 18, 2006 3:12 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Sat May 29, 2010 1:37 am

i drove for over an hour today but breaks down over 3000 rpm, i think o2 sensor is faulty since it usuallys stays on 7.5 and then jumps to 22,will upload msq for you guys to diagnose and test
2010-05-29_18.09.22.msq
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby pit_celica » Sat May 29, 2010 10:13 am

Looking at your .msq file, my recommendation would be to flatten your ve table and disable EGO correction until your wideband read normal values.

To disable EGO correction, set 'Active above RPM' to something like 8000 RPM.
On your VE table, the 50 kpa line has lower VE values than the 40 kPA one. Try to make the VE table a little more linear : more kPA = bigger VE number and more RPM = bigger VE number. This is not true for all the VE table, but it will be a nice way to start.

And if I were you, I would make the rev cut setting a little higher (about 7000-7200 RPM).

For the problem at 3000 RPM, take a datalog and join it to your next post. It will be more easy to diagnose the problem than it is with only the .msq file.

Hope to help!

Sam
pit_celica
Master MS/Extra'er
 
Posts: 631
Joined: Tue Jul 18, 2006 3:12 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Sat May 29, 2010 6:49 pm

where is the rev cut setting ?
data log attached, I truly hope someone can shed some light on this since I'm lost at interprating these
2010-05-30_09.38.28.msl
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby pit_celica » Sun May 30, 2010 6:14 am

OK, I looked at your datalog and there are some little things that need to be fixed before doing anything else :

1- Your accel/decel settings are making the engine going into accel/decel mode everytime, even at idle. Remove accel/decel function doing this : Under 'Accel Enrich'/'Acceleration Wizard' , set TPS vs MAP enrichment strategy all the way to 100%. Set MAP treshold at 255, set TPS treshold at 255, set Decel amount at 100. Now, you will not have any accel enrichment, so do not be hard on the throttle plate on the next runs. Slowly press the throttle to raise the RPM, no hard WOT!

2- Your coolant readings are a little noisy. I do not know how to cure this, but I would look at the coolant sensor ground. Where is it grounded?

3- The after-start enrichment is triggering at T = 81704.375 to T = 81708.328. Not sure what is the problem here, but there is definitely something wrong.

4- Your coolant sensor seems to be hitting a max at 101.6. This is in °C right? What calibration did you use for the coolant sensor? Which coolant sensor are you using?

5- Your wideband seems to be giving you only 7.5 or 22.3 peaks. Did you calibrate your wideband? Which wideband are you using? Is it a Narrowband O2 sensor? If you are using a narrow-band sensor, select Narrow-band sensor under 'Calibrate AFR sensor'. And I would highly suggest you to use a wideband sensor if you are planning of tuning the engine yourslef.

For the rev-cut setting, go to Basic Setup/Rev limiter. I suggest you 'Fuel cut', '7000', '7200' for the settings.

Try to solve some of the problems above and get back with another datalog.

Sam
pit_celica
Master MS/Extra'er
 
Posts: 631
Joined: Tue Jul 18, 2006 3:12 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Sun May 30, 2010 8:42 am

standard celica coolant sensor 1 wire
lc-1 wideband just calibrated suspect faulty
yes Celsius
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Sun May 30, 2010 11:53 pm

set TPS vs MAP enrichment strategy all the way to 100%. Set MAP treshold at 255
calibrated coolant sensor to toyota
manually recalibrated LC-1 and in software too, no effect so changed to innovate 10: 20:1
set the rev-cut setting 7000 soft 7200 hard
some logs attached but stiil rpm problem over 3000
2010-05-31_11.30.45.msl
2010-05-31_11.30.45.msl
2010-05-31_11.55.51.msl
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby pit_celica » Mon May 31, 2010 3:13 pm

You need to have the basis covered nicely before trying to go high rpm (>3000 RPM). You need to be able to idle nicely at about 1000 RPM, 30-40 kpa, 13-13.5 AFR. Are you able to do that now?

What kind of idle valve are you using? I'm asking this because you have IAC steps AND PWM idle duty varying in the datalogs. I suggest you to remove any idle control before tuning something else. Use the throttle stop screw to keep the engine idling at about 1000 RPM.

The other negative point is that ASE is triggering randomly. This is not good. I do not know the conditions to trigger ASE, but they are happening and they are richening your mixture when you do not want it.

Are you looking at the datalogs yourself or are you simply joining them to your posts here? You need to understand what your engine is doing if you want to tune it yourself. This begin by looking at the datalogs yourself and understanding all the values you see in it.

Another thing, do not press the throttle aggressively like you are doing on these datalogs. Everything is going too fast to accurately see something. Try to be gentle on the throttle pedal and slowly increase throttle to get more RPM.

Try to add some dwell and see if you can go higher than 3000 RPM.

Post a new datalog AND your new .msq file so everyone can follow what you are doing.

Sam
pit_celica
Master MS/Extra'er
 
Posts: 631
Joined: Tue Jul 18, 2006 3:12 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Mon May 31, 2010 3:28 pm

I'm still getting use to tunerstudio, I look at the logs and see vibrations. but dont understand why some of it is occuring.
I'm using PWM with a 40 ohm resister, I wish I knew how to reduce idle, I still suspect the o2 sensor, I have logs with gentle acceleration but they are over 2mb
how do you add dwell?
I am learning a lot from your posts Sam and very much appreciate them
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby pit_celica » Mon May 31, 2010 4:01 pm

No problem man. I'm simply warning you to not trying to goo too far for now. Try to get the basic stable. Did you read the entire tuning section of the Megamanual? Have a look at it : http://www.msextra.com/doc/ms2extra/MS2 ... anual.html

I've seen that you are using a LC-1 wideband. Does is have a gauge? If yes, does this gauge matches the Tunerstudio's values all the time? If not, you need to calibrate it carefully. Here's how I did it with my AEM wideband : http://www.msefi.com/viewtopic.php?f=38&t=35569 (mostly the last post).

What intake manifold are you using? Caldina or gen2? In any way, to remove idle control from the equation, plug the IAC hose and play with the throttle stop screw on the throttle body to keep the engine at about 1000 RPM. In the software, under Startup/idle, 'Idle Control' , set 'Algorithm' to 'None' for now.

Sam
pit_celica
Master MS/Extra'er
 
Posts: 631
Joined: Tue Jul 18, 2006 3:12 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Mon May 31, 2010 9:17 pm

no i dont have a gauge with it, but i do have a spare LC-1
USING CALDINA manifold and manifold temp
i have just moved my digital speedo to other battery and its now working ok, therefore i may have bad or staticy ignition power circuit maybe my ignition circuit is overloaded this may accoumt for for noisey signals from gauges
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Tue Jun 01, 2010 1:54 am

attached are normal
idle sensor disconected
and none in idle section

also note

timing light settings

1200 rpm 215 deg tooth no.1 angle settings....12 deg btdc
1300 rpm 205 deg tooth no 1 angle setting ......20 deg btdc
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

Re: 36-4 questions (was Getting a new trigger wheel added)

Postby batgirl » Tue Jun 01, 2010 8:37 am

attached are normal
idle sensor disconected
and none in idle section



2010-06-01_17.21.27.msl
noidlesensor2010-06-01_17.23.47.msl
none2010-06-01_17.29.29.msl
batgirl
Helpful MS/Extra'er
 
Posts: 86
Joined: Fri Apr 23, 2010 2:45 pm

PreviousNext

Return to MS2/Extra Development

Who is online

Users browsing this forum: No registered users and 1 guest