[FW MOD] ms2extra 3.3.0b gslender v2.4.4

This is a forum for discussing the development and testing of alpha MS2/Extra code. Documentation
(Runs on MS2 and Microsquirt)

Moderators: jsmcortina, muythaibxr

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby BenGTT » Fri Mar 30, 2012 12:11 am

Hello Grant,

Flashed one of my other capricious car with your firmware and again, THANKS !!!

This car had always starting issue when it was hot under the bonnet.
It is using all the oem component and there is no problem for hot starting with original ecu.
I always had to idle at +-13AFR, 13.5 (normal opération) at the max to allow easy start and idle (15-15.5 AFR hot restart) after 15-20 minutes for the first 1 or 2 minutes.
I did put a fuel temp sensor and found that E85 was hot only for a few second only so I assume it is not the problem.
Air temps sensor is an open element in sort of plastic epoxy before throttle plate in the air flow.
ASE help a lot but sometimes when fast hot restart happen with same air temp, it gives fuel when not needed. It must be related to temp of the intake parts, manifold, cylinder head, injectors coils temp maybe ?
I don't know how the OEM are dealing with this, but they seems to have a sort of ASE too and maybe they are ignoring the air temp correction or disabling it during hot restart ?
Do you think it could help to have this option in the MS2 ? It happens at a temp of 50°C or more, but since the car is turbocharged with a small intercooler, I can't use MAT correction table to fix it or it will add fuel when boosting and temp is going 50/60°C at the max.
Anyway, the idle code works very well, because before with hot start, the idle was hunting so much in a loop, now it continues to run without diying. :) I even could have a normal operation at 14.5-14.6 AFR and hot restart @ 16.5-17AFR with only some minor difficulties.

Ben
BenGTT
Master MS/Extra'er
 
Posts: 387
Joined: Sun Nov 23, 2008 4:46 am
Location: France

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby Perkele » Fri Mar 30, 2012 1:12 am

gslender wrote:
Perkele wrote:Only one thing I don't seem to fully understand is the dashpot decay.
My dashpot adder is 4.3% and decay is 10 and I'm using the IVT table.
But it doesn't seem to work as planned as you can see in the picture, it does add the dashpot adder but it drops back to IVT value right after. And most of the time it doesn't add the adder att all.

Watch status4 as it will tell you when DP is being added (it should be 34 - which is PWMIDLE_RESET_JUSTLIFTED + PWMIDLE_RESET_DPADDED) and 16 when waiting for PID to take effect (PWMIDLE_RESET_CALCNEWTARG).
I've also seen that you have targ rpm clt curve that is 950rpm when 90deg and then 1200rpm when 100 deg ???? wtf !!
G

The idle target is that way because I wan't to keep my idle oil pressure high when the engine gets really hot. Normal temp operating temp is 80-90C and then the ilde oil pressure is 2+bar@950rpm but when the engine gets over 100C example at track the idle oil pressure drops down to 1-1.5bar so a bit higher rpm will keep the pressure up. Even with 10W-60 oil. So it's just a safety feature. :)
Last edited by Perkele on Fri Mar 30, 2012 1:20 am, edited 1 time in total.
Perkele
Helpful MS/Extra'er
 
Posts: 124
Joined: Tue Feb 17, 2009 11:15 am

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby gslender » Fri Mar 30, 2012 1:14 am

BenGTT wrote:Hello Grant,

Flashed one of my other capricious car with your firmware and again, THANKS !!!

This car had always starting issue when it was hot under the bonnet.
It is using all the oem component and there is no problem for hot starting with original ecu.
I always had to idle at +-13AFR, 13.5 (normal opération) at the max to allow easy start and idle (15-15.5 AFR hot restart) after 15-20 minutes for the first 1 or 2 minutes.
I did put a fuel temp sensor and found that E85 was hot only for a few second only so I assume it is not the problem.
Air temps sensor is an open element in sort of plastic epoxy before throttle plate in the air flow.
ASE help a lot but sometimes when fast hot restart happen with same air temp, it gives fuel when not needed. It must be related to temp of the intake parts, manifold, cylinder head, injectors coils temp maybe ?
I don't know how the OEM are dealing with this, but they seems to have a sort of ASE too and maybe they are ignoring the air temp correction or disabling it during hot restart ?
Do you think it could help to have this option in the MS2 ? It happens at a temp of 50°C or more, but since the car is turbocharged with a small intercooler, I can't use MAT correction table to fix it or it will add fuel when boosting and temp is going 50/60°C at the max.
Anyway, the idle code works very well, because before with hot start, the idle was hunting so much in a loop, now it continues to run without diying. :) I even could have a normal operation at 14.5-14.6 AFR and hot restart @ 16.5-17AFR with only some minor difficulties.

Ben


Send me a log of the problem and I will think it over... gslender at. Gmail. Dot. Commm

G
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby Greg G » Fri Mar 30, 2012 2:31 am

You mean something like "if MAT > x degrees F, taper in ASE over x cycles"? Or "if MAT >x degrees F, disable ASE"?
1996 Mazda MX-5 1.6L NA6/ Mazdaspeed M45 SC/ BSP AW Intercooler/ Maruha F-cams/ 425cc RX-8 injectors/ DIYPNP

MS2/Extra test mule :)
Greg G
Experienced MS/Extra'er
 
Posts: 311
Joined: Thu Mar 10, 2011 11:33 pm

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby gslender » Fri Mar 30, 2012 2:57 am

Perkele wrote:I wan't to keep my idle oil pressure high when the engine gets really hot. Normal temp operating temp is 80-90C and then the ilde oil pressure is 2+bar@950rpm but when the engine gets over 100C example at track the idle oil pressure drops down to 1-1.5bar so a bit higher rpm will keep the pressure up. Even with 10W-60 oil. So it's just a safety feature. :)


I didn't think you needed to worry about oil pressure when at idle - normally the issue for oil pressure is when under high boost/load (which tends to force oil out of the bearings and journals) - and is why oil under high pressure is needed at those times. But hey, if you want to have a higher idle when hotter - fine. :?
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby Perkele » Fri Mar 30, 2012 4:34 am

gslender wrote:Watch status4 as it will tell you when DP is being added (it should be 34 - which is PWMIDLE_RESET_JUSTLIFTED + PWMIDLE_RESET_DPADDED) and 16 when waiting for PID to take effect (PWMIDLE_RESET_CALCNEWTARG).
G

But back to my original question so when status4 goes to 34 I should see IVT value + adder decaying to IVT?
This picture is from the log I posted on my question and on the current position IVT is 27.7% and adder is 4.3% so should it jump to 32% when status4 goes 34?
Is some of my settings wrong or what is preventing the adder to be added? Or is my understading wrong? :mrgreen:

Thanks again.
Perkele
Helpful MS/Extra'er
 
Posts: 124
Joined: Tue Feb 17, 2009 11:15 am

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby Greg G » Fri Mar 30, 2012 5:50 am

Do you keep the idle valve open during acceleration?
1996 Mazda MX-5 1.6L NA6/ Mazdaspeed M45 SC/ BSP AW Intercooler/ Maruha F-cams/ 425cc RX-8 injectors/ DIYPNP

MS2/Extra test mule :)
Greg G
Experienced MS/Extra'er
 
Posts: 311
Joined: Thu Mar 10, 2011 11:33 pm

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby Perkele » Fri Mar 30, 2012 10:19 am

Greg G wrote:Do you keep the idle valve open during acceleration?

Yes I actually do. I have noticed that the transition from idle to drive and back goes smoother like this.
Perkele
Helpful MS/Extra'er
 
Posts: 124
Joined: Tue Feb 17, 2009 11:15 am

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby piledriver » Mon Apr 02, 2012 6:35 am

I replumbed my MAP sampling setup, added a filter in meatspace in the form of a ~1L "catch can" that runs off the plenum and acts as a condensate trap for my PCV system, ~14"x3/8" line connecting.
(preexisting setup, just was sampling direct to plenum, just rearranged a bit)

Was able to turn the MAP lags back to 100 and the squarewave weird accel/dcel triggering is gone, was also able to turn my thresholds back down on MAP accels from 400 to ~150 ish where they work again.
Always doing things the hard way, MS2 sequential w/ v1.01 mainboard, LS2 coils. 80 mile/day commuter status.
piledriver
Super MS/Extra'er
 
Posts: 1122
Joined: Tue Oct 27, 2009 6:24 am
Location: Van Alstyne, Texas

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby nismoautoxr » Fri Apr 06, 2012 7:56 pm

Im trying to download the mod but there doesnt seem to be any firmware in the link that says firmware...am I doing it wrong
Ricky-
1995 Nissan 240sx, LS1 v8 N/A 6speed trans
MS3&MS3X v.3.0 PCB
30lb/hr Hi-Z inj.,230/232 @.050 on 114LSA cam
sequential fuel and sequential spark
LS3/LSA card MAF sensor
nismoautoxr
Super MS/Extra'er
 
Posts: 2366
Joined: Sun May 29, 2011 10:28 am
Location: birmingham ,Alabama. U.S.A.

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby Greg G » Fri Apr 06, 2012 7:59 pm

nismoautoxr wrote:Im trying to download the mod but there doesnt seem to be any firmware in the link that says firmware...am I doing it wrong


Yes. I just downloaded it again to confirm.
1996 Mazda MX-5 1.6L NA6/ Mazdaspeed M45 SC/ BSP AW Intercooler/ Maruha F-cams/ 425cc RX-8 injectors/ DIYPNP

MS2/Extra test mule :)
Greg G
Experienced MS/Extra'er
 
Posts: 311
Joined: Thu Mar 10, 2011 11:33 pm

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby gslender » Fri Apr 06, 2012 8:00 pm

nismoautoxr wrote:Im trying to download the mod but there doesnt seem to be any firmware in the link that says firmware...am I doing it wrong


Probably. There is a zip file called "ms2extra_alpha_330b_gslender_v2.4.4.zip" that contains s19 files for Megasquirt2 and Microsquirt2.

Download the PDF (gslender.mod.application_notes.pdf) and read them, it explains what to do to install the firmware.

G
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby nismoautoxr » Fri Apr 06, 2012 8:30 pm

pardon my PC incompetence LOL. So if I understand correctly ...I just go to my 3.3.0b folder and delete the 2 S19 files and paste the one from this thread into that folder ....?
Ricky-
1995 Nissan 240sx, LS1 v8 N/A 6speed trans
MS3&MS3X v.3.0 PCB
30lb/hr Hi-Z inj.,230/232 @.050 on 114LSA cam
sequential fuel and sequential spark
LS3/LSA card MAF sensor
nismoautoxr
Super MS/Extra'er
 
Posts: 2366
Joined: Sun May 29, 2011 10:28 am
Location: birmingham ,Alabama. U.S.A.

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby gslender » Fri Apr 06, 2012 8:35 pm

nismoautoxr wrote:pardon my PC incompetence LOL. So if I understand correctly ...I just go to my 3.3.0b folder and delete the 2 S19 files and paste the one from this thread into that folder ....?


correct, but just copy over the top, dont need to delete first
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby nismoautoxr » Fri Apr 06, 2012 8:49 pm

thanks G
Ricky-
1995 Nissan 240sx, LS1 v8 N/A 6speed trans
MS3&MS3X v.3.0 PCB
30lb/hr Hi-Z inj.,230/232 @.050 on 114LSA cam
sequential fuel and sequential spark
LS3/LSA card MAF sensor
nismoautoxr
Super MS/Extra'er
 
Posts: 2366
Joined: Sun May 29, 2011 10:28 am
Location: birmingham ,Alabama. U.S.A.

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby nismoautoxr » Sat Apr 07, 2012 8:33 pm

Now that firmware is absolutely impressive . It is absolutely fantastic !!!!. :yeah!: Im running with no lags whatsoever with 100% TPS dot AE / threshold of 5!!!!! with no ...absolutely no false AE triggers and the idle control is very near perfect with no tweaks to any of the settings as is .im attaching my MSQ for you to look over GSLENDER. That is stellar work guys .

Had a spot of trouble at first with the idle speed.It was caused by a mod I used to use for table switching on PE0(hardware switch ) . I originally used it for table switching and totally forgot it was still there untill I turned the feature on and PID was disabled since the toggle was still switched to ground LOL.
Ricky-
1995 Nissan 240sx, LS1 v8 N/A 6speed trans
MS3&MS3X v.3.0 PCB
30lb/hr Hi-Z inj.,230/232 @.050 on 114LSA cam
sequential fuel and sequential spark
LS3/LSA card MAF sensor
nismoautoxr
Super MS/Extra'er
 
Posts: 2366
Joined: Sun May 29, 2011 10:28 am
Location: birmingham ,Alabama. U.S.A.

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby gslender » Sat Apr 07, 2012 9:25 pm

nismoautoxr wrote:Now that firmware is absolutely impressive . It is absolutely fantastic !!!!. :yeah!: Im running with no lags whatsoever with 100% TPS dot AE / threshold of 5!!!!! with no ...absolutely no false AE triggers and the idle control is very near perfect with no tweaks to any of the settings as is .im attaching my MSQ for you to look over GSLENDER. That is stellar work guys .

Had a spot of trouble at first with the idle speed.It was caused by a mod I used to use for table switching on PE0(hardware switch ) . I originally used it for table switching and totally forgot it was still there untill I turned the feature on and PID was disabled since the toggle was still switched to ground LOL.


Glad you like!

I'd suggest you check the Idle Adaptive Voltage Compensation - the values are relative to the battery baseline (which floats but hovers around the avg values). Voltage values should be -2,-1.5,-1,0,0,0

Also, I see you've set IVT for CLT - I tend to think it makes more sense for it to be MAT based as this is the thing that changes from cold to warm... and unless you believe the idle valve duty remains the same for all those CLT temps, then you'll need to change them.

You don't have Adaptive Idle Advance enabled - that truly delivers rock stable idle... and helps recover too. So play with that and read up in the various past docs I've released in the earlier builds.

G
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby nismoautoxr » Sat Apr 07, 2012 10:24 pm

G, I guess I dont have my head wrapped around the calculation formulas for IAVC. Why are the numbers in the negative? i see the affect but the numbers you ahve posted dont seem to get the job done for my car when the high blower and the AC fan comes on The idle starts out at around 900 then as I increase the fan speed the idle speed drops and it doesnt recover enough to reach the target idle speed. Should I increase the numbers in the negative or the positive ?

Also the load advance KPA is very sensitive as it tries to adapt then the KPA teeters above and below the KPA limit and causes the timing load advance to activate and deactivate. Its definitely goingt otake me some tinkering but there are definitely alot more tools in the box for it now !
Ricky-
1995 Nissan 240sx, LS1 v8 N/A 6speed trans
MS3&MS3X v.3.0 PCB
30lb/hr Hi-Z inj.,230/232 @.050 on 114LSA cam
sequential fuel and sequential spark
LS3/LSA card MAF sensor
nismoautoxr
Super MS/Extra'er
 
Posts: 2366
Joined: Sun May 29, 2011 10:28 am
Location: birmingham ,Alabama. U.S.A.

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby nismoautoxr » Sun Apr 08, 2012 4:33 pm

Ignore my last post . It was late and I had several celebratory beers when I posted that . I see what you were saying G on hte IAVC and have it set up now ...a little differant than the example and its working even better . I ditched the load advance and wnet adaptive and that works much better for my setup with the AC on . Again very impressive improvements on the TPS dot smoothing as well as the idle controls .Im down to 2.5 TPS dot threshold on AE.

I guess its about time that I tackle learning my way around EAE next LOL. Im sure that is going ot be a treat but now with the absolutely noise free TPS dot that will be much easier than my first attempt.
Ricky-
1995 Nissan 240sx, LS1 v8 N/A 6speed trans
MS3&MS3X v.3.0 PCB
30lb/hr Hi-Z inj.,230/232 @.050 on 114LSA cam
sequential fuel and sequential spark
LS3/LSA card MAF sensor
nismoautoxr
Super MS/Extra'er
 
Posts: 2366
Joined: Sun May 29, 2011 10:28 am
Location: birmingham ,Alabama. U.S.A.

Re: [FW MOD] ms2extra 3.3.0b gslender v2.4.4

Postby weeblebiker » Mon Apr 09, 2012 3:37 pm

getting ready to load this to address rpm and tps/map dot noise.

might even re-try the bosch isv idle stabilizer I wired in and dumped because the pid never held better stability than the bleeder bypass screws and adjustable throttle stop knob on my turbo itbs project.

Any thought of applying the idle pid control changes to the boost control?
v2.2 box, ms2, duel wheel, sequential ignition, staged injection, boost control, maf
'87 VW scirocco, 2L 16V, TD0-14T, itbs E85
weeblebiker
Experienced MS/Extra'er
 
Posts: 334
Joined: Sun May 11, 2008 4:03 pm

PreviousNext

Return to MS2/Extra Development

Who is online

Users browsing this forum: No registered users and 2 guests