Greetings from new user 3SGTE gen 3

A general forum and a place for initial or prospective users. See Manuals/Documentation
Click here to enter
Contact a Forum Administrator
If unsure where to post, post in this sub-forum.

Moderators: jsmcortina, muythaibxr

Greetings from new user 3SGTE gen 3

Postby zvargulis » Sat Sep 03, 2016 5:48 am

Hey guys i have been researching megasquirt for many years and have just finished building my DIY MS3.

It will be for running my GEN3 3SGTE MR2 1994 SW20.
So far the car is stock with just full berk system and ebay intercooler.
I have a wide band on it at the moment and can see that the factory rich conditions hit afr's of as low as 9:1 under WOT at around 16psi boost. So it will be good to gain access to fueling soon and pull that closer to some more ideal numbers.

So yeah wouldnt mind your input on some of my wiring setup, im a bit worried about loosing some factory features such as electric power steering and AC control. Should I be planning to still run parts of my old ECU in parallel with megasquirt.

Below is a link to my ECU pinout and below is what i am thinking.
Unsure about which 1 of the multiple out puts from my dizy.
and which one is my ignitier out.... see below:

http://www.mr2australia.com/uploaded/ar ... inouts.jpg

Megaquirt D37 -> to -> Stock ECU HARNESS
FP1 37 FPR Bank two BL
IGN 36 IGT/IGF?? Bank one
INJ2 35 #10-#40 Bank one
INJ2 34 #10-#40 Bank one
INJ1 33 #10-#40 Bank one
INJ1 32 #10-#40 Bank one
IAC2B 31
IDL 30 RSO/RSC Bank one
IAC2A 29
12 RAW 28 EFI MAIN Bank three
IAC1B 27
Vref (+5V) 26 VTA/VTA2? Bank two
IAC1A 25
Tach in 24 NE? Bank one
O2 23 Wbo2 FROM WIDE
TPS 22 VTA/VTA2? Bank two
CLT 21 THW Bank two
MAT 20 THA Bank two
GND 19 E01 & E02 Bank one
GND 18 E01 & E02 Bank one
GND 17 E01 & E02 Bank one
GND 16 E01 & E02 Bank one
GND 15 E01 & E02 Bank one
GND 14 E01 & E02 Bank one
GND 13 E01 & E02 Bank one
GND 12 E01 & E02 Bank one
GND 11 E01 & E02 Bank one
GND 10 E01 & E02 Bank one
GND 9 E01 & E02 Bank one
GND 8 E01 & E02 Bank one
GND 7 E01 & E02 Bank one
SPR4 6 FLEX SENSE
SPR3 5 FUEL SENSE
SPR2 4
SPR1 3
GND 2 E01 & E02 Bank one
GND 1 E01 & E02 Bank one

What should i plan to do with that third bank that has lots of accessories?

Thanks for the help!
-------------------------------------------------------------
MR2 3SGTE Gen 3
MS3X DIY, DIY BOB
zvargulis
MS/Extra Newbie
 
Posts: 11
Joined: Sun Jul 08, 2012 7:05 am

Re: Greetings from new user 3SGTE gen 3

Postby benckj » Sat Sep 03, 2016 7:15 pm

Glad to see you making some progress toward the 3sgte build. When I tested stock ECU AFR's I dropped below 8 even when I had boost turned up to 17psi. Without the MS I couldn't get the rich mixtures into check.

Not sure why you will sacrifice AC and PS control using MS3. The MS2 platform supports those functions and I have had no issues with running them. Never really got AC idle up to work but now that my tune is better the engine doesn't miss a beat when AC is turned on.

Jim
MSPNP v2 with 3.57 firmware
FTDI USB interface on SD Android 5.1 head unit
Toyota MR2 98 3sgte
TD05sl2-18g (billet wheel & high flow turbine)
A2W IC
WI with 50/50 meth/water
User avatar
benckj
Master MS/Extra'er
 
Posts: 389
Joined: Mon Dec 19, 2011 3:21 pm

Re: Greetings from new user 3SGTE gen 3

Postby benckj » Tue Sep 06, 2016 2:19 pm

I see your panning to run a flex fuel sensor. Do you have E85 in OZ or are you blending your own fuel?

As a matter of interest I bought several cheap drums of methanol and use 10% in all my cars. Its a very good addative to increase octane and keep systems clean. I also use WI to spray a 50/50 mix of methanol and water when into high boost (ie >14psi). This compounded my problem with stock ECU overfueling but did it to ensure reliable operation during high boost. Lost our locally available 98 fuel after the earthquake hit Christchurch several years ago.

Jim
MSPNP v2 with 3.57 firmware
FTDI USB interface on SD Android 5.1 head unit
Toyota MR2 98 3sgte
TD05sl2-18g (billet wheel & high flow turbine)
A2W IC
WI with 50/50 meth/water
User avatar
benckj
Master MS/Extra'er
 
Posts: 389
Joined: Mon Dec 19, 2011 3:21 pm

Re: Greetings from new user 3SGTE gen 3

Postby zvargulis » Mon Jan 08, 2018 3:30 am

So about 1 year later and finally had a bit of free time to spend on the ECU project. this is a little update

Attached is my wiring diagram, i decided mid year to get the MSeextra and have made a loom using a DIY BOB.

I fitted the ecu to the car today for the first time and this is where i have gotten to;

I can see my sensors are working well, calibrated TPS and can see that coolant and manifold temp is displaying something close to what it should be.

I have used a base map msq from benjk (cheers jim :D ) which i believe is a MSPNP tune with his edits.

I am now stuck at the step of trying to see my RPM sync, I tried to take multiple tooth logs but they came out all empty and I don't see any data on the screen in realtime.
I haven't fiddled with the potentiometers yet but assumed that I should see/log something even if it is garbage. I had a nippondenso CAS distributor.

I guess i need to do more reading, my plan for tomorrow is to:
check that i soldered the correct jumper wires to suit the distributor signal output
set the pots to something similar to another 3sgte setting
add tempory grounds to see if this helps
workout why my log did not record anything at all.
Attachments
megasquirt wiring 8 jan 2018.pdf
(346.11 KiB) Downloaded 10 times
2018-01-08_20.34.22.csv
(92 Bytes) Downloaded 4 times
2018-01-08_21.21.08.msq
tune
(285.04 KiB) Downloaded 14 times
-------------------------------------------------------------
MR2 3SGTE Gen 3
MS3X DIY, DIY BOB
zvargulis
MS/Extra Newbie
 
Posts: 11
Joined: Sun Jul 08, 2012 7:05 am

Re: Greetings from new user 3SGTE gen 3

Postby zvargulis » Mon Jan 08, 2018 3:39 am

looking further at my wiring diagram, i notice i have left G- (4H) completely not connected...... that is likely the issue.
-------------------------------------------------------------
MR2 3SGTE Gen 3
MS3X DIY, DIY BOB
zvargulis
MS/Extra Newbie
 
Posts: 11
Joined: Sun Jul 08, 2012 7:05 am

Re: Greetings from new user 3SGTE gen 3

Postby zvargulis » Tue Jan 09, 2018 5:00 pm

Still no luck with getting any sync at all.

I have Ne signal going to the pin 24 on the main board

G1 going to cam input pine 32 on extra board.

G- tied to pin 2 gnd of main board.

I have no extra resistors which might be the next thing I try and have adjusted pots as suggest per manual.( Settings on msq above)

I tried cranking for 20-30 seconds and still see nothing on the composit logger (logs and msq as posted above.)

I have spent two days of leave trying to get somewhere, I plug the factory ecu in and it fires up no problems.

I am registering TPS, CLT and MAT sensor values fine so I think I can trust my wiring.

Attached are the options I selected in the back of the main board.

Any help would be appreciated.

Next thing I will try is mimicking redpheonix set which would be 10k inline with both signals and to use G2 instead of G1.Image

Sent from my Nexus 6P using Tapatalk
-------------------------------------------------------------
MR2 3SGTE Gen 3
MS3X DIY, DIY BOB
zvargulis
MS/Extra Newbie
 
Posts: 11
Joined: Sun Jul 08, 2012 7:05 am

Re: Greetings from new user 3SGTE gen 3

Postby benckj » Tue Jan 09, 2018 6:15 pm

Glad to see your making some progress on this build. Wish I could help with your questions but I'm afraid its beyond my current experience. As mine was a PNP model it was a very simple and straight forward exercise.

If I was building my own EMS I'd probably use a JimSim module from MS to test the unit without risking engine components. Really want to have as many problems nutted out before connection to engine loom. Other may comment on how useful this device is.

https://www.diyautotune.com/product/jim ... assembled/

or

https://www.diyautotune.com/product/meg ... bled-unit/
MSPNP v2 with 3.57 firmware
FTDI USB interface on SD Android 5.1 head unit
Toyota MR2 98 3sgte
TD05sl2-18g (billet wheel & high flow turbine)
A2W IC
WI with 50/50 meth/water
User avatar
benckj
Master MS/Extra'er
 
Posts: 389
Joined: Mon Dec 19, 2011 3:21 pm

Re: Greetings from new user 3SGTE gen 3

Postby Matt Cramer » Wed Jan 10, 2018 6:31 am

How exactly is the MS2 modified for the second VR sensor input? I see nothing wired to JS10, the normal pin for cam trigger input.
Matt Cramer
Super MS/Extra'er
 
Posts: 13769
Joined: Thu Apr 16, 2009 8:08 pm

Re: Greetings from new user 3SGTE gen 3

Postby zvargulis » Wed Jan 10, 2018 3:58 pm

Matt Cramer wrote:How exactly is the MS2 modified for the second VR sensor input? I see nothing wired to JS10, the normal pin for cam trigger input.
I have made no modifications at all, I have MS3X could it be an issue that I am using a mspnp tune? I have the following setup:


Ne signal going to the pin 24 on the main board

G1 going to cam input pin 32 on extra board.

G- tied to pin 2 gnd of main board.

JS10 is pin36 of the main board d-type? I thought that is designated as a ignitor out?

Thanks for your reply.

Sent from my Nexus 6P using Tapatalk
-------------------------------------------------------------
MR2 3SGTE Gen 3
MS3X DIY, DIY BOB
zvargulis
MS/Extra Newbie
 
Posts: 11
Joined: Sun Jul 08, 2012 7:05 am

Re: Greetings from new user 3SGTE gen 3

Postby zvargulis » Thu Jan 11, 2018 4:31 am

benckj wrote:Glad to see your making some progress on this build. Wish I could help with your questions but I'm afraid its beyond my current experience. As mine was a PNP model it was a very simple and straight forward exercise.

If I was building my own EMS I'd probably use a JimSim module from MS to test the unit without risking engine components. Really want to have as many problems nutted out before connection to engine loom. Other may comment on how useful this device is.

https://www.diyautotune.com/product/jim ... assembled/

or

https://www.diyautotune.com/product/meg ... bled-unit/
Thanks Jim, really determined to get this running before uni goes back and I loose my free time.

I'm keeping good documentation so hopefully you might decide to to go MS3X for the extra features

Sent from my Nexus 6P using Tapatalk
-------------------------------------------------------------
MR2 3SGTE Gen 3
MS3X DIY, DIY BOB
zvargulis
MS/Extra Newbie
 
Posts: 11
Joined: Sun Jul 08, 2012 7:05 am

Re: Greetings from new user 3SGTE gen 3

Postby Matt Cramer » Thu Jan 11, 2018 8:25 am

Sorry, missed that it was an MS3X. The G sensor would need to go to the MS3X cam input.
Matt Cramer
Super MS/Extra'er
 
Posts: 13769
Joined: Thu Apr 16, 2009 8:08 pm

Re: Greetings from new user 3SGTE gen 3

Postby zvargulis » Thu Jan 11, 2018 3:54 pm

Matt Cramer wrote:Sorry, missed that it was an MS3X. The G sensor would need to go to the MS3X cam input.
Which it is, noticed there is a typo in my wiring pdf.

This weekend I am going to try to use G2 instead of G1 to the extra cam input, and add 10k ohm resistors in series with Ne and G2.

I also have a USB oscilloscope now so will try and have a look at what the ECU is recieveing.

I also have found a tune from forum member redpheonix who has the exact same setup as me and noticing ignition settings are a bit different to what I currently have.

Just a question when trying to view a signal in the composite logger, does the tooth settings in the ignition setup effect what is being displayed on the logger, is there any signal processing that will filter and only search for my 24/1? I noticed that there was an option from the drop down for crank log and crank & cam log for tooth settings? I'm just wondering for the sake of trouble shooting would I be better selecting crank and cam log for a confidence check?

Sent from my Nexus 6P using Tapatalk
-------------------------------------------------------------
MR2 3SGTE Gen 3
MS3X DIY, DIY BOB
zvargulis
MS/Extra Newbie
 
Posts: 11
Joined: Sun Jul 08, 2012 7:05 am

Re: Greetings from new user 3SGTE gen 3

Postby zvargulis » Sat Jan 13, 2018 7:04 pm

Hey all

Made some progress today, I made two-three changes at once so i cannot exactly say what helped bring sync in Matt will probably pinpoint it exactly with his experience.

One change I made was moved the G- of the dizzy VR sense from pin 2 GND to the pin7 sense ground, I have trouble believing this did it as looking at the schematic this is pin7 is tied in with the common ground (unless trace rounting of the PCB has pin 7 routed closer to the VR conditioning circuit grounds?? again probably not going to make a huge difference)

Change two, twiddled all the pots again as per the manual, measured the test points saw 0.4V on the 'top'of R54 and 0.56 on the ZC test point of the extra board.

Change three, to be able to easily get my oscilliscope probes through out the VR circuits I soldered about 5 short wires through from the start to end of the VR circuit. ($10 i loose sync once I go through and remove these wires :lol: )


Next steps now are to:
Study the logs to see if the timing information is usable
Add the proper cal information for the MR2 CLT, MAP and MAT sensors
Get the timing light out to check the timing
Attachments
some progress 8 10k res red pheonix sens gnd.msl
latest log
(370.88 KiB) Downloaded 3 times
progress 10k sens gnd.csv
(10.85 KiB) Downloaded 3 times
megasquirt wiring 14 jan.pdf
wiring
(346.26 KiB) Downloaded 5 times
-------------------------------------------------------------
MR2 3SGTE Gen 3
MS3X DIY, DIY BOB
zvargulis
MS/Extra Newbie
 
Posts: 11
Joined: Sun Jul 08, 2012 7:05 am

Re: Greetings from new user 3SGTE gen 3

Postby zvargulis » Sat Jan 13, 2018 7:08 pm

This is the tune, and a snip it of the tooth log before the battery crapped it
Attachments
progress 14 jan.msq
(285.67 KiB) Downloaded 12 times
2018-01-14_12.25.58.csv
tooth log
(36.64 KiB) Downloaded 3 times
-------------------------------------------------------------
MR2 3SGTE Gen 3
MS3X DIY, DIY BOB
zvargulis
MS/Extra Newbie
 
Posts: 11
Joined: Sun Jul 08, 2012 7:05 am


Return to General, New users, Purchasing

Who is online

Users browsing this forum: No registered users and 1 guest