New serial protocol / MS3 pre1.1 alpha codes 12+

Testing and development of Megasquirt 3

Moderators: muythaibxr, jsmcortina

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby jsmcortina » Thu Aug 25, 2011 9:37 am

AbatelliCristian wrote:My tps calibration is ok. But if tps is reverse, TS going off? with previus firmware it wasn't a problem

What do you mean by "TS going off" ?

I found this was a firmware bug (compiler issue) and it is removed for the next release.

I've been a bit busy recently, so the next alpha isn't ready yet.

James
I can supply, repair or upgrade Megasquirts in UK.

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 27116
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby AbatelliCristian » Thu Aug 25, 2011 11:21 pm

Perfect, very thanks.
You check for chanell 4 vvt?
when is ready I test it.

The tps is not problem, is all ok.
AbatelliCristian
Master MS/Extra'er
 
Posts: 420
Joined: Sun Oct 10, 2010 6:33 am

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby jsmcortina » Fri Aug 26, 2011 2:08 am

No VVT changes have been made - I thought you said this was working ok now ?

James
I can supply, repair or upgrade Megasquirts in UK.

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 27116
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby AbatelliCristian » Fri Aug 26, 2011 3:05 am

In bmw s65 engine I load only alpha10a because all alpha11-12-13.. channel4 vvt not read. Now I test alpha 13 in other engine for test new serial protocol.
If you see the topic "vvt test and idea" I have writed the ideas for optimize vvt system.
AbatelliCristian
Master MS/Extra'er
 
Posts: 420
Joined: Sun Oct 10, 2010 6:33 am

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby msoultan » Mon Aug 29, 2011 6:19 pm

I just loaded up alpha 13 after testing 11 and it seems to run fine. The only issue is that it is running really rich at idle - I don't know if that's a heat-soak issue or something similar as I did the upgrade after running on alpha 11 for about 15 minutes. Other than that, my cruise AFRs seemed to be pretty spot-on, and I'm using "include AFR".

Should jumping from 11 to 13 require a retune for any portions of the VE table?
User avatar
msoultan
Super MS/Extra'er
 
Posts: 1021
Joined: Sun Jun 27, 2004 12:04 pm
Location: Long Beach, CA - USA

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby msoultan » Mon Aug 29, 2011 9:21 pm

Ok, 13 is definitely running much richer than alpha 11. I have to use flood clear for it to start and it's backfiring from being too rich. I tried loading 11 and the loader isn't able to work (prolly due to the new communication protocol). I'm gonna try with the jumper and see if it's able to load 11 back on that way. I'll keep ya posted....
User avatar
msoultan
Super MS/Extra'er
 
Posts: 1021
Joined: Sun Jun 27, 2004 12:04 pm
Location: Long Beach, CA - USA

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby msoultan » Mon Aug 29, 2011 10:45 pm

Ok.. turns out it was my EGR valve that was slightly open - everything looked normal except the AFR and idle just wasn't right. After tapping on it a few times to get it closed, the engine is purring along nicely. I did have to lean out my idle and also tweak the cranking PWs a bit, but other than that it seems to be running nicely.

thanks,
Mike
User avatar
msoultan
Super MS/Extra'er
 
Posts: 1021
Joined: Sun Jun 27, 2004 12:04 pm
Location: Long Beach, CA - USA

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby dvanderk » Sat Sep 10, 2011 6:26 am

Any new updates on the next MS3 code? :D Cant wait for the next release!
dvanderk
Experienced MS/Extra'er
 
Posts: 158
Joined: Thu Oct 07, 2010 7:23 pm

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby jsmcortina » Sun Sep 11, 2011 10:20 am

We've been busy on non-Megasquirt things of late so there's been a pause. I've driven a number of hundred miles on the current code snapshot, but there are some things I want to tidy up before we are ready for alpha 14.

James
I can supply, repair or upgrade Megasquirts in UK.

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 27116
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby jsmcortina » Mon Sep 12, 2011 8:02 am

Alpha 14 released

Main changes since alpha 13
Remove 'txbuf' and replace with smaller buffer.
Implement CAN_FWD with newserial
Serial tweaks to allow reading/writing datax1 (read the clock)
SDcard, different VBR detection code
Zetec VCT wheel mode
Support for SDcard serial with newserial
Megaview working
Allow generic sensors to share ADCs
Remove adc6/7 from outpc
Add fuel flow and consumption (need to test all staging etc. combinations.)
Optispark mostly working on physical test
Knock analogue input still works if knock window output unused.
Audi type flywheel decoder.
Added 2JZ VVTi decoder
Comp logger works (somewhat) with XGATE wheel modes
Option to set tertiary tach input
Allow flipping polarity on hi-res tach input.
Config error for backwards TPS calibration.
Remove defective TPS calc code.
Default hardware now MS3X spark,fuel,cam
Overboost switching works as expect
Serial timeout tweak.
RX8 36-2-2-2 switch front/rear rotors (were transposed.)
Internal realtime clock uses different chip
Increase ALS timing table to allow +ve.
Serial write now copied in long,words,chars in ASM to improve speed and coherency.
Added gauges to testmode dialogue.
Added 2JZ VVTi wheel mode test/fix
Fix y8s' SDcard.
(EDIT: )Fix AE taper
Added Honda TSX/D17 (24+1 crank, 4+1 cam) decoder
Report SD error 30 correctly.
Automatic noise filter added on hi-res input for opti/CAS/flywheel.
Change ini limits to 10-100 for lag factors.
CAN passthrough work (more to do)

Known issues
CAN passthrough still incomplete. You might have success using 8 byte packets, but trying to read or write large chunks of data in one go does not work correctly yet.

The alpha can be downloaded from: http://www.msextra.com/doc/ms3/files/alpha/
As per the included README files, an up to date TunerStudio is REQUIRED.

James
I can supply, repair or upgrade Megasquirts in UK.

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 27116
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby prof315 » Fri Sep 16, 2011 9:46 am

Up and running on alpha 14 as of this morning. So far so good and it'll get a real test tomorrow as I have to drive across the state to fix/tune somebody's Miata PnP. 8)

I will say that I noticed the update took very little time, maybe 1/2 what it normally takes.
Linfert Performance: The Megasquirt guy in Central Florida
92 Corrado 2.0L ABA and Borg Warner EFR 6258 on MS3Pro.
Support the developers!
prof315
Super MS/Extra'er
 
Posts: 1836
Joined: Sun Jan 18, 2009 3:13 am
Location: Melbourne, FL

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby msoultan » Fri Sep 16, 2011 9:54 am

I loaded it yesterday and the car started - haven't had a chance to drive it around yet...
User avatar
msoultan
Super MS/Extra'er
 
Posts: 1021
Joined: Sun Jun 27, 2004 12:04 pm
Location: Long Beach, CA - USA

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby prof315 » Sat Sep 17, 2011 3:20 pm

Things were perfect the whole trip running alpha 14. I still need to get my water injection totally dialed in but no issues with the firmaware at all. AND I left the Tampa area with another happy owner of a megasquirted car. :)
Linfert Performance: The Megasquirt guy in Central Florida
92 Corrado 2.0L ABA and Borg Warner EFR 6258 on MS3Pro.
Support the developers!
prof315
Super MS/Extra'er
 
Posts: 1836
Joined: Sun Jan 18, 2009 3:13 am
Location: Melbourne, FL

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby opel » Sun Sep 18, 2011 1:44 pm

Did you get a chance to stick in the flexfuel input frequency on one of the generic outputs?
opel
Helpful MS/Extra'er
 
Posts: 88
Joined: Wed Jun 18, 2008 10:33 pm

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby 93white3400z » Sat Sep 24, 2011 8:25 pm

James,

I know you said you need to test all combinations for fuel consumption but if you want to see one that doesn't work, I've attached my MSQ for you to try. Gauge either stay at 0 or at a crazy high number.

Thanks!
MSDroid (Android App) for MegaSquirt available for free!
Image

Like MSDroid on Facebook
-----------------------------------------
1993 Chevrolet Cavalier Z24
3400 Turbocharged Intercooled
MS3 v3.57+MS3X
93white3400z
Master MS/Extra'er
 
Posts: 651
Joined: Mon Aug 25, 2008 11:37 pm
Location: Montreal, Quebec

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby xrattiracer » Sun Oct 02, 2011 2:54 pm

attempted to do an update from a11 to a14 today, but it seemed to get stuck on serial protocol stuff. i seem to remember a12 was where that changed, so i did a12 as an interim step and then a14 loaded fine.
no problems, just an fyi.
xrattiracer
Experienced MS/Extra'er
 
Posts: 195
Joined: Fri Aug 01, 2008 2:25 pm

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby charged3800z24 » Mon Oct 03, 2011 6:07 pm

Not sure if it matters, but on A14, my project finally starts fine. I always had issues with cold starts regaurdless of temp range. I tried everything I could think of. After using A14, it has been spot on. Have no idea why. Looking forward to final!

Specs
Previous code 1.0.2
3800 Series II v6 Supercharged
Buick C3I ignition
Stock 36.4lb/hr injectors (6) -non sequential
Stock GM sensors

Thanks

Jason
charged3800z24
Experienced MS/Extra'er
 
Posts: 207
Joined: Thu Nov 15, 2007 8:53 pm

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby kizzoalfa » Wed Oct 05, 2011 1:18 pm

I changed to Alpha 14 today. I have an own designed display (like Megaviewer) what I used in the past to display certain parameters in case I do not have my laptop with me.

I realized that in Burst mode in the new serial format there are 376 bytes transfered instead of 296.

I changed my code accordingly.

My problem is that looks like the burst mode not working by the way that I send the 0x65 (A letter) to the controller since it is returning nothing. It was working before the serial protocol change.

here si what I get back for the 0x41:

sent: 0x41
Received: 0001803FBA6CAD

Can any of you help me what is the right format I need to use for the new serial protocol to get the 376 bytes out of the MS3?

Thank you.

Zoltan
---------------------------------------------------------------
Alfa Romeo 75 2.0, Supercharged by Eaton M45, MS3
kizzoalfa
Experienced MS/Extra'er
 
Posts: 169
Joined: Fri Apr 15, 2011 11:02 am
Location: Szombathely, HUNGARY

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby jsmcortina » Wed Oct 05, 2011 1:39 pm

kizzoalfa wrote:sent: 0x41
Received: 0001803FBA6CAD

That's unrecognised command.

The new serial system maintains Megaview compatability so you may use "a 00 06" for the Megaview styled data. For full new serial support, I'll upload the specification document in a bit.

James
I can supply, repair or upgrade Megasquirts in UK.

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 27116
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: New serial protocol / MS3 pre1.1 alpha codes 12+

Postby kizzoalfa » Thu Oct 06, 2011 9:44 am

Than as I understand the Single letter command A is not supported. Do you have any plan that it will work in the future?

My system was designed to get data from the real time variables what MS3 send by answering the "A".

Zoltan
---------------------------------------------------------------
Alfa Romeo 75 2.0, Supercharged by Eaton M45, MS3
kizzoalfa
Experienced MS/Extra'er
 
Posts: 169
Joined: Fri Apr 15, 2011 11:02 am
Location: Szombathely, HUNGARY

PreviousNext

Return to MS3 Development

Who is online

Users browsing this forum: No registered users and 1 guest