ms2 sequential questions

All questions about MS2/Microsquirt/Microsquirt module. See also MS2/Extra manuals

Moderators: jsmcortina, muythaibxr

ms2 sequential questions

Postby ChevytoyR1 » Mon Jan 02, 2012 1:23 am

im assembling an ms2 for 4cyl full sequential for a nissan sr20det and diyautotune dist wheel. i was wondering if i can use the vr circuit for the primary signal and the hall circuit for the 2nd signal? if so how do i wire the 2nd signal on the board?
im trying it on the stim with 5v on top of c30, 2nd triger in on xg1, and optoout to js10.. it doesnt work with the stim but if i tuch the optoin side jumper with my finger it works for a sec and turns off.. any idea on what im doing wrong?

edit: i think my problem is that im not getting a signal on the 2nd triger output of the stim. stim set up for 36-1 the 2nd trigger volts stays at steady 4.98v.. any way how to fix this?
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby Matt Cramer » Mon Jan 02, 2012 7:33 am

Sure, this will work; you just jumper OptoOut to JS10. What pin are you using for the second trigger input on the DB37?
Matt Cramer
Super MS/Extra'er
 
Posts: 8980
Joined: Thu Apr 16, 2009 8:08 pm

Re: ms2 sequential questions

Postby ChevytoyR1 » Mon Jan 02, 2012 10:06 am

im using IAC2B
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby Matt Cramer » Mon Jan 02, 2012 10:45 am

How is this set up on your JimStim?
Matt Cramer
Super MS/Extra'er
 
Posts: 8980
Joined: Thu Apr 16, 2009 8:08 pm

Re: ms2 sequential questions

Postby ChevytoyR1 » Mon Jan 02, 2012 11:17 am

Stim is set up for 36-1.. when i set it up for 36-1 cam wheel.. i get sequential no problem .. but when i set it to dual wheels with missing tooth and 2nd trigger pin jumped to iac2b pin i get no rpm and d14 led blinks as it was single coil rpm but shows no rpm in ts.
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby racingmini_mtl » Mon Jan 02, 2012 11:28 am

That means your second trigger does not work. With a single wheel setup, the sequential setting means semi-sequential and it doesn't use the second trigger. With the dual wheel setup, you need both triggers to get sync and RPM.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 6465
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: ms2 sequential questions

Postby ChevytoyR1 » Mon Jan 02, 2012 3:42 pm

So is my stim 2nd trigger broken?
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby racingmini_mtl » Mon Jan 02, 2012 5:15 pm

Perform the tests shown here: http://jbperf.com/JimStim/JimStim_v1_5_ ... ml#testing. You don't need to do everything but only the part for the 2nd trigger.

If the test passes then the issue is on the MS side. By the way, have you put the wire jumper from the 2nd trigger pin header to the 19-pin header using the pin corresponding to the correct DB37 pin? If the test fails check the solders on Q2 on the JimStim.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 6465
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: ms2 sequential questions

Postby ChevytoyR1 » Mon Jan 02, 2012 8:25 pm

jean i tested the primary signal its fine then did the 2nd trigger test and it fail.. Q2 resolder and still failed.. what next?
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby racingmini_mtl » Mon Jan 02, 2012 8:31 pm

You would need to check the signal from the CPU. If you have an oscilloscope, check the signal out of pin 16 of the CPU.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 6465
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: ms2 sequential questions

Postby ChevytoyR1 » Tue Jan 03, 2012 2:45 am

is there a different way to check the cpu? i dont have an oscilloscope.. and pin 16 is the one near D2 right?
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby racingmini_mtl » Tue Jan 03, 2012 8:23 am

ChevytoyR1 wrote:is there a different way to check the cpu? i dont have an oscilloscope.. and pin 16 is the one near D2 right?

Correct.

You could use a LED with a 330R inline resistor. Connect the positive side of the LED to pin 16 and the other side to ground (the resistor can be on either side). Be careful not to short anything when doing that. You can do the same test as before. If the LED flashes then the CPU is correct and you will need to check R24 and Q2. Also, check the solder on pin 16 and on R24.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 6465
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: ms2 sequential questions

Postby ChevytoyR1 » Wed Jan 04, 2012 4:02 am

At low rpm i can see the led stay on then turns off for a split second then stays on then turns off for split second and so on this is on the solder joint at pin 16 ... i get nothing on r24 and q2
Last edited by ChevytoyR1 on Wed Jan 04, 2012 4:13 am, edited 1 time in total.
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby ChevytoyR1 » Wed Jan 04, 2012 4:11 am

I put power to one side of the led and r24 is grounded all pins of q2 are grounded but the pin closer to the switches is dimmer..
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby racingmini_mtl » Wed Jan 04, 2012 8:54 am

Which power did you put on the LED? You're on the 3.3V side so do NOT use any power other than 3.3V when probing that side (Q2 has the middle pin on the 3.3V side with one pin grounded and the other pin that can be anything from floating to 5V to 12V).

Re-check the solders on Q2 to see if there is any bridge or cold solder but you may need to replace it.

Without having a scope or having the board in hands, it is difficult to say for certain what the issue is.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 6465
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: ms2 sequential questions

Postby ChevytoyR1 » Wed Jan 04, 2012 12:19 pm

I used 12v lol i think ill just order another stim
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby ChevytoyR1 » Thu Jan 12, 2012 4:55 am

hey jean ive put a resistor off pin16 straight to iac2b and sequential works perfect.. i replaced q2 and still no signal off 2nd trigger any ideas.. atleast i know my ms is working correct.. just seems like im getting no signal to the 2nd trigger cuircuit..
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby racingmini_mtl » Thu Jan 12, 2012 8:29 am

Without having the board in my hands to check it, it is very difficult to say what could be the problem. The way to check would be to use a scope and probe all the points from the CPU to see where the signal stops. Then check the component, the solder and the board trace to see if anything is wrong.

By the way, connecting anything to the CPU that doesn't run at 3.3V is not a good idea. You can easily fry the CPU. But in this case you confirmed that the MS and the JimStim CPU are working. The problem is somewhere between the CPU and the iac2b pin.

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 6465
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Re: ms2 sequential questions

Postby ChevytoyR1 » Thu Jan 12, 2012 12:32 pm

U dont happened to have a schematics of the board or atleast that circuit? That way i can trace what goes to where on the board?
ChevytoyR1
Experienced MS/Extra'er
 
Posts: 360
Joined: Mon Oct 27, 2008 12:15 am
Location: Los Angeles, CA

Re: ms2 sequential questions

Postby racingmini_mtl » Thu Jan 12, 2012 12:45 pm

The JimStim schematics are available on the web site: http://jbperf.com/JimStim/index.html (link in third paragraph).

Jean
jbperf.com Main site . . . . . . . . . . . . . . . . . . . . . . jbperf.com Forum
Image
racingmini_mtl
Super MS/Extra'er
 
Posts: 6465
Joined: Sun May 02, 2004 6:51 am
Location: Quebec, Canada

Next

Return to MS2/Extra, MS2, Microsquirt and Microsquirt module support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests