Gremlin is winning.. (strange miss)

All Megasquirt 1 support questions. See also the Documentation

Moderators: muythaibxr, jsmcortina

Gremlin is winning.. (strange miss)

Postby grawill » Sun Mar 04, 2012 4:00 pm

98 Dodge neon 2.0L / 20psi turbo
MS1 on v3.0 board (RSAutosport's Super420a)
MSnS Extra 29y4
MSQ -
2012-03-04_17.51.40.msq

LOG File -
04mar2012_01.msl


I can drive the car, but the Idle isn't smooth, sounds like a slight miss. Rev up the idle and it starts some strange cycle of a miss. Here's a pic of MegaLog viewer and the full log is attached.

Over the last few months, I have replaced the coil pack, wires, injectors, and plugs to try and clear this up with no avail. I welcome any suggestions.

Thanks.
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby HidRo » Sun Mar 04, 2012 4:10 pm

I cannot say 100%, but I believe you are running into Over run fuel cut.
Your settings are a bit off, I guess.
Set it a bit better, with tps lower than 1% for example. (as you are using ms1, you will have to add the adc for this).
Image
Golf II + 1.8T 20V + MSII V3.0 http://eight620vt.tk/
HidRo
Super MS/Extra'er
 
Posts: 1034
Joined: Mon Dec 28, 2009 4:56 pm
Location: Portugal

Re: Gremlin is winning.. (strange miss)

Postby grawill » Sun Mar 04, 2012 8:45 pm

Thanks. I looked into the over run settings. Currently, 0% throttle is 43adc according to TunerStudio's throttle inc file and my over run settings "TPS lower than" setting was set for 45 or 2% TPS.

I'll set my "TPS lower than" setting to 44 and see if it helps. If that fails to fix my problem, I'll turn over run off and see if the problem goes away.

Question:
My attached pic shows a steady TPS of 3%, which is above the original over run setting. As I understand the over run protection, it shouldn't have kicked in unless the TPS was at or below the "TPS lower than" setting... which means it should not have been cutting fuel. Am I wrong in this understanding?

Thanks.
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby HidRo » Mon Mar 05, 2012 1:33 am

Set the TPS to 0 (not sure why I did not say that yesterday). You want over run fuel cut to kick in when you lift throttle. So 0% is the way to go.
But it's a good test to disable it all together and test.
Image
Golf II + 1.8T 20V + MSII V3.0 http://eight620vt.tk/
HidRo
Super MS/Extra'er
 
Posts: 1034
Joined: Mon Dec 28, 2009 4:56 pm
Location: Portugal

Re: Gremlin is winning.. (strange miss)

Postby grawill » Mon Mar 05, 2012 1:19 pm

The setting is "TPS lower than".. how would it ever reach less then 0% and trigger the over run?
Is the setting really "TPS at or less than" ?

Thanks.
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby HidRo » Wed Mar 07, 2012 3:16 pm

Never mind...
I was mixing the disable and the set it right.
If you set it to 0 it will disable it. Enable by setting lower than 1% or 2%.
But test with it disabled, to see if it does it anyway.
Image
Golf II + 1.8T 20V + MSII V3.0 http://eight620vt.tk/
HidRo
Super MS/Extra'er
 
Posts: 1034
Joined: Mon Dec 28, 2009 4:56 pm
Location: Portugal

Re: Gremlin is winning.. (strange miss)

Postby jsmcortina » Wed Mar 07, 2012 6:23 pm

Something looks badly wrong with the rpm input? It shouldn't be a sawtooth.

James
I can supply, repair or upgrade Megasquirts in UK.

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 25961
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: Gremlin is winning.. (strange miss)

Postby grawill » Wed Mar 07, 2012 7:25 pm

I tested the over run settings and it seems to have removed the issue in the pic above, however it has not changed the miss.

James.. thanks for your input. That may lead to the root cause of some of my issues.

Thinking out loud for a min:
-I use the stock crank sensor and set the MS to use the Neon/420a decoder.
-Crank sensor wire is shielded from sensor to MS unit and shielding is grounded only at the MS side to the ground pin of the MS
-TPS/O2/Tach wires are also shielded in the same manor as the crank sensor.
-TPS signal shows no sign of interference.

Giving the above info, can I rule out interference or grounding issues (assuming the TPS signal would likely show any interference issues)?
I'm thinking it may be a bad crank sensor.

Thoughts?
Thanks!
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby grawill » Wed Mar 07, 2012 9:12 pm

Looking at some logs from a month ago, here is a few pics that show similar crank signal issues:
Solid TPS signal, but crank and MAP signals seem strange. MAP signal comes from 4Bar built on the board.
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby grawill » Thu Mar 08, 2012 6:10 pm

Changed the crank sensor with a spare I had sitting around. RPM looks a bit more smooth, but I still have something strange going on.
Here's a pic of a log using a different crank sensor:
Megalog_pic3_newCrankSensor.png
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby grawill » Thu Mar 08, 2012 6:19 pm

Could a bad solid state fan relay cause this problem?
I noticed my fans, controlled by the MS via the stock solid state relay, do not always turn off completely. I've noticed them operating in a very slow speed, then turn on to full speed when needed.

I think I switch over to a standard automotive relay and see if it helps.

Any other suggestions are welcome.

Thanks.
Ted.
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby grawill » Sun Mar 11, 2012 12:46 pm

Anyone?
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby jsmcortina » Sun Mar 11, 2012 12:51 pm

Please take and post some composite and tooth logs of the engine idling.
Save the two log types to different files.

James
I can supply, repair or upgrade Megasquirts in UK.

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 25961
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: Gremlin is winning.. (strange miss)

Postby grawill » Sun Mar 11, 2012 4:06 pm

All three log files zipped:
Log files.zip


4sec video of TunerStudio's screen during idle.
4sec - 20MB Video

The tick noise in the video is a glitch and is not audible in person.
Thank you for taking the time to look at this issue for me.

Ted.
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby jsmcortina » Sun Mar 11, 2012 4:51 pm

Could you post a composite log too.
EDIT: Scrub that, only just noticed that you are on MS1 which doesn't have a composite logger.

I've forgotten all about the 420A decoder for MS1 even though I wrote it, so I'd best leave it for someone with more recent experience to chime in.

James
I can supply, repair or upgrade Megasquirts in UK.

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 25961
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: Gremlin is winning.. (strange miss)

Postby grawill » Tue Mar 13, 2012 2:18 pm

Anyone?
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby nathanhardy » Sat Apr 14, 2012 3:18 pm

maybe its just ms1 it seems like every car ive heard on ms1 including mine seems to have a miss type sound out the exhuast.... could just be my cams but my vr6 vw does that :D is it afecting drivabillty?
nathanhardy
Helpful MS/Extra'er
 
Posts: 126
Joined: Sat Mar 17, 2012 10:13 pm

Re: Gremlin is winning.. (strange miss)

Postby Matt Cramer » Mon Apr 16, 2012 8:00 am

MS1 doesn't have a composite logger, but it does have a tooth logger. Could you post a tooth log?
Matt Cramer
Super MS/Extra'er
 
Posts: 7605
Joined: Thu Apr 16, 2009 8:08 pm

Re: Gremlin is winning.. (strange miss)

Postby grawill » Mon Apr 16, 2012 8:11 am

Tooth logs are included in the zip file above.
Download link HERE

Thanks for taking the time to look at those for me.

Ted.
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Re: Gremlin is winning.. (strange miss)

Postby grawill » Mon Apr 16, 2012 8:15 am

nathanhardy wrote:maybe its just ms1 it seems like every car ive heard on ms1 including mine seems to have a miss type sound out the exhuast.... could just be my cams but my vr6 vw does that :D is it afecting drivabillty?


Yes. While it does start every time and gets me from point A to B every time, you can tell it has issues. I turned my boost down from 20 to 12psi just to be safe until I figure out whats going on.

Ted.
grawill
Helpful MS/Extra'er
 
Posts: 88
Joined: Thu Sep 22, 2005 6:27 pm

Next

Return to MS1/Extra support

Who is online

Users browsing this forum: Google [Bot] and 2 guests