TunerStudio Plugin Support

For discussion of Phil Tobin's Tuner Studio software (Only about the tuning software itself, not about how to tune or firmware features)

Moderator: LT401Vette

Re: TunerStudio Plugin Support

Postby gslender » Fri Apr 06, 2012 7:55 pm

Also, there is no concept of "remove plugin" for folks that don't wish to use, or someone does something buggy etc.

G
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Re: TunerStudio Plugin Support

Postby LT401Vette » Fri Apr 06, 2012 8:31 pm

Oh yeah, it works... That is basically all the exe does, shell the command "javaw -jar TunerStudioMS.jar".
Double clicking the jar works on Windows and OSX, but on linux you have to run it from a terminal because linux doesn't set the working dir when you double click.

One thing that might be getting you is a 64 bit vs 32 bit JRE.. You do need to have the right RXTX driver in place for what ever JRE starts it. When starting by the exe, it is a 32 bit exe so it will invoke the 32 bit JRE and so I have the 32 bit RXTX driver in there. By Double clicking it can start in 64 bit mode if you have a 64 bit JRE installed, or if you are running it from eclipse while it is running on a 64 bit JDK. Then you can just move the 64 bit RXTX driver in place. That is how most of my development is done, 64 bit win7 on a 64 bit jre

Try running it from a command prompt with that command, then if you are running a 64 bit JRE and it complains, move the RXTX driver from the dir"
[TunerStudioInstallDir]\lib\alternateLinuxDrivers\win64\

move it into the [TunerStudioInstallDir]

Then you should be able to double click the jar.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 8293
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: TunerStudio Plugin Support

Postby LT401Vette » Fri Apr 06, 2012 8:34 pm

gslender wrote:Also, there is no concept of "remove plugin" for folks that don't wish to use, or someone does something buggy etc.

G


Ah yes.. The code is there to do it, it does so to upgrade / replace, but I forgot to put the menu on..

If you delete the jar from the dir:

[UserHomeDir]/.efianalytics/TunerStudio/plugins/

the plugin is uninstalled.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 8293
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: TunerStudio Plugin Support

Postby gslender » Fri Apr 06, 2012 8:44 pm

LT401Vette wrote:One thing that might be getting you is a 64 bit vs 32 bit JRE.. You do need to have the right RXTX driver in place for what ever JRE starts it. When starting by the exe, it is a 32 bit exe so it will invoke the 32 bit JRE and so I have the 32 bit RXTX driver in there. By Double clicking it can start in 64 bit mode if you have a 64 bit JRE installed, or if you are running it from eclipse while it is running on a 64 bit JDK. Then you can just move the 64 bit RXTX driver in place. That is how most of my development is done, 64 bit win7 on a 64 bit jre


That is probably it. I am running 64bit windows.

LT401Vette wrote:Try running it from a command prompt with that command, then if you are running a 64 bit JRE and it complains, move the RXTX driver from the dir"
[TunerStudioInstallDir]\lib\alternateLinuxDrivers\win64\

move it into the [TunerStudioInstallDir]

Then you should be able to double click the jar.


Made no difference, still complains about the serial drivers missing and not available. Works fine from the TS.exe though?

Anyway, I'll keep messing with it, but clearly getting it to launch from JAR isn't as smooth as it could be... the 32/64 loader could be sorted in Java code and made to load the right serial lib based on the name yeah?

G
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Re: TunerStudio Plugin Support

Postby LT401Vette » Sat Apr 07, 2012 2:44 pm

The exe is 32 bit, so it will run in 32 bit and always use the 32 bit driver.. It keeps support simpler, but at some point I figure on putting out a 64 bit installer. So far I haven't seen measurable performance gains on windows in 64 bit. So it hasn't been much a priority.

so you can either put the 64 bit RXTX driver in the TunerStudio install root, or set the lib path like this:

java -Djava.library.path=./lib/alternateLinuxDrivers/win64/ -jar TunerStudioMS.jar
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 8293
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: TunerStudio Plugin Support

Postby gslender » Sat Apr 07, 2012 3:21 pm

Figured it out. :yeah!:

When running as a java- jar or double-clicking the jar file it didn't have a path to the lib location (ever!) so the EXE must make sure it is set correctly.

I think this is something you could do within the Java application so that (at a default) ./lib is the default path if the path isn't already set. This would have allowed the TS jar to at least auto load regardless and saved me some hair :lol:

BTW - the 64 bit/32 bit wasn't an issue for me as I didn't install the 64bit version of Java on my Windows 7 64bit OS.

My TunerStudioAppDebug.txt contents.... after java -Djava.library.path=./lib/ -jar TunerStudioMS.jar

TunerStudio 1.34 started on Sun Apr 08 08:20:16 EST 2012
JRE 1.6.0_23, Windows 7 6.1, x86
java.library.path=./lib/
TunerStudioMS.jar
Look:Metal, ClassName:'javax.swing.plaf.metal.MetalLookAndFeel'
Look:Nimbus, ClassName:'com.sun.java.swing.plaf.nimbus.NimbusLookAndFeel'
Look:CDE/Motif, ClassName:'com.sun.java.swing.plaf.motif.MotifLookAndFeel'
Look:Windows, ClassName:'com.sun.java.swing.plaf.windows.WindowsLookAndFeel'
Look:Windows Classic, ClassName:'com.sun.java.swing.plaf.windows.WindowsClassicLookAndFeel'
Setting Look & Feel to:com.sun.java.swing.plaf.nimbus.NimbusLookAndFeel
WARNING: RXTX Version mismatch
Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.1-7
8/04/12 8:20:17 AM :Info: Initialized RXTX driver: 39ms.
8/04/12 8:20:17 AM :Debug: Loading Plugin from ExampleTunerStudioPlugin.jar
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Re: TunerStudio Plugin Support

Postby LT401Vette » Sun Apr 08, 2012 11:42 pm

Generally I have the RXTX driver in the root of the install too, so you don't need the lib if you are on the default 32 bit driver.
Or if you did like I said way in the beginning an installed RXTX.. :)
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 8293
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: TunerStudio Plugin Support

Postby gslender » Mon Apr 09, 2012 12:39 am

LT401Vette wrote:Or if you did like I said way in the beginning an installed RXTX.. :)


Huh? When did you say that, and what do you mean ? :?
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Re: TunerStudio Plugin Support

Postby gslender » Tue Apr 24, 2012 6:44 pm

The latest version of TS1.40 seems to have broken all plugins including the example. Any clues as to what has changed and if an new example plugin will be provided that has the updated code to work correctly?

G
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Re: TunerStudio Plugin Support

Postby LT401Vette » Tue Apr 24, 2012 6:57 pm

Do you mean 1.40 or 1.39?

1.39 did break the api. A new method was added to the ApplicationPlugin interface for the plugin to report the required specification. This method is called by TS so to help TS maintain backward compatibility going forward.

The examples and code where updated last week when 1.39 went out. You can get them here:
http://tunerstudio.com/index.php/manual ... io-plugins

I'm expecting a lot of enhancements to the plugin api, and intend to keep backward compatibility once this release is promoted to stable.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 8293
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: TunerStudio Plugin Support

Postby gslender » Tue Apr 24, 2012 7:06 pm

LT401Vette wrote:Do you mean 1.40 or 1.39?

1.39 did break the api. A new method was added to the ApplicationPlugin interface for the plugin to report the required specification. This method is called by TS so to help TS maintain backward compatibility going forward.

The examples and code where updated last week when 1.39 went out. You can get them here:
http://tunerstudio.com/index.php/manual ... io-plugins

I'm expecting a lot of enhancements to the plugin api, and intend to keep backward compatibility once this release is promoted to stable.


All working now!!

I upgraded from prior to 1.39 and went to 1.40 but didn't know about the new API, must of missed that forum post (or it didn't happen)... no biggie... was just confused for a second.

G
Mazda MX5 + MS3 Pro
User avatar
gslender
Super MS/Extra'er
 
Posts: 1072
Joined: Fri Sep 16, 2011 5:29 am
Location: Brisbane, Australia

Previous

Return to Tuner Studio

Who is online

Users browsing this forum: No registered users and 0 guests