Changing AFR targets changes AFR... EGO is disabled?

For discussion of Phil Tobin's Tuner Studio software (Only about the tuning software itself, not about how to tune or firmware features)

Moderator: LT401Vette

Changing AFR targets changes AFR... EGO is disabled?

Postby piledriver » Fri Apr 20, 2012 9:33 pm

Hopefully this isn't my second stupid question of the day...

Did a free air calibration on my WBO2 this evening, once I found my giant pair of vice grips to get it out.
(it sneered at the 22mm O2 sensor socket, which is quite bent now, good thing it's a lifetime warranty item...)
Found the outer body of the sensor (in the pipe) was in contact with the tailpipe about half way down, gave tailpipe some love with a rattail file, no contact anymore.

In any case, the WBO2 has been in use for ~20K miles, and it's possible, (OK, certain) that it was reading off a bit, as the numbers I'm getting are ~2.5 points higher than previously, which in my case are NOW sane numbers, with ~14:1 at idle and 16ish at cruise, I have been running the map set so the motor liked what I was feeding it, it appears now I was at ~normal AFR values all along, achieved by the ass dyno..

Now comes the part I'm not getting:
EGO is disabled, readout only.
I open the AFR targets, and do a +2.5 across the board.
VE table is not changed, but instantly everything goes very lean ~18:1 and the motor is limping as you would expect.
I fire up VEAL and let it fix it at idle, and it cranks the VE table numbers back up and it starts to purr agai as it gets richer.

What do I have set that I'm unaware of that can jack the fueling up by changing ONLY the AFR targets, with EGO disabled?
I'm still about .5 AFR off between the JAW and what the MS is seeing, but I can probably fix that in the JAWs output table..
Always doing things the hard way, MS2 sequential w/ v1.01 mainboard, LS2 coils. 80 mile/day commuter status.
piledriver
Super MS/Extra'er
 
Posts: 980
Joined: Tue Oct 27, 2009 6:24 am

Re: Changing AFR targets changes AFR... EGO is disabled?

Postby LT401Vette » Fri Apr 20, 2012 9:53 pm

Are you MS2e?

You probably have "Incorporate AFR Target" set to "Include AFR Target"

it is in the dialog:
Basic setup --> More Engine Constants

The basic point there is that by including the AFR targets in the calc, once your VE table is tuned, you can decide to make it richer or leaner just by adjusting the AFR targets and your VE table is left alone. It is only corrected to make it hit the target AFR.
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
http://www.TunerStudio.com
http://www.efiAnalytics.com/MegaLogViewer/
Support the firmware running your engine:
http://www.msextra.com/doc/donations.html
User avatar
LT401Vette
Super MS/Extra'er
 
Posts: 7766
Joined: Sat Jul 16, 2005 8:07 am
Location: Charlotte, NC

Re: Changing AFR targets changes AFR... EGO is disabled?

Postby piledriver » Fri Apr 20, 2012 9:58 pm

Sorry, MS2-e gslenders flavor 2.44 (3.3.0b based)

That's probably it then, makes sense.
I'll play with the settings see if I can salvage the old VE table and still have a sane AFR target table, it was about perfect.

If not, I'll just have to go for a long drive with VEAL running.
Always doing things the hard way, MS2 sequential w/ v1.01 mainboard, LS2 coils. 80 mile/day commuter status.
piledriver
Super MS/Extra'er
 
Posts: 980
Joined: Tue Oct 27, 2009 6:24 am

Re: Changing AFR targets changes AFR... EGO is disabled?

Postby piledriver » Fri Apr 20, 2012 10:08 pm

IIRC someone said there was a setting that could tweak the AFR target table and leave VE alone in VEAL?
Always doing things the hard way, MS2 sequential w/ v1.01 mainboard, LS2 coils. 80 mile/day commuter status.
piledriver
Super MS/Extra'er
 
Posts: 980
Joined: Tue Oct 27, 2009 6:24 am

Re: Changing AFR targets changes AFR... EGO is disabled?

Postby piledriver » Sat Apr 21, 2012 3:18 pm

I ended up loading a recent tune, turning "include AFR target" off, and %scaling the whole VE table up evenly so that the AFR at idle was about right, tad on the richer side.
(hopefully the error was reasonably linear)

Will take a few drives for VEAL and MLV sessions to sort it out to pefection again, but it's much more reasonable now, and the WBO2 is much more responsive/provides reasonable readings without the tailpipe as a heatsink.
Always doing things the hard way, MS2 sequential w/ v1.01 mainboard, LS2 coils. 80 mile/day commuter status.
piledriver
Super MS/Extra'er
 
Posts: 980
Joined: Tue Oct 27, 2009 6:24 am

Re: Changing AFR targets changes AFR... EGO is disabled?

Postby piledriver » Wed Apr 25, 2012 8:25 pm

My issue is resolved by simply turning it off and running VEAL for awhile and some smoothing, but what would be the proper/intended usage of this feature?

Perhaps set up an accurate VE table with a NB at at stoich for your fuel (include AFR targets off) then tweak it by changing the AFR target table with "include AFR targets" turned on?
(assuming you only had a NB, I could see the need for this)
Always doing things the hard way, MS2 sequential w/ v1.01 mainboard, LS2 coils. 80 mile/day commuter status.
piledriver
Super MS/Extra'er
 
Posts: 980
Joined: Tue Oct 27, 2009 6:24 am

Re: Changing AFR targets changes AFR... EGO is disabled?

Postby wrenchdad » Fri Apr 27, 2012 1:40 am

piledriver wrote:My issue is resolved by simply turning it off and running VEAL for awhile and some smoothing, but what would be the proper/intended usage of this feature?

Perhaps set up an accurate VE table with a NB at at stoich for your fuel (include AFR targets off) then tweak it by changing the AFR target table with "include AFR targets" turned on?
(assuming you only had a NB, I could see the need for this)


Its my understanding that turning on "Include AFR Target" is just what LT401Vette stated "it allows you to change your AFR targets after your VE table is tuned WITHOUT having to retune your VE table BUT turning it on/off requires a retune of your VE table, because its in the fuel cals.

hope this helps,
later wd
wrenchdad
Master MS/Extra'er
 
Posts: 551
Joined: Mon Feb 14, 2005 5:30 am
Location: Natchez, Mississippi


Return to Tuner Studio

Who is online

Users browsing this forum: No registered users and 4 guests