Megasquirt ON BMW m52 Engine

General support questions and announcements for MS3. See also www.ms3efi.com for MS3 information

Moderators: jsmcortina, muythaibxr

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Sat Jun 09, 2012 12:55 pm

billr wrote:Referring to the schematic you linked to recently, showing the 2N2222...

Voltage at 54 drops to 2V, right? Measure voltages on 30, 85, 86, and 87A of the ECU relay, and voltage on the 2N2222 collector. Also measure resistance of the ECM relay coil. It would help to verify the current in the collector circuit, to make sure it is only handling the coil current. It really sounds like a wiring problem, not the triggering of that ECM relay.

yes, on 54.. when i just connected ecu, everything was ok, on 54 pin was ~12v, then as soon i tried to start engine, ecu lost power immediately. and after that all time on pin 54 comes 2V.... i've installed new transistor, new resistor but nothing...(the same was 2 days ago with 7.5k) strange...

on 30 and 86 comes 12v...

87A is pin 54 yes? as i said there's 2v

on 86 (pin 27) 10V

and how to measure resistance of the ECM relay coil ? :cry:


billr wrote:
Edit: You could also try by-passing that 2N2222, just short the collector to ground. However, if there is some kind of a wiring problem that may fry a wire instead of just heating the transistor. Be careful, observant, and quick.


ok.. i try tomorrow
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby billr » Sat Jun 09, 2012 3:32 pm

Did you have a typo there? 86 should not be going to that item 27 relay, 85 goes there. 30 and 86 are supposed to be 12V, but do they stay up at 12V while you try to crank and 54 drops to 2? Likewise, 54 is supposed to be same as 87A, but there is wiring and connectors in between, right? Checking voltage at 87A is necessary to verify if that wiring is OK. Is the ECM relay socketed, does it have the same 30-85-86-87x pin numbering? What about the collector voltage, is that what was 10V while cranking?
billr
Super MS/Extra'er
 
Posts: 1887
Joined: Sun May 15, 2011 11:41 am

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Sun Jun 24, 2012 11:52 am

hello again :)

today i've started the engine with megasquirt... on 413

engine not works perfect, but i hope i tune it :yeah!:

one problem i got is vvt error, that displays time to time...

i think its because of this warnings?

how can i fit them? i use alpha 20


and here is my log. please someone look at it.. any note is useful for me
Last edited by maxo-tt1 on Sun Jun 24, 2012 11:57 am, edited 1 time in total.
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby jsmcortina » Sun Jun 24, 2012 11:55 am

Those warnings are about unrelated settings that were removed. It is safe to ignore those particular ones.

They have no effect on VVT.

James
I can supply, repair or upgrade Megasquirts in UK.

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 27978
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Mon Jun 25, 2012 5:56 am

jsmcortina wrote:Those warnings are about unrelated settings that were removed. It is safe to ignore those particular ones.

They have no effect on VVT.

James

thanks ;)

one more simple question in required fuel calculation please

how to calculate engine displacement and injector flow?

for example if engine is 2800cc 6 cylinders, engine displacement will be 2800/6?

i've found flowrate calculator here http://msextra.com/doc/ms3/fuel.html

but i don't know how much maximum horsepower may i get
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Wed Jun 27, 2012 12:10 pm

we've started engine on my m52 at least.

looks to be ok... just needs some tune....

thanks all for you support :yeah!:

http://www.youtube.com/watch?feature=pl ... M2KqIIW9uA
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Thu Jun 28, 2012 1:12 am

can you guys recommend me which spark plugs will be better on MS?

denso iridium or NGK iridium? :RTFM:
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Sat Jun 30, 2012 5:47 am

engine works ok udner 3000 rpm. not goes upper then 3k. at 3000 rpm tuenrstudio says "Not Synced"

what it may be? :cry:

logs here, please someone...
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby billr » Sat Jun 30, 2012 7:53 am

Post your current .msq, the most recent I saw was from 4/18/12. In that one "MAT correction value" was set to 1%, surely that has been changed by now?
billr
Super MS/Extra'er
 
Posts: 1887
Joined: Sun May 15, 2011 11:41 am

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Sat Jun 30, 2012 7:59 am

billr wrote:Post your current .msq, the most recent I saw was from 4/18/12. In that one "MAT correction value" was set to 1%, surely that has been changed by now?

no, the same msq now...

mat correction scaling is 1% yes, how much it should be?


p.s
i've tried now 50%, 70 and 100, but the same again...seems to be working normal under 3000 rpm... but not goes upper 3k. :( too strange, looks like something limits it? :cry:
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby jsmcortina » Sat Jun 30, 2012 9:03 am

That MAT scaling has nothing to do with losing tach sync.

Your problem is the signal coming from your crank sensor. If you look at the composite logs you posted you'll see that the missing tooth region is showing a false tooth and you are losing sync.

James
I can supply, repair or upgrade Megasquirts in UK.

My Success story: viewtopic.php?f=104&t=34277
MSEXTRA documentation at: http://www.msextra.com/doc/index.html
jsmcortina
Site Admin
 
Posts: 27978
Joined: Mon May 03, 2004 1:34 am
Location: Birmingham, UK

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Sat Jun 30, 2012 9:33 am

jsmcortina wrote:That MAT scaling has nothing to do with losing tach sync.

Your problem is the signal coming from your crank sensor. If you look at the composite logs you posted you'll see that the missing tooth region is showing a false tooth and you are losing sync.

James

aha, i've noticed it now. and why may it happen only after 3000 rpm and not before?

sensor is fully working, car runs perfect on its stock 413 ecu

any idea?

maybe it need regulation from ms3 itself? as i know it has signal control on mainboard like this one on pic (p.s i've rotate them in a past)
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby billr » Sat Jun 30, 2012 12:21 pm

Agreed, your primary problem is sync loss, MAT has nothing to do with that. I pointed out the 1% MAT scaling only because it caught my attention while looking at the "old" .msq file. I suggest setting it to 100% and leaving it there. Tune using real engine variables, like VE, ignition timing, and injector timing, injector dead-time, etc; "re-writing" physics for tuning is just going to create more confusion. I feel the same about req_fuel, "it is what it is"... calculate it correctly for your engine and injectors and leave it there.
billr
Super MS/Extra'er
 
Posts: 1887
Joined: Sun May 15, 2011 11:41 am

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Sat Jun 30, 2012 1:01 pm

billr wrote:Agreed, your primary problem is sync loss, MAT has nothing to do with that. I pointed out the 1% MAT scaling only because it caught my attention while looking at the "old" .msq file. I suggest setting it to 100% and leaving it there. Tune using real engine variables, like VE, ignition timing, and injector timing, injector dead-time, etc; "re-writing" physics for tuning is just going to create more confusion. I feel the same about req_fuel, "it is what it is"... calculate it correctly for your engine and injectors and leave it there.

aha, i really need better configuration for them, but may it be the reason of sync loss? more or less my configuration level is enough for the engine to make more then 3K rpm

i think there is something other....

its already 3 days that i trying tune it, i've tried too much variants, but... couldn't reach more then 3k rpm... :(

can you share your tune? you have ms on m50 yes?
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby billr » Sat Jun 30, 2012 2:05 pm

I hope I didn't confuse thing even further. None of the things I mentioned will account for the sync loss, and there is no point in working on tuning until you have reliable sync. My application is a 427 inch Chevy engine, so my tune wouldn't help you at all! One more time... reliable sync is essential for the MS to operate, there is no way to "work around" that.
billr
Super MS/Extra'er
 
Posts: 1887
Joined: Sun May 15, 2011 11:41 am

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Sun Jul 01, 2012 1:25 am

billr wrote:I hope I didn't confuse thing even further. None of the things I mentioned will account for the sync loss, and there is no point in working on tuning until you have reliable sync. My application is a 427 inch Chevy engine, so my tune wouldn't help you at all! One more time... reliable sync is essential for the MS to operate, there is no way to "work around" that.

its clear. now i have bigger problem then starting engine :)

please look at image above, on mainboard things with red cycle, do you know what are whey?
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Sun Jul 01, 2012 5:43 am

i've found the same problem here
http://www.msextra.com/forums/viewtopic ... 01&t=34328

maybe i need 10k resistor also? between motronic 16 pin(crank signal) and ms pin 24?


or only on VR is needed?
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Sun Jul 01, 2012 8:10 am

:yeah!: i've fixed it.

installed 10k resitor in crank signal and everything is ok.

thanks all for help
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby maxo-tt1 » Tue Jul 03, 2012 4:46 am

one question about required fuel calculation

why its so that when i insert high injector flow value, required fuel reduces?

for example my
engine displacelemnt is 2800 cc
cylinders 6
air fuel ratio 14.7

and if i set injector flow 180, req fuel is 17.4, but if i set flow 250, req fuel 12.5, can someone explain how it works please?

as i searched the net, my injector Flow Rate: 205 cc/min
User avatar
maxo-tt1
Helpful MS/Extra'er
 
Posts: 140
Joined: Wed Dec 21, 2011 1:27 pm

Re: Megasquirt ON BMW m52 Engine

Postby Matt Cramer » Tue Jul 03, 2012 5:06 am

Required fuel is your base pulse width. Bigger injectors need less pulse width.
Matt Cramer
Super MS/Extra'er
 
Posts: 9007
Joined: Thu Apr 16, 2009 8:08 pm

PreviousNext

Return to MS3 General Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests