Menu bar missing - MLV for Mac

Questions specific to Megalogviewer

Moderator: LT401Vette

Menu bar missing - MLV for Mac

Postby David_G » Fri Oct 27, 2017 10:41 am

Hi everyone,

Since the upgrade to MLV for Mac v4.1.17, my menue bar is missing, so I can't do a thing in MLV. Not even entering my registration to check if that changes anything.
I tried going back to an older version (which worked fine before the upgrade) but the menu bar is still missing.

Java is updated to the newest version and TunerStudioMS is working fine WITH menu bar ;)

What can I do about that? Please advise!
Bildschirmfoto 2017-10-27 um 21.41.19.jpg
Bildschirmfoto 2017-10-27 um 21.41.19.jpg (130.43 KiB) Viewed 90 times
Helpful MS/Extra'er
Posts: 78
Joined: Wed Apr 02, 2014 1:14 am

Re: Menu bar missing - MLV for Mac

Postby LT401Vette » Sat Oct 28, 2017 1:11 pm

Unfortunately the version MLV isn't going to matter. It break with the MLV update, Apple broke most apps with the update to High Sierra 10.13.

We had a nice customer that sent us a fix for it, we need to update the installer with this fix.
Unfortunately, this fix can not go in an auto update, it will require reinstalling the app.

Or apply this and it should make things better.

In Finder Right-click on Megalogviewer in Applications and select Show Package Contents
Select Contents
Open Info.plist for editing
Find the line that says <key><CFBundleAllowMixedLocalizations></key> and change the line below it from <true/> to <false/>
Save the changes
Phil Tobin
EFI Analytics, helping to simplify EFI
Next Generation tuning software.
Supporting all MegaSquirt versions and firmwares.
Support the firmware running your engine:
User avatar
Super MS/Extra'er
Posts: 10409
Joined: Sat Jul 16, 2005 8:07 am
Location: Moorseville, NC

Re: Menu bar missing - MLV for Mac

Postby David_G » Sat Oct 28, 2017 1:21 pm

Awesome, Thank you very much for the quick help!
You are totally right, I did the update to HighSierra before upgrading MLV and TS, I forgot about that...

I just applied the "info.plist" change and everything works fine again.

I then also did the same to TunerStudioMS because I couldn't quit the application the usual way (cmd+q) but only by manually closing the windows with the mouse.
After the plist change, that is also working fine again. :yeah!:
Helpful MS/Extra'er
Posts: 78
Joined: Wed Apr 02, 2014 1:14 am

Return to Megalogviewer

Who is online

Users browsing this forum: No registered users and 1 guest